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Disclaimer 
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Electronic Data Interchange (EDI) Overview 
Electronic Data Interchange (EDI) is a companion product that you can use to set up an electronic trading 
relationship with your customers and vendors. EDI enables your company to conduct routine business 
transactions through an automatic computer-to-computer exchange of business documents. You have the 
ability to send and receive documents electronically in a standardized ANSI X12 format, communicating 
through a third-party dial-up network. For example, you can use EDI to submit a purchase order to a 
vendor. They, in turn, can use EDI to send you an order acknowledgement, shipping notice, and invoice. 

Electronic processing of documents for purchasing, scheduling, and sales activity can provide dramatic 
savings of time and money through lower administrative costs. In addition, using the simplicity and speed 
of EDI enables you to strengthen customer relations, reduce inventories, and shorten sales cycles, 
resulting in improved business controls and greater efficiencies. 

EDI Communication Method 
Value-added networks, also known as VANs, handle the exchange of data between trading partners. In 
addition to sending and receiving data, they are responsible for the messages and security requirements 
between EDI trading partners. They ensure that your transmissions are successful and that other 
businesses do not intercept your transmissions. 

Trading partners submit transactions to their VAN. The VAN then processes and groups transactions 
before sending them to their final destination. 

Your relationship with your VAN is like having a mailbox at the post office, with the following functions: 

• The Eclipse system places outgoing EDI transactions in the Outgoing EDI Status Queue. On a 
regular basis, your system initiates a network call to your VAN and transmits the outgoing items 
from the queue to your mailbox. The VAN checks your mailbox on a regular basis, picks up your 
outbound transactions, and distributes them to the designated destinations. 

• As the VAN receives incoming transactions sent to you, it places them in your mailbox. On a 
regular basis, your system initiates a network call to your VAN, picks up the inbound transactions 
from your mailbox, and processes them accordingly. 

EDI Trading Partner Profiles 
For each customer or vendor with whom you have an EDI relationship, you need to set up a trading 
partner profile. The system uses the information stored in the profiles to determine how to prepare data 
for transmission to and process data received from each trading partner. 

EDI Data Formatting Standard 
EDI uses the standards set by the Accredited Standards Committee (ASC) X12. X12 transactions are 
divided into sets defined by numbers. For example, an 850 is a purchase order and an 810 is an invoice. 

EDI Enveloping Structure 
EDI uses an enveloping structure for electronically transmitting a series of diverse business transactions. 
EDI can transmit transaction sets of different types from one party to another in the same transmission by 
enveloping each type. A hierarchical structure of headers and trailers groups the data logically for easy 
interpretation by the receiver. EDI envelopes have the following characteristics: 
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• An interchange envelope can contain multiple transactions for the same trading partner. The 
envelope begins with an Interchange Control Header (ISA) and ends with an Interchange Control 
Trailer (IEA). 

• Within the envelope, transactions are grouped by transaction type. For example, 810s are in one 
group and 850s are in another group. Each group begins with a Functional Group Header (GS) and 
ends with a Functional Group Trailer (GE). 

• The data in a document, such as an 810, is called a transaction set and begins with a Transaction 
Set Header (ST) and ends with a Transaction Set Trailer (SE). 

EDI Mappers 
Mappers are internal subroutines used to do one of the following: 

• Convert EDI transmissions into system transactions. 

• Convert system transactions and documents into EDI transmissions. 

EDI is fully integrated with the Eclipse system and can be accessed from any terminal. For detailed 
example of mapping, login to the customer support web site (http://support.epicor.com). From the 
Documentation link, go to Downloads and EDI. 

Using EDI 
Refer to the following topics for information on setting up and using the EDI programs: 

• EDI Setup Overview 

• EDI Maintenance Overview 

• Sending EDI Transactions Overview 

• Receiving EDI Transactions Overview 

http://support.epicor.com/
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EDI Administrator Responsibilities 
The EDI administrator should check the following three things on a daily basis: 

• EDI Outgoing Status Queue - Monitor documents in various stages of being sent that have 
remained in the queue too long. 

Note: Eclipse considers any document that remains in the queue more than two business 
days as overdue and requiring attention. 

• EDI Activity Log - Monitor the daily activity logged by EDI programs to ensure that documents 
are being created, received, and enveloped. 

• EDI Error Queue Maintenance - Monitor inbound and outbound document errors that have not 
been addressed. 
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EDI Setup Overview 
Now that your company has made the decision to use EDI, you need to set up your system for handling 
EDI transactions. This includes initiating the EDI process, and entering company, customer, and vendor 
EDI information into the system. 

Initiating the EDI Process 
Before your system can send and receive EDI transactions, you must initiate the EDI process by 
subscribing to a value added network (VAN). 

Company Setup 
After subscribing to a VAN, FTP, or HTTP data transfer method, use the following programs on the EDI 
Maintenance menu to set up your company to use EDI: 

• EDI Setup Maintenance - Displays a centralized screen from which to view and edit the internal 
settings of your EDI parameters. 

• EDI Network Call Scheduling - Enables you to do the following: 

• Set up and change the network configuration. 

• Schedule network calls to your VAN, FTP, or HTTP partner to access your mailbox. 

• Make a direct network call to your VAN, FTP, or HTTP partner to access your mailbox. 

Customer and Vendor Setup 
your company is set up for EDI, you need to set up customers and vendors as EDI trading partners using 
the following program: 

• EDI Trading Partner Maintenance - Provides profile data screens used to set up trading partner 
information. 

After the trading partner profile is defined, you can set up the following additional EDI functions: 

• Customer EDI Invoicing - Sets up customers to be invoiced through EDI. 

• Vendor EDI Transmission - Sets up Eclipse to transmit documents to the vendor through EDI. 

• Customer and Vendor Activity Triggers - Sets up customers to receive order confirmations and 
shipment notifications and vendors to receive purchase orders and remittance advice through EDI. 

• Vendor-Managed Inventory - Sets up vendors to manage your inventory by EDI. 

From open orders, you can also: 

• Handle EDI Custom Data - View custom EDI information on incoming sales orders or enter 
custom EDI information on outgoing purchase orders. 
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Initiating the EDI Process 
To initiate the EDI process, you must subscribe to a value added network (VAN) and establish the 
interchange information for your company. 

VANs 
The Eclipse EDI system supports transmissions with a VAN via standard FTP. We recommend the Epicor 
TDX VAN. Contact EDI Support for more information. 

Interchange Information 
ISA and GS segments are data envelopes created by the EDI software. The segments contain information 
used to identify and route EDI documents, as follows: 

• ISA segments contain the qualifier and interchange ID. 

• GS segments contain a group ID used to identify a group or division within your company. 

Interchange information is displayed in the following format: 

Qualifier-ISAID-GSID 

Where the first set of characters represents the qualifier, the second set represents the interchange ID, and 
the third set represents the group ID. 

Qualifier 
The qualifier informs the network of the type of interchange ID that follows. 

The following table describes the typical qualifiers: 

Qualifier The interchange ID that follows is... 
ZZ mutually defined. 

01 the Dun & Bradstreet ID number for your company. 

12 a telephone number. 

Interchange ID 
The interchange ID is a unique identifier for your company. It can come from different sources. For 
example, if your company has a Dun & Bradstreet number, your VAN can use that number as the 
interchange ID. 

In most cases, the interchange ID is assigned by the selected VAN. 

Group ID 
The group ID can be used to identify multiple branches within your company. We recommend that the 
group ID be the same as the interchange ID. 



Setting Up EDI Activity Triggers 

6 

Setting Up EDI Activity Triggers 
After you have created an EDI trading partner profile for a customer or vendor, you can set up some EDI 
activities to be automatically triggered by events in the system using the following procedures: 

• Customer Activity Triggers 

• Vendor Activity Triggers 

Customer Activity Triggers 
You can set up the system to send order confirmations and shipment notifications to customers as EDI 
transactions. 

To set up EDI activity triggers for a customer: 

1. From the Maintenance menu, select Customer to display the Customer Maintenance window. 

2. In the Customer field, enter the name of the customer for whom to set up EDI activity triggers. 

3. From the Additional menu, select Activity Trigger to display the Activity Trigger Maintenance 
window. 

4. To trigger order confirmations for this customer to be sent by EDI, do the following: 

• In the Trigger Description field, select EDI Order Entry. 

• In the Activity Description field, select EDI Sales Document. 

• From the File menu, select Activity Properties and at the EDI Document Type prompt enter 
856. 

5. To trigger shipment notifications for this customer to be sent by EDI, do the following: 

• In the Trigger Description field, select Shipment Notification. 

• In the Activity Description field, select one of the following options: 

• EDI Adv Shipping Notification - Sends one 856 per shipped generation. 

• EDI Single Adv Shipping Not - Sends one 856 per ship-to address on the truck when a 
shipping manifest is closed. This option requires a customized mapper. 

• From the File menu, select Activity Properties and at the EDI Document Type prompt enter 
one of the following options: 

• 856 - Advance Ship Notice. 

• 857 - Shipment and Billing Notice. 

• 810 - Invoice. 

6. Save the record and exit Customer Maintenance. 

Vendor Activity Triggers 
You can set up the system to send vendors purchase orders and remittance advice through EDI. 
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To set up EDI activity triggers for a vendor: 

1. From the Maintenance menu, select Vendor to display the Vendor Maintenance window. 

2. In the Vendor field, enter the name of the vendor for whom to set up EDI activity triggers. 

3. From the Additional menu, select Activity Trigger to display the Activity Trigger Maintenance 
window. 

4. To trigger a purchase order for this vendor to be sent by EDI, do the following: 

• In the Trigger Description field, select New Purchase Order. 

• In the Activity Description field, select EDI Purchasing Document. 

• From the File menu, select Activity Properties and at the EDI Document Type prompt enter 
850. 

5. To trigger a direct purchase order for this vendor to be sent by EDI, do the following: 

• In the Trigger Description field, select New Direct Order. 

• In the Activity Description field, select EDI Purchasing Document. 

• From the File menu, select Activity Properties and at the EDI Document Type prompt enter 
850. 

6. To trigger a remittance advice for this vendor to be sent by EDI, do the following: 

• In the Trigger Description field, select EFT Remittance Advice. 

• In the Activity Description field, select EDI doc for Remit Advice. 

• From the File menu, select Activity Properties and at the EDI Document Type prompt enter 
820. 

7. Save the record exit Vendor Maintenance. 
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Setting Up Customer EDI Invoicing 
After you have created an EDI trading partner profile for a customer, you can set up the system to send 
the customer's invoices by EDI. 

To set up customer EDI invoicing: 

1. From the Maintenance menu, select Customer to display the Customer Maintenance window. 

2. In the Customer field, enter the name of the customer for whom to set up EDI invoicing. 

3. From the Pricing menu, select Price Information to display the Customer Pricing Information 
window. 

4. In the Invoice Fax Copies field, select EDI. 

5. Save the record and exit Customer Maintenance. 
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Setting Up Vendors for EDI Transmission 
After you create an EDI trading partner profile for a vendor, you can set up the system to send documents 
to the vendor by EDI. 

To set up a vendor for EDI transmission: 

1. From the Maintenance menu, select Vendor to display the Vendor Maintenance window. 

2. In the Vendor field, enter the name of the vendor to which you want to send EDI documents. 

3. From the Additional menu, select Additional Vendor Information to display the Additional 
Vendor Information window. 

4. In the Print Status Override field, select EDI. 

Note: The EDI option is only available if the vendor is assigned to a trading partner 
profile. 

5. If your company uses vendor managed inventory, in the Allowed Pricing Variance field 
designate an acceptable pricing variance for incoming 855s. 

For each vendor you do business with using EDI, you can select whether to use the pricing 
defined in Eclipse, or whether to allow a variance in either dollars or a percentage. Use the 
Allowed Pricing Variance field and the field adjacent to it to indicate the pricing variance 
allowed for this vendor. If the difference in pricing information that is defined in Eclipse is 
outside the range you enter here on transactions with this vendor, the system uses the pricing 
information defined in Eclipse. 

6. In the Freight Days field, enter the number of days lead time required for a shipment from this 
vendor. The system adds that number of days to the ship date on 855s and 856s to determine the 
expected arrival date of the shipment. 

7. Save the record and exit the window. 
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Handling EDI Custom Data on Orders 
Use the EDI Custom Data window to view custom EDI information on incoming sales orders or enter 
custom EDI information on outgoing purchase orders. 

 Important: EDI Support must customize the mapper for transactions that use the fields 
displayed on this window. 

To handle EDI custom data on an order: 

1. On the Header tab of a sales order or purchase order, from the Edit menu, select EDI to display 
the EDI User Defined Data window. The following occurs: 

• The system populates the File Name field with EDI.ADD.DATA, the name of the file where it 
stores the data entered on this screen. 

• The Desc ID field displays the transaction ID. 

• The Prompts column displays the custom prompts defined for EDI. 

• The Category column is not used by EDI. 

• On incoming documents, the Input column displays the data associated with each prompt. 

2. To enter custom data on an outgoing order, enter the requested information in the Input column 
for any of the prompts listed on the window. If the field is validated, you can select from a list of 
options. 

3. Use the following menu options as needed: 

To... Use this menu option... 
displays the Maintenance Log 
Viewing window, where you can 
view changes made to the 
EDI.ADD.DATA file. 

File > Log 

change the order in which the 
Prompts display 

File > Sort 
Select one of the following options: 
• Default - Sorts by the order defined in the Product 

Classification Sort List control maintenance record. If that 
record is blank, the items display in alphabetical order. 

• By Attribute - Sorts by the attribute number assigned in 
Dictionary Maintenance. 

• By Category by Prompt - Sorts alphabetically by category and 
then alphabetically by prompt within each category. 

• By Category by Attribute - Sorts alphabetically by category 
and then ascending order by attribute number. 

• By Prompt - Sorts alphabetically by prompt name. 

4. Save your changes and return to the sales order or purchase order. 
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Setting Up an ***EDI Product Not Found*** Product 
When the system processes an EDI order for a product it cannot identify or find a match for, the system 
substitutes a default product for the line item so it can continue processing the order. The line item 
comment for these products contain as much information as possible from the line item received in the 
EDI order. At a later time an employee can review the order and the line item comments and replace the 
default product entries with actual products. The line item comments for these products contain the detail 
received for the product in the 850. As you overwrite these line items with products in your product file, 
the system maintains the original line item comments. This allows you to validate your pricing 
information against what your customers sent in 850. 

For the EDI program to use this feature, you need to create a product for this purpose in Product 
Maintenance and then assign the product to the EDI Default Product If Not Found control maintenance 
record. 

To create an ***EDI Product Not Found*** product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Click the New Product button. 

3. In the Description field, enter ***EDI PRODUCT NOT FOUND *** as the product 
description. 

4. In the Price Line field, enter nonstock. 

5. In the Buy Line field, enter nonstock. 

6. In the Status field, select the NonStock status. 

7. In the UM Defaults area, in the Quantity field for the default unit of measure, enter 1. 

8. In the GL Account/Product Type field, select a miscellaneous code. 

9. Save the record and exit the window. 

To assign the product to the EDI Default Product If Not Found control maintenance record: 

1. From the System > System Files menu, select Control Maintenance to display the Control 
Maintenance window. 

2. In the Keyword field, enter EDI Default Product If Not Found to display the prompt for that 
record. 

3. At the prompt, enter the ***EDI PRODUCT NOT FOUND*** product you created in the 
procedure above. 

4. Save the record and exit the window. 
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EDI Setup Maintenance Overview 
Control maintenance records govern the operation of EDI and authorization keys govern user access to 
EDI functions. 

EDI Setup Maintenance provides a centralized location for viewing and editing the control maintenance 
records. 

The following topics apply to Setup Maintenance: 

• Setting Up EDI Parameters 

• Control Maintenance Records and Authorization Keys for EDI 
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Setting Up EDI Parameters 
Set up EDI parameters to govern the operation View and edit the following parameters: 

• EDI Default Parameters 

• EDI Archive Parameters 

• Additional EDI Parameters 

 To edit EDI default parameters: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI Setup 
Maintenance to display the EDI Setup Maintenance screen. 

Note: If prompted, log on to the character-based system. 

The following fields display EDI default parameters: 

Field Description 
Default EDI A/P Batch Default A/P batch ID to be used any time an invoice is received via 

EDI, as determined by the Default EDI A/P Batch control 
maintenance record. You can leave this parameter blank. 

Default EDI Sales Source Default sales source for EDI sales, as determined by the Default 
EDI Sales Source control maintenance record. You can leave this 
parameter blank. 

Default Print Status To "E" 
For 

Default print status for purchase orders to EDI vendors, as 
determined by the Default Print Status To "E" For All EDI 
Vendors control maintenance record.   

EDI Default Product If Not 
Found 

Default EDI product for the product-not-found situation, as 
determined by the EDI Default Product If Not Found control 
maintenance record. This parameter is required. 

Include Default Shipping 
Instruc 

Indicates whether to include default shipping instructions on 
incoming EDI orders, as determined by the Include Default 
Shipping Instructions On EDI Orders control maintenance 
record. You can leave this parameter blank. 

2. Use the Defaults hot key to display a list of the EDI default control maintenance records. 

3. Select the control maintenance record to change. 

4. At the prompt, enter the new value. 

5. Press Esc three times to save the information and return to the EDI Setup Maintenance screen. 

To edit EDI archive parameters: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI Setup 
Maintenance to display the EDI Setup Maintenance screen. 

Note: If prompted, log on to the character-based system. 
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The following fields display EDI archive parameters: 

Field Description 
Archive EDI Inbound 
Documents After (Days) 

Number of days after which the EDI inbound documents are 
archived, as determined by the Archive EDI Inbound 
Documents After (Days) control maintenance record. 

Archive EDI Inbound Envelopes 
After (Days) 

Number of days after which the EDI inbound envelopes are 
archived, as determined by the Archive EDI Inbound 
Documents After (Days) control maintenance record. 

Archive EDI Outbound 
Envelopes After (Days) 

Number of days after which the EDI outbound envelopes are 
archived, as determined by the Archive EDI Inbound 
Documents After (Days) control maintenance record. 

Archive EDI Review Queue 
Documents After (Days) 

Number of days after which the EDI review queue documents are 
archived, as determined by the Archive EDI Inbound 
Documents After (Days) control maintenance record. 

2. Use the Archives hot key to display a list of the EDI archive control maintenance records. 

3. Select the control maintenance record to change. 

4. At the prompt, enter the new value. 

5. Press Esc three times to save the information and return to the EDI Setup Maintenance screen. 

To edit the additional EDI parameters: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI Setup 
Maintenance to display the EDI Setup Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. To change the IDs displayed in the EDI.ADM Msg Grp column, do the following: 

• Use the Message Group hot key to display the Message Group Maintenance screen. 

• Change the IDs assigned to the EDI.ADM message group, as needed. 

• Press Esc to update the message group and return to the EDI Setup Maintenance screen. 

Note: This is the only message group that can use a period. Do not assign this message 
group to trackers. The system sends important EDI information, such as error 
messages, to these users. 

3. To change the interchange information assigned to a branch in the EDI Outgoing IDs column, do 
the following: 

• Use the Outgoing IDs hot key to display the EDI Outgoing ID control maintenance record. 

• Edit the record. 

• Press Esc to update the record and return to the EDI Setup Maintenance screen. 

You must assign an outgoing ID to each branch that uses EDI. You and your VAN determine the 
outgoing ID for each branch. 

4. To change a branch listed in the A/P branches column, do the following: 
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• Use the A/P Brs hot key to display the Assign EDI Invoices To A/P Branch control 
maintenance record. 

• Edit the record. 

• Press Esc to update the record and return to the EDI Setup Maintenance screen. 

The A/P Brs field displays the A/P branch where the system creates a payable record when the 
designated branch receives an EDI 810 invoice.   

5. Press Esc to exit the screen and return to the EDI menu. 
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Control Maintenance Records and Authorization Keys for EDI 
Following are the control maintenance records and authorization keys used for EDI. 

Control Maintenance Records 
Set the following control maintenance records: 

EDI AP 
• Assign EDI Invoices To A/P Branch 

• Default EDI A/P Batch 

• Do Not Display Payables Entered Via EDI In The AP Preview Queue 

• Enable 856 Processing For Directs 

• Order Processing Lock For EDI Payables (New in Release 9.0.5) 

• Override Print Status For Reconciled Direct EDI Invoices 

• Pass All Freight Charges For EDI Directs On To Customer 

EDI ARCH 
• Archive EDI Inbound Documents After (Days) 

• Archive EDI Inbound Envelopes After (Days) 

• Archive EDI Outbound Envelopes After (Days) 

• Archive EDI Review Queue Documents After (Days) 

EDI DFLT 
• EDI Product Matching Priorities 

• EDI Pricing UOM Conversion Table 

• EIPP Inbound Filename Criteria 

EDI ID 
• EDI Outgoing ID 

EDI OE 
• Allow Auto-Matching For Lot Order With EDI 

• Allow Printing of Zero/Negative Dollar Direct Shipment PO 

• Allow Writer Field To Be Blank On EDI 840, 850, And 855 VMI Orders 

• Create A Report For Zero Quantity Or Confirming EDI Orders 

• Default EDI Sales Source 

• Default Print Status To "E" For All EDI Vendors 

• Disable Checking Part #'s, UOM's, And Quantities On EDI Invoices 
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• EDI Default Product If Not Found 

• Include Default Shipping Instructions on EDI Orders 

• Incoming EDI 846 Status 

• Log Remote Pricing Variance 

• Prevent Search for EDI Part Identifiers in Product Index 

• Send Carton Packing Detail in EDI 856 

• Store EDI Order Confirmation Message In 

EDI Purchasing 
• EDI Product Matching Priorities 

• Expire All Matrix Cells When EDI 845 Contracts Are Imported 

• Reconcile EDI 810 Open Generations With Partial Matches 

• Update Rebate View Dates When An EDI 845 Processes 

EPDW EDI 
• EDI IDW Interchange ID 

• EDI IDW Member Number 

Authorization Keys 
Set the following authorization keys: 

• EDI.ACTIVITY.VIEW 

• EDI.IN.REVIEW 
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Making EDI Network Calls Overview 
The system makes network calls to your value added network (VAN) to transmit EDI documents. After 
making a connection, the system sends outgoing EDI documents to and retrieves incoming EDI 
documents from your mailbox at the VAN. 

Before you can make network calls, you need to create a network configuration profile. A configuration 
profile records the network access telephone number and your company's identification information for 
that network. 

After a network configuration profile is in place, you can schedule the system to make network calls at 
regular intervals. You can also make a network call now. 

Complete the following tasks to setup EDI network calls: 

• Create network configuration profiles. 

• Schedule network calls. 

• Make network calls now. 

• Change an EDI network call schedule. 
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Creating Network Configuration Profiles 
Before the system can make calls to the network provider your company uses for electronic data 
interchange, you need to create a network configuration profile. 

To create a network configuration profile: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Network Call Scheduling to display the EDI Network Call Scheduling screen. 

Note: If prompted, log on to the character-based system. 

2. In the Network field, press F10 and select your network provider. 

3. Use the Network Config hot key to display the Network Configuration Profile screen. 

Note: The screen for each network provider is different. 

4. Complete the fields on the Network Configuration Profile screen. 

5. Press Esc to save the information and return to the EDI Network Call Scheduling screen. 

6. Press Esc again to exit the EDI Network Call Scheduling screen. 
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Scheduling EDI Network Calls 
Schedule regular network calls to your value added network (VAN) to access your mailbox. 

Before you can schedule network calls, you need to create a network configuration profile. 

To schedule EDI network calls: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Network Call Scheduling to display the EDI Network Call Scheduling screen. 

Note: If prompted, log on to the character-based system. 

2. In the Network field, press F10 and select your VAN. 

The Last Call field displays the day and time of the last network connection attempt. 

3. Use the Network Config hot key to create a network configuration profile for your network 
provider, if it hasn't already been done. 

4. Use the Schedule Call hot key to display the Phantom Scheduler screen and set up a schedule for 
making network connections to send or receive documents. 

Note: When trying to connect to one of the networks, there is no guarantee for a 
successful connection due to issues with modems, telephone lines, and a network 
that can be very active. We recommend setting up a schedule to make periodic 
attempts throughout the day. 

5. Use the following hot keys as needed for troubleshooting purposes: 

Hot Key Description 
View EDI Activity Log Displays the EDI Activity Log, where you can view the log entries. 

Chk Modem Status Checks the modem connection. 
The system displays one of the following messages: 
• Modem Check ok. Press Enter to Continue. 
• Modem Check Failed. Reset the Modem. Then Press Enter to Continue. 

Note: Changes to the data on the Network Call Scheduling screen may 
prevent communication with your network provider. 

6. Press Esc to exit the EDI Network Call Scheduling screen. 
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Changing EDI Network Call Schedules 
You can change an EDI network call schedule when necessary. For example, you can change the 
frequency of calls or delete the current schedule. 

To change an EDI network call schedule: 

1. From the System menu, select Phantom Status to display the Phantom Status window. 

2. In the Program Name column, select the process called EDI Network Call. 

3. From the File menu, select one of the following: 

• Kill - Stops the process and deletes it from the phantom. 

• Edit Schedule - Displays the Phantom Job Scheduler Maintenance window, where you can 
edit the schedule. 

4. Press Esc to exit the Phantom Status screen. 
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Making EDI Network Calls Now 
Typically, you schedule the system's calls to your value added network (VAN). You can also initiate a 
network call at any time, if necessary. 

Before you can make network calls, create a network configuration profile. 

To make an EDI network call now: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Network Call Scheduling to display the EDI Network Call Scheduling screen. 

Note: If prompted, log on to the character-based system. 

2. In the Network field, press F10 and select your VAN. 

The Last Call field displays the day and time of the last network connection attempt. 

3. Use one of the following hot keys: 

• Call Now Foreground - Makes an immediate attempt to connect to the network. You can view 
the progression of the call. Running a call in the foreground ties up your terminal for the 
duration of the call. Press Enter when the following message displays: *** CALL 
COMPLETE ***. The system returns you to the EDI menu. 

• Call Now Background - Makes an immediate attempt to connect to the network, while leaving 
your terminal free to perform other tasks. Running a call in the background places an entry in 
the Phantom Status screen for the duration of the call. The system returns you to the EDI 
menu. 
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EDI Trading Partner Profile Overview 
For each customer or vendor with whom you have an EDI relationship, you need to set up a trading 
partner profile. The system uses the information stored in the profiles to prepare data for transmission to 
and process data received from each trading partner. 

Trading Partner Profiles 

The trading partner profile identifies the entity's unique trading partner ID and the ISA Envelope 
information, including the communication standard, version number, optional security information, and 
data separators that the value added network (VAN) uses. 

Group Profiles 

Each trading partner profile contains one or more group profiles. An EDI group profile identifies the EDI 
documents your company exchanges with that trading partner group. 

Assigning an EDI customer or vendor to a group profile identifies their trading partner and the documents 
they exchange with that trading partner. Multiple vendors or customers can use the same group profile. 

Typically, a trading partner has just one group, and the trading partner and group IDs are the same 
number. If a company has multiple divisions, there may be multiple group numbers associated with the 
trading partner ID. For example, a corporation may have separate lighting and wiring divisions, and each 
division is assigned its own group ID. 
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Creating EDI Trading Partner Profiles 
An EDI trading partner profile contains the following information necessary for you to exchange EDI 
documents with the designated trading partner: 

• Trading partner name, ID, EDI standard, and ISA version used. 

• ISA envelope defaults and other miscellaneous information. 

• Trading partner group profile information. 

Each customer or vendor with whom you have an EDI relationship must be assigned to a trading partner 
profile. 

To create a trading partner profile: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Trading Partner Maintenance to display the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Enter the trading partner information. 

3. Change ISA envelope information defaults, if necessary. 

4. Enter additional information, as needed, in the following trading partner information tables: 

• Internal Account Number - The account number your vendor uses to identify your company 
and its branches. 

• EFT Account Information - Information specific to the trading partner's and your company's 
banking information. You need to set EFT account information only if your company creates 
an EDI 820 (EFT) payment. 

• Alternate Remit-To Account - A remit-to account to a payable that is different than the 
account that is associated with the ship-from account. 

• Override Send ID - Trading partner IDs used instead of the IDs specified in the EDI Outgoing 
ID control maintenance record. 

• Ship Via Information - Transport type codes used instead of the ship via defined in the 
purchase order, to send in an 850 Purchase Order document to your vendor. 

• Unknown UOM Processing - Unit of measure to use when a trading partner's UOM is 
unknown. You can use a system default or create a cross-reference table for the customer or 
vendor units of measure and the system units of measure. 

• User Defined Information - Additional information that custom mappers use at the trading 
partner level. For example, if your trading partner is Kohler, enter your Kohler account number 
to use with the Kohler mapper. 

Note: If information for a trading partner has been defined in any of these tables, the 
Active Information Tables field at the top of the EDI Group Profile Maintenance 
screen displays Yes. Otherwise, it displays No. 

5. Enter group profile information. 
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6. To flag the message system to ignore the control numbers the trading partner sends, use the 
Ignore Ctrl#'s hot key. 

The system sends a message to the users in the EDI.ADM message group each time a control 
number is received out of sequence. An asterisk (*) displays to the left of the hot key name if EDI 
is to ignore out-of-sequence ISA control numbers. 

7. Press Esc to save the trading partner profile and clear the screen. 
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Deleting EDI Trading Partner Profiles 
Delete an EDI trading partner profile when it is no longer needed. 

Before you can delete an EDI trading partner profile, you must delete the group profiles assigned to it. 

To delete a trading partner profile: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Trading Partner Maintenance to display the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Trading Partner ID field, enter the ID of the trading partner you want to delete. 

3. Use the Delete Profile hot key. 

The system displays the following prompt: Are You Sure You Want to Delete ALL EDI Info? 
(Y/N). 

Note: If you attempt to delete a profile of a trading partner that is associated with an 
active group, the system displays the following message: There Are Still Active 
Groups. Delete Them First. 

4. At the prompt, enter Y to delete the profile. 
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Displaying EDI Trading Partner Profiles 
Display a trading partner profiles in one of the following ways: 

• Customer Maintenance - After displaying a record in Customer Maintenance, you can display the 
trading partner profile to which the customer record is linked. 

• Vendor Maintenance - After displaying a record in Vendor Maintenance, you can display the 
trading partner profile to which the vendor record is linked. 

• EDI Menu - In EDI Trading Partner Profile Maintenance, you can display a trading partner profile 
by entering the trading partner name or ID. 

To display a trading partner profile from Customer Maintenance: 

1. From the Maintenance menu, select Customer to display the Customer Maintenance window. 

2. In the Customer field, enter a customer name or ID. 

3. From the Additional menu, select EDI to display the customer's trading partner profile. 

Note: If prompted, log on to the character-based system. 

If a trading partner profile has not been set up for this customer, the screen is blank. 

To display a trading partner profile from Vendor Maintenance: 

1. From the Maintenance menu, select Vendor to display the Vendor Maintenance window. 

2. In the Vendor field, enter a vendor name or ID. 

3. From the Additional menu, select EDI to display the vendor's trading partner profile on the EDI 
Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

If a trading partner profile has not been set up for this vendor, the screen is blank. 

To display a trading partner profile from the EDI menu: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Trading Partner Maintenance to display the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Trading Partner ID field, enter the name or ID of the trading partner whose profile to 
display. 
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EDI Trading Partner Profile Maintenance Overview 
The system uses the information stored in trading partner profiles to prepare data for transmission to and 
process data from each trading partner. 

Use EDI Trading Partner Profile Maintenance to enter trading partner information and view or edit 
default ISA Envelope information. Use the hot keys  to enter trading partner-specific information, such as 
internal account numbers, EFT account information, alternate remit-to account information, override send 
IDs, additional ship via information, unknown unit of measure processing instructions, and user-defined 
information. 
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Entering EDI Trading Partner Information 
The first task in creating an EDI trading partner profile is to enter the following trading partner 
information: 

• Trading partner's ISA ID. 

• Trading partner's name. 

• Name of your network provider. 

• EDI standard used with this trading partner. 

• ISA version agreed upon between you and your trading partner. 

Enter this information in the top sections of the EDI Trading Partner Profile Maintenance screen. 

Note: You can mass load some information for your trading partner documents, see Mass 
Uploading EDI Trading Partner Settings in the Report Writer/Mass Load 
documentation. 

To enter trading partner information: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Trading Partner Maintenance to display the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Trading Partner ID field, press F10, select New, and press Enter. Then enter the qualifier 
and interchange ID, separated by a tilde (~). For example, enter 01~001181858. 

The trading partner assigns these numbers to you. 

3. In the Name field, enter the name by which to identify this trading partner. 

4. In the Transmission Method field, press F10 and select your network provider (VAN). 

The system populates the EDI Standard field, with the EDI record layout standard used with this 
trading partner. The available standards are: 

• X-X12 - ASC X12, the standard created by the Accredited Standards Committee, which was 
chartered to develop uniform standards for electronic interchange of business transactions. 

• T-UCS - Uniform Communication Standard, the electronic data interchange standard used by 
the grocery industry and other wholesale and retail-oriented industry sectors. 

5. To synchronize control numbers from a previous system with those to be assigned by the Eclipse 
system, enter the numbers in the Last Ctrl # Sent and Received fields. Otherwise, leave these 
fields blank. 

These fields display the system-assigned control numbers identifying the last EDI envelopes 
exchanged by your company with this trading partner. 

6. In the ISA Version field, press F10 and select the version used by your trading partner. 

7. Press Esc to save this information and exit the EDI Trading Partner Profile Maintenance screen. 
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Changing ISA Envelope Information Defaults 
The fields in the ISA Envelope Information section of the EDI Trading Partner Profile Maintenance 
screen display defaults associated with your network provider. If your network provider requires changes, 
you can change the defaults. 

To change ISA envelope information defaults: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

The ISA envelope information fields are set to the defaults listed in the following table. Change 
the ISA envelope information defaults only if requested by your network provider. 

Field Default 
Security Qualifier 00 

Leave this field set to the default 00 for not used, unless requested otherwise. 

Security Blank 
This field remains blank unless 01 is entered in the Security Qualifier field. If 
required, your trading partner will provide the security password. 

Auth Info Qualifier 00 
Leave this field set to the default 00 for not used, unless requested otherwise. 

Auth Info Blank 
This field remains blank, unless something other than 00 is entered in the Auto 
Info Qualifier field. If required, your trading partner provides the 
authorization. 

ISA Version The ISA (Interchange Control Header) version number trading partner uses. 

Test N 
Indicates that transmissions using this profile are not for Test purposes. 
Changing this field to Y flags transmissions using this profile as Test rather 
than Production. Normally, trading partners have separate interchange IDs for 
Test and Production. 

Separator Asterisk ( * ) 
Separates fields within a segment. 

Sub-Separator A right square bracket ( ] ) 
Separates sub-fields within a field. 

Terminator Character used to makr the end of a segment. The most commonly used 
terminator is the tilde (~). 

Rep Separator Delimiter used to separate repeated occurrences of a simple data element or a 
composite data structure in ISA versions 00402 or higher. The default 
separator is "|". 

2. Press Esc to update the trading partner profile and exit the EDI Trading Partner Profile 
Maintenance screen. 
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EDI Trading Partner Specific Tables Overview 
Use the trading partner specific tables associated with a trading partner profile to enter optional 
information used to ensure proper data is present to process EDI documents with the vendor or customer. 
For example, you can enter data such as internal account numbers, EFT account information, alternate 
remit-to account information, override send IDs, additional ship via information, unknown unit of 
measure processing instructions, and user-defined information. 

Use the following procedures to enter this information: 

• Entering an Internal Account Number 

• Entering EFT Account Information 

• Entering an Alternate Remit-To Account 

• Entering Override Send IDs 

• Entering Additional Ship Via Information 

• Defining Unknown UOM Processing 

• Entering Authorized 867 Branches 

• Entering Trading Partner User-Defined Information 
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Entering EDI Internal Account Numbers 
Use the TP's Internal Account # Maintenance screen to enter the account number your trading partner 
uses to identify your company. Trading partners may have an internal account number for each of your 
branches. 

To enter an internal account number: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Account #s to display the Account #s screen. 

3. Select Internal Acct # to display the TP's Internal Account # Maintenance screen. 

4. For each branch listed, enter the account number your trading partner supplied. 

5. Press Esc twice to save this information and return to the EDI Trading Partner Profile 
Maintenance screen. 
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Entering EFT Account Information for EDI 
You can set up EDI 820 payment transactions to a vendor to create an electronic funds transfer (EFT) 
from your bank account to their bank account. Use the EFT Account Info screen to enter information 
specific to the trading partner's and your company's banking information. 

Important: The EFT companion product is required for EFT functionality. In addition, Eclipse 
EDI Support must customize the 820 mapper for transactions that use information 
entered in this window. 

To enter EFT account information: 

1. Display the record for a trading partner vendor on the EDI Trading Partner Profile Maintenance 
screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Account #s to display the Account #s screen. 

3. Select EFT Account Info to display the EFT Account Info screen. 

4. Enter the following information regarding the EFT account: 

Field Description 
Receiver's ABA # Vendor's 9-digit American Banking Association routing number, 

which identifies the vendor’s bank. 

Receiver's Account # Vendor's bank account number to which payment is deposited. 

Receiver's Account Type Vendor's bank account type. 

Sender's ABA # Your company's 9-digit American Banking Association routing 
number, which identifies your bank. 

Sender's Account # Your company's account number from which the payment is made. 

Sender's Account Type Your company's bank account type. 

Sender's DUNS # Your company's DUN & Bradstreet D-U-N-S (Data Universal 
Numbering System) number, used to identify businesses for data-
processing purposes. 

5. Press Esc twice to save this information and return to the EDI Trading Partner Profile 
Maintenance screen. 
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Entering EDI Alternate Remit-To Accounts 
An EDI vendor trading partner may request that you remit payments to an account other than the vendor's 
ship-from account. In this case, you need to identify the alternate remit-to account that trading partner 
wants you to use. 

 Important: EDI Support must customize the mapper to use the alternate remit-to account. 

To enter an alternate remit-to account: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Account #s to display the Account #s screen. 

3. Select Alt Remit-To Acct to display the Alt Remit-To Account prompt. 

4. At the prompt, enter the remit-to account to which the system should post the payable. 

5. Press Enter to save the information and return to the Account #s screen. 

6. Press Esc to exit this screen and return to the EDI Trading Partner Profile Maintenance screen. 
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Entering EDI Override Send IDs 
The EDI trading partner ID for your company is stored in the EDI Outgoing ID control maintenance 
record. This ID identifies your company on every outgoing EDI transaction. You can have the same ID 
for each branch in the company or different IDs. 

If a trading partner has any of your branches set up in their system with a trading partner ID other than the 
one you set up with your VAN, enter that ID on the Override Sender's ID screen for that trading partner. 
The system uses the override ID on outgoing EDI transactions to that trading partner. 

To enter override send IDs: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Override Send IDs to display the Override Sender's ID 
screen. 

The system populates the ISA # and Name fields with data from the Trading Partner Profile 
Maintenance screen. The Branch column lists each branch defined for your company. 

3. To identify a branch of your company to the trading partner with an override ID, complete the 
following fields: 

• In the ISA ID Override field, enter the override qualifier and interchange ID. 

• In the GS ID Override field, enter the override group ID. 

4. Repeat step 3 for each branch that requires override IDs. 

5. Press Esc to save the information and return to the EDI Trading Partner Profile Maintenance 
screen. 
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Entering Additional EDI Ship Via Information 
On outgoing EDI 850 Purchase Order documents, some vendors require that you cross-reference system 
ship vias to their user-defined codes or standard ANSI transportation type codes. 

Use the EDI Ship Via Maintenance screen to specify the ship via information required by the EDI trading 
partner vendor. 

 Important: EDI Support must customize the mapper to use this ship via information. 

To enter additional ship via information: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Ship-Vias to display the EDI Ship-Via Maintenance 
screen. 

The Eclipse Ship Via column displays all the ship vias defined for your system. 

3. If your trading partner requires a specified code when a designated ship via is assigned to a 
purchase order, use the TP Code hot key to enter or edit the code in the TP Ship Via field. 

This code is included in 850 Purchase Order documents with the designated ship via for this 
trading partner in data element TD505. 

4. If your trading partner requires the ANSI code for the transportation type when a designated ship 
via is assigned to a purchase order, use the X12 Transport hot key to select the transportation 
type code. 

This code is included in 850 Purchase Order documents with the designated ship via for this 
trading partner in data element TD504. 

Note: The options displayed for the X12 Transport hot key are determined by the ISA 
Version number used by this trading partner. The system displays the ISA version 
number next to the VerRel hot key. Use this hot key, if needed, to change the 
version number. 

5. Press Esc to exit this screen and return to the EDI Trading Partner Profile Maintenance screen. 
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Defining EDI Unknown UOM Processing 
Incoming 850 purchase orders may contain units of measure that the system does not recognize. Handle 
unknown units of measure in one of the following ways: 

• Replace the unknown unit of measure with the default selling unit of measure defined for that 
product in the system. 

• Convert the unknown unit of measure to a system unit of measure set up in a UOM cross-reference 
table. 

Convert the unit of measure for each line on purchase order documents the system sends to a 
vendor to the unit of measure the vendor requires. Likewise, the system converts the customer's 
unit of measure in a sales order to the corresponding system unit of measure. 

 Important: EDI Support must customize the mapper to use the information you define for unknown 
units of measure. 

Use the EDI Pricing UOM Conversion Table control maintenance record to set up which EDI units of 
measure map to system units of measure for pricing purposes. 

To define unknown UOM processing: 

1. Display the record for a trading partner displayed on the EDI Trading Partner Profile 
Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select UOMs to display the EDI Unknown UOM Processing 
screen. 

3. In the Method field, press F10 and select one of the following processing options: 

Method Description 
Default Selling 
UOM 

Replaces the unknown unit of measure with the default selling unit of measure 
defined for the product. 

Note: Selecting this option overrides settings previously entered using the TP 
Specific UOM Table option described below. 

TP Specific UOM 
Table 

Displays the UOM Cross Reference screen, where you can set up a cross-
reference list of the customer units of measure and the corresponding system 
units of measure. 
• In the Cus/Ven UOM field, enter the unit of measure the customer 

wants to send or the vendor wants to receive. 
• In the Eclipse UOM field, enter the corresponding system unit of measure. 
Press Esc to save the cross reference table. 
The system converts the unknown unit of measure to the cross-referenced 
system unit of measure. 

4. Press Esc to save the information and return to the EDI Trading Partner Profile Maintenance 
screen. 
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Entering Authorized EDI 867 Branches 
For outgoing EDI 867 Product Transfer and Resale Reports, some vendors require that you forward sales 
from any branch that is not an authorized location to the closest branch that is authorized. 

Use the Assign EDI 867 To Authorized Branch screen to cross-reference branches that are not authorized 
locations to other branches that are authorized. These sales are generated in the home branch for the 
customer and are counter sales to the authorized branch. 

To assign authorized 867 branches: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select Authorized 867 Branches to display the Assign EDI 867 
To Authorized Branch screen. 

3. For each branch that is not authorized to send an 867, enter another branch that can send an 867 
for that branch. 

4. Press Esc to save the information and return to the EDI Trading Partner Profile Maintenance 
screen. 
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Entering EDI Trading Partner User-Defined Information 
Use the EDI Trading Partner User-Defined Info Table screen to define additional information to include 
in EDI documents sent to or received from a designated trading partner. 

Note: Use a different screen to enter group profile user-defined information. 

 Important: EDI Support must customize the mapper for transactions that use user-defined 
information. 

To enter trading partner user-defined information: 

1. Display the record for a trading partner on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Use the Edit Tables hot key and select User Defined to display the EDI Trading Partner User-
Defined Info Table screen. 

The ISA # and Name fields display the trading partner ID and name. 

3. In the Code column, enter codes to be used by a customized mapper. 

You can enter up to 10 user-defined codes. 

4. In the Description column, enter a description for each code. The description is optional. 

5. Repeat steps 3 and 4 to enter additional codes. 

You can enter up to 10 user-defined codes. 

6. Press Esc to save the information and return to the EDI Trading Partner Profile Maintenance 
screen. 
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EDI Group Profile Maintenance Overview 
Each trading partner profile contains one or more group profiles. For each document, the group profile 
identifies: 

• The mapper subroutine that converts EDI data to Eclipse system format or system data to EDI 
format. 

• Whether a 997 acknowledgement must be sent. 

• The last control number the system assigned to a received or sent document of this type with the 
designated trading partner group. 

Use the EDI Group Profile Maintenance screen to define the types of incoming and outgoing documents 
exchanged with EDI trading partner groups and the customers and vendors assigned to those groups. 

Use the hot keys on the Group Profile Maintenance screen to enter additional information required to 
process a document, such as receive codes, send codes, global defaults, and user-defined information. 
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Creating EDI Group Profiles 
An EDI group profile identifies the customer or vendor records in your system associated with the group 
ID and the EDI documents your company exchanges with that group. 

The following guidelines apply to linking customers and vendors to group IDs: 

• Any customer or vendor in the system can only link to one group ID. 

• Multiple customer accounts or vendor accounts can link to the same group ID. 

Every EDI trading partner is assigned one or more group IDs. Typically, a trading partner has just one 
group, and the trading partner and group IDs are the same number. If a company has multiple divisions, 
there may be multiple group numbers associated with the trading partner ID. For example, a corporation 
may have separate lighting and wiring divisions, and each division is assigned its own group ID. 

To create a group profile: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

When you create a new trading partner profile, the system populates the Group ID column with 
the trading partner profile number. 

To enter a new group ID, position the cursor on a blank line in the Group ID column and enter 
the ID. 

2. Define the documents exchanged with this group. 

3. Enter additional EDI document information, as needed. 

When you finish entering document information, the system returns to the EDI Trading Partner 
Profile Maintenance screen. To the right of the Group ID field, Customer Name or Vendor 
Name displays, depending on the account you assign to the group. 

4. Use the View hot key to toggle the customer or vendor field name, if necessary. 

5. If the entity associated with this group ID is a customer, enter their name in the Customer Name 
field. 

The system populates the remaining fields on this line as follows: 

Field Descriptions 
BT Asterisk (*) identifies a bill-to customer. 

ST Asterisk (*) identifies a ship-to customer. 

Customer Acct# Customer account number. 

  

Note: To assign multiple customer accounts to the group ID, use the Multiple Bill-To 
Accounts hot key. 

6. If the entity associated with this group ID is a vendor, enter their name in the Vendor Name 
field. 
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The system populates the remaining fields on this line as follows: 

Field Descriptions 
PT Asterisk (*) identifies a pay-to vendor. 

SF Asterisk (*) identifies a ship-from vendor. 

Vendor Acct# Vendor account number. 

Note: To assign multiple vendor accounts to the group ID, use the Multiple Ship-From 
Accounts hot key. 

7. For each group profile, enter additional information, as needed, in the following group profile 
information tables: 

• Receive Code - Codes used by all inbound 850 mappers, which direct documents coming into 
this group to the proper bill-to and ship-to accounts. 

• Send Code - Codes used by a customized mapper, which identify outgoing documents from 
this group with specific pay-to or ship-from account. 

• User Defined - Additional information used by custom mappers at the group level. 

8. Change the group profile global defaults, if needed. 

9. Press Esc to save the updated group profile and return to the Trading Partner Profile Maintenance 
screen. 
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Deleting EDI Group Profiles 
Delete an EDI group profile when it is no longer needed. Before you can delete an EDI trading partner 
profile, you must delete the group profiles assigned to it. 

To delete a group profile: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Group ID column, do the following: 

• Select the group profile you want to delete. 

• Tab to the customer or vendor name and clear the field. 

The system clears the corresponding account number column. 

Note: Use the Multiple Accounts hot key to delete multiple accounts. 

3. Use the Group Profile Maintenance hot key to display the EDI Group Profile Maintenance 
screen. 

4. If an alternate interchange ID is assigned to the group profile, do the following: 

• Use the Add'l Doc Info hot key to display the EDI Add'l Doc Info screen. 

• Clear the Alternate Interchange ID field. 

• Press Esc to return to the Group Profile Maintenance screen. 

Note: You must delete the alternate interchange ID before you can delete the group 
profile. 

5. Use the Delete Profile hot key to delete the profile. 

The system displays the following prompt: Are You SURE You Want To Delete ALL This 
Groups EDI Info? (Y/N). 

Note: You can delete a group profile that defines an outbound 810 or outbound 857 only 
if the Invoice Fax Copies field on the Customer Pricing/Printing screen is not set 
to E for EDI. 

6. At the prompt, type Y and press Enter. 

The system displays the following message: This group has been deleted. Press Enter. 

7. Press Enter to return to the EDI Trading Partner Profile Maintenance screen. 
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Defining Documents Exchanged with EDI Groups 
Use the EDI Group Profile Maintenance screen to define the types of incoming and outgoing documents 
exchanged with EDI trading partner groups. 

For each document you exchange with a trading partner group, you need to define the document type, 
whether it is incoming or outgoing, and the document version number you are using for this transaction 
set. The system uses this information to select a default mapper for the document. 

The system provides generic mappers for several documents for no fee. Custom mappers are necessary 
when a required mapping routine is not available or modifications must be made to an existing mapping 
routine to meet trading partner requirements. Customization is subject to a custom programming charge 
for those clients who do not subscribe to EDI Platinum support. For those clients who subscribe to EDI 
Platinum support, most customized mappers are provided at no fee. 

To process documents for which there is no mapper, use the EDI.PRINT.DOC subroutine, which sends a 
copy of the document to your Hold file. From there you can view or print the data. 

Note: If you use Corcentric™ third party A/P processing, captures the vendor and 
invoice number necessary to contact the Corecentric website. Use the Corcentric 
option from the Inquiries menu in A/P Entry to view the information captures. 

To define the documents exchanged with an EDI group: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

The following information displays in the header of the screen: 

Field Description 
Group# Qualifier, interchange ID, and group ID, which identify this group to your 

network provider. 

Name Name of the trading partner group. The system populates this field with the 
name of the trading partner. Update the name, if necessary. 

Active Information 
Tables 

Indication whether any receive codes, send codes, or user-defined data have 
been entered for this group. 
Use the Edit Tables hot key to enter this information. 

3. In the Doc field, enter the document type to send to or receive from this trading partner group. 
Press F10 to select from a list of document types. 

4. In the In/Out field, enter I or O to designate whether this document is inbound or outbound. 

Note: If you enter I for an 855 document, the system prompts you to specify the 855 
Function Type. 

5. Use the Add'l Doc Info hot key to display the EDI Add'l Doc Info screen, where you enter 
additional information required to process the document. 
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6. In the Ver/Rel field, enter the document version number you are using for this transaction set. 
Press F10 to select from a list of version numbers. 

Note: You and the trading partner will agree upon the version number of the document 
before establishing the partnership. 

The system populates the Mapper/Subroutine field with a generic mapper/subroutine name, if 
one exists. For example, in the Mapper/Subroutine name 850.003.020.O: 

• 810 identifies the document as an invoice. 

• 850 identifies the document as a PO. 

• 003 represents the ANSI version number. (Numeric only) 

• 020 represents the ANSI release number. (Numeric only) 

• O identifies the document as o 

7. In the Mapper/Subroutine Name field, do one of the following: 

• Press Enter to accept the default mapper/subroutine name. 

• Press F10 and select a custom mapper. 

• Type EDI.PRINT.DOC in the Mapper/Subroutine Name field and press Enter. 

8. In the 997 field, indicate how to use a 997 (Functional Acknowledgment) with the document. 
How you answer the question depends on whether the document is incoming or outgoing. 

Documents Option Action 
Incoming Y Sends a 997 to the trading partner to acknowledge that the incoming 

document has been received. 
We recommend using this option. 

N Does not send a 997. 

Outgoing Y Clears the document from the EDI Outgoing Status Queue right after it 
is sent, without waiting to receive a 997 acknowledgment from the 
trading partner. 

N Waits to clear the document from the EDI Outgoing Status Queue 
until the system receives a 997 acknowledgment from the trading 
partner to whom it was sent. 
We recommend using this option. 

9. The number in the Control # field identifies the last transaction. The system assigns the number 
if the document is outgoing, or picks up the number from the trading partner's document if the 
document is incoming. Change this number only if you are using a different EDI package with 
this trading partner and need to synchronize control numbers to continue an existing sequence. 

10. Repeat steps 3 through 9 for each document type you exchange with the designated trading 
partner group. 

Note: To delete a document type, position the cursor on the type and press Alt-Delete. 
You can delete the last outbound 810 or outbound 857 from a trading partner 
group profile only if the Invoice Fax Copies field on the Customer 
Printing/Pricing screen is not set to E for EDI. 
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11. If necessary, use the Delete Profile hot key to delete all EDI document information for the 
displayed group. The system prompts you to confirm the deletion. 

12. Press Esc to save the document information and return to the EDI Trading Partner Profile screen. 
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Entering Additional EDI Document Information 
Use the EDI Add'l Doc Info screen to define additional information required to process a document 
assigned to an EDI trading partner's group profile. 

Note: If you are defining additional document information for inbound 845s, you can 
access the document information in Solar Eclipse from the 845 Contract Upload 
Queue. 

To enter additional EDI document information: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Select a document number and use the Add'l Doc Info hot key to display the EDI Add'l Doc Info 
screen. 

The document number you select determines the fields displayed in the EDI Add'l Doc Info 
screen. 

4. Complete the fields on the EDI Add'l Doc Info screen, as needed. 

Note: The fields available for each document are different depending on your document 
number selection. For example, the system displays different fields if you select 
an 855 than if you select an 845. See the Field Options on the EDI Add'l Doc Info 
Screen below for more information. 

5. Press Esc to save the information and return to the EDI Group Profile Maintenance screen. 

Field Options on the EDI Add'l Doc Info Screen 

The following table describes all the possible fields on the EDI Add'l Doc Info screen: 

Inbound Documents 
• Inbound 810 Fields 

Field Applies To Description 
Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the 
Multi Users hot key to display the Maintenance Users screen. 
Each user or message group entered can only access contracts 
for vendors with a home branch in their branch list. 

Grp/User to be 
Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an 
EDI transaction is received. 

Enable Auto-
Approve on 
Invoicing 

Inbound 810 Enter Y to have the system reconcile and approve the EDI 
invoice for payment when the line items match and the dollar 
amount is within the over/short range. The default is N. 
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Field Applies To Description 
Create 855/856 
Documents 
From 810 

Inbound 810 Enter Y to have the system generate an 855 P/O 
Acknowledgment or an 856 Advanced Ship Notice against the 
P/O. If you enter Y, then press F10 to select the documents. The 
default is N. 
This function applies to vendors that are unable to send either 
the 855 or 856 documents. 

Create Payables 
for Non-Eclipse 
PO#s 

Inbound 810 Enter Y to create a payable for non-Eclipse purchase order 
numbers, and to attach a message to the payable stating that it is 
a non-Eclipse purchase order number. The system checks the 
vendor's home branch and first authorized branch based on the 
User Accessible Branches window, if there is no valid G/L 
branch. 
When selecting Yes for this field, you can also select which type 
of document to check: 855, 856, or Both. 
The default is N. 

Note: Setting this option to Y can be useful when converting a 
legacy system to Eclipse. 

Note: Invoices for either option remain in the EDI 810 Review 
Queue for processing marked as "No Match."  

Reconcile 
Invoice Freight 
Charges 

Inbound 810 If you enter Y and the invoice amount differs from the purchase 
order amount by the freight amount, the system marks that 
invoice as a perfect match in the 810 Review Queue. The default 
is N. 

Process 
Invoices for 
Directs 

Inbound 810 Enter Y to have the system try to match the inbound 810 
invoices to the purchase order of a direct order. If a match is 
found, the system receives that purchase order generation and 
reconciles the 810 invoices against that generation. The default 
is N. 
If the Direct Invoice option in the Order Status Print Status 
Defaults control maintenance record is blank or set to any status 
other than No Print, set the Enable Auto Approve on 
Invoicing field in this screen to Y. The default print status set 
for the ship via for the order and the setting in the Print Status 
On Direct When Payable Approved control maintenance 
record affect whether the print status for the order changes to P 
when the invoice is approved. 
If the Direct Invoice option in the Order Status Print Status 
Defaults control maintenance record is set to No Print, then the 
print status for the order will not change when the invoice is 
approved, regardless of how the ship via for the order or the 
Print Status On Direct When Payable Approved control 
record are set. 

Note: The system allows for zero dollar ($0.00)direct orders to 
process. 
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Field Applies To Description 
Enable Terms 
Checking 

Inbound 810 Enter Y to have the system verify the terms defined in the 810 
with the terms from the purchase order. If the terms do not 
match, the match code in the 810 Review Queue is T. The 
default is N. 

Freight Already 
Posted on 
Eclipse PO 

Inbound 810 Enter Y to indicate that freight is already posted on the Eclipse 
purchase orders. The customer posts the freight to the purchase 
order during the receiving process. Direct orders do not have 
freight included on the purchase order. Vendors may bill for 
freight and have this put in the freight bucket in AP Entry. The 
default is N. 

Alternate 
Interchange ID 

Inbound 850 Identify a test ID (or alternate production ID) for your trading 
partner. It follows the same format as the group number. Use 
this field instead of setting up a separate profile for the purpose 
of testing with your partner.        

Note: When entering EDI Trading Partner Maintenance and 
entering a Trading Partner ID number, the IDs listed include this 
Alternate Interchange ID. We recommend that you always 
choose the main profile and get to the Alternate Interchange ID 
through the main profile, not by selecting the alternate 
interchange at this point. 

Check All 
Unpaid Gens 

Inbound 810 If you leave this field blank or enter N, the system checks for 
matches only at the generation level. The default is N. 
Enter Y to have the system check for an exact match on one 
generation and then also check for an exact match by summing 
all of the received unpaid generations on that purchase order. 

If you enter Yes in this field and theEDI PO Variances For 
EDI 810 Invoices control maintenance record is also set to Yes, 
then orders with multiple generations with a variance are auto-
matched to an 810 vendor invoice. 

If you enter Yes in this field and the Reconcile EDI 810 Open 
Generations With Partial Matches control maintenance record 
is set to Yes, then the system automatically reconciles any open 
generations with partial matches on the defined criteria when 
received through the EDI 810 invoice. 

Use PO Terms Inbound 810 Enter Y to use the terms, such as discount amount, discount 
date, and due date, from the purchase order rather than the 810. 
If you set this field to Y, the system ignores the setting in the 
Enable Terms Checking field and uses the terms from the 
purchase order regardless of what is sent in the 810. 
When set to Yes, the system does not consider the Discount 
Amount field as being overridden on the payable being created. 
Enter N to use the terms sent in the 810. If the Enable Terms 
Checking field is set to Y, the system verifies the terms in the 
810 against those in the purchase order. If the terms do not 
match, the match code in the 810 Review Queue is T. If the 
terms in the 810 are incomplete, the system places the item in 
the 810 Review Queue without creating the payable. The default 
is N. 
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Field Applies To Description 
Allow Match 
Invoice in 
Closed Period 

Inbound 810 Enter Y to allow the system to automatically match an 810 
vendor invoice and a prior period receipt, regardless of other 
matched criteria, and the system creates a payable for the 
invoice. 
If you enter Y, the system displays the Allow Days After Close 
prompt. Enter the number of days after the closing date that 
invoices can still be matched. For example, you enter 30. The 
system uses this setting if the period close date was in the past 
30 days. If this prompt is left blank, then this setting works 
regardless of when the period was closed. 
The Create PO Variance for EDI 810 Invoices control 
maintenance record must also be set to Yes for the payable to 
apply to the prior period receipt automatically. The system then 
creates a P/O variance record. 

Allow Match 
Lot Item 
Invoice 

Inbound 810 You must have the Allow Auto-Matching For Lot Order 
With EDI control maintenance record set to Yes for this field to 
display. 

Use Branch 
Lookup Table 

Inbound 810 Enter Y to use the Branch Lookup Table to match store numbers 
with Eclipse Branch IDs.  
For more information about this table, see Linking Store 
Numbers and Eclipse IDs for EDI. 

Use Match Job 
Management 
Invoice 

Inbound 810 This option works with the Payable Variance Resolution Queue 
(PVRQ) logic. If you have the the PVRQ enabled and this 
option is set to Yes, then purchase order created through the  Job 
Management order is reconciled with a payable. 

Enable Auto 
Freight Debit 
Memo 

Inbound 810 Enter Y to allow the system to create debit memos automatically 
for this trading partner.  
For more information, see Automatic 810 Matching for Lot 
Orders in this documentation or Using Debit Memos in the 
Accounts Payable documentation. 

• Inbound 830 Fields 

Field Applies To Description 
Initial Order 
Status 

Inbound 830 
Inbound 840 
Inbound 850 
P/O 
Inbound 855 
VMI 

Enter the default order status. We recommend setting this field as 
follows: 
• B (Bid) For 830s, 840s, and 850s. 
• O (Open) For 855 VMIs. 
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Field Applies To Description 
Round Up To 
Minimum 
Sales Quantity 

Inbound 830 
Inbound 846 
Inbound 850 
Inbound 862 

Indicate whether the system should round up the order quantity for 
a product when a minimum package quantity is defined but the 
customer didn't order that quantity. 
• Y - Rounds up. 
• N - Does not round up. 
• Q - Sends the order to the Remote Order Entry Review Queue 

for review. 
If you leave this field blank, the system uses the setting in the 
Round Up to Minimum Sales Quantity field on the EDI Group 
Profile Global Info Table. 

Use Partner's 
Pricing on 
Orders 

Inbound 830 
Inbound 850 

P/O Enter Y to use the pricing provided by the trading partner in 
the 850 inbound documents. The default is N. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors 
with a home branch in their branch list. 

• Inbound 840 Fields 

Field Applies To Description 
Initial Order 
Status 

Inbound 830 
Inbound 840 
Inbound 850 
P/O 
Inbound 855 
VMI 

Enter the default order status. We recommend setting this field as 
follows: 
• B (Bid) For 830s, 840s, and 850s. 
• O (Open) For 855 VMIs. 

Default Writer Inbound 840 
Inbound 850 
Inbound 855 
VMI 

Select the user for the system to display in the Written by field in 
the header of the sales order or quote created by the transaction. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors 
with a home branch in their branch list. 

• Inbound 845 Fields 

Note: Use the Product Matching hot key to define how you want the EDI 845 to 
determine matching priorities on the product data. This is new in Release 9.0.5. 
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Field Applies To Description 
Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to be 
Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Alternate 
Interchange ID 

Inbound 845 Identify a test ID (or alternate production ID) for your trading 
partner. It follows the same format as the group number. Use this 
field instead of setting up a separate profile for the purpose of 
testing with your partner.        

Note: When entering EDI Trading Partner Maintenance and 
entering a Trading Partner ID number, the IDs listed include this 
Alternate Interchange ID. We recommend that you always choose 
the main profile and get to the Alternate Interchange ID through the 
main profile, not by selecting the alternate interchange at this point. 

Cost/Price 
Matrix 

Inbound 845 Select from the following options for how you want to handle 
matrix creations based on the incoming document from your trading 
partner: 
• C - Cost Only Matrix - This option creates a cost-only matrix 

with matrix type 'O.' 
• P - Price Only Matrix - This option creates a price-only 

matrix which restricts cost values from EDI. 
• B - Cost and Price Matrix - This option creates a matrix with 

both options. 

Default Selling 
Formula 

Inbound 845 Enter the pricing formula, if the vendor always uses the same 
formula for determining your selling price for 845 pricing contracts. 
The system populates the Formula column in the Sell Price view on 
the 845 Contract Detail with this formula. 
You can override the formula for individual customers in the 
Formula field on the Contract Upload Settings screen in Customer 
Maintenance or for individual 845s in the Formula column of the 
Sell Price view of the 845 Contract Detail. 

Update 
COMM-COST 
on Sell Matrix 

Inbound 845 Indicate whether the system should upload and update the COMM-
cost in addition to the COGS cost. 
If set to Yes, the system applies the formula and basis for the rebate 
cost of goods sold (COGS) to the rebate COMM cost, and from the 
direct COGS to the direct COMM cost. 
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Field Applies To Description 
Invert 
Multiplier 

Inbound 845 Specify whether the vendor sends straight multipliers or an inverse 
multiplier in their inbound 845 documents. The multiplier is a 
number that the vendor sends in the 845 that is used in the pricing 
matrix formula to calculate the rebated cost that is applied to a 
product when it is sold. The vendor can send the multiplier in one of 
two formats: 
• Actual multiplier - For example, the formula is sent as 

0.55 and the value used in the pricing matrix formula is the 
exact same value. In this case, set this field to No to indicate 
in the formula that you want to use 55% of the amount. 

• Inverse multiplier - For example, the formula is sent as 0.55, but 
it needs to be inverted to 0.45. In this case, set this field to Yes to 
indicate in the formula that you want to use 55% off the amount. 

Auto Create 
845 Renewal 
SPA 

Inbound 845 Enter Y to let the system create renewals automatically for special 
pricing agreements (SPA). The system conducts the same checks as 
if you were processing it manually through the 845 Contract Upload 
Queue. 

Default Global 
SPA COGS 
Basis 

Inbound 845 Enter the cost-of-good-sold (COGS) basis you want the system to 
use when automatically processing SPA agreements. 

Default Global 
SPA Direct 
COGS Basis 

Inbound 845 Enter the direct cost-of-good-sold (COGS) basis you want the 
system to use when automatically processing SPA agreements. 

Sell Groups Inbound 845 Use the Sell Groups hot key to display the Sell Group Translation 
screen, where you list the vendor's product groups and map them to 
Eclipse sell groups. 
• In the Vendor Group column, enter the vendor's product 

groups. 
• In the Sell Group column, for each vendor group, select or enter 

the corresponding Eclipse sell group. 
• Use the Group Matrix hot key, as needed, to display the 

Buy/Sell Group Maintenance screen, where you can create new 
Eclipse sell groups. 

Enable Product 
Matching 
Priority 
New in Release 
9.0.5 

Inbound 845 Indicate if you want to match your products when receiving EDI 
845 documents by other parameters than by UPC or EAN codes.  
You can decide which options on which to match and in what order 
giving you more control over your product matching priorities. Set 
this option to Yes to activate the Product Matching hot key. For 
more information about this option, see Defining Product Matching 
Priorities for EDI. 
By leaving this set to No, the system works as designed prior to 
Release 9.0.5 using the UPC and EAN codes on 845 documents. 

Note: Matching options are automatically available for the 
following EDI documents: 810, 855, 856, and 845.  
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Field Applies To Description 
Ignore Purpose 
Code for Auto 
Creation 

Inbound 845 In conjunction with the Auto Create 845 Renewal SPA option 
above, you can set this option to Yes to only bypass the EDI 845 
Contract Review Queue and automatically update the sell matrix 
records. This requires the second field value in the Beginning 
Segment for Price Authorization Acknowledgement/Status 
(BPA) be set to 04. 

The default is No. 

If this option is set to Yes, the system addresses the following: 
• If Sell Matrix records already exist for the specified contract 

and product, then the system automatically sets the existing 
records to expire the day before the new contract records are 
set to take effect, and creates new Sell Matrix records for the 
updated contract information. 

• If Sell Matrix records do not already exist for the specified 
contract and product, then the system  automatically creates 
new Sell Matrix records for the contract information. 

• If the system is unable to match a part number (UPC or vendor 
catalog) in the 845 data, then the 845 contract information for 
only the product(s) that the system was unable to match goes 
to the EDI 845 Contract Review Queue.  

• Inbound 846 Fields 

Field Applies To Description 
Round Up To 
Minimum 
Sales Quantity 

Inbound 830 
Inbound 846 
Inbound 850 
Inbound 862 

Indicate whether the system should round up the order quantity for a 
product when a minimum package quantity is defined but the 
customer didn't order that quantity. 
• Y - Rounds up. 
• N - Does not round up. 
• Q - Sends the order to the Remote Order Entry Review Queue for 

review. 
If you leave this field blank, the system uses the setting in the 
Round Up to Minimum Sales Quantity field on the EDI Group 
Profile Global Info Table. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors with 
a home branch in their branch list. 

• Inbound 849 Fields 
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Field Applies To Description 
Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors with 
a home branch in their branch list. 

Alternate 
Interchange 
ID 

Inbound 849 Identify a test ID (or alternate production ID) for your trading 
partner. It follows the same format as the group number. Use this 
field instead of setting up a separate profile for the  purpose of 
testing with your partner.        

Note: When entering EDI Trading Partner Maintenance and 
     entering a Trading Partner ID number, the IDs listed include this 
Alternate Interchange ID. We recommend that you always choose 
the main profile and get to the Alternate Interchange ID through the 
main profile, not by selecting the alternate interchange at this point. 

Disable 
Payable 
Creation 

Inbound 849 Select at the Trading Partner level to disable the system from 
creating payables during 849 transaction processing. 
By disabling the payable creation, all payables are sent to the P/O 
Variance Queue for review. You can use the EDI Trading Partner 
Mass 810 Options Settings to load this setting, if needed. 

• Inbound 850 Fields 

Field Applies To Description 
Initial Order 
Status 

Inbound 830 
Inbound 840 
Inbound 850 
P/O 
Inbound 855 
VMI 

Enter the default order status. We recommend setting this field as 
follows: 
• B (Bid) For 830s, 840s, and 850s. 
• O (Open) For 855 VMIs. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors with 
a home branch in their branch list. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Use Partner's 
Pricing on 
Orders 

Inbound 830 
Inbound 850 

P/O Enter Y to use the pricing provided by the trading partner in the 
850 inbound documents. The default is N. 

Note: When set to Yes, partner prices display on all generations of 
the created order regardless how the transaction is processed: 
manually or through the phantom processor. 
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Field Applies To Description 
Alternate 
Interchange 
ID 

Inbound 850 Identify a test ID (or alternate production ID) for your trading 
partner. It follows the same format as the group number. Use this 
field instead of setting up a separate profile for the purpose of 
testing with your partner.        

Note: When entering EDI Trading Partner Maintenance and 
entering a Trading Partner ID number, the IDs listed include this 
Alternate Interchange ID. We recommend that you always choose 
the main profile and get to the Alternate Interchange ID through the 
main profile, not by selecting the alternate interchange at this point. 

EDI Order 
Entry 
Discount% 

Inbound 850 Enter the percentage discount the system gives to customers who 
send in orders using EDI. If you leave this field blank, the system 
does not give a discount. 
To set up EDI discounts, create a G/L account for EDI discounts 
and assign this account to the EDI Discount Given autoposting item. 

Round Up To 
Minimum 
Sales Quantity 

Inbound 850 Indicate whether the system should round up the order      quantity 
for a product when a minimum package quantity is  defined but the 
customer didn't order that quantity. 
• Y - Rounds up. 
• N - Does not round up. 
• Q - Sends the order to the Remote Order Entry Review Queue to 

be reviewed. 
If you leave this field blank, the system uses the setting in the 
Round Up to Minimum Sales Quantity field on the EDI Group 
Profile Global Info Table.                                                              

Remove 'Price 
Per' Comment 
Line from 
Order 

Inbound 850 If you enter Y, the price per  line item comment that includes 
pricing information is not included in the printed order. 
For example, you direct ship to a customer's customer. The shipping 
ticket that you pack with the order includes the printable line item 
comments from the order. Using this setting, you can remove the 
line item comment that contains pricing information so the direct 
ship customer does not see the prices that your customer is pays for 
the items on the order. 

• Inbound 855 Fields 
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Field Applies To Description 
855 Function 
Type 

Inbound 855 Identify the function the 855 serves: 
• VMI - Enables the vendor to create purchase orders on 

your system. Used with the outbound 852 Product 
Activity Data document. 

• P/O Ack - Creates open generations by ship date as defined in 
the 855 documents from your vendor. 

Note: If the trading partner sends both 855 types, select P/O Ack 
for this field. The system uses data element 02 from the BAK 
segment to identify VMI orders. If this code is AP, the system 
treats this order as though the vendor is trying to create an order 
for the distributor. The system treats anything other than AP as a 
P/O Acknowledgment. 

Dflt Lead 
Time if NO 
Shp Dt 
Provided 

Inbound 855 Enter the number of days it takes the vendor to send material from 
their warehouse. The system adds this number to the date of the 
855 and uses this calculated date as the expected receive date. The 
default is a blank field. 
This field applies to vendors that do not send a ship date in the 
855 documents. 

Override 
Perfect Match 
Auto-Clearing 

Inbound 855 Enter Y to keep inbound purchase orders that have a perfect 
match in the EDI 855 P/O Acknowledgement Review Queue's 
Active view until you move them to the Cleared view. If this field 
is set to N, the system automatically clears any purchase orders 
with a match level of P from the Active view in the queue and 
moves them to the Cleared view. 

Process 
Multiple Stock 
PO Ack 855s 

Inbound 855 Enter Y to enable the system to process multiple 855s per order. 
The default is N. 

Received 
Document 
Notification 

Inbound 855 Select who to notify when the system receives an EDI 855. If you 
leave this field blank, the system does not message a user when it 
receives an 855. 
• GRP/USER - The system sends a message to the user 

you enter in the Grp/User field that displays after you 
select this option. 

• WRITTEN BY - The system sends a message to the user 
specified in the Written by field in the header of the order. 

Received 
Document 
Reviewer 

Inbound 855 Select who to assign in the EDI 855 Review Queue to review the 
record created for the incoming document. If you leave this field 
blank, the system does not assign a user. 
• GRP/USER - The system assigns the user you enter in 

the Grp/User field that displays after you select this 
option. 

• WRITTEN BY - The system assigns the user specified in the 
Written by field in the header of the order. 
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Field Applies To Description 
Update Req'd 
Date with the 
Ship Date 

Inbound 855 Enter Y or N to override the system default defined in theUpdate 
The Required Date With Ship Date Received On An EDI 855 
control maintenance record. 
• Y - The system updates the required date on EDI 

purchase orders with the ship date received on EDI 855 
P/O Acknowledgements. 

• N - The system does not update the required date. 

Use Partner's 
Pricing on 
VMI Orders 

Inbound 855 
VMI 

Enter Y to use the pricing provided by the trading partner in the 
855 inbound documents when creating VMI orders. The default is 
N, in which case the system creates the order using matrix or 
price sheet pricing. 

Initial Order 
Status 

Inbound 830 
Inbound 840 
Inbound 850 
P/O 
Inbound 855 
VMI 

Enter the default order status. We recommend setting this field as 
follows: 
• B (Bid) For 830s, 840s, and 850s. 
• O (Open) For 855 VMIs. 

Use Receive 
Code Table on 
VMI Orders 

Inbound 855 
VMI 

Set to Y (Yes) to have Eclipse use the code table for VMI orders. 
The default is No. 

When an Inbound 855 VMI order is received from a 
vendor, the system automatically attempts to create an 
Eclipse purchase order from the data. By default, the Ship-
From is the first vendor account number attached to the EDI 
Trading Partner Profile. To specify which vendor to user for 
the purchase orders, set this option to Yes and complete the 
EDI Group Profile Receive Code Info Table accordingly. 

Send 
Duplicate 
VMI 855 to 
the EDI 855 
Review Queue 

Inbound 855 
VMI 

Set to Y (Yes) to send duplicate VMI 855 documents to the EDI 
855 Review Queue, instead of the EDI Error Queue. The 
documents have a message indicating that the purchase order 
already exists in the system. From the EDI 855 Review Queue, 
users can select the Vendor Item Detail screen for the purchase 
order and a message displays indicating the 855 was from a 
duplicate VMI order: VMI 855 FROM VENDOR. PO 
NUMBER ALREADY EXISTS. REVIEW FOR CHANGES. 
The default is No. 

Use Next 
Available PO# 
for VMI 
Orders 

Inbound 855 
VMI 

New in Release 9.0.1 
Set to Y (Yes) to uses the next available purchase order number 
generated by Eclipse when creating purchase orders for VMI 
transactions. The VMI transaction program then uses the next 
available purchase order number and populates the Order ID 
field on the purchase order Header tab with the vendor's Order 
ID sent in the 855 document. 

• Inbound 856 Fields 
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Field Applies To Description 
Auto-Clear 
Review Queue 
Entry 

Inbound 856 Set the following options, as needed, to tell the system when to 
clear the EDI Review Queue of these transactions: 
• Clear on Perfect Match - System clears transactions 

when all items and quantities match. 
• Clear when No Open Gens - System clears transactions with 

no open generations. These include 856 records with no 
generations with un-received line items on the purchase order 
or record with an invalid purchase order number. 

• Clear Directs - System clears transactions marked as direct 
purchase orders. 

Enable 
Processing for 
Directs 

Inbound 856 Indicate if you want to process direct orders using the 856 
inbound document process. 
You can use this option even if the Enable 856 Processing For 
Directs control maintenance record is not set to Yes. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an 
EDI transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors 
with a home branch in their branch list. 

Alternate 
Interchange 
ID 

Inbound 856 Identify a test ID (or alternate production ID) for your trading 
partner. It follows the same format as the group number. Use this 
field instead of setting up a separate profile for the  purpose of 
testing with your partner.        

Note: When entering EDI Trading Partner Maintenance and 
entering a Trading Partner ID number, the IDs listed include this 
Alternate Interchange ID. We recommend that you always choose 
the main profile and get to the Alternate Interchange ID through 
the main profile, not by selecting the alternate interchange at this 
point. 

• Inbound 860 Fields 

Field Applies To Description 
Initial Tracker 
Status 

Inbound 860 Enter the default status the system assigns to the trackers it 
creates for incoming 860s. 
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Field Applies To Description 
Received 
Document 
Review 
Hierarchy 

Inbound 860 Options let users specify who is responsible for processing the 
860 document. You can select Writer, Inside Sales, and Outside 
Sales in any combination. 
Eclipse then parses out the Customer purchase order and finds a 
single sales order with the received customer P/O #. Eclipse uses 
the hierarchy set in this field to send to users. 
If no user is set to receive the document, Eclipse sends to the 
standard User/Msg Group defined in the EDI 860 Add'l Doc Info 
screen. 

• Inbound 862 Fields 

Field Applies To Description 
Round Up To 
Minimum 
Sales Quantity 

Inbound 830 
Inbound 846 
Inbound 850 
Inbound 862 

Indicate whether the system should round up the order quantity 
for a product when a minimum package quantity is defined but 
the customer didn't order that quantity. 
• Y - Rounds up. 
• N - Does not round up. 
• Q - Sends the order to the Remote Order Entry Review Queue 

for review. 
If you leave this field blank, the system uses the setting in the 
Round Up to Minimum Sales Quantity field on the EDI Group 
Profile Global Info Table. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an 
EDI transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors 
with a home branch in their branch list. 

• Multiple Inbound Transaction Fields 

Field Applies To Description 
Initial Order 
Status 

Inbound 830 
Inbound 840 
Inbound 850 
P/O 
Inbound 855 
VMI 

Enter the default order status. We recommend setting this field as 
follows: 
• B (Bid) For 830s, 840s, and 850s. 
• O (Open) For 855 VMIs. 
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Field Applies To Description 
Round Up To 
Minimum 
Sales Quantity 

Inbound 830 
Inbound 846 
Inbound 850 
Inbound 862 

Indicate whether the system should round up the order quantity 
for a product when a minimum package quantity is defined but 
the customer didn't order that quantity. 
• Y - Rounds up. 
• N - Does not round up. 
• Q - Sends the order to the Remote Order Entry Review Queue 

for review. 
If you leave this field blank, the system uses the setting in the 
Round Up to Minimum Sales Quantity field on the EDI Group 
Profile Global Info Table. 

Use Partner's 
Pricing on 
Orders 

Inbound 830 
Inbound 850 

P/O Enter Y to use the pricing provided by the trading partner in 
the 850 inbound documents. The default is N. 

Default Writer Inbound 840 
Inbound 850 
Inbound 855 
VMI 

Select the user for the system to display in the Written by field in 
the header of the sales order or quote created by the transaction. 

Grp/User to 
be Notified of 
Document 

Inbound docs 
(except 855) 

Enter the ID of the person or message group to notify when an 
EDI transaction is received. 

Grp/User to 
Review 
Received 
Document 

Inbound docs 
(except 855) 

Enter the ID of the user or message group handling the account. 
To assign maintenance users by branch for an 845, use the Multi 
Users hot key to display the Maintenance Users screen. Each user 
or message group entered can only access contracts for vendors 
with a home branch in their branch list. 

Outbound Documents 
• Outbound 810 

Field Applies To Description 
Grp/User to 
be Notified of 
997 

852 and 855 

Outbound 
850 and 810 

Enter the User ID or Group ID who should be notified when an 997 
transmission is received. 

Default 
Outgoing 
Transmission 
Status 

852 and 855 

Outbound 
850 and 810 

Enter the default status to use for outgoing transmissions, such as 
SEND or HOLD. 

Alternate 
Interchange 
ID 

852 and 855 

Outbound 
850 and 810 

Enter the interchange ID to use if the ID is different than the 
Primary ID listed in the current profile. The same format must be 
used: XX~ISAID~GSID 
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Field Applies To Description 
Transmission 
Method 
Override 

Outbound 810 
Outbound 852 

Enter an alternate transmission method to override the default 
transmission method set for the trading partner in EDI Trading 
Partner Profile Maintenance. 
For example, if you send invoices through a third party billing 
company, that company may have a different EDI transmission 
default than the customer to which the EDI trading partner profile 
is assigned. Use this field to specify an alternate transmission 
method for the outbound invoice. 

Send Credit/ 
Zero Bal 
Invoices 

Outbound 810 Select one of the following options to indicate whether the system 
sends 810s for invoices with negative balances (credits) or zero 
balances. The default is Y. 
• C - Send Credits 
• Z - Send Zero Balance Invoices 
• Y - Send Both 
• N - Send Neither 

Note: If you select an option that prints zero balance invoices, the 
Print Paid-In-Full control maintenance record must be set to Y. 
These invoices are not necessarily paid in full. The invoice might 
be for replacement items or there is no charge for some other 
reason, but the customer still needs to receive the invoice. 

Send Pricing 
Data in Qty 
UOM (Y/N) 

Outbound 810 
Outbound 850 

Enter Y to convert the pricing information to the same unit of 
measure as the quantity information. The default is N. 
You can define how EDI units of measure are converted to system 
units of measure in the EDI Pricing UOM Conversion Table 
control maintenance record. 

• Outbound 850 

Field Applies To Description 
Grp/User to 
be Notified of 
997 

852 and 855 

Outbound 
850 and 810 

Enter the User ID or Group ID who should be notified when an 997 
transmission is received. 

Default 
Outgoing 
Transmission 
Status 

852 and 855 

Outbound 
850 and 810 

Enter the default status to use for outgoing transmissions, such as 
SEND or HOLD. 

Alternate 
Interchange 
ID 

852 and 855 

Outbound 
850 and 810 

Enter the interchange ID to use if the ID is different than the 
Primary ID listed in the current profile. The same format must be 
used: XX~ISAID~GSID 

Send Pricing 
Data in Qty 
UOM (Y/N) 

Outbound 810 
Outbound 850 

Enter Y to convert the pricing information to the same unit of 
measure as the quantity information. The default is N. 
You can define how EDI units of measure are converted to system 
units of measure in the EDI Pricing UOM Conversion Table 
control maintenance record. 
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Field Applies To Description 
Disable 
Sending 
BP/Eclipse 
Part # 

Outbound 850 Enter Y to prevent the generic outbound 850 mapper from sending 
the BP qualifier followed by the internal Eclipse part number. The 
default is N. 

Use Purchase 
Order Date 

Outbound 850 Enter Y to use the purchase order's ship date when you create the 
outbound 850 by changing the purchase order's print status to E for 
EDI. 
Leave this field blank or enter N to use the date that the purchase 
order was entered instead of the order's ship date when you create 
the outbound 850 by changing the purchase order's print status to E 
for EDI. 
The default is N. 

Include Price 
Branch ID in 
N1 BT 

Outbound 850 Enter Y to include the four-digit pricing branch ID at the end of the 
EDI ID in the N1 BT 04 segment of the outbound 850 document. 

Include Price 
Branch ID in 
N1 BY 

Outbound 850 Enter Y to include the four-digit pricing branch ID at the end of the 
EDI ID in the N1 BY 04 segment of the outbound 850 document. 

Include Ship 
Branch ID in 
N1 ST for 
Directs 

Outbound 850 Enter Y to send the DUNS+4 for outbound 850s for direct ship 
orders. 

Enable 
Consolidated 
Drop Point 
PO 

Outbound 850 Enter Y to allow users to consolidate purchase orders by drop 
point. 

Include 
Customer 
Shipping 
Instructions 
on Directs 

Outbound 850 Indicate whether to include customer shipping instructions for 
direct sales orders.  

Include 
Country of 
Origin on 
PO1 Seg  

Outbound 850 Indicate whether to include the Country of Origin on the line item 
detail for purchase orders. 

2 or 3 
Character 
Abbreviation 

Outbound 850 If you enter Yes in the Include Country of Origin on PO1 Seg 
field, then use this field to indicate if you need two or three 
characters for the country abbreviation. For example, the United 
Kingdom requires two (UK), but the United States requires three 
(USA).  

• Outbound 852 

Field Applies To Description 
852 
Processing 
Control File 

Outbound 852 Press F10 and select the trading partner-specific control record 
that determines how the system accumulates 852 data. 
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Field Applies To Description 
Grp/User to 
be Notified of 
997 

852 and 855 

Outbound 850 

Enter the User ID or Group ID who should be notified when an 
997 transmission is received. 

Default 
Outgoing 
Transmission 
Status 

852 and 855 

Outbound 850 

Enter the default status to use for outgoing transmissions, such as 
SEND or HOLD. 

Alternate 
Interchange 
ID 

852 and 855 

Outbound 850 

Enter the interchange ID to use if the ID is different than the 
Primary ID listed in the current profile. The same format must be 
used: XX~ISAID~GSID 

Transmission 
Method 
Override 

Outbound 810 
Outbound 852 

Enter an alternate transmission method to override the default 
transmission method set for the trading partner in EDI Trading 
Partner Profile Maintenance. 
For example, if you send invoices through a third party billing 
company, that company may have a different EDI transmission 
default than the customer to which the EDI trading partner profile 
is assigned. Use this field to specify an alternate transmission 
method for the outbound invoice. 

Include 
'Catalog' 
Items 

Outbound 852 Enter Y to accumulate catalog index items and primary index 
items for the 852 report. The default is N. 

Include 
'Tags' 

Outbound 852 Enter Y to include transfer quantities for tags sales order items. 
The default is DFLT.   
Leave this field set to DFLT to use the settings set in the selected 
file displayed in the 852 Processing Control File field. 

• Outbound 855 

Field Applies 
To 

Description 

Grp/User to 
be Notified of 
997 

855 Enter the User ID or Group ID who should be notified when an 997 
transmission is received. 

Default 
Outgoing 
Transmission 
Status 

855 Enter the default status to use for outgoing transmissions, such as SEND 
or HOLD. 

Alternate 
Interchange 
ID 

855 Enter the interchange ID to use if the ID is different than the Primary ID 
listed in the current profile. The same format must be used: 
XX~ISAID~GSID 

Automatically 
Send 855 
Only One 
Time 

855 Set to Yes to send the 855 document only once. 
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Field Applies 
To 

Description 

Disallow Job 
Management 
Outbound 
855 

855 Set to Yes to ignore the New Sales Order and EDI Sales 
Document activity triggers for Job Management orders and 
disable the E-EDI print status. 

The default is No. 

• Outbound 856 

Field Applies 
To 

Description 

Grp/User to 
be Notified of 
997 

856 
Advance 
Ship 
Notice 

Enter the User ID or Group ID who should be notified when an 997 
transmission is received. 

Default 
Outgoing 
Transmission 
Status 

856 
Advance 
Ship 
Notice 

Enter the default status to use for outgoing transmissions, such as 
SEND or HOLD. 

Alternate 
Interchange 
ID 

856 
Advance 
Ship 
Notice 

Enter the interchange ID to use if the ID is different than the Primary 
ID listed in the current profile. The same format must be used: 
XX~ISAID~GSID 

Send Carton 
Packing Detail 

856 
Advance 
Ship 
Notice 

If you generate an EDI 856 Advance Ship Notice from Sales Order 
Entry on an order in an invoiced status, the system sends carton 
packing data if found. If no carton packing data is found, the system 
treats the 856 as if this control maintenance record is set to No. 
The setting here overrides the Send Carton Packing Detail in EDI 
856 control maintenance record. 

Note: Carton Packing is an Eclipse companion product. Contact your 
inside salesperson for more information. 

Suppress 856 
for Credit 
Invoice 

856 
Advance 
Ship 
Notice 

Indicate if you want to send an 856 advance notice for credit invoices. 

New in Release 8.7.9. 

Include 
Header Level 
Tracking 
Number 

856 
Advance 
Ship 
Notice 

Set to Yes to include tracking numbers using the following hierarchy: 
1. The system first uses tracking numbers posted to the change log in 
the sales order generation from the Shipping Manifest companion 
product. If found, the system uses these tracking numbers on the 856 
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Field Applies 
To 

Description 

REF Qualifier 
to Use 

856 
Advance 
Ship 
Notice 

outbound transaction. 
2. If no tracking numbers are found in the change log, the system 
looks for tracking numbers added manually to the Internal Notes 
field on the sales order. These must be added with asterisks followed 
by the REF Qualifier, for example *CN1Z1234560300000010. 
If both are blank, the REF segment for the tracking numbers will not 
be reported, per EDI standards. 
Note: Any tracking numbers are sent to the Header for the Outbound 
856. 

These two fields are mutually dependent. You must have both 
populated. 

• Multiple Outbound Transaction Fields 

Field Applies To Description 
Send Pricing 
Data in Qty 
UOM (Y/N) 

Outbound 810 
Outbound 850 

Enter Y to convert the pricing information to the same unit of 
measure as the quantity information. The default is N. 
You can define how EDI units of measure are converted to 
system units of measure in the EDI Pricing UOM Conversion 
Table control maintenance record. 

Transmission 
Method 
Override 

Outbound 810 
Outbound 852 

Enter an alternate transmission method to override the default 
transmission method set for the trading partner in EDI Trading 
Partner Profile Maintenance. 
For example, if you send invoices through a third party billing 
company, that company may have a different EDI transmission 
default than the customer to which the EDI trading partner profile 
is assigned. Use this field to specify an alternate transmission 
method for the outbound invoice. 

Default 
Outgoing 
Transmission 
Status 

Outbound docs Enter one of the following options to define the initial status of 
the document in the EDI Outgoing Status Queue. 
• Send - The document goes to the EDI Outgoing Status 

Queue with a status of Send. The document stays in the 
queue until the system makes the next network call to the 
VAN. 

• Hold - The document goes to the EDI Outgoing Status Queue 
with a status of Hold. The document stays in the queue until 
you change the status to Send or delete the document. 

To change the status of a document, do so from the EDI Outgoing 
Status Queue, not from the group profile. 

Grp/User To 
Be Notified 
of 997 

Outbound docs Enter the user or message group handling the account. 

• All documents 
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Field Applies 
To 

Description 

Alternate 
Interchange 
ID 

All docs Enter a test ID or alternate production ID for your trading partner. The ID 
follows the same format as the group number. Use this field instead of 
setting up a separate profile for the purpose of testing with your partner. 

Note: When entering EDI Trading Partner Maintenance and entering a 
Trading Partner ID number, the IDs listed include this Alternate Interchange 
ID. We recommend that you always select the main profile and get to the 
Alternate Interchange ID through the main profile, not by selecting the 
alternate interchange at this point. 

Field Applies To Description 
Display 2 
Decimals in 
Rebate 
Detail 

Outbound 844 
Inbound 849 

Enter Y to display the actual cost, rebate cost, difference amount, and 
the extended rebate amount for the total quantity sold of the product 
to two decimal places in outbound 844 rebate reports. 
The decimal place rounding also applies to inbound 849 rebate 
responses. Enter Y in this field to display the rebate cost, cost, and 
rebate amounts to two decimal places. 
Enter N to round to three decimal places. 
Note: The system uses standard rounding logic. If the third decimal 
place is 5 for greater, the second decimal point is rounded up. 
Amounts on the 849 rebate responses can extend anywhere from two 
to six digits. When the system compares the vendor cost on the 
inbound 849 to the cost in Eclipse, rounding may cause the system to 
see items on the 849 as exceptions. Use this field to indicate how you 
want the system to handle rounding to avoid rebate items from 
unnecessarily being considered exceptions. 
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Entering EDI Group Profile Receive Codes 
The system routes incoming EDI order transactions that affect the sales order ledger, such as 850s or 
832s, to trading partner group IDs. 

If multiple customer ship-to accounts are associated with one group profile, you need to set up receive 
codes for each one. When a ship-to customer in this group sends an EDI order or request for bid, they 
include their receive code in the EDI document. As your system receives the document, it uses the receive 
code to determine the ship-to account to which to assign the transaction. 

Typically, your trading partner provides these codes. 

Receive Code Format 
The receive code has a two-part format. Each part can be up to 17 alphanumeric characters. The parts are 
separated by a dash. 

• The ID preceding the dash identifies the bill-to customer. The ID is transmitted in the N1-BT 
segment (field four) of the document. 

• The ID following the dash identifies the ship-to customer. The ID is transmitted in the N1-ST 
segment (field four) of the document. 

Use the EDI Group Profile Receive Code Info Table screen to enter group profile receive codes. 

To enter a group profile receive code: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select the Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Use the Edit Tables hot key, select Receive Code, and press Enter to display the EDI Group 
Profile Receive Code Info Table screen. 

The system populates the Group # and Name fields with view-only information from the EDI 
Group Profile Maintenance screen. 

4. In the Receive Code field, enter the receive code. 

Note: If your trading partner does not provide a bill-to code, enter a dash followed by the 
ship-to code. 

5. In the Customer Name field, enter the account with which to associate this receive code. 

6. To enter additional receive codes, repeat steps 4 and 5. 

7. Press Esc to save the list and return to the EDI Group Profile Maintenance screen. 
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Entering EDI Group Profile Send Codes 
When multiple entities use the same group profile, use the EDI Group Profile Send Code Info Table 
screen to specify codes that identify each entity. The codes identify the ship-froms or ship-tos from which 
the documents originated. If a trading partner requests that a unique code be sent for a specific location, 
enter that code on this screen. 

 Important: EDI Support must customize the mapper to incorporate this information in the 
transaction. 

To enter a group profile send code: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Use the Edit Tables hot key, select Send Codes, and press Enter to display the EDI Group 
Profile Send Code Info Table screen. 

The system populates the Group # and Name fields with view-only information from the EDI 
Group Profile Maintenance screen. 

4. In the Send Code field, enter the code used to identify the customer ship-to or vendor ship-from. 

5. In the Customer/Vendor Name field, enter the customer ship-to or vendor ship-from account 
with which to associate the send code. 

6. To enter additional send codes, repeat steps 4 and 5. 

7. Press Esc to save the list and return to the EDI Group Profile Maintenance screen. 
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Entering EDI Group Profile User-Defined Information 
Use the EDI Trading Partner Profile User-Defined Info Table screen to define additional information to 
include in EDI documents sent to or received from a designated group profile. 

Note: Use a different screen to enter trading partner user-defined information. 

Important: EDI Support must customize the mapper for transactions that use information entered 
on this screen. 

To enter group profile user-defined information: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Use the Edit Tables hot key, select User Defined, and press Enter to display the EDI Trading 
Partner Profile User-Defined Info Table screen. 

The system populates the ISA# and Name fields with view-only information from the EDI Group 
Profile Maintenance screen. 

4. In the Code field, enter information to use with a customized mapper. You can change this as 
needed instead of having to re-customize the mapper. 

5. In the Description field, enter a description of the corresponding code. This field is optional. 

6. Repeat steps 4 and 5 to enter additional codes. 

You can enter up to 10 user-defined codes. 

7. Press Esc to save this information and return to the EDI Group Profile Maintenance screen. 
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Changing EDI Group Profile Global Defaults 
Use the EDI Group Profile Global Info Table to change the default settings for flags that check for the 
following problems: 

• Out-of-sequence control numbers. 

• Duplicate purchase order numbers. 

• Line item quantities not matching minimum sales quantity. 

The default entry for each field is N. If you enter Y in any of the following fields, the system displays an 
asterisk (*) next to the corresponding flag name on the EDI Group Profile Maintenance screen to show 
that this check is activated. The flag names are located below the hot keys on the screen. 

Also use this table to indicate how this trading partner group sends their rebate reports and to indicate 
whether the part number matching routine for inbound documents compares the product information to 
internal Eclipse product numbers first rather than last. 

To change group profile global defaults: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Use the Global Settings hot key to display the EDI Group Profile Global Info Table screen. 

The Group# and Name fields identify the group for which you are entering the global 
information. 

4. Complete the following fields, as needed: 

Field Description 
Ignore GS Ctrl # 
Mismatch 
Warnings 

Indicate whether the system should ignore mismatch warnings when an 
inbound document arrives with an out-of-sequence functional group control 
number. 
• Y - The system does not send a message to the EDI Administrator. When a Y 

is entered in this field, the system displays an asterisk (*) next to the Ctrl# 
field below the hot keys. 

• N - The system sends a message to the EDI Administrator, identifying the 
document with the out-of-sequence control number. This is the default. 
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Field Description 
Check for Duplicate 
PO #s 

Indicate whether the system should check incoming orders for duplicate 
purchase order numbers. 
• Y - After you enter a Y in this field, the system prompts you to specify the 

number of previous days to check for duplicate numbers. The system 
displays the number you enter here next to the Dup PO Days field below the 
hot keys. Before creating a new sales order from an incoming 850, the 
system checks the existing sales orders from the same customer for duplicate 
purchase order or release numbers. It checks all the non-canceled orders 
within the number of days specified. If a duplicate is found, the system sends 
the document to the EDI Error Queue. 

Note: The 850 can be re-queued by removing the Duplicate P/O Check, re-
queuing the document, and resetting the Duplicate P/O Check. 

• N - The system creates a sales order for every incoming 850, regardless of 
the purchase order and release number the customer assigned to the order. 
This is the default. 

 Round Up To 
Minimum Sales 
Quantity 

Indicate whether the system should round up the order quantity for a product 
on an incoming 830, 846, 850, or 862 order when a minimum package quantity 
is defined but the customer did not order that quantity. 
• Y - The system rounds up the order quantity. 
• N - The system does not round up the order quantity. This is the default. 
• Q - The system sends the order to the Remote Order Entry Review Queue for 

review. 

Book Letter of 
Credit Vendor 

Indicate whether this trading partner group must send their 844s from a rebate 
purchase order created by the rebate report book letters of credit option. 
• Y - This vendor must use the rebate report book letters of credit option and 

send their 844 from the rebate purchase order. 
• N - This vendor is not required to use the rebate report book letters of credit 

option and can send their 844 from the rebate report. 

Match on Eclipse 
Internal PN First 

Indicate whether the part number matching routine for inbound documents 
compares the product information to internal Eclipse product numbers first 
rather than last. The default is N. 
• Y - First. 
• N - Last. 

Use Branch 
Customer D&B in 
N104 

Set the field to Y for outbound mappers to check the branch customer record to 
see if the D&B number is populated. 
If the branch record's D&B number is populated, the system sends that number 
for the N104 EDI ID. The system calculates the N103 qualifier from the N104 
ID. If it is a DUNS number, the system sends 1. If it is a DUNS+4 number, the 
system sends 9. Otherwise, if the document is a vendor facing document, the 
system sends 92, Defined by Buyer. If it is a customer facing document, the 
system sends 91, Defined by Seller. 

Search Product 
Index for Parts 

Indicate if you want to skip searching product descriptions for EDI documents 
for this trading partner. Set this field to Yes to override the global setting in the 
Prevent Search for EDI Part Identifiers in Product Index control maintenance 
record. 



Solar Eclipse Electronic Data Interchange (EDI) 

73 

Field Description 
Transaction Types 
In Separate 
Envelope 

enter Y to place documents for this trading partner in separate outbound FTP 
files. 
To envelope documents of different types in a single FTP file, leave this field 
set to N. 

Important: If you have a value in the Alternate Interchange ID field, the 
system does not sent documents in separate envelopes regardless of setting this 
field to Yes. 

5. Press Esc to save the changes and return to the EDI Group Profile Maintenance screen. 
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Copying EDI Group Profiles 
To create a new group profile that uses the same transaction sets, mappers, and additional document 
information already defined for another group profile, you can copy the information from that profile. 

You can copy a group profile from the same or another trading partner profile. 

To copy a group profile: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Trading Partner ID field, enter the trading partner to whose record to copy the group 
profile. 

3. Select a Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

4. Use the Copy Profile hot key and press Enter to display the copy prompts. 

5. In the Copy From Trading Partner ID field, verify that the trading partner ID is the ID that 
contains the group you want to copy. If it is not, delete the entry in this field, press F10, and 
select the correct trading partner ID. 

6. In the Copy From Group ID field, press F10, select the group profile to copy, and press Enter. 

Note: The copied profile overwrites any group profile information in the new record, 
except for the account numbers or alternate IDs. 

The system returns to the EDI Trading Partner Profile Maintenance screen. 

7. Enter the customer or vendor associated with this new profile in the Customer Name or Vendor 
Name field on the EDI Trading Partner Profile Maintenance screen. This setting links the account 
to the profile. 

Note: The account number cannot be assigned to any other EDI trading partner profile. 
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Assigning Multiple Accounts to Customer Group IDs 
Use the Multiple Accts Maintenance screens in EDI Trading Partner Profile Maintenance to assign 
multiple customer bill-to accounts to the same trading partner group profile. 

For example, a large corporation might have multiple customer accounts, which all use the same trading 
partner profile. 

Set up a trading partner group profile for one customer account. Then use the following procedure to 
specify the additional customer accounts that use this profile. 

To assign multiple customer accounts to customer group IDs: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. To change the column heading in the group information section to Customer Name, use the 
View hot key. 

3. Position the cursor on the customer account name and use the Multiple Bill-To Accts hot key to 
display the Multiple Bill-To Accts Maintenance screen. 

The screen displays the following information: 

Field Description 
Customer Name Name of customer account. 

BT Displays an asterisk (*) if customer is a bill-to account. 

ST Displays an asterisk (*) if customer is a ship-to account. 

PT Not used for customers. 

SF Not used for customers. 

BT Acct# Internal account number for a bill-to customer or the bill-to customer associated 
with the ship-to account. 

Note: Assign a bill-to account if you plan to send EDI invoices to this customer. 
To automate batch processes for EDI, see Defining Customer Invoice Printing 
Options. 

ST Acct# Internal account number for a ship-to customer. 

4. In the Customer Name column, position the cursor on a blank line and enter the name of another 
customer that uses the same trading partner group profile. 

The system populates the remaining fields for that customer. 

5. Use the following hot keys, as needed: 

Hot Key Description 
Export Downloads the screen information and the Receive/Send codes in a .csv 

spreadsheet format to open in a spreadsheet program, such as Excel. 

Press Alt+X and browse your desktop to enter the file path and file name 
to save the file for later management. 
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Hot Key Description 
Import Import additional customers and their current Receive/Send codes. 

Press Alt+I to browse your desktop and select the file to import into the system. 
The import does not overwrite existing data. If any import errors occur, such as 
duplicate entries, the system sends a user message and a report to Your Hold 
File for review. 
File requirements: 
• The file must be a comma-separated file (.csv format). 
• Column headers expected by the import utility: Entity Name, BT/PT, 

ST/SF, Receive Code, and Send Code. 
• The ST/SF column cannot be blank. 

5. To add additional customers, repeat step 4. 

6. Press Esc to save the data and exit the screen. 
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Assigning Multiple Accounts to Vendor Group IDs 
Use the Multiple Accts Maintenance screens in EDI Trading Partner Profile Maintenance to assign 
multiple vendor accounts to the same trading partner group profile. 

For example, a large corporation may have multiple vendor accounts, which all use the same trading 
partner profile. 

Set up a trading partner group profile for one vendor account. Then use the following procedure to specify 
the additional vendor accounts that use this profile. 

To assign multiple vendor accounts to vendor group IDs: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. To change the column heading in the group information section to Vendor Name, use the View 
hot key. 

3. Position the cursor on the vendor account name and use the Multiple Ship-From Accts hot key 
to display the Multiple Ship-From Accts Maintenance screen. 

The screen displays the following information: 

Field Description 
Vendor Name Name of vendor account. 

BT Not used for vendors. 

ST Not used for vendors. 

PT Displays an asterisk (*) if vendor is a pay-to account. 

SF Displays an asterisk (*) if vendor is a ship-from account. 

PT Acct# Internal account number for a pay-to vendor or the pay-to vendor associated 
with the ship-from account. 

Note: To define EDI as the default print status for outgoing P/Os, see Entering 
Miscellaneous Vendor Information. 

SF Acct# Internal account number for a ship-from vendor. 

4. In the Vendor Name column, position the cursor on a blank line and enter the name of a vendor 
that uses the same trading partner group profile. 

The system populates the remaining fields for that vendor. 

5. Use the following hot keys, as needed: 

Hot Key Description 
Export Downloads the screen information and the Receive/Send codes in a .csv 

spreadsheet format to open in a spreadsheet program, such as Excel. 
Press Alt+X and browse your desktop to enter the file path and file name to 
save the file for later management. 
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Hot Key Description 
Import Import additional vendors and their current Receive/Send codes. 

Press Alt+I to browse your desktop and select the file to import into the system. 
The import does not overwrite existing data. If any import errors occur, such as 
duplicate entries, the system sends a user message and a report to Your Hold 
File for review. 
File requirements: 
• The file must be a comma-separated file (.csv format). 
• Column headers expected by the import utility: Entity Name, BT/PT, 

ST/SF, Receive Code, and Send Code. 
• The ST/SF column cannot be blank. 

5. To add additional vendors, repeat step 4. 

6. Press Esc to save the data and exit the screen. 
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EDI Integrated Transactions 
The Eclipse system is capable of receiving and printing any valid ANSI X12 formatted transaction. Any 
inbound document not listed in the following tables can be translated using the EDI.PRINT.DOC print 
routine, which produces a report that is placed in the Hold file. 

The following tables list the transactions integrated into the system. All documents listed have a generic 
mapper that you can use with many trading partners. Some trading partners require customization to the 
generic mappers. Customization is subject to a custom programming charge for those clients who do not 
subscribe to EDI Platinum support. For those clients who subscribe to EDI Platinum support, most 
customized mappers are provided at no charge. 

Contact EDI Support to obtain a quote for mapper customization. 

Customer Transaction Set 
The following table lists the customer transactions integrated into the system: 

Trans 
Set 

Description Inbound Outbound 

810 Generic Invoice: Customization is likely.   X 

830 Forecast Schedule: Produces sales order bid. Customization is 
likely. 

X   

840 Request for Quote (RFQ): Produces sales order bid X   

843 Response to RFQ   X 

850 Purchase Order/Sales Order X   

855 P/O Acknowledgment: Acknowledges customer order   X 

856 Advance Ship Notice   X 

857 Advance Ship Notice & Billing   X 

860 Purchase Order Change Requests: creates Hold file report only X   

865 P/O Acknowledgment With Change: Acknowledges customer 
order with changes 

  X 

997 Functional Acknowledgments X X 

Vendor Transaction Set 
The following table lists the vendor transactions integrated into the system. 

Trans 
Set 

Description Inbound Outbound 

810 Invoice X   

820 Generate Remittance Advice   X 

844 Product Transfer Account Adjustment/Rebate Reporting with 
Book Letters of Credit option 

  X 

845 Price Authorization Acknowledgment: Creates price contract. X   
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Trans 
Set 

Description Inbound Outbound 

849 Response to Product Transfer Account Adjustment when used 
with Book Letters of Credit option. 

X   

850   Purchase Order/Sales Order   X 

852 Product Activity Data: Customization likely .   X 

855 P/O Acknowledgment: Type 1 - Produces a vendor purchase 
order or creates an order generated by the vendor. 

X   

855 P/O Acknowledgment: Type 2 - Updates expected ship dates 
and compares pricing. This type of 855 does not update pricing, 
it only shows a comparison between pricing on the purchase 
order and pricing in the 855. 

X   

856 Advance Ship Notice X   

867 Point of Sale Reporting   X 

997 Functional Acknowledgments X X 
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ANSII X12 Transaction Set 
The Accredited Standards Committee (ASC) of the American Standards Institute has defined the 
following set of EDI transactions. Asterisks (*) denote transactions that have been integrated into the 
Eclipse system as inbound transactions, outbound transactions, or both. 

Contact EDI Support about viewing or printing transactions that have not yet been integrated. 

Transaction Description 
100 Insurance Plan Description 

101 Name and Address Lists 

104 Air Shipment Information 

105 Business Entity Filings 

106 Motor Carrier Rate Proposal 

107 Request for a Motor Carrier Rate Proposal 

108 Response to a Motor Carrier Rate Proposal 

109 Vessel Content Details 

110 Air Freight Details and Invoice 

112 Property Damage Report 

120 Vehicle Shipping Order 

121 Vehicle Service 

124 Vehicle Damage 

125 Multi-Level Railcar Load Details 

126 Vehicle Application Advice 

127 Vehicle Baying Order 

128 Dealer Information 

129 Vehicle Carrier Rate Update 

130 Student Educational Record (Transcript) 

131 Student Educational Record (Transcript) Acknowledgment 

135 Student Loan Application 

138 Testing Results Request and Report 

139 Student Loan Guarantee Result 

140 Product Registration 

141 Product Service Claim Response 

142 Product Service Claim 

143 Product Service Notification 

144 Student Loan Transfer and Status Verification 

146 Request for Student Educational Record (Transcript) 

147 Response to Request for Student Educational Record (Transcript) 
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Transaction Description 
148 Report of Injury 

149 Notice of Tax Adjustment or Assessment 

150 Tax Rate Notification 

151 Electronic Filing of Tax Return Data Acknowledgment 

152 Statistical Government Information 

153 Unemployment Insurance Tax Claim or Charge Information 

154 Uniform Commercial Code Filing 

155 Business Credit Report 

157 Notice of Power of Attorney 

159 Motion Picture Booking Confirmation 

160 Transportation Automatic Equipment Identification 

161 Train Sheet 

163 Transportation Appointment Schedule Information 

170 Revenue Receipts Statement 

175 Court and Law Enforcement Notice 

176 Court Submission 

180 Return Merchandise Authorization and Notification 

185 Royalty Regulatory Report 

186 Insurance Underwriting Requirements Reporting 

188 Educational Course Inventory 

189 Application for Admission to Educational Institutions 

190 Student Enrollment Verification 

191 Student Loan Pre-Claims and Claims 

194 Grant or Assistance Application 

195 Federal Communications Commission (FCC) License Application 

196 Contractor Cost Data Reporting 

197 Real Estate Title Evidence 

198 Loan Verification Information 

199 Real Estate Settlement Information 

200 Mortgage Credit Report 

201 Residential Loan Application 

202 Secondary Mortgage Market Loan Delivery 

203 Secondary Mortgage Market Investor Report 

204 Motor Carrier Load Tender 

205 Mortgage Note 

206 Real Estate Inspection 
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Transaction Description 
210 Motor Carrier Freight Details and Invoice 

211 Motor Carrier Bill of Lading 

212 Motor Carrier Delivery Trailer Manifest 

213 Motor Carrier Shipment Status Inquiry 

214 Transportation Carrier Shipment Status Message 

215 Motor Carrier Pick-up Manifest 

216 Motor Carrier Shipment Pick-up Notification 

217 Motor Carrier Loading and Route Guide 

218 Motor Carrier Tariff Information 

219 Logistics Service Request 

220 Logistics Service Response 

222 Cartage Work Assignment 

223 Consolidators Freight Bill and Invoice 

224 Motor Carrier Summary Freight Bill Manifest 

225 Response to a Cartage Work Assignment 

242 Data Status Tracking 

244 Product Source Information 

248 Account Assignment/Inquiry and Service/Status 

249 Animal Toxicological Data 

250 Purchase Order Shipment Management Document 

251 Pricing Support 

252 Insurance Producer Administration 

255 Underwriting Information Services 

256 Periodic Compensation 

260 Application for Mortgage Insurance Benefits 

261 Real Estate Information Request 

262 Real Estate Information Report 

263 Residential Mortgage Insurance Application Response 

264 Mortgage Loan Default Status 

265 Real Estate Title Insurance Services Order 

266 Mortgage or Property Record Change Notification 

267 Individual Life 

268 Annuity Activity 

270 Eligibility 

271 Eligibility 

272 Property and Casualty Loss Notification 
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Transaction Description 
273 Insurance/Annuity Application Status 

275 Patient Information 

276 Health Care Claim Status Request 

277 Health Care Claim Status Notification 

278 Health Care Services Review Information 

280 Voter Registration Information 

285 Commercial Vehicle Safety and Credentials Information 
Exchange 

286 Commercial Vehicle Credentials 

288 Wage Determination 

290 Cooperative Advertising Agreements 

300 Reservation (Booking Request) (Ocean) 

301 Confirmation (Ocean) 

303 Booking Cancellation (Ocean) 

304 Shipping Instructions 

309 U.S. Customs Manifest 

310 Freight Receipt and Invoice (Ocean) 

311 Canadian Customs Information 

312 Arrival Notice (Ocean) 

313 Shipment Status Inquiry (Ocean) 

315 Status Details (Ocean) 

317 Delivery/Pickup Order 

319 Terminal Information 

322 Terminal Operations and Intermodal Ramp Activity 

324 Vessel Stow Plan (Ocean) 

325 Consolidation of Goods in Container 

326 Consignment Summary List 

350 U.S. Customs Status Information 

352 U.S. Customs Carrier General Order Status 

353 U.S. Customs Events Advisory Details 

354 U.S. Customs Automated Manifest Archive Status 

355 U.S. Customs Acceptance/Rejection 

356 U.S. Customs Permit to Transfer Request 

357 U.S. Customs In-Bond Information 

358 U.S. Customs Consist Information 

361 Carrier Interchange Agreement (Ocean) 

362 Cargo Insurance Advice of Shipment 
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Transaction Description 
404 Rail Carrier Shipment Information 

410 Rail Carrier Freight Details and Invoice 

414 Rail Carhire Settlements 

417 Rail Carrier Waybill Interchange 

418 Rail Advance Interchange Consist 

419 Advance Car Disposition 

420 Car Handling Information 

421 Estimated Time of Arrival and Car Scheduling 

422 Shipper's Car Order 

423 Rail Industrial Switch List 

425 Rail Waybill Request 

426 Rail Revenue Waybill 

429 Railroad Retirement Activity 

431 Railroad Station Master File 

432 Rail Description 

433 Railroad Reciprocal Switch File 

434 Railroad Mark Register Update Activity 

435 Standard Transportation Commodity Code Master 

436 Locomotive Information 

437 Railroad Junctions and Interchanges Activity 

440 Shipment Weights 

451 Railroad Event Report 

452 Railroad Problem Log Inquiry or Advice 

453 Railroad Service Commitment Advice 

455 Railroad Parameter Trace Registration 

456 Railroad Equipment Inquiry or Advice 

460 Railroad Price Distribution Request or Response 

463 Rail Rate Reply 

466 Rate Request 

468 Rate Docket Journal Log 

470 Railroad Clearance 

475 Rail Route File Maintenance 

485 Ratemaking Action 

486 Rate Docket Expiration 

490 Rate Group Definition 

492 Miscellaneous Rates 
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Transaction Description 
494 Rail Scale Rates 

500 Medical Event Reporting 

501 Vendor Performance Review 

503 Pricing History 

504 Clauses and Provisions 

511 Requisition 

517 Material Obligation Validation 

521 Income or Asset Offset 

527 Material Due-In and Receipt 

536 Logistics Reassignment 

540 Notice of Employment Status 

561 Contract Abstract 

567 Contract Completion Status 

568 Contract Payment Management Report 

601 U.S. Customs Export Shipment Information 

602 Transportation Services Tender 

620 Excavation Communication 

625 Well Information 

650 Maintenance Service Order 

715 Intermodal Group Loading Plan 

805 Contract Pricing Proposal 

806 Project Schedule Reporting 

*810* Invoice 

811 Consolidated Service Invoice/Statement 

812 Credit/Debit Adjustment 

813 Electronic Filing of Tax Return Data 

814 General Request 

815 Cryptographic Service Message 

816 Organizational Relationships 

818 Commission Sales Report 

819 Operating Expense Statement 

*820* Payment Order/Remittance Advice 

821 Financial Information Reporting 

822 Account Analysis 

823 Lockbox 

824 Application Advice 
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Transaction Description 
826 Tax Information Exchange 

827 Financial Return Notice 

828 Debit Authorization 

829 Payment Cancellation Request 

*830* Planning Schedule with Release Capability 

831 Application Control Totals 

832 Price/Sales Catalog 

833 Mortgage Credit Report Order 

834 Benefit Enrollment and Maintenance 

835 Health Care Claim Payment/Advice 

836 Procurement Notices 

837 Health Care Claim 

838 Trading Partner Profile 

839 Project Cost Reporting 

*840* Request for Quotation 

841 Specifications/Technical Information 

842 Nonconformance Report 

*843* Response to Request for Quotation 

*844* Product Transfer Account Adjustment 

*845* Price Authorization Acknowledgment/Status 

846 Inventory Inquiry/Advice 

847 Material Claim 

848 Material Safety Data Sheet 

*849* Response to Product Transfer Account Adjustment 

*850* Purchase Order 

851 Asset Schedule 

*852* Product Activity Data 

853 Routing and Carrier Instruction 

854 Shipment Delivery Discrepancy Information 

*855* Purchase Order Acknowledgment 

*856* Ship Notice/Manifest 

*857* Shipment and Billing Notice 

858 Shipment Information 

859 Freight Invoice 

860 Purchase Order Change Request - Buyer Initiated 

861 Receiving Advice/Acceptance Certificate 
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Transaction Description 
862 Shipping Schedule 

863 Report of Test Results 

864 Text Message 

*865* Purchase Order Change Acknowledgment/Request - Seller 
Initiated 

866 Production Sequence 

*867* Product Transfer and Resale Report 

868 Electronic Form Structure 

869 Order Status Inquiry 

870 Order Status Report 

871 Component Parts Content 

872 Residential Mortgage Insurance Application 

*875* Grocery Products Purchase Order 

876 Grocery Products Purchase Order Change 

877 Manufacturer Coupon Family Code Structure 

878 Product Authorization/De-authorization 

879 Price Information 

*880* Grocery Products Invoice 

881 Manufacturer Coupon Redemption Detail 

882 Direct Store Delivery Summary Information 

883 Market Development Fund Allocation 

884 Market Development Fund Settlement 

885 Retail Account Characteristics 

886 Customer Call Reporting 

887 Coupon Notification 

888 Item Maintenance 

889 Promotion Announcement 

891 Deduction Research Report 

893 Item Information Request 

894 Delivery/Return Base Record 

895 Delivery/Return Acknowledgment or Adjustment 

896 Product Dimension Maintenance 

920 Loss or Damage Claim - General Commodities 

924 Loss or Damage Claim - Motor Vehicle 

925 Claim Tracer 

926 Claim Status Report and Tracer Reply 

928 Automotive Inspection Detail 
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Transaction Description 
940 Warehouse Shipping Order 

943 Warehouse Stock Transfer Shipment Advice 

944 Warehouse Stock Transfer Receipt Advice 

945 Warehouse Shipping Advice 

947 Warehouse Inventory Adjustment Advice 

980 Functional Group Totals 

990 Response to a Load Tender 

996 File Transfer 

*997* * Functional Acknowledgment 

998 Set Cancellation 



EDI Maintenance Overview 

90 

EDI Maintenance Overview 
Use the following programs to maintain EDI queues and monitor the daily activities of EDI: 

• EDI Activity Log Viewing - Displays a transmission summary of connection attempts, actual 
connections, and transaction information, such as whether a document was sent or received. 

View the log daily to track transmission activity. 

• EDI Outgoing Status Queue - Provides a summary of outgoing documents that are waiting to be 
sent, have been enveloped, or have been sent, but whose receipt has not yet been acknowledged by 
the recipient. When a trading partner acknowledges receipt of a sent item, the system removes the 
item from the queue. 

Monitor the queue daily and follow up on items that remain in the queue too long. 

• EDI Error Queue Maintenance - Provides a list of all inbound document errors. Generally, when an 
error occurs, the system does not process the transaction. 

Follow up daily on the reported errors, so the transactions can be resent or reprocessed. 

• EDI Archive Maintenance - Provides access to records stored in the archives. 

Use the archives to research problems by viewing the data transmitted in the documents and 
envelopes. 

Document archives, active and inactive: 

• EDI Inbound Document Archive Maintenance 

• EDI Inbound Document Inactive Archive Maintenance 

Envelope archives, active and inactive: 

• EDI Inbound Envelope Archive Maintenance 

• EDI Inbound Envelope Inactive Archive Maintenance 

• EDI Outbound Envelope Archive Maintenance 

• EDI Outbound Envelope Inactive Archive Maintenance 
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Monitoring the EDI Activity Log 
The EDI activity log contains a summary of transmission connection attempts, actual connections, and 
transaction information, such as whether a document was sent or received. The log is a permanent 
repository for this information and maintenance is not required. 

Refer to the EDI Error Glossary for explanations of the messages that can display in the queue. 

Use the EDI Activity Log Viewing screen to monitor the daily activity logged by EDI programs. 

To monitor the EDI activity log: 

1. From the System > Systems Programming > EDI > EDI Maintenance menu, select EDI 
Activity Log Viewing to display the EDI Activity Log Viewing screen. 

Note: If prompted, log on to the character-based system. 

2. To filter the list, use the Sel hot key to display the Selection Criteria screen. 

3. Make entries in as many fields as you want or leave the screen blank to display all entries in the 
log. 

Field Description 
Select Pattern String of characters in the first two lines of the log entry comment field. 

Select User ID ID of user responsible for the log entry.  Press F10 to display a list of user IDs. 

Select Sec Level Security level on the log entry. 

Select Source Source of the log entry. Press F10 to display a list of sources. 

Select Open Only Enter one of the following: 
• Y - Displays log entries that are currently open on your job queue. 
• N - Displays all log entries. The default is N. 

Select As Of Date Positions the cursor on the last item entered on or before this date. 

4. Press Esc to display the selected log entries on the EDI Activity Log Viewing screen. 

The log entries display in date and time sequence, with the most recent entries listed first. They 
display the following information: 

Field Description 
User ID User who performed the action that generated the log entry. 

Date Date of the log entry. 

Time Time of the log entry. 

Comment System- or user-generated comments describing the log entry. 

5. Use the following hot keys, as needed, to change the view: 

Hot Key Description 
Synop Changes the expanded view to display each comment's first line only. 

Expand Changes the synopsis view to display the entire text of each log entry's comment. 
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By default, the entire text of each log entry's comment displays. 

6. If a log entry contains a Customer #, Product #, Sales Order #, or Invoice #, use the View or 
Edit hot keys to view or edit the associated records. 

If the log entry contains multiple IDs, the hot key displays a list from which you can select the 
record you want to view. 

7. Use the remaining hot keys on the EDI Activity Log Viewing screen to perform the following 
functions: 

Hot Key Function 
New Displays the EDI Log Entry screen, where you can create a new entry in the EDI log. 

Note: We recommend that you not use this hot key. 

Edit Item Displays the EDI Log  Entry screen, where you can edit the log entry on which the 
cursor is positioned. 

Note: We recommend that you not use this hot key. If you do, we recommend that 
you use this option only to add information.  Editing or removing a system-generated 
comment may result in misleading or incorrect information. 

Append Displays the Append Message screen, where you can append a comment to the log 
entry. 

Note: We recommend that you not use this hot key. 

UserQ Displays the User Job Queue Viewing screen, where you can enter a user ID and view 
that user's job queue. 

JobQ Displays the Call Tracking Entry screen, where you can create a tracker for a 
customer, vendor, or user. 

Note: All activity log viewing screens use the same screen layout and hot keys. Hot keys 
that should not be used with the EDI log, even though they are functional, are so 
noted in the table. 

8. Press Esc to exit this screen. 
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Maintaining the EDI Error Queue 
The EDI Error Queue Maintenance screen displays inbound and outbound document errors that have not 
been addressed. 

For example, the system may receive a document without a mapping routine set up or without a definition 
in EDI Trading Partner Profile Maintenance. An inbound document from an undefined trading partner 
displays the following error message: No Trading Partner Profile Found. 

After addressing an error, you can requeue the transaction or delete the entry from the queue. 

You should monitor and maintain this queue daily. 

To maintain the EDI Error Queue: 

1. From the System > Systems Programming > EDI > EDI Maintenance menu, select EDI Error 
Queue Maintenance to display the EDI Errors screen. 

Note: If prompted, log on to the character-based system. 

2. Select an error and press Enter to display the EDI Error Queue Maintenance screen. 

This screen displays the raw data that pertains to the error. The first line of data shows the error 
message. 

3. Refer to the EDI Error Glossary for an explanation of the message and action to take. 

4. Complete the following tasks, as needed: 

To... Use this hot key... 
extract information from the displayed data 
and partially set up a new trading partner 
profile 

Auto Setup 
When Auto Setup is finished, you must manually set up 
the rest of the trading partner profile. 

reprocess the displayed data Requeue 
After the requeue process runs, the system displays the 
EDI Error Queue Maintenance screen. 
• If successful, the system deletes the entry from 

the queue. 
• If unsuccessful, the system reenters the error in the 

EDI Errors list. 

display the EDI Trading Partner Profile 
Maintenance screen, where you can create 
a new EDI trading partner profile 

Profile Maintenance 

delete the queue entry displayed on the 
screen 

Delete 
The system prompts you to confirm the deletion. 

display the transaction data on the Hold 
Entry Pre-View screen 

Print 
When you press Esc to exit this screen, the system 
prompts you to save the report in the Hold file and then 
displays the EDI Error Queue Maintenance screen. 

enter the bill-to or ship-to (N1-BT/N1-ST) 
data for the trading partner in response to a 
5 - Partner Sub-ID Not Found error 

Add Sub-ID 
At the prompt, enter the correct Eclipse customer and 
then requeue the document. 
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5. Press Esc to exit the EDI Error Queue Maintenance screen and return to the EDI Errors screen. 

6. Press Esc again to exit the EDI Errors screen. 
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Reviewing the EDI Outgoing Status Queue 
The EDI Outgoing Status Queue lists outgoing EDI documents that are in various stages of being sent. 
Statuses show which documents are waiting to be sent, have been enveloped, have been sent but not yet 
acknowledged by the recipient, or were sent with errors. Monitor and maintain this queue daily. 

When a document remains in the queue too long or the status changes to ACK ERROR, you need to 
research the problem and handle the error. 

To review the EDI Outgoing Status Queue: 

1. From the System > Systems Programming > EDI > EDI Maintenance menu, select EDI 
Outgoing Status Queue to display the EDI Outgoing Status Queue. 

2. Use the optional header fields to limit the display in the queue, if needed. 

Field Description 
Begin Date First date for which to view items in the queue. 

End Date Last date for which to view items in the queue. 

Trading Partner Trading partner name. 

Document Type Document type number. 

Status Queue status. 

3. Click Update to display the following information: 

Field Description 
Trading Partner Name of the trading partner to which you are transmitting the EDI document. 

Doc Type of document being sent, such as an 852 or 810. 

Reference ID# ID used to identify the document being sent, such as a purchase order 
number or an invoice number. 

Status Status of the outgoing document: Send, Sent, Hold, Enveloped, or Ack Error. 

Entry Date/Time Date and time assigned to the document when it entered the queue. 

997 EDI ID assigned to each document on a next available number basis. 
• Blank - Waiting for status or to be cleared. 
• - Document rejected. 
• - Document accepted, but errors were noted. 

Vendor Name Name of the vendor to which you are transmitting the EDI document. 

4. Review the queue and address any errors or handle documents, as needed. See below for more 
options on this queue. 
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More Options for the EDI Outgoing Status Review Queue 

The following tasks can be completed from the EDI Outgoing Status Review Queue: 

Option Description 
View the envelope information. Change View > Views > Envelope Details 

View the document data as your trading 
partner sees it (raw data format) to confirm that 
the correct information is being sent 

File > View Document 

delete a document from the queue if an item 
with an Ack Error status was rejected by the 
trading partner due to a fatal error. A fatal error 
has a code of R, M, W, or X. 

File > Delete Document 
Use this option if an item with an ACK ERROR status was 
rejected by the trading partner due to a fatal error, indicated by 
code R, M, W, or X. The system records deletions in the EDI 
Activity Log. 

delete multiple documents older than a 
designated date from the queue. 

File > Delete by Date 
At the prompt, enter the date to delete documents from that 
date and older. The system records deletions in the EDI 
Activity Log. 

Note: If you use the Header fields to filter the list of 
documents displayed in the queue, the Delete By Date option 
only applies to the items on the selected list. 

change the status of outbound documents from 
Send to Hold or from Hold to Send 

Note: You can change the SENT status to 
SEND only for the 820, 852, and 867 
documents. You cannot change the Enveloped 
and Ack Error statuses. 

File > Change Status 
Select Hold or Send and click OK. 
Press and hold the Ctrl key to select more than one document. 
The system saves changes in the EDI Activity Log. This record 
contains the EDI Reference ID and the statuses before and 
after the change. 

view the required 997 ID for a queue item with 
a status of Sent 

Select the Status for the selected document and let the cursor 
hover to display the 997 ID. 
A functional acknowledgement must contain this ID for the 
system to clear the item from this queue. 
Use with EDI Inbound Document Archive Maintenance. If the 
system does not clear an item off the EDI Outgoing Status 
Queue when the functional acknowledgment is received, use 
these columns to compare the required ID with the received 
ID. 

manually post the item to the change log and 
clear it from the queue cleanly to keep to track 
of the documents. 

File > Manual 997 
The system prompts you to confirm the posting. 
Use this option if an item with the ACK ERROR status was 
accepted with non-fatal errors, indicated by code E. 

Note: When you clear documents from the queue using this 
option, the system makes an entry in the EDI Activity Log. 
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EDI Outgoing Document Statuses 
The system places a document in the EDI Outgoing Status Queue with an initial status of Send or Hold. 
The Default Outgoing Transmission Status field on the EDI Add'l Doc Info screen in Trading Partner 
Group Maintenance determines the initial status. 

When a call to the network starts, the system envelopes items with the Send status into an outgoing file 
and changes each item status to Enveloped. After the system determines that the network call has 
completed and the transmission was successful, it changes each item status to Sent. 

The system receives 997 acknowledgments for sent items from the trading partners and does one of the 
following: 

• If a 997 shows no errors, the system removes the document from the queue. 

• If a 997 contains an error code, the document remains in the queue and the status changes to Ack 
Error. When this occurs, you need to resolve the error. 

The following table describes the outgoing EDI document statuses: 

Status Description 
Send The document is waiting to be sent to the network set up for that trading partner in 

Trading Partner Profile Maintenance. 
When a call to that network is started, all items with a Send status are enveloped into an 
outgoing file and their status changes to Enveloped. After the system determines the 
network call is complete and the transmission was successful, their status changes to 
Sent. 

Note: As of Release 9.0.4, if the document reminder is sent via e-mail and contains 
HTML content, the system respects the formatting ensuring easier reading. 

Sent The document has been sent to the network, but the recipient has yet been to 
acknowledge the document. 
The document stays in the queue with a Sent status until the recipient sends back a 997 
Functional Acknowledgement. The system matches the 997 with the Sent document, and 
then removes the document from the queue. An entry in the change log of the order reads 
** EDI 997 ACKNOWLEDGEMENT RECEIVED **. 

Enveloped The document is being transmitted. 
If the status remains Enveloped after connection to the network is complete, the 
document was not successfully transmitted to the network. Check the EDI Activity Log 
Viewing screen for a Network Call Complete entry and the corresponding Transmission 
Summary Report. 

Hold The document is waiting to be sent, but has been placed on hold. 
Use the Change Status hot key to place items on Hold or enter hold as the Default 
Outgoing Transmission Status in Trading Partner Group Maintenance. The Hold status 
remains in effect until you manually change it to Send using the Change Status hot key. 
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Status Description 
Ack Error In response to the document that was transmitted, the trading partner has sent a 997 

Functional Acknowledgement with one of the following codes: 
• E - The document was accepted, but with non-fatal errors. 

In the EDI Outgoing Status Queue, use the Manual 997 hot key to manually post the 
item and clear it from the queue. 

• R - The document was rejected due to fatal errors. 
 
Contact the trading partner to determine what caused the error. Resend the document 
after resolving the problem. Then use the Delete hot key to remove the Ack Error from 
the queue. 
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Viewing EDI Outgoing Document Data 
From the EDI Outgoing Status Queue, you can select a document and view the raw data. You can also use 
the Edit Data hot key to display the screen in edit mode. Viewing and editing raw data can help 
determine errors that are causing documents to not transmit successfully. 

To view EDI outgoing document data: 

1. From the System > Systems Programming > EDI > EDI Maintenance menu, select EDI 
Outgoing Status Queue to display the EDI Outgoing Status Queue screen. 

Note: If prompted, log on to the character-based system. 

2. Use the View hot key to display the EDI Outgoing Status Queue Viewing screen. 

This screen displays the raw data in the selected EDI document. 

3. To edit the displayed data, do the following: 

• Use the Edit Data hot key to change the screen to edit mode. 

• Make changes to the data, as needed. 

• Press Esc to save the changes. 

Note: The changes do not display. 

4. Press Esc to return to the EDI Outgoing Status Queue screen. 
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Handling Errors on the EDI Outgoing Status Queue 
When the system receives 997 acknowledgments from trading partners for sent items, one of the 
following occurs in the EDI Outgoing Status Queue: 

• If the 997 shows no errors, the system removes the document from the queue. 

• If the 997 contains an error code , the document remains in the queue and the status reads ACK 
ERROR. 

• If the 997 contains an alert code , the document remains in the queue and the status reads ACK 
ERROR. 

When this occurs, you need to find the error code and resolve the error. 

Finding an Error Code 
The Ack Error status displays when a trading partner has sent a 997 functional acknowledgment with an 
error code E for accepted with errors, or R, M, W, or X for rejected. You can find the 997 error code in 
one of the following places: 

• Change log in the header of the order 

On the Header screen in order entry, use the Change Log hot key to display the Change Log 
Viewing screen. From this screen, use the Change ShipDate/Inv# hot key and select ALL. The 
change log entries for all the generations of the order display. The error entries should read ** EDI 
997 ACK ERROR CODE: E** for errors noted, or ** EDI 997 ACK ERROR CODE: R** for 
errors rejected. 

• Inbound Document Archive 

On the Inbound Document Archive screen, use the Select hot key to list the 997 documents. Use 
the View hot key to display the document data. Locate the error code in the AK5 segment. Below 
are two examples of 997 data with error codes: 

The first example shows that the purchase orders being acknowledged were rejected (code R): 

ST*997*305362457 
AK1*PO*2171 
AK2*850*0001 
AK5*R 
AK2*850*0002 
AK5*R 
AK9*R*2*2*0 

The second example shows that the purchase order being acknowledged was accepted, but errors 
were noted (code E) 

SE*8*305362457 
ST*997*0181 
AK1*PO*182 
AK2*850*0001 
AK5*E 
AK9*E*1*1*1 
SE6*0181 
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Handling Errors 
The Ack Error status displays when a trading partner has sent a 997 functional acknowledgment with an 
E or R error code. Handle documents with these errors as follows: 

• E - The trading partner accepted the item with errors. 

In the EDI Outgoing Status Queue, use the Manual 997 hot key to manually post the item and 
clear it from the queue. 

• R, M, W, or X - The trading partner rejected the item. 

Contact the trading partner to determine what caused the error. Resend the document after 
resolving the problem. Then use the Delete hot key to remove the entry with the Ack Error status 
from the queue. 
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Sending EDI Transactions Overview 
After you have set up EDI trading partner profiles for outgoing transactions, the Eclipse system can send 
transactions to the customers and vendors associated with these profiles. 

Refer to the following topics for detailed information about sending EDI transactions: 

• Sending EDI 810 Invoices 

• Sending EDI 820 Remittance Advice Information 

• Sending EDI 820B Purchasing Activity Reports to WIT 

• Sending EDI 843 Responses to Requests for Quote 

• Sending EDI 844 Rebate Reports 

• Sending EDI 850 Purchase Orders 

• Sending EDI 852 Product Activity Reports 

• Sending EDI 855 Purchase Order Acknowledgments 

• Sending EDI 856 Advance Ship Notices 

• Sending EDI 857 Advance Ship Notices and Billing 

• Sending EDI 861 Receiving Advice Documents 

• Sending EDI 865 P/O Acknowledgments With Change 

• Sending EDI 867 Product Transfer and Resale Reports 

• Sending EDI 997 Functional Acknowledgments 
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Sending EDI 810 Invoices 
The system transmits invoices to vendors using EDI when the Print field on the Status tab of the 
invoiced order generation is set to EDI. Before you can send an 810, set up your system as follows: 

• Create a trading partner profile for which an 810 outbound document is defined. 

• Assign the customer to whom you are sending the invoice to this profile. 

Note: Use the Order Processing Lock For EDI Payables control maintenance record to 
tell the system to terminate the processing of an order through EDI 810 when it is 
locked by a user or other process. Additionally, you can indicate how many 
minutes you want the system to wait before terminating the process. This is new 
in Release 9.0.5. 

Use the procedures in this topic to complete the following tasks: 

• Flag a customer for EDI batch processing. 

• Resend a single invoice using EDI. 

Batch Processing 
If you flag a customer record for EDI, the system sets the print status during batch processing. 

To flag a customer for EDI batch processing: 

1. From the Maintenance menu, select Customer to display the Customer Maintenance window. 

2. In the Customer field, enter the customer's name. 

The system displays the customer's record. 

3. From the Pricing menu, select the Pricing Information option to display the Customer Pricing 
window. 

4. In the Invoice Fax Copies field, select EDI. 

5. Save the updated customer record and exit the window. 

Single Invoice Processing 
To re-send a single invoice using EDI, set the print status in the sales order. 

To resend a single invoice using EDI: 

1. Display an invoiced order in Sales Order Entry. 

2. Click the Status tab. 

3. In the Print field of the generation to be transmitted, select EDI. 

If the 810 outbound document is not defined in the trading partner profile for the customer, E is 
not an available option in the Prt field. 

4. Save the updated order and exit the window. 
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Sending EDI 820 Remittance Advice Information 
Generate a remittance advice for checks that have been sent. You can generate remittance advice for a 
single check or for all trading partners that have set up an 820. You can also set up an activity trigger to 
send 820s when the system generates electronic funds (EFT) payments. 

The system sends a deduction segment if a deduction is taken in the payable. The system searches for the 
following words in the reasons entered for a deduction amount in the payable (G/L > Deductions from 
the A/P Entry window) and sends the appropriate deduction code along with the amount of the deduction. 
The system searches for the words in the order they appear below. 

• Pric - (to catch "price" or "pricing") sends code for "pricing error" 

• Damage - sends code for "item not accepted - damaged" 

• Short - sends code for "quantity contested" 

• Tax - sends code for "tax deducted" 

• Freight - sends code for "freight deducted" 

If the system does not find any of these words in the reason code, the code for "quantity contested" is sent 
by default. Only one deduction segment is sent per payable. If a payable contains multiple deductions, the 
system sends the total amount (sum) of the individual deductions. 

Before you can send an 820, set up your system as follows: 

• Create a trading partner profile for which an 820 document is defined. 

• Enter the EFT account information in the trading partner profile. 

• Assign the vendor to whom you are sending the remittance advice to this profile. 

To set the vendor activity trigger for EFT payments, do the following in Activity Trigger Maintenance: 

• Select the EFT Remittance Advice trigger description. 

• Select the EDI Doc for Remit Advice activity description. 

• Use the Activity Properties option and select the 820 document type. 

To generate an EDI 820 remittance advice: 

1. Display the EDI 820 Remittance Advice screen in one of the following ways: 

• From the System > Systems Programming > EDI > EDI Generate Reports menu, select 
EDI 820 Remittance Advice. 

• From the A/P menu, select EDI 820 Remittance Advice. 

2. In the Bank Account field, select the bank account from which the checks were drawn. This field 
is required. 

3. Complete one of the following fields: 

• To generate remittance advice for one check, complete the Check # field. The check number 
can be alphanumeric. 

• To generate remittance advice for all trading partners that have set up an 820, complete the 
Check Posting Date field. 
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4. Click Generate. 

The system generates the requested 820 Remittance Advice documents and places them in the 
EDI Outgoing Status Queue. The system transmits the documents to your trading partners during 
the next scheduled network call. 
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Sending EDI 843 Responses to Requests for Quote 
In response to an 840 Request for Quote from an EDI customer, the system creates a sales order with a 
Bid status and places it in the Remote Order Entry Review Queue. The system sends a message to the 
user responsible for reviewing incoming 840s. This person reviews the 840 and then changes the Prt 
status to E for EDI. When the user presses Esc to exit the bid, the system sends your customer an EDI 
843 Response to RFQ. 

Before you can send an 843, set up the system as follows: 

• Create a trading partner profile for which an 843 outbound document is defined. 

• Assign the customer to whom you are sending the 843 to this profile. 

To send an EDI 843 Response to Request for Quote: 

1. From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. 

2. Select the bid, and from the Order menu select Edit Order. 

3. Edit the bid, as needed. 

4. Display the Status tab of the bid and change the Prt status to E for EDI. 

5. Save the order and exit the window. 

The system transmits an EDI 843 Response to RFQ to the customer from which you received the 
840. 

Note: To remove the bid from the Remote Order Entry Review Queue, select the order, 
and from the Edit menu select Clear Review. 
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Sending EDI 844 Rebate Reports 
The 844 Product Transfer Account Adjustment (Outbound) is an EDI report sent to your vendors showing 
sales that qualify for rebate offers. 

Use the Customer Sales Rebates Report to view rebate offers you have passed along from vendors to your 
customers and generate the 844. The 844 report lists product sales eligible for vendor rebates. 

Note: In response to an 844, the vendor sends back an EDI 849 Response to Product 
Transfer Account Adjustment, which indicates the rebate they plan to pay. 

Before you run the report, set up your system and the vendor record for EDI processing. How you set up 
your system determines which mapper the system uses to process the 844 you send. You can transmit an 
844 with or without using the book letter of credit feature. To set up the system, do the following: 

• Define an outbound 844 document for the trading partner profile you are using. 

On the EDI Add'l Doc Info screen for the 844, complete the following fields, as needed: 

• Grp/User to be Notified of 997 

• Default Outgoing Transmission Status 

• Alternate Interchange ID 

• Assign the vendor account for which you run the report to a group profile defined for the EDI 
trading partner profile. 

• To send an 844 using the book letter of credit feature, also do the following: 

• Complete the Rebate Detail Setup Information control maintenance record. 

• Enter Y in the Book Letter of Credit Vendor field in the EDI Group Profile Global Info 
Table for the trading partner group profile. 

To send an EDI 844 rebate report: 

1. From the System > System Programming > EDI > EDI Generate Reports menu, select EDI 
844 Product Customer Sales Rebates. 

Note: You can also display this report from the Reports > End of Month Reports > 
Customer Reports menu, select Customer Sales Rebates. 
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2. Complete the fields, as needed, in the Customer Sales Rebate Report window considering the 
following: 

To... Do this: 
send a 
standard 
844 

• Select one of the options that begins with Br in the Sort By field. 
• Select the Create & Queue EDI Documents field in the Report Options area. 

Note: You can do this only if the vendor is not flagged as a Book Letter of Credit vendor in 
the trading partner group profile. 

Consider the following when you are selecting these options: 

Scenario If the EDI 
'Book 
Letter of 
Credit 
Vendor' 
field set 
to... 

and 
Customer 
Sales 
Rebate 
Report 
'Book 
Letter of 
Credit' 
is... 

and the 
'Create & 
Queue EDI 
Document' 
option is... 

Then... 

1 Yes Yes Yes The document is created and queued. 

2 Yes No No 
A message displays to the user 
indicating they must select the Book 
Letter of Credit option. 

3 No Yes Yes. The document is created and queued. 

4 No No Yes A warning message displays and 
only an EDI document is created. 

  

send a 
book 
letter of 
credit 
844 

• Select one of the options that begins with Br in the Sort By field. 
• From the File menu, select Book Letter of Credit complete the associated fields. 

3. Set options, if needed, and generate the report. 

• For a standard 844, the system transmits the report to the vendor. 

• For a book letter of credit 844, the system creates the report and creates a negative received 
purchase order for the rebate vendor. The quantity on the order is -1 and the product added to 
the purchase order is the miscellaneous charge product created for rebate requests as specified 
in the Rebate Detail Setup Information control maintenance record. The amount of the 
purchase order is the total rebate amount the vendor owes you. 

Upon creation of the purchase order, the system populates the Rebate Detail file, which 
contains the item detail that comprises the purchase order total. 

Note: When you receive an EDI 849 Response to Product Transfer Account 
Adjustment from the vendor in reply to the rebate request, the system updates 
the data in this file. 
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If your company uses landed average cost or average cost as your COGS (cost of goods sold) 
basis and you are capitalizing freight to inventory, the system creates a journal entry that 
reconciles the inventory valuation. Inventory was credited at the rebate cost rather than the 
purchase order cost, due to the sell matrix COGS override. 

The system also sends you a message with the purchase order number and journal entry 
number, if one was created. 

4. If you generated a book letter of credit 844, transmit the negative purchase order to the vendor, as 
follows: 

• Open the negative purchase order. 

• On the Status tab, enter E for EDI in the Print field. 

If the 844 document is not defined in the trading partner profile for the vendor, E is not an 
available option in the Prt field. 

• At the prompt, select the 844 document, and then exit the order. 

The system sends the EDI 844 Rebate Request to the EDI Outgoing Status Queue when you 
exit the order. The system transmits the report to your trading partner during the next scheduled 
network call. After the report is transmitted, the system changes the status of the purchase 
order to No. 
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Sending EDI 850 Purchase Orders 
The system transmits purchase orders to vendors using electronic data processing (EDI) when you set the 
print status of the order to EDI. The system only sends 850s for purchase order and direct order 
generations that contain line items with a quantity other than zero. 850s are not sent when no items exist 
on an order generation. 

Before you can send 850s from a purchase order, set up your system and the vendor record for EDI 
processing. 

• Create a trading partner profile for which an 850 document is defined. 

• Assign the vendor to whom you are sending the purchase order to this profile. 

If you have the New Purchase Order activity trigger set to EDI Purchasing Document for a vendor and are 
creating purchase orders from the Return Goods Queue, Procurement Confirmation Queue, or through the 
Suggested P/O program, the system does not automatically generate an 850. 

Use the Allow Printing of Zero/Negative Dollar Direct Shipment PO to indicate if you want to include 
zero or negative dollar direct shipment purchase orders when sending the EDI 850 transaction for 
customers on credit hold. 

To send an EDI purchase order: 

1. Display the Body tab of an open order in Purchase Order Entry. 

Note: Add quote or contract numbers to the order, as needed. 

2. Click the Status tab of the order. 

3. In the Print field, enter EDI. 

If the 850 document is not defined in the trading partner profile for the vendor, E is not an 
available option in the Prt field. 

If the system sent an 850 for the original order generation, the system does not populate any new 
generations created for that order during receiving with E, even if the Print Status Override 
field and/or the Default Print Status To "E" For All EDI Vendors control maintenance record 
are set to Yes. 

4. Exit the window to process the order. 

The system displays the following message: EDI 850 Document Queued - Send: Next Scheduled. 

5. Click Enter to clear the message and display a blank Purchase Order Entry window. 

The system sends the purchase order to the EDI Outgoing Status Queue. The system transmits the 
document to your trading partner during the next scheduled network call. 
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Entering Quote or Contract Numbers on EDI 850 Purchase 
Orders 
EDI programs can transmit quote or contract identification numbers in purchase orders at the line item or 
order header levels. To accurately communicate special offer pricing to your vendor without using free-
form text, use designated quote and contract qualifiers and place the information in designated locations 
in your Eclipse records. When the EDI program encounters a quote or contract number in the purchase 
order, the program creates a REF segment for each applicable PO1 segment in EDI transmission. 

Quote and Contract Qualifiers 
As your trading partner announces special programs or quotes, remember to ask for the quote numbers 
you should use to take advantage of the programs. Use the following contract qualifiers to identify price 
quote or promotion (promo) numbers, quote numbers, and contract numbers: 

Qualifier Qualifier and 
Number 

Description 

*PR *PRquote# Price quote (also known as Promo) number. 

*Q1 *Q1quote# Quote number. 

*CT *CTcontract# Contract number. 

The following rules apply to using quote and contract qualifiers: 

• Each qualifiers starts with an asterisk (*). 

• Each qualifier must be in ALL CAPS. 

• Each qualifier and number combination must contain no paces. 

The following table shows examples of incorrect and correct quote and contract numbers: 

Incorrect Problem Correct 
*pr9999 lowercase letters *PR9999 

CT9999 no * *CT9999 

*Q9876 the qualifier is *Q1, not just *Q *Q19876 

*PR 4444 space between *PR and quote number *PR4444 

Assigning Quote or Contract Numbers to Purchase Orders Line Items 
You can assign quote or contract numbers to any of the following: 

• Line items on a purchase order. 

• Buy or sell matrix cells, if the quote or contract applies to all products that use the designated 
matrix. 

• Purchase order Header, if the quote or contract applies to all products on the order. 

• Vendor record, if the quote or contract applies to all orders from that vendor. 



Entering Quote or Contract Numbers on EDI 850 Purchase Orders 

112 

To assign a quote or contract number to a purchase order line item: 

1. From the Purchase menu, select Purchase Order Entry and display the purchase order to which 
to assign a quote or contract number 

2. Select the line item to which you want to assign the quote or contract number, and from the Line 
Item menu select Comment to display the Line Item Comments window. 

3. In a blank line and enter the quote or contract number. 

4. Save your changes and exit the window. 

To assign a quote or contract number to a buy or sell matrix cell: 

1. From the Maintenance > Price Maintenance menu, select Buy Matrix or Sell Matrix and the 
matrix cell to which you want to assign a quote or contract number. 

2. Click the Additional tab. 

3. In the Select Comment Type field, select Matrix Tag Along Comments. 

4. In the comment area, enter the quote or contract number on a blank line. 

5. Save your changes and exit the window. 

When you add a product that uses the designated matrix to an EDI purchase order, the EDI 
program automatically creates a REF segment at the line item level. When you use this 
procedure, you do not have to enter a line item comment in the Body of the order for these 
products. 

To assign a quote or contract number to the Header of a purchase order: 

1. From the Purchase menu, select Purchase Order Entry and display the purchase order to which 
you want to assign the quote or contract number. 

2. Click the Header tab. 

3. In the Shipping Instructions field, enter the quote or contract number on a blank line. 

Note: Do not use free-form descriptions of special buying programs or quotes in this 
field. Aside from the *PR/*CT/*Q1 quote numbers, use this field for delivery and 
shipping instructions only. Enter free-form delivery/shipping instructions on other 
lines. 

4. Save your changes and exit the window. 

To assign the same quote or contract number to all orders from a vendor: 

1. From the Maintenance menu, select Vendor to display the Vendor Maintenance window and 
display the vendor record to which you want to assign the quote or contract number. 

2. From the Orders menu, select Vendor Order Entry Instructions to display the Vendor Order 
Entry Instructions window. 

3. In the Instruction Type field, select Vendor Instructions. 

4. In the space provided, enter the quote or contract number. 

5. Save your changes and exit the vendor record. 
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By default, when you create a purchase order for the designated vendor, the system populates the 
Shipping Instructions field on the order's Header tab with the quote or contract number. You 
can edit or delete the number if an order does not qualify for the quote. 



Sending EDI 855 Purchase Order Acknowledgments 

114 

Sending EDI 855 Purchase Order Acknowledgments 
The system transmits purchase order acknowledgements to customers using EDI when you set the print 
status of an incoming order to EDI. 

Before you can send an 855, set up your system and the customer record for EDI processing as follows: 

• Create a trading partner profile for which an 855 document is defined. 

• Assign the customer to whom you are sending the acknowledgement to this profile. 

When an EDI customer submits a purchase order to your company, the following happens: 

• The system creates a sales order with a Bid status. 

• The system sends a message to the user responsible for reviewing incoming orders. This person 
does the following: 

• Reviews the order and makes any needed changes. 

• Enters the corresponding EDI acknowledgment type codes. 

• Changes the Bid status to an open status. 

• Changes the print status to EDI. 

• The system sends the customer an EDI 855 Purchase Order Acknowledgment. 

To send an EDI purchase order acknowledgement to a customer: 

1. Display an EDI bid on the Sales Order Entry Body tab in one of the following ways: 

• From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. Select the bid and from the Order menu, select Edit 
Order. 

• From the System > Message System menu, select Message Queue. If necessary, set the mode 
to Received. Select the bid and from the Message menu, select View Item. 

2. Edit the order as needed. 

If you change a line item, select Line Item > Comment and enter one of the following codes: 

Code Description 
~AC Item accepted and shipped. 

~DR Item accepted - Date rescheduled. 

~IC Item accepted - Changes made. 

~IP Item accepted - Price change. 

~IQ Item accepted - Quantity changed. 

~IR Item rejected. 

Note: After you transmit the 855, remove the rejected items from the order. 

~IA Item accepted. 
This is the default value if a code is not entered in this field. 
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3. Display the order's Header tab and enter one of the following acknowledgement type codes in the 
Shipping Instructions field: 

Code Description 
~AC Acknowledge - with detail and change. 

~AD Acknowledge - with detail, no change. 
This is the default if a code is not entered in this field. 

~AE Acknowledge - with exception detail only. 

~RD Rejected - with detail. 

Note: After you transmit the 855, cancel the order. 

4. Display the order's Status tab and change the order status to an open status, such as Call When 
Complete. 

Note: The status cannot be Bid, Invoiced, or Canceled. 

5. In the Print field, change the print status to EDI. 

6. Save the order and exit the window. 

The system sends the acknowledgment to the EDI Outgoing Status Queue. The system transmits 
this document to your trading partner during the next scheduled network call.. 
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Sending EDI 856 Advance Ship Notices 
The system can create and send an EDI 856 Advance Shipping Notice from the Shipping Manifest Queue 
immediately after the manifest is created or when you ship from StarShip. Use activity triggers to set up 
these processes. You can also manually send an 856 by setting the Print field on the Status screen of the 
invoiced order generation to EDI. 

If you want to process direct orders through the EDI system and process them the same as EDI 856 
standard orders, use the Enable 856 Processing For Directs control maintenance record. 

Note: If the 810 outbound document is not defined in the trading partner profile for the 
customer, E is not an available option in the Prt field. 

Before you can send an 856, set up your system as follows: 

• Create a trading partner profile for which an 856 outbound document is defined. 

• Assign the customer to whom you want to send the advance ship notice to this profile. 

To set up activity triggers on the customer's Activity Trigger Maintenance window, do the following: 

• In the Trigger Description column, select one of the following: 

• Manifest Lock - to send a notice from the Shipping Manifest Queue. 

• Shipment Notification - to send a notice from StarShip. 

• In the Activity Description column for either trigger description, select one of the following: 

• EDI Adv Shipping Notification - The system sends an EDI document for each order on a 
given stop. 

• EDI Single Adv Shipping Not - The system sends one EDI document for all orders on a given 
stop. It sends a document for the first order and skips the other orders. 

• From the File menu, select Activity Properties and then select the 856 document type. 
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Sending EDI 857 Advance Ship Notices and Billing 
The system can create and send an EDI 857 Advance Ship Notice and invoice from the Shipping Manifest 
Queue immediately after the manifest is created. Use activity triggers to set up this process. You can also 
manually send an 857 by setting the Print field on the Status tab of the invoiced order generation to EDI. 
If the 857 outbound document is not defined in the trading partner profile for the customer, E is not an 
available option in the Prt field on the Status screen. 

Before you can send an 857, set up the system as follows: 

• Create a trading partner profile for which an 857 outbound document is defined. 

• Assign the customer to whom you want to send the invoice to this profile. 

To set up activity triggers on the customer's Activity Trigger Maintenance window, do the following: 

• In the Trigger Description column, select the Manifest Lock trigger description. 

• In the Activity Description column, select one of the following: 

• EDI Adv Shipping Notification - The system sends an EDI document for each order on a 
given stop. 

• EDI Single Adv Shipping Not - The system sends one EDI document for all orders on a given 
stop. It sends a document for the first order and skips the other orders. 

• From the File menu, select Activity Properties and then select the 857 document type. 
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Sending EDI 861 Receiving Advice Documents 
The system can send an EDI 861 Receiving Advice document to acknowledge a received shipment from a 
vendor. The system generates an 861 when a user changes the Print status on a received purchase order 
generation to EDI. If the 861 document is not defined in the trading partner profile for the vendor, E is 
not an available option in the Prt field. You can also set a vendor activity trigger, so the system 
automatically sends an 861 when the status of a purchase order generation from that vendor changes to 
Received. 

Before you can send an 861, set up your system as follows: 

• Create a trading partner profile for which an 861 outbound document is defined. 

• Assign the vendor to whom you want to send the 861 to this profile. 

To set the activity trigger for the vendor, do the following in Activity Trigger Maintenance: 

• In the Trigger Description column, select the Received Purchase Order trigger description. 

• In the Activity Description column, select the EDI Purchasing Document activity description. 
The system sends an EDI document for each order on a given stop. 

• From the File menu, select Activity Properties and then select the 861 document type.   
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Sending EDI 865 Purchase Order Acknowledgments With 
Change 
After processing an EDI 860 Purchase Order Change Request from your customer, which informs you of 
changes they want to make to a prior order, you can create an EDI 865 Purchase Order Acknowledgement 
With Change in response. The system transmits purchase order acknowledgements with change to 
customers using EDI when you set the print status of the order to EDI. 

Before you can send an 865, set up your system and the customer record for EDI processing as follows: 

• Create a trading partner profile for which an 865 document is defined. 

• Assign the customer to whom you are sending the acknowledgement to this profile. 

When an EDI customer submits a purchase order to your company, the following happens: 

• The system creates a sales order with a Bid status. 

• The system sends a message to the user responsible for reviewing incoming orders. 

• This person does the following: 

• Reviews the order and makes any needed changes. 

• Enters the corresponding EDI acknowledgment type codes. 

• Changes the Bid status to an open status. 

• Changes the print status to EDI. 

• The system then sends the customer an EDI 855 Purchase Order Acknowledgment. 

To send an EDI purchase order acknowledgement with change to a customer: 

1. Display an EDI bid on the Sales Order Entry Body tab in one of the following ways: 

• From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. Select the bid and from the Order menu and select Edit 
Order. 

• From the System > Message System menu, select Message Queue. If necessary, set the mode 
to Received. Select the bid and from the Message menu and select View Item. 

2. Edit the order as needed. 

If you change a line item, select Line Item > Comment and enter one of the following codes: 

Code Description 
~AC Item accepted and shipped. 

~DR Item accepted - Date rescheduled. 

~IC Item accepted - Changes made. 

~IP Item accepted - Price change. 

~IQ Item accepted - Quantity changed. 

~IR Item rejected. 
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Code Description 
~IA Item accepted. 

This is the default value if a code is not entered in this field. 

3. Display the order's Header tab and enter one of the following acknowledgement type codes in the 
Shipping Instructions field: 

Code Description 
~AC Acknowledge - with detail and change. 

~AD Acknowledge - with detail, no change. 
This is the default if a code is not entered in this field. 

~AE Acknowledge - with exception detail only. 

~RD Rejected - with detail. 

4. Display the Status tab of the order and change the order status to an open status, such as Call 
When Complete. 

Note: The status cannot be Bid, Invoiced, or Canceled. 

5. In the Print field, change the print status to EDI. 

6. Save the order and exit the window. 

The system sends the acknowledgment to the EDI Outgoing Status Queue. The document is 
transmitted to your trading partner during the next scheduled network call. 
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Sending EDI 867 Product Transfer and Resale Reports 
Some vendors require that you send them periodic reports of their products that you have sold. You can 
use the EDI 867 Product Transfer and Resale Report to send vendors this information. The program 
creates a report for each selected branch. 

 Important: You can also generate an EDI 867 report from the Product Sales Report using the 
EDI 867 Doc field. When you create the EDI 867, the system generates a standard 
Product Sales Report, EDI 867s for each of the branches for which you run the 
report, and places a report in your Hold file that mimics the data in each of the 
branch reports. The system uses the data in the Hold file when you generate an 
EDI 867 Audit Report. 

Before you can send an 867, set up your system and the vendor record for EDI processing. 

• Create a trading partner profile for which an 867 outbound document is defined. 

Some sales are made from locations that are not authorized locations but are close to the branch 
that is authorized. In Trading Partner Maintenance, use the Edit Tables hot key and select 
Authorized 867 Branches to display the Assign EDI 867 To Authorized Branch screen, where you 
can cross-reference branches that are not authorized locations to other branches that are authorized. 
These sales are generated in the home branch for the customer and are counter sales to the 
authorized branch. 

• Assign the vendor to whom you want to send 867 documents to this profile. 

To send an EDI 867 Report: 

1. From the System > System Programming > EDI > EDI Generate Reports menu, select EDI 
867 Product Transfer & Resale to display the EDI 867 Product Transfer & Resale screen. 

Note: If prompted, log on to the character-based system. 

2. In the Branch field, enter the branch or territory for which to run the report. Enter all to run the 
report for all branches and territories. 

3. In the Start Date field, enter the first date of the period to include in this report. You can enter a 
calendar date or a variable date. 

4. In the End Date field, enter the last date of the period to include in this report. You can enter a 
calendar date or a variable date. 

5. In the Qty Type field, select the product location quantity type for which to run the report. To run 
the report for all types, leave this field blank. 

6. In the EDI Trading Partner field, enter the EDI vendor for whom you want to generate this 
report. 

7. In the Include Directs field, indicate whether to include directs in the report. The default is Yes. 

8. In the Include Transfers field, indicate whether to include transfers in the report. The default is 
No. 

9. In the Select by field, indicate how to select transactions for the report: 

• Shipping Branch - Selects transactions by shipping branch. This is the default. 
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• Pricing Branch - Selects transactions by pricing branch. 

10. To run the report for designated price lines, use the Price Lines hot key. By default, the report 
includes all price lines. 

11. Use the Hold or Opts hot key, as needed to run the report. 

The system creates the EDI 867 transaction to the vendor, places it in the EDI Outgoing Status 
Queue, and sends a report to your Hold file. After the report is transmitted, the system changes 
the status of the purchase order to No. 

Note: Due to the amount of data on each line of the report, download the report to see 
some columns. The Hold file report is unaffected by the branch selection, because 
it always shows all items for all branches for which you run the report. 
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Running EDI 867 Vendor Audit Reports 
Create an EDI 867 Vendor Audit Report to tally and validate the actual dollar amounts sent to your 
vendor on the EDI 867 Product Transfer and Resale Report. When you create the EDI 867, the system 
generates a standard Product Sales Report, EDI 867s for each of the branches for which you run the 
report, and places a report in your Hold file that mimics the data in each of the branch reports. The system 
uses the data in the Hold file when you generate an EDI 867 Audit Report. 

You can only run the audit report after running the 867 Product Transfer and Resale Report. 

The audit uses the same start and end date you used on the Product Transfer and Resale Report, if you run 
the two in succession without closing the report driver window. 

To run an EDI 867 Vendor Audit Report: 

1. Run an EDI 867 Product Transfer and Resale Report, or generate an 867 document using the 
Product Sales Report. 

2. From the Reports > End of Month Reports > Product Sales Reports menu, select Product 
Sales to display the Product Sales Report window. 

3. Complete the fields in the General tab and click the Additional tab. For more information, see 
Running the Product Sales Report in the Solar Eclipse Reporting documentation. 

4. In the 867 Audit Vendor field, select the vendor for which you want to run the audit. 

5. Set options, if needed, and generate the report. 

The report lists the products that were sent on the 867 for the same sales date range and EDI 
trading partner. 

If you use the Print or Hold menu options, depending on your authorization level, the system 
may prompt you to choose whether to view generic (commission) costs, cost of goods sold, or no 
costs on the report. Select an option to run the report. 
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Purging the EDI 867 Log File 
If you generate 867 documents when you run the Product Sales Report, the system logs the sales orders 
and items contained on each EDI 867 Product Transfer and Resale Report in a log file. If the invoice date 
on a sales order included in the report changes, the system checks the log file for the sales order number 
so the items are not double reported on subsequent 867 documents. 

We recommend that you purge the EDI 867 log file periodically to delete older transmissions that are no 
longer needed. 

To purge the EDI 867 log file: 

1. From the System > System Programming > EDI > EDI Generate Reports menu, select EDI 
867 Purge Sales Transmissions to display the EDI 867 Purge Log Process window. 

2. In the Purge As Of field, enter the date before which you want to purge transmissions. For 
example, if you want to purge all transmissions older than March 30, 2009, enter 03/30/2009 in 
this field. 

3. Do one of the following to purge the transmissions: 

• To purge the files immediately, select File > Begin. 

• To schedule the purge to run at a later time, select Options > Schedule. For more information, 
see Scheduling Phantom Processes in the System Maintenance documentation. 
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Sending EDI 870 Order Statuses or Shipment Statuses 
The system transmits order status documents to customers using EDI when an order is in an open status 
and you change the print status to E for EDI. If your system is set up to use 870 shipment status 
documents, the system transmits the shipment status to the customer when the order's status changes to 
invoiced. You can use multiple 870s instead of sending 855 purchase order acknowledgements and 856 
advance ship notices, however, you can only use 870s at the request of your trading partners. Most 
customers still use 855s and 856s. 

 Important: The system provides the ability to send an 870. However, if you require the 870 
document, we do not provide a standard EDI mapper. Custom fees are required to 
define a specific mapper for each trading partner. 

Before you can send an 870, set up your system as follows: 

• Create a trading partner profile for which an 870 document is defined. 

• Assign the customer to whom you are sending the status document to this profile. 

• Assign the Bid to New Order and Shipment Notification activity triggers to the customer and set 
the Activity Description for each to EDI Sales Document. Use the File > Activity Properties 
menu and select the 870 option for each trigger. 

The user responsible for reviewing incoming orders does the following: 

• Reviews the order. 

• Makes any needed changes. 

• Changes the Bid status to an open status, or to a shipped status when the order ships, such as 
invoiced. If activity triggers are set up, the system sends the 870 automatically. 

• If activity triggers are not set up, you can send the 870 manually by changing the print status to E 
for EDI and selecting the status documents. 

To send an EDI 870 order status or shipment status to a customer: 

1. Display an EDI bid on the Sales Order Entry Body tab in one of the following ways: 

• From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. Select the bid and from the Order menu, select Edit 
Order. 

• From the System > Message System menu, select Message Queue. If necessary, set the mode 
to Received. Select the bid and from the Message menu, select View Item. 

2. Edit the order, as needed. 

3. Display the Status tab of the order. 

4. Change the order status to an open status such as Call When Complete, or a shipped status such 
as Invoiced. 

5. If the activity triggers are not set up to send the document automatically, change the print status to 
EDI in the Print field. 

6. Save the order and exit the window. 
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The system sends the document to the EDI Outgoing Status Queue. The system transmits the 
document to your trading partner during the next scheduled network call. 
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Sending EDI 997 Functional Acknowledgments 
An outgoing EDI 997 Functional Acknowledgment is a document that your system sends to a trading 
partner to acknowledge that it has received an EDI document they sent to you. 

The process of sending 997s is automatic if you flagged the incoming document for send 997s when you 
defined the documents in EDI Group Profile Maintenance. When your system receives the document, it 
sends a 997 in return. 
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Receiving EDI Transactions Overview 
After you have set up EDI trading partner profiles for incoming transactions, the system can process 
transactions received from the customers and vendors associated with these profiles. 

Refer to the following topics for detailed information about processing inbound transactions: 

• EDI Review Queues Overview 

• Part Number Matching 

• Receiving EDI 810 Invoices Overview 

• Receiving EDI 830 Forecast Schedules 

• Receiving EDI 832 Price/Sales Catalog Requests 

• Reviewing EDI 840 Requests for Quote 

• Receiving EDI 845 Price Authorization Acknowledgments 

• Receiving EDI 846 Inventory Advice Documents 

• Receiving EDI 849 Responses to Product Transfer Account Adjustments 

• Reviewing EDI Inbound 850 Purchase Orders 

• Receiving EDI 855 P/O Acknowledgments Overview 

• Reviewing EDI 856 Advance Ship Notices Overview 

• Receiving EDI 860 P/O Change Requests 

• Receiving EDI 862 Shipping Schedules 

• Receiving EDI 997 Functional Acknowledgments 



Solar Eclipse Electronic Data Interchange (EDI) 

129 

EDI Part Number Matching 
When the system receives an 810, 855, or 856, it tries to find an exact match for each line item listed on 
the invoice, acknowledgement, or ASN.  

Use the EDI Product Matching Priorities control maintenance record to define the hierarchy in which 
you want the system to match product IDs for incoming EDI documents: 810, 855, and 856. Settings at 
the EDI Trading Partner level supercede this control maintenance record.  

By default, the system uses the standard Eclipse product matching types. The system makes comparisons 
of inbound product information in the following order to try to find the matching product in your system: 

• UPC to the Primary UPC and Secondary UPC field of the Product file. 

• Vendor part/catalog# to the Vendor Part Number Cross Reference table. 

• Vendor part/catalog# to User Defined product IDs. 

• Vendor part/catalog# to the Catalog ID field of the Product file. 

• Vendor part/catalog# to the Key Words or Description field of the Product file. 

• Buyer PN to the internal Eclipse product number. 

You can rearrange these priorities based on your warehouse needs.  

To set EDI part number matching: 

1. From the System > System Files menu, select Control Maintenance. 

2. In the Filter Description field, enter EDI Product and select EDI Product Matching Priorities. 

The system displays the available Product Matching Types in their current priority order. 

3. Use the Enabled column check boxes to select which priorities you want the system to use for 
matching EDI documents. 

4. Use the Move Up and Move Down buttons to rearrange the options in the order that you watch 
the system to match. 

5. To include a cost variance match, use the Ledger Detail ID and Unit Cost Variance area to 
enter the values you want to use: None, Percentage, or Dollars. For example, if you want the 
system to ignore a dollar amount within a two cent difference, select Dollar Amount and enter 
.02. 

6. To restore the original system values, click Default Values. 

7. Click Save. 

If a match is not found after the system runs through this query, the item is a NO MATCH. 

Note: Prior to Release 9.0.3, to have the system check the internal Eclipse product 
number first rather than last, you set the Match on Eclipse Internal PN First 
field on the EDI Group Profile Global Info Table screen to Y. As of Release 9.0.3, 
use the EDI Product Matching Priorities control maintenance record to move 
the Eclipse Internal Part Number option to the top of the list. 
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Defining Product Matching Priorities for EDI 
Use the EDI Product Matching Priorities screen to indicate how you want to match your products when 
receiving EDI documents. Prior to Release 9.0.5, the system only matched by UPC or EAN codes. Now, 
you can decide which options on which to match and in what order giving you more control over your 
product matching priorities. 

The system checks these product matching priorities first when creating the product matches. If no 
matches are found, the system checks the UPC code listing in Product Maintenance to resolve the 
information matches. 

Note: These options are automatically available for the following EDI documents: 810, 
855, 856, and 845. However, while it's available for the EDI 845, if must enable 
this new matching priority for EDI 845 documents. Use the EDI 845 Add'l Doc 
Info parameters to disable this feature by setting the Enable Product Matching 
Priority option to No. By leaving this set to No, the system works as designed 
prior to Release 9.0.5 using the UPC and EAN codes on 845 documents. 

To define your product matching: 

1. From the System > System Programming menu, select EDI. 

2. From the EDI Maintenance menu, select EDI Trading Partner Maintenance. 

3. In the Trading Partner ID field, select the trading partner for which you want to define 
priorities. 

4. Navigate to the Group ID you want to define and use the Group Profile Maintenance hot key. 

5. Navigate to the Incoming document you want to review and use the Global Settings > Product 
Matching hot keys. 

 
6. Use the Enable/Disable hot key to manipulate the asterisks column and indicate which options 

you want to match. 

7. Use the Move Up/Down hot keys to rearrange the options ensuring that the system matches your 
products in the order you want. 

Important: By default this new matching screen will inherit your current company 
hierarchy settings.  
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8. Press Esc to save your changes and exit the screen. 

See Also: 

Entering Additional EDI Document Information 
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EDI Review Queues Overview 
Use EDI queues to review data documents related to purchase orders received from vendors. When the 
system receives an EDI document, it processes the document and displays the status in the corresponding 
queue. Users who monitor the queues can see which documents have processed successfully and which 
were not processed due to errors. 

The system contains queues for the following inbound EDI transactions: 

• 810 Invoices 

• 845 Price Authorization Acknowledgments 

• 855 P/O Acknowledgments 

• 856 Advance Ship Notices 
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Structure of Inbound EDI Review Queues 
The system stores all incoming EDI documents in document-specific queues. This keeps the documents 
available for audit purposes. 

The following EDI queues are structured in the same way: 

• EDI 810 Invoice Review Queue 

• EDI 855 P/O Acknowledgement Review Queue 

• EDI 856 P/O Advance Ship Notice Review Queue 

Each queue has three views for accessing the documents assigned to that queue: 

• Active - When documents arrive, the system assigns them to the Active view. The review queue 
displays information indicating how the document was processed. 

• Cleared - When you delete or clear a document from the Active view, it moves to the Cleared 
view. 

• Archived - After documents have been in the queue the number of days specified in the Archive 
EDI Review Queue Documents After (Days) control maintenance record, they move from the 
Cleared view to the Archived view. The system stores each document in a directory that 
corresponds to the month and year the document was received. 

To indicate the view you want to see, use the Select View field in the queue selection windows when you 
are entering selection criteria for filtering content displayed in each queue. 
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Receiving EDI 810 Invoices Overview 
An EDI vendor can send an 810 invoice after the vendor ships an order. When your system receives an 
810, it adds the document to the EDI 810 Invoice Review Queue. Use the queue to review 810 documents 
you have received from vendors. Users must be assigned the EDI.IN.REVIEW authorization key to 
access the review queue. 

Note: If you use Corcentric™ third party A/P processing, captures the vendor and 
invoice number necessary to contact the Corecentric website. Use the Corcentric 
option from the Inquiries menu in A/P Entry to view the information captures. 

Before the system can receive an 810, set up the system as follows: 

• Create a trading partner profile for which an 810 inbound document is defined. 

• Assign the vendor from whom you are receiving the invoice to this profile. 

The following topics explain how to process inbound 810s: 

• Reviewing Inbound EDI 810 Invoices 

• Reprocessing EDI Invoices 

• How the System Processes EDI 810s 

• EDI 810 Invoice Match Levels 
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Reviewing Inbound EDI 810 Invoices 
When your system receives an 810 invoice from an EDI vendor, it adds the document to the EDI 810 
Invoice Review Queue with an active status. If the purchase order number is valid and the invoice number 
is not a duplicate, the system creates a payable and attempts to match the invoice to a purchase order. 

View a summary of the active invoices in the Active view of the EDI 810 Invoice Review Queue screen. 
To view information on mismatches, see the unsuccessful matches information below including the 
Product Matching Audit available from the queue. 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

Use the queue to review the invoices and to complete the following tasks: 

• Reprocess 810s in the queue that were unable to make a match when they entered the queue. For 
example, if the invoice arrives before the order is received, the system cannot match the invoice to 
the purchase order. The result is no match. 

• Clear approved invoices. 

• Review invoices that were not approved and that have variances. 

• Delete invoices from the Active view that no longer require your attention. For example: 

• The invoice is a duplicate. 

• You cancel the payable. 

• The payable is in a closed period. 

• No payable has been created for the entry. 

To display the EDI 810 Invoice Review Queue: 

1. Do one of the following to display the EDI Review Queue Selection Criteria window: 

• From the System > Systems Programming > EDI > EDI Review Queues menu, select 810 
Invoice (Inbound). 

• From the A/P menu, select EDI 810 Invoice Review Queue. 

2. Enter the selection criteria and click OK to populate the EDI 810 Invoice Review Queue with 
invoices that match the criteria. 
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Field Description 
Sort By Sort order of selected items. The default is Ascending By Date. Select from the 

following options: 
• Ascending By Date - Sorts the items from oldest to newest by the 

received date for invoices or by the ship date for acknowledgements 
and ASNs. 

• Descending By Date - Sorts the items from newest to oldest by the received 
date for invoices or by the ship date for acknowledgements and ASNs. 

• Ascending By Trading Partner - Sorts the items in alphabetical order by 
trading partner name. 

• Descending By Trading Partner - Sorts the items in reverse alphabetical 
order by trading partner name. 

User ID User ID of the user assigned to review incoming 810s. 
This field defaults to your user ID. To review 810s for all users, leave this field 
blank. 
You must have Level 1 authorization in the EDI.IN.REVIEW authorization 
key to view your own entries in the EDI 810 Invoice Review Queue. Level 2 
authorization is required to view other user's entries. 

Branch Branch to which the invoices are assigned. Enter all for all branches. 

Vendor Vendor who sent the invoices. To review 810s from all vendors, leave this 
field blank. 

View Review status of an 810 invoice. Displays invoices based on one of the 
following statuses: 
• Active - 810s requiring review that have not been cleared from the 

queue. 
• Archived - 810s older than the number of days specified in the Archive EDI 

Review Queue Documents After (Days) control maintenance record. In the 
Directory field, select the month and year to access. 

• Cleared - Reviewed 810s that have been cleared from the queue. 

Start Date First date in a range for which to view invoices. For example, if you want to 
review all invoices received in July 2006, enter 07/01/06 in this field and 
07/31/06 in the Select End Date field. 

End Date Last date in a range for which to view invoices. For example, if you want to 
review all invoices received in July 2006, enter 07/01/06 in the Select Start 
Date field and 07/31/06 in the End Date field. 

PO # Purchase order number associated with the invoice. The system searches for all 
generations of the purchase order number you enter. For example, if you 
wanted to see only invoices received that match generations of purchase order 
P1067075, enter P1067075 in this field. 
To search all purchase orders in the system, leave this field blank. 

Invoice Specific vendor invoice number. To display all invoices, leave this field blank. 

AP # System-assigned payable number of the accounts payable entry associated with 
the invoice. For example, if you want to see only invoices reconciled on 
payable Y109779, enter Y109779 in this field. 
To search all payables, leave this field blank. 
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Field Description 
Invoice Type Type of invoice to display in the queue: 

• Purchase Orders - Payables resulting from a standard purchase order 
in the system. 

• Directs - Payables resulting from an order that goes directly from your 
vendor to your customer. Items on direct orders do not pass through your 
inventory at your warehouse, however, the dollars are still posted in and then 
out by your accounting group. 

• Freight - Payables that include freight charges. 
• Tagged -  Payables that result from purchase orders that are tagged to sales 

orders. Tagging occurs when an item on a purchase order is procured outside 
the normal path of replenishment. 

• Canceled - Payables that have been canceled in the system. 
• Problem - Payables that do not have a valid sales order or purchase order 

number. 
• Lot Item - Payables that include lot items. 
• Job Management - Payables that include items from Job Management 

orders. 

Pay To Vendor Select a pay to vendor by which you want to display the queue. 

The summary information for each invoice displays. 

Column Description 
Match Level The level of success, or match level, the system had in matching the 810 

invoice to the purchase order. Click the Message icon to view an 
explanation of the status. 
Note: Match levels also apply to lot orders. 

Approved Whether the payable has been approved for payment. 

Purchase Order Purchase order number associated with the invoice. 

Payable The system-assigned payable ID 
If the Payable field for the 810 is blank, one of the following conditions 
exists: 
• The invoice is a duplicate. 
• The purchase order ledger record does not exist. 
• The account number attached to the 810 is not assigned to a trading 

partner profile and a payable was not created. To correct this problem, 
assign the account number to a trading partner profile and requeue the 
entry from the Archive Data within the review queue. The system 
creates a payable and new entry in the review queue. 

Delete the old review queue entry with the blank Payable field. 

Invoice Type The type of invoice associated with the system-created payable created. 
• Direct - The payable resulted from a direct order. 
• Tagged - A freight charge is associated with the payable and the order is 

tagged. 
• Freight - A freight charge is associated with the payable. 
• Canceled - The payable has been canceled. 
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Column Description 
Trading Partner The trading partner who sent the invoice. 

Pay To Vendor  Pay-to vendor listed on the invoice or payable. 

Ship From Vendor Ship-from vendor listed on the invoice or payable. 

Vendor Invoice Amt Amount the vendor invoiced. 

Reconciled Amt Invoice amount matched to the purchase order. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Reconciled Amount/Difference. 

Difference Difference between the invoiced and reconciled amounts. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Reconciled Amount/Difference. 

Status Indication if the invoice is in the Purchase Order Variance Queue. 
• An exclamation point icon  when viewing Active invoices indicates 

that the invoice is in the Purchase Order Variance Queue. Variances are 
created for EDI invoices where there is enough information to match a 
received purchase order generation and that have cost or quantity 
discrepancies. For example, an EDI 810 that is in the 810 Review Queue 
with a match level of Some Line Items Matched might also result in an 
entry in the variance queue. 

• A green icon  indicates the invoice was cleared through the normal 
approval process. 

• A red icon  when viewing Cleared invoices in the 810 Review Queue 
indicates that the invoice was removed from the view manually. 

Click the icon to view additional information about the invoice, such as 
when it was cleared from the queue, or if a variance record was created. 
The Create PO Variances For EDI 810 Invoices control maintenance 
record must be set to Yes for the system to create variance records for EDI 
810s. 

Lot Invoice If an invoice is attached, a check mark  displays.  

Received Date Date the system received the invoice. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Received Date/Reference Number. 

Pay Date The payment date of the payable associated with the invoice. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Pay Date/Reference Number. 

Reference # System-assigned sequential number that identifies the review queue entry. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Received Date/Reference Number. 

Note: To refine or change your search, select Edit > Select and enter new selection 
criteria. 
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3. From the Edit menu, select Clear Approved to clear all approved entries from the Active view 
of the queue and move them to the Cleared view. 

To research unsuccessful invoice matches: 

1. Display the EDI 810 Invoice Review Queue. 

2. Use any of the following options to research any unsuccessful invoices matches: 

To... Select this menu option... 

display the associated purchase order View > View PO 

display the invoice formatted data, including quantities, prices, 
descriptions, and fixture types. 
The Product Matching Audit displays at the bottom of this 
window to provide more detail, such as UPC code or product IDs.  
Ensure that the columns you want to view are selected in View > 
Configure Vendor Item Detail. 

View > Vendor Item Detail 

display the EDI Archive Viewing window, where you can view the 
raw EDI data from the invoice 

View > Archive Detail 

clear invoices that have already been approved Edit > Clear Approved 

reprocess 810s in the queue that did not make a match level upon 
arrival. 
The requeue process looks at those entries in the queue with a 
match level of No Match and Some Match and rechecks the 
purchase orders for a better match. It only checks those entries 
whose associated payable has not been reconciled. 

Edit  > Requeue 

manually reconcile the selected invoice and approve the payable Edit > Edit AP 

adjust the Batch ID of all the payables listed or only the payables 
having no batch IDs or individual payable. Use the Batch ID 
column to adjust batch information, as needed. 

Change view: Options > 
Change View > Receive Date / 
Batch ID 
Then use: 
Edit > Assign Batch ID for All 

Edit > Assign Batch ID for 
Unassigned 

3. Exit the EDI 810 Invoice Review Queue. 

More Options When Using the EDI 810 Invoice Review Queue 

The following are additional options you can use when reviewing EDI invoices in the EDI 810 Invoice 
Review Queue: 

To... Select this menu option... 
toggle between the available columns depending on 
what you would like to review. 

Options > Change View 

display the EDI Review Queue Selection window, 
where you can change the 810 selection criteria used 
to display invoices 

Edit > Select 
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To... Select this menu option... 
delete the selected invoice that no longer requires 
your attention from the Active view and move it to 
the Cleared view of the queue, 

Edit > Delete 

select the columns that display in the queue, to view 
the information that meets your needs 

View > Configure Vendor Item Detail 
The selection works like selecting columns in a 
report. For more information, see in Eclipse 
documentation. 

View Options on the EDI 810 Invoice Review Queue 

Use the View Manager  or select Options > Change View to select from the following: 

Use this view: Default Columns in All Views 
Reconciled Amount / 
Difference 

Match Level / Approved / Purchase Order / Payable / Invoice Type / 
Trading Partner / Pay To Vendor / Ship From Vendor / Vendor Invoice 
Amt / Reconciled Amt / Difference / Status / Lot Invoice / Message 

Received Date / 
Reference Number 

Match Level / Approved / Purchase Order / Payable / Invoice Type / 
Trading Partner / Pay To Vendor / Ship From Vendor / Vendor Invoice 
Amt / Vendor Invoice Amt / Received Date 

Pay Date / Reference 
Number 

Match Level / Approved / Purchase Order / Payable / Invoice Type / 
Trading Partner / Pay To Vendor / Ship From Vendor / Vendor Invoice 
Amt / Pay Date / Reference # / Status / Lot Invoice / Message 

Release Number 
Invoice Number 

Match Level / Approved / Purchase Order / Release # / Payable / Vendor 
Inv# / Vendor Inv Dte / Trading Partner / Pay To Vendor / Ship From 
Vendor / Vendor Invoice Amt / Reconciled Amt / Difference / Status / Lot 
Invoice / Message 

Received Date / Batch 
ID 

Match Level / Approved / Purchase Order / Payable / Invoice Type / 
Trading Partner / Pay To Vendor / Ship From Vendor / Vendor Invoice 
Amt / Received Date / Batch ID / Status / Lot Invoice / Message 

User Defined View 
Maintenance 

Launches User Defined View Maintenance so you can customize your 
view. 
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How the System Processes EDI 810s 
After an EDI vendor ships an order, they can send an 810 invoice for the shipment. When the 810 arrives, 
your system processes it as follows: 

1. Adds the 810 document to the EDI 810 Invoice Review Queue with an active status. 

2. Creates a payable. 

If the vendor account number attached to the 810 is not assigned to a trading partner profile, the 
system does not create a payable. It sets the 810 match level to No Matches and leaves the 
Payable field in the review queue blank. 

Note: When a payable is created, the system considers settings from EDI as overwrite 
values on the payable. This means if you change post date or invoice date, the 
system does not update the due date or pay date automatically because the system 
considers the those dates values as having been previously overwritten. 

3. Attempts to match the payable to the purchase order, if the purchase order number is valid and the 
invoice number is not a duplicate. 

The system tries to match the items on the 810 to a received generation on the purchase order by 
looking at the total number of line items, quantities for matching line items, and total dollar 
amount. 

4. Recognizes the purchase order contains lot items. If yes, then the system does the following: 

• Applies the invoice amount less freight and tax to the purchase order in A/P Entry. 

• Automatically populates the A/P Billed field in the A/P Open Lot Item screen with amount 
applied to the purchase order. 

• Automatically selects the Material Detail Needed check box in the A/P Open Lot Item screen. 

• If the vendor invoice is less than the remaining lot cost, the system accepts the Create B/O Ship 
Date based on A/P rules. 

• The payable remains unapproved and goes to the P/O Variance Queue for resolution. 

Depending on the matching results, the system sets the 810 match level and determines whether 
the payable status is Approved, as shown in the following table: 

   
Matching Results 

Match Level Payable 
Approved 

System finds an exact match and the terms codes on the 
invoice and purchase order match. 

Perfect Match Y 

System cannot find a received generation on the purchase 
order. 
This match may occur if the 810 arrives before the items 
have been received. Re-queuing the 810 at a later date may 
correct this match level. 

No Matches N 

System finds an exact match but the terms codes on the 
invoice and purchase order do not match. T N 
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Matching Results 

Match Level Payable 
Approved 

Items and quantities have an exact match, but the dollar 
amount is not within the acceptable over/short range. The 
over/short range is set in the A/P Over/Short Maximum 
Parameters control maintenance record or the Over/Short 
Percentage and Over/Short Dollars fields in Vendor 
Maintenance. 

G N 

Accounting period for the payable or purchase order is 
closed. 

Accounting Period 
for PO Closed 

N 

Invoice contains a freight amount, but the purchase order is 
flagged as freight allowed. 

F N 

The purchase order is in the process of being received or in 
process by a user and cannot be reconciled until it is 
completely received. 
Re-queuing the 810 at a later date may correct this match 
level. 

I N 

System does not find an exact match, but finds a partial 
match. 

Some Line Items 
Matched 

N 

No line items match. No Matches N 

If the Create PO Variances For EDI 810 Invoices control maintenance record is set to Yes, the system 
creates entries in the Purchase Order Variance Queue for EDI invoices if there is enough information to 
match a received purchase order generation and there are cost or quantity discrepancies between the two. 
The payable for the invoice is not approved through EDI if it is outside the over/short parameters set in 
Vendor Maintenance. 

In addition, if you enter Yes in Check All Unpaid Gens field on the EDI Add'l Doc Info screen and the 
Create PO Variances for EDI Invoices control maintenance record is also set to Yes, then orders with 
multiple generations with a variance are auto-matched to an 810 vendor invoice. 
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Reprocessing EDI 810 Invoices 
The EDI 810 Invoice Review Queue displays invoices received by EDI. If the system receives an invoice 
before it receives the vendor shipment, the entry in the review queue shows that the system did not find a 
matching received purchase order. After the shipment is received, you can reprocess the invoice. You can 
also reprocess invoices after making changes to matching purchase orders. 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

We recommend that you reprocess invoices in the queue daily. You can schedule the process to run 
automatically for the following: 

• Single invoices. 

• All invoices within a specified date range. 

Note: You can use the Invoice Processing Entry screen to process invoices manually, if 
needed. For more information, see Processing Paper Invoices in the Accounts 
Payable online help documentation. 

To reprocess a single EDI 810 invoice: 

1. With items listed in the EDI 810 Invoice Review Queue, select the 810 you want to reprocess. 

2. From the Edit menu, select Requeue and select one of the following options at the Requeue 
Option prompt: 

• Requeue Now - Starts the process immediately. 

• Schedule - Displays the Phantom Scheduler window, where you can schedule the process to 
complete at a later time. 

The requeue process looks at those entries in the queue with a match level of No Match and Some 
Match and rechecks the purchase orders for a better match. It only checks those entries whose 
associated payable has not been reconciled. If you have made manual changes to the payable, 
such as to the payable date, the system does not override the changes when you reprocess the 
invoice. 

3. In the Current Line or Date Range field, type c for current line and press Enter. 

The reprocessing is immediate. The system displays the following message: Processing Finished 
for 1 Item(s). The date follows the message. 

4. Exit the EDI 810 Invoice Review Queue. 

To reprocess EDI 810 invoices within a date range: 

1. With items listed on the EDI 810 Invoice Review Queue screen, use the Requeue hot key. 

2. At the prompt, select one of the following options: 

• Requeue Now - Starts the process immediately. 

• Schedule - Displays the Phantom Scheduler screen, where you can schedule the process to run 
at a later time. 

3. In the Current Line or Date Range field, enter d for date range. 
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4. To select 810s received on or after a designated date, complete the Start Date field. 

5. To select 810s received on or before a designated date, complete the End Date field. 

6. Press Esc. 

One of the following things occurs: 

• If no invoices exist within the specified date range, the system displays the following message: 
No Items Found to Requeue for. The date range follows the message. 

• If invoices within the specified date range exist, the system processes the invoices and displays 
the following message: Processing Finished for 'x' Item(s). The date range follows the 
message. 

7. Exit the EDI 810 Invoice Review Queue. 
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EDI 810 Invoice Match Levels 
Match levels indicate the success the system has in matching the items and quantities on the 810 invoice 
to the items and quantities on a received generation of the purchase order. 

Note: Match logic applies for lot orders. If the system recognizes the order as a lot, the 
same rules and automatic payable logic will apply. Lot orders are indicated with 
by *Lot* displayed in the Qty field on the order. 

The system displays the following match levels in the EDI 810 Invoice Review Queue: 

Level Description 
No Matches No match, for any of the following reasons: 

• The 810 contains an invalid purchase order number. 
• The 810 invoice number is a duplicate. 
• The 810 arrives before the items have been received. 
• The account number attached to the 810 is not assigned to a trading partner profile. 
• The system cannot match any items and quantities on the 810 with items and quantities on 

a received generation of the purchase order. 

L Invoice not reconciled because the order contains a lot item. 

Some line items 
matched 

Some items and quantities match. 

G Items and quantities match, but the dollar amount is not within the acceptable over/short 
range. The over/short range is set in the A/P Over/Short Maximum Parameters control 
maintenance record or the Over/Short% and Over/Short$ fields in Vendor Maintenance. 

Note: The system reincorporates any unapproved amount posted by EDI into the total then 
determining the over/short amounts. 

Perfect Match Items and quantities match. The dollar amount matches or is within the acceptable over/short 
range. The over/short range is set in the A/P Over/Short Maximum Parameters control 
maintenance record or the Over/Short% and Over/Short$ fields in Vendor Maintenance. 

Note: The system reincorporates any unapproved amount posted by EDI into the total then 
determining the over/short amounts. 

Accounting 
Period for PO 
Closed 

Accounting period for the payable or purchase order is closed. 

T Items and quantities match, but terms in the invoice do not match the terms in the purchase 
order. 
The system makes this check only if the Enable Terms Checking field on the EDI Add’l 
Doc Info screen for the 810 document in EDI Group Profile Maintenance is set to Y. 

Freight Not 
Allowed 

The invoice contains a freight amount, but the purchase order is flagged as freight allowed. 
The system does not auto-reconcile purchase orders with a Freight Not Allowed message. 

I The purchase order is in the process of being received or in process by a user and cannot be 
reconciled until it is completely received. 

Note: Click the Message icon in the Message field of the line item in the queue to view 
the system-generated message associated with the match level. 
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Automatic 810 Matching for Lot Orders 
Eclipse provides a way to increase the vendor payable processing time and accuracy by automatically 
creating payable records and matching those records to purchase orders. You can manage your EDI 810 
lot orders through the P/O Variance Queue. By using the P/O Variance Queue, users can review the 
individual items that on EDI 810 lot orders. After the 810 Invoice is received for a lot order, the system 
uses the predefined matching rules to automatically process the order. 

Review the following control maintenance records before using automatic lot matching. 

• Create PO Variances for EDI Invoices - This must be set to Yes. 

• Automatic Cash Receipts Option - Decide how you want the matching rules to work for your 
cash receipts. 

The system does the following when matching: 

• Applies the invoice amount in the payable record minus freight and tax to the purchase order. 

• Automatically populates the A/P Open Lot Item from the A/P Billed field with the amount applied 
to the purchase order. 

• Selects the Material Detail Needed check box in the A/ P Open Lot Item window.  

 
The system checks the invoice to see if the invoice is more or less than the remaining cost: 

If the invoice is... Then the system does this: 

More than the 
remaining cost: 

• Automatically-selects Match Open Cost at the authorize payment prompt. 
• For a transaction in which the vendor invoice cost is $500 and the 

remaining cost on the lot order is $400, this results in the system adjustment 
of A/P billed amount for the remaining cost on the lot order. In this 
example, $400. The system displays a variance of $100 in the P/O Variance 
Queue for resolution. 

• Users can then resolve the variance, per their company instructions. 
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If the invoice is... Then the system does this: 

Less than the 
remaining 

• The system accepts the Create B/O Ship Date if the total lot cost is not 
reconciled in full or not billed in full. 

• The payable then remains unapproved and the variance is sent to the P/O 
Variance Queue to be managed with the usual process. 
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Linking Store Numbers and Eclipse Branch IDs for EDI 
Use the Branch Code Lookup feature to cross-reference your internal store numbers to the Eclipse branch 
IDs assigned in the system. By using this table, when EDI 810s come in the system can reconcile the 
information. You can also include the credit branch so the system can apply credit memos appropriately.  

Note: This table is also used when automatically creating debit memos. 

To link a store number and branch ID: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Select an EDI 810 Incoming document and use the Addl Doc Info hot key.  

4. Set the Use Branch Lookup Table field to Y. 

5. Press Esc to return to Group Profile Maintenance. 

6. Use the Edit Tables hot key. 

7. Select Branch Code Lookup. 

8. Complete the following columns: 

• Store - Enter the store number. 

• Branch - Enter the branch ID that corresponds to the store number. 

• Credit Branch - Enter the branch number that the system should use for credit and debit 
memos. 

8. Press Esc and save your changes. 
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Cross-Referencing Trading Partner Ship Vias for EDI 
Use the Ship Via Lookup feature to cross-reference your internally assigned ship vias to the ship vias set 
up in Eclipse. By using this table, when EDI 810s come in the system can assign the correct ship via 
accordingly. 

To add a cross-referenced ship via: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Select an EDI 810 Incoming document. 

4. Use the Edit Tables hot key and select Ship Via Lookup. 

5. In the Trading Partner Via enter the ship via assigned by the trading partner. 

6. In the corresponding line in the Eclipse Ship Via column, enter the ship via Eclipse should use 
when receiving and 810 document in the system. 

7. Press Esc to save your changes and return to the EDI Group Profile Maintenance screen 
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Adjusting Batch ID Information for Invoices 
Use the Batch ID in the EDI 810 Invoice Review Queue to modify the Batch ID of all the payables listed 
or only the payables having no batch IDs or individual payable.  

To adjust batch ID information for EDI invoices: 

1. Do one of the following to display the EDI Review Queue Selection Criteria window: 

• From the System > Systems Programming > EDI > EDI Review Queues menu, select 810 
Invoice (Inbound). 

• From the A/P menu, select EDI 810 Invoice Review Queue. 

2. Enter the selection criteria and click OK to populate the EDI 810 Invoice Review Queue with 
invoices that match the criteria. 

Field Description 
Sort By Sort order of selected items. The default is Ascending By Date. Select from the 

following options: 
• Ascending By Date - Sorts the items from oldest to newest by the received 

date for invoices or by the ship date for acknowledgements and ASNs. 
• Descending By Date - Sorts the items from newest to oldest by the received 

date for invoices or by the ship date for acknowledgements and ASNs. 
• Ascending By Trading Partner - Sorts the items in alphabetical order by 

trading partner name. 
• Descending By Trading Partner - Sorts the items in reverse alphabetical 

order by trading partner name. 

User ID User ID of the user assigned to review incoming 810s. 
This field defaults to your user ID. To review 810s for all users, leave this field 
blank. 
You must have Level 1 authorization in the EDI.IN.REVIEW authorization 
key to view your own entries in the EDI 810 Invoice Review Queue. Level 2 
authorization is required to view other user's entries. 

Branch Branch to which the invoices are assigned. Enter all for all branches. 

Vendor Vendor who sent the invoices. To review 810s from all vendors, leave this 
field blank. 

View Review status of an 810 invoice. Displays invoices based on one of the 
following statuses: 
• Active - 810s requiring review that have not been cleared from the queue. 
• Archived - 810s older than the number of days specified in the Archive EDI 

Review Queue Documents After (Days) control maintenance record. In the 
Directory field, select the month and year to access. 

• Cleared - Reviewed 810s that have been cleared from the queue. 

Start Date First date in a range for which to view invoices. For example, if you want to 
review all invoices received in July 2006, enter 07/01/06 in this field and 
07/31/06 in the Select End Date field. 
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Field Description 
End Date Last date in a range for which to view invoices. For example, if you want to 

review all invoices received in July 2006, enter 07/01/06 in the Select Start 
Date field and 07/31/06 in the End Date field. 

PO # Purchase order number associated with the invoice. The system searches for all 
generations of the purchase order number you enter. For example, if you 
wanted to see only invoices received that match generations of purchase order 
P1067075, enter P1067075 in this field. 
To search all purchase orders in the system, leave this field blank. 

Invoice Specific vendor invoice number. To display all invoices, leave this field blank. 

AP # System-assigned payable number of the accounts payable entry associated with 
the invoice. For example, if you want to see only invoices reconciled on 
payable Y109779, enter Y109779 in this field. 
To search all payables, leave this field blank. 

Invoice Type Type of invoice to display in the queue: 
• Purchase Orders - Payables resulting from a standard purchase order 

in the system. 
• Directs - Payables resulting from an order that goes directly from your 

vendor to your customer. Items on direct orders do not pass through your 
inventory at your warehouse, however, the dollars are still posted in and then 
out by your accounting group. 

• Freight - Payables that include freight charges. 
• Tagged -  Payables that result from purchase orders that are tagged to sales 

orders. Tagging occurs when an item on a purchase order is procured outside 
the normal path of replenishment. 

• Canceled - Payables that have been canceled in the system. 
• Problem - Payables that do not have a valid sales order or purchase order 

number. 
• Lot Item - Payables that include lot items. 
• Job Management - Payables that include items from Job Management 

orders. 

Pay To Vendor Select a pay to vendor by which you want to display the queue. 

The summary information for each invoice displays. 

Column Description 
Match Level The level of success, or match level, the system had in matching the 810 

invoice to the purchase order. Click the Message icon to view an 
explanation of the status. 
Note: Match levels also apply to lot orders. 

Approved Whether the payable has been approved for payment. 

Purchase Order Purchase order number associated with the invoice. 
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Column Description 
Payable The system-assigned payable ID 

If the Payable field for the 810 is blank, one of the following conditions 
exists: 
• The invoice is a duplicate. 
• The purchase order ledger record does not exist. 
• The account number attached to the 810 is not assigned to a trading 

partner profile and a payable was not created. To correct this problem, 
assign the account number to a trading partner profile and requeue the 
entry from the Archive Data within the review queue. The system 
creates a payable and new entry in the review queue. 

Delete the old review queue entry with the blank Payable field. 

Invoice Type The type of invoice associated with the system-created payable created. 
• Direct - The payable resulted from a direct order. 
• Tagged - A freight charge is associated with the payable and the order 

is tagged. 
• Freight - A freight charge is associated with the payable. 
• Canceled - The payable has been canceled. 

Trading Partner The trading partner who sent the invoice. 

Pay To Vendor  Pay-to vendor listed on the invoice or payable. 

Ship From Vendor Ship-from vendor listed on the invoice or payable. 

Vendor Invoice Amt Amount the vendor invoiced. 

Reconciled Amt Invoice amount matched to the purchase order. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Reconciled Amount/Difference. 

Difference Difference between the invoiced and reconciled amounts. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Reconciled Amount/Difference. 
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Column Description 
Status Indication if the invoice is in the Purchase Order Variance Queue. 

• An exclamation point icon  when viewing Active invoices 
indicates that the invoice is in the Purchase Order Variance Queue. 
Variances are created for EDI invoices where there is enough 
information to match a received purchase order generation and that 
have cost or quantity discrepancies. For example, an EDI 810 that is 
in the 810 Review Queue with a match level of Some Line Items 
Matched might also result in an entry in the variance queue. 

• A green icon  indicates the invoice was cleared through the normal 
approval process. 

• A red icon  when viewing Cleared invoices in the 810 Review 
Queue indicates that the invoice was removed from the view 
manually. 

Click the icon to view additional information about the invoice, such as 
when it was cleared from the queue, or if a variance record was created. 
The Create PO Variances For EDI 810 Invoices control maintenance 
record must be set to Yes for the system to create variance records for 
EDI 810s. 

Lot Invoice If an invoice is attached, a check mark  displays.  

Received Date Date the system received the invoice. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Received Date/Reference Number. 

Pay Date The payment date of the payable associated with the invoice. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Pay Date/Reference Number. 

Reference # System-assigned sequential number that identifies the review queue 
entry. 

Note: If the review queue does not contain the field, use the Options > 
Change View menu and select Received Date/Reference Number. 

Note: To refine or change your search, select Edit > Select and enter new selection 
criteria. 

3. From the Options menu, select Receive Date / Batch ID to display the Batch ID associated with 
the payables, if any. 

4. From the Edit menu, select one of the following: 

• Assign Batch ID for ALL - Assigns a batch ID for all rows that have a payable. 

• Assign Batch ID for Unassigned - Assigns a batch ID for all rows that have a payable, but no 
batch ID assigned. 

Note: You can also use the Batch ID column to assign a single batch number to a single 
row. 
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5. At the prompt, enter the batch ID you want to use and click OK. 

Note: You cannot change a batch ID on a canceled payable. 

6. Save your changes and exit the screen. 
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Receiving 823 Lockbox Documents 
Eclipse Business Connect EFT can help you streamline your A/P and A/R processes with easy-to-use 
functionality that lets you pay your vendor invoices by transmitting funds to your bank electronically and 
accept electronic payments from your customers. It works in conjunction with EDI 820 remittance advice 
documents - to let your vendors know which invoices are being paid via EFT, and to alert your system to 
incoming electronic payments from designated customers. 

There are several options of EFT Eclipse supports. 

• Outbound Vendor EFT 

• Positive Pay 

• Inbound Lockbox 

Outbound Vendor EFT 
The Outbound Vendor EFT option allows customers to generate EFT checks instead of paper checks. 
Vendors must be in enabled for EFT through check setup and Vendor Maintenance. The purchase order 
and A/P process must be completed with the payable created and invoice approved.  

Instead of generating a paper check, the system generates an EFT flat file to send to the bank and saves it. 
The system saves all these files until the user runs the EFT transmission release to send the file to a 
queue. Then the system automatically can send a single file to the bank with all the transmissions 
included. Users can also manually send the files to the bank. 

To enable a vendor for EFT: 

1. From the Maintenance menu, select Vendor. 

2. In the Vendor field, enter the vendor name or ID to display the vendor details. 

3. From the Additional menu, select Vendor Payment Information. 

4. Set the Payment Via EFT field, to Yes. 

5. Save your changes and exit the window. 

Positive Pay 
The Positive Pay process allows you to generate a flat file to send to the bank. The bank uses this file to 
validate the amounts printed on the original checks match the amounts the pay-to customer is attempting 
to cash the check for.  

Positive Pay requires no changes to the check printing process. The program is scheduled to send a flat 
file via FTP and can only send through FTP. You can use Pretty Good Privacy (PGP) encryption.  

Note: Many programs required custom work because many banks require different 
formats. 

You can schedule the program to run nightly or manually each time you generate a check.  
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Inbound Lockbox 
The Inbound Lockbox process requires cooperation from the customer's bank. The bank generates a file 
to send to the customers through e-mail or posting to an FTP site for retrieval. The system can then 
process this file and automatically create a cash receipt based on matching logic for an invoice. 

Users must upload the file to the Your Hold Files. When the process runs, the system automatically 
creates cash receipts. The system only supports fixed width files. The spooler (hold file) allows you to 
specify the format of the file.  
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Receiving EDI 830 Forecast Schedules 
An EDI 830 Forecast Schedule is a document your customer sends to inform you of their projected 
product needs. The requirements are either firm or forecasts. 

Before the system can receive an 830, set up the system as follows: 

• Create a trading partner profile for which an 830 inbound document is defined. 

• Assign the vendor from whom you are receiving the 830 to this profile. 

You can set up your trading partner profiles to process 830s in one of the following ways: 

• Select a custom mapper, which creates an open sales order for the products listed. 

• Run the EDI.830.PRINT.DOC program, which formats the data and sends the 830 Forecast 
Schedule Report to your Hold file. 

• Run the EDI.PRINT.DOC program, which translates the raw data and places an unformatted report 
in your Hold file. 

Managing orders created by 830s is a complex process, for the following reasons: 

• With each 830 your system creates a new order that contains products that may have been included 
on a previous 830. 

• When a product listed has a zero quantity requirement, the system sends a message to the EDI 
Error Queue. 

We recommend that you discuss this transaction with EDI Support before using it. 
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Receiving EDI 832 Price/Sale Catalog Requests 
The EDI 832 Price/Sale Catalog Request is a document used by the Product Data Warehouse (PDW) 
application. 

Before the system can receive an 832, set up the system as follows: 

• Create a trading partner profile for which an 832 inbound document is defined. 

• Assign the vendor from whom you are receiving the 832 to this profile. 

For more information, see Importing IDW Catalog Data into PDW. This is for standard PDW, not 
Enhanced PDW (PDW2). 
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Reviewing EDI 840 Quote Requests 
In response to an 840 Request for Quote from an EDI customer, the system creates a sales order with an 
RFQ status and places it in the Remote Order Entry Review Queue. The system sends a message to the 
user responsible for reviewing incoming orders. After this person reviews the bid and makes any 
necessary changes, the system sends your customer an EDI 843 Response to RFQ. 

Before the system can receive an 840, set up the system as follows: 

• Create a trading partner profile for which an 840 inbound document is defined. 

• Assign the vendor from whom you are receiving the 840 to this profile. 

To review an EDI 840 request for quote: 

1. Display the EDI bid in Sales Order Entry in one of the following ways: 

• From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. The system displays "RFQ" in the Sta column for 840s. 
Select the item and from the Order menu, select Edit Order. 

• From the System > Message System menu, select Message Queue. If necessary, set the mode 
to Received. Select the bid and from the Message menu, select View Item. 

2. Edit the bid, as needed. 

3. Display the Status tab of the bid. 

4. Change the Print status to EDI. 

5. Save the order and exit the window. 

The system transmits an EDI 843 Response to RFQ to the customer from which you received the 
840. 

Note: To remove the bid from the Remote Order Entry Review Queue, select the order 
and from the Edit menu, select Clear Review. 
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Receiving EDI 845 Price Authorization Acknowledgments 
Overview 
EDI vendor trading partners use 845 Price Authorization Acknowledgments to send you information 
about special pricing contracts for selling designated products to designated customers. 

For example, your standard cost for a Brand A fluorescent light is $6. One of your large customers 
requests competitive pricing on the Brand A fluorescent lights they buy from you. If you can give them a 
good price, they will buy all their lights from you rather than from your competitor down the street. So, 
you ask your Brand A vendor to lower your cost, just for the lights you sell to this customer. The vendor 
lowers the cost by offering you a rebate for each light you sell to this customer. You are then in a position 
to offer the customer a lower price and win their business. 

Each 845 transaction represents one vendor agreement for one customer or group of customers. The 
system uses the detail information from the 845 to create new sell matrix cells that establish the rebate 
cost that the vendor gives you for each product and product group included in the agreement. You then 
define a special selling price to use with those customers, if applicable. 

When the system receives an 845 from an EDI vendor, the system places the contract information in the 
EDI 845 Contract Upload Queue. After reviewing the data in the contract and adding any missing 
information to the Eclipse system, you requeue the 845 and then run the update, which creates, expires, 
and updates matrix cells in the Eclipse system. 

The system creates a sell matrix cell for each contract detail line item and then removes the line item from 
the 845 entry in the queue. Any line item for which the system could not create a matrix cell remains in 
the queue, from which you can view the contract detail and review the errors. If you do not want to create 
a matrix cell for a line item in error, you can manually remove the line item from the contract detail. If 
you do not want to create matrix cells for any of the line items in error, you can return to the queue and 
delete the 845 entry from the queue. If the system creates a matrix cell for every line item in the 845, it 
removes the 845 entry from the queue. 

The system tracks sales of products tied to pricing contracts and reports these sales when you send EDI 
844 Product Customer Rebate transactions (rebate requests) to the vendors who gave you the contracts. 
The vendors send back EDI 849 Response to Product Transfer Account Adjustment transactions, which 
indicate the rebates they will pay. 
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Setup Requirements for the EDI 845 Review Queue 
For users to manage and the system to process EDI 845s, the following setup is required. 

Control Maintenance Records 
The following control maintenance records should be considered when managing the queue: 

• Expire All Matrix Cells When EDI 845 Contracts Are Imported 

• Update Rebate View Dates When An EDI 845 Processes 

Authorization Keys 
The following authorization keys are required for users managing the queue: 

• EDI.IN.REVIEW - Allows access to the EDI 845 Contract Upload Queue. 

• PRODUCT.MAINT - Allows access to Product Maintenance. Users must be assigned Level 2 to 
edit a record. 

• SMATRIX.MAINT - Allows access to Sell Matrix Maintenance and Quick Sell Matrix 
Maintenance. 

• BUY.SELL.GROUP.MAINT - lows access to Buy/Sell Group Maintenance. 

• SMATRIX.COST.EDIT - Allows users to edit costs on Sell Matrix Maintenance and Quick Sell 
Matrix Maintenance. 

• SMATRIX.COGS.EDIT - Allows users to cost-of-goods-sold (COGS) costs on Sell Matrix 
Maintenance and Quick Sell Matrix Maintenance. 

Trading Partner Maintenance 
Create a vendor trading partner profile for which an 845 inbound document is defined. 

• Assign the vendor to a group profile defined for this trading partner. 

• On the EDI Add'l Doc Info screen for the 845, complete the following fields, as needed: 

• Grp/User to Review Received Document 

• Grp/User to be Notified of Document 

• Alternate Interchange ID 

• Cost Only Matrix 

• Default Selling Formula 

If the vendor's contract includes product group information, use the Sell Groups hot key on the 
EDI Add'l Doc Info screen to map the vendor's product groups to Eclipse sell groups. Trading 
Partner Maintenance is current unavailable in Solar Eclipse. 
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Customer Maintenance 
When you receive a pricing contract from a vendor, create a customer contract record for which the 
system sets up the sell matrix information. Then link the customers for which this contract was created to 
the customer contract record. The following method of creating and then linking to a customer contract 
record enables you to link multiple customers to one pricing contract. 

Set up customer records for contract pricing, as follows: 

• Create a generic customer contract record in Customer Maintenance. 

Include words that identify the vendor and the contract number in the Name and Index fields or 
use additional keywords to store them as keywords. 

Note: Because the system displays the Index in the 845 Queue, we recommend that you 
at least include the contract number in the Index field. The system cannot create 
the upload without the contract number being in one of these three locations. 

To set customer-level defaults, select Edit > Contracts on the Customer Pricing/Printing window. 

The sell matrix cells will be associated with this customer contract record. The actual customer 
records to whom this contract applies will link to this customer contract record for pricing. 

Note: Create a customer contract record for each new contract number. If a vendor sends 
an 845 with updated pricing and effective dates for an existing contract, the 
system uses the customer contract record that you set up the first time you 
received that contract number. 

• For each customer to whom this contract applies, select Edit > Contracts on the Customer 
Pricing/Printing window in Customer Maintenance to display the Contract Pricing window and 
enter the customer contract name. 
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Reviewing and Processing EDI 845 Pricing Contracts 
EDI vendor trading partners use 845 Price Authorization Acknowledgments to send you information 
about special pricing contracts for selling designated products to designated customers. Use this 
information to create new sell matrix cells that establish the rebate cost that the vendor gives you and the 
selling price you use with those customers. 

When the system receives an 845 from an EDI vendor, the system places the contract information in the 
EDI 845 Contract Review Queue. 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

The system uses the contract number to search the Name, Index, and Additional Keywords fields in 
Customer Maintenance for a matching customer contract record and sets the status of the queue entry, in 
the Status column, to one of the following: 

• Review (or Reviewed) - The system found a matching customer contract record, and the contract 
details are ready for review. 

• Updated - A contract for which you have run an update. When the 845 comes in, the system 
checks for an existing matrix cell that has pricing and rebate information. If the system finds a 
current matrix cell, that existing cell is expired as of the effective date of the new cell. The system 
then creates a new cell with the same type as the old one that was expired. The new rebate cost 
information is added to the new cell and the pricing information is copied over from the old, 
expired cell. Select View > Contract Detail from the 845 Contract Review Queue to review these 
line items. When all items on a contract are updated, the system removes the contract from the 
queue. 

Use the Expire All Matrix Cells When EDI 845 Contracts Are Imported control maintenance 
record to automatically expire all existing matrix values a day before new matrix created based on 
the imported EDI 845 effective date. For detailed information and examples, see EDI Control 
Maintenance Records in the online help documentation. 

Set the Update Rebate View Dates When An EDI 845 Processes control maintenance record to 
update Effective Dates and Expiration Dates for both Cost view and Rebate view in the sell matrix. 
Use caution as this may change your rebate costs. For detailed information, see EDI Control 
Maintenance Records in the online help documentation. 

• Not found - The system could not find a matching customer contract record. Create or identify a 
customer contract record and requeue the 845 before you can process the contract details. 

To review EDI 845 price contracts in the 845 Review Queue: 

1. Display the Selection Criteria window in one of the following ways: 

• From the System > Systems Programming > EDI > EDI Review Queues menu, select EDI 
845 Review Queue. 

• From the Purchase > Queues menu, select EDI 845 Contract Upload to display the EDI 845 
Review Queue. 

2. Enter the selection criteria and click OK to display 845 documents that meet the criteria. 
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Field Description 
Branch/Tr/All The branch, branches, or territory for which you want to display items in 

the EDI review queue. This is the branch to which the 845 contract 
update applies. This field defaults to All. 

Vendor Vendor that sent the 845. 

User User ID of the user assigned to review incoming 845s. 
This field defaults to your user ID. To review 845s for all users, leave 
this field blank. 
You must have Level 1 authorization in the EDI.IN.REVIEW 
authorization key to view your own entries in the queue. Level 2 
authorization is required to view other users' entries. 

Contract Pricing contract number. 

Received Start Date First received date for which to view 845s. For example, if you want to 
review all 845 contracts received in July 2007, enter 07/01/07 in this 
field and 07/31/07 in the Select End Date field. 

Received End Date Last received date for which to view 845s. For example, if you want to 
review all 845 contracts received in July 2007, enter 07/01/07 in the 
Select Start Date field and 07/31/07 in this field. 

Status Contract status: 
• All - All contracts. This is the default. 
• Reviewed - New contracts ready for review. 
• Updated - Contracts for which you have run an update and error 

messages need to be reviewed. 
• No Match - Contracts for which the system did not find a match. 

The system displays the following information about the selected 845s display on the EDI 845 
Review Queue window: 

Field Description 
Check box Flag that indicates which contracts the system processes when you use the File 

> Update Items menu option. Select the check box in this column to flag a 
contract for processing. 
When all items on a contract are processed, the system removes the contract 
from the queue. 
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Field Description 
Status Status of the 845 document in the queue: 

• R (Review) - A new contract that needs to be reviewed before doing 
an update. 

• U (Updated) -  A contract for which you have run an update. Following an 
update, the system deletes contract detail line items that successfully created 
new sell matrix cells, but still lists the contract detail line items that did not 
create new sell matrix cells. Select View > Contract Detail to review these 
line items. When all items on a contract are updated, the system removes the 
contract from the queue. 

• N (Not Found) - The inbound 845 did not match an existing customer 
contract record. Resolve this situation before processing any contract details, 
as follows: 
• Create or identify a customer contract record in Eclipse for this 845. 
• Enter the customer name in the Customer field in the 845 Contract 

Upload Queue. If the field does not display, select Options > Change 
View > Customer. When you do this, the system changes the status from 
Not Found to Review. 

Note: When you set up or edit a customer contract record, add the contract 
number to the entity record Name and Index fields or additional keywords for 
the contract. 

Type 
  

The 845 type: 
• 00 - New 
• 04 - Change to existing contract. The system finds the existing matrix cell 

and expires it, and then creates a new matrix with the new data from the 845. 
• 30 - Matrix renewal 
• 56 - Expire existing matrix 
To expire but not change an existing matrix cell, the vendor must send the 
contract with the type code of 56. 

Vendor Vendor that sent the 845. 

Customer Customer record to which the pricing contract applies. 

Contract Number Pricing contract number from the 845. 

Branch The branch or territory to which the contract applies. Type all if the contract 
applies to all branches. The system respects the user's branch authorization. 
This field is required. 

Important: Branch information for this field is based on your settings in the 
EDI 845 Vendor/Territory Cross Reference table. You can change the branch 
information in the EDI 845 Review Queue for a single session, but when you 
re-update the display the system refers to and pulls the branch information 
from this cross-reference table. 

Note: If a contract comes through with an unknown branch, the system sets the 
branch to DFLT. 

Last Received Date and time the 845 was received or last processed. 

3. To review and edit the detail of a contract, select a contract and select Edit > Contract Detail 
from the to display the Contract Detail window. 
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4. To update the contract in the Eclipse system, select the check box in the first column and select 
File > Process to display the Contract Update screen. 

The system creates a sell matrix cell for each contract detail line item and then removes the line 
item from the 845 contract detail. Any line item for which the system could not create a matrix 
cell remains in the contract detail, from which you can review the errors. After the system updates 
the items, it displays an error message indicating how many items processed successfully. 

Note: If you prefer to view the errors prior to processing any records, select File > Scan 
For Errors to display the error messages prior to entering items into the matrix. 

If you do not want to create a matrix cell for a single line item, you can manually remove the line 
item from the contract detail right-click on the row and select Delete Rows. If you do not want to 
create matrix cells for all the line items, you can return to the queue and select the check box for 
that contract and use the File > Delete to remove the 845 entry. 

If the system creates a matrix cell for every line item in the 845, it removes the 845 entry from the 
queue. 

More Options for Reviewing and Processing EDI 845 Pricing Contracts 

The 845 Contract Upload Review Queue also offers these options for reviewing and processing 845 
pricing contracts: 

To... Use this menu option... 
view the raw data of the 845 View > Archive Detail 

view and edit contract detail information View > Contract Detail 

enter new criteria for filtering the queue Edit > Select 

reprocess the selected 845 contract Edit > Requeue 

select which contracts to update and 
launch the update processes 

Edit > Update Items 
• In the Select Items field, select one of the following options: 
• Update All - Selects all contracts in the queue. 
• Flagged Items - Selects only the contracts flagged for update 

in the Update column on the queue. This option is the default. 
• Click OK to launch the update process. 

Note: You can verify the updates in the new sell matrix created 
from your actions. After the system updates the items, it displays 
an error message indicating how many items processed 
successfully. 

define additional information required to 
process an 845 contract for the selected 
vendor 

Edit > EDI Additional Document Information 
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Reviewing and Editing EDI 845 Pricing Contract Detail 
Review and edit the detail of pricing contract information the system receives on EDI 845 Price 
Authorization Acknowledgment documents. Each line on the Contract Detail window displays the data 
relevant to each product and product group included in the selected contract. The system uses the UPC# 
to locate matching product records in Eclipse and uses the group ID to locate matching sell groups in the 
Sell Group Translation window associated with the 845's group profile in Trading Partner Maintenance. 
The system sorts the queue entries in the following order: 

• Products not found. 

• Matching products, sorted by price line and then product sequence within price line. 

• Groups not found. 

• Matching groups, in alphabetical order. 

The system creates a sell matrix cell for each matched line when you run the contract update. Before 
running the update, you need to review and edit the contract detail. 

Use the views in the Contract Detail window to review and scan for errors and edit the contract detail. As 
you are reviewing details, the lines in error display with an icon  in the Error field. Move your cursor 
over the icon to display the error message. You can also select the item in error and select View > View 
Error messages. Use the Error icon as a way to scan the list for the items that require your attention 
before updating the contracts. 

• EDI/Product Group - Use this view to research and correct ** Product Not Found ** and ** 
Group Not Found ** entries. After you have made corrections to the product and group records, 
return to the queue and reprocess the 845. 

• Rebate Cost - Use this view to set the rebate cost for stock sales of the designated products/groups 
to the designated customers. 

• Direct Cost - Use this view only if the contract offers you a rebate cost for direct orders. 

• Sell Price - Use this view only if the vendor specifies the contract sell price or if you want to adjust 
your standard selling price for the customer. If you want to create cost-only matrix cells for the 
contract, use this view to set the Cost column to Yes. 

Note: The system auto-populates the fields in this view, if default values have been set in 
Customer Maintenance or Trading Partner Maintenance. 

Note: You can double-click the Error column heading to sort all the lines with errors to 
the top of the queue. 

To review and edit EDI 845 pricing contract detail: 

1. Display the Selection Criteria window in one of the following ways and enter the selection 
criteria: 

• From the System > System Programming > EDI > EDI Review Queues menu, select EDI 
845 Review Queue. 

• From the Purchase >Queues menu, select EDI 845 Review Queue. 

2. Select a contract you want to review or edit and select View > Contract Detail to display the 
EDI/Product Group view of the Contract Detail window. 
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Note: The window has four views. Select Options > Change View to select a different 
view. 

3. Review and edit the data displayed in the EDI/Product Group view to resolve "product not 
found" and "group not found" errors by updating the Product file and the Sell Group Table in 
Trading Partner Maintenance, as needed. 

After making the required updates and before viewing the other views, return to the queue and 
select Edit > Requeue to reprocess the 845. 

Leave product/group "not found" entries in the queue if you do not want to create matrix cells for 
those products/groups. When you run an update, the system ignores these entries. You can also 
use the Alt-Delete keys to delete line items for products you do not sell. 

Field Description 
Error Move your cursor over the icon in this field to display the error for the line 

item. This field is blank for items received without errors. 

Group/Product Eclipse description of the product or product sell group. 
Products 
The system uses the UPC# from the 845 to locate matching product records in 
Eclipse. If the system cannot find a matching product, it displays the following 
message: ** Product Not Found **. In this case, select Edit > Product Maint 
to access Product Maintenance and use the UPC# or the vendor catalog number 
to search the Product file for a matching record. When you find a match, select 
Additional Data > UPC Code Maintenance within Product Maintenance and 
enter the UPC# in the Primary UPC or Secondary UPC field in the UPC 
Codes Maintenance window. 
Product Groups 
The system uses the group ID to locate matching sell groups in the Sell Group 
Translation window associated with the 845's group profile in Trading Partner 
Maintenance. If the system cannot find a matching product group, it displays 
the following message in this field: ** Group Not Found **. In this case, you 
need to update the Sell Group Translation window to include the group ID. 

UPC # Product's universal product code. 
Data from the 845 populates this field. 

Price Line Eclipse price line to which the product or product group belongs. 
Data from the Eclipse product record or the product sell group populates this 
field. 

Vendor Group / 
Catalog # 

Vendor's product group ID or product catalog number. 
Data from the 845 populates this field. 

Matrix Indication whether a sell matrix cell for this product, product group, customer 
and branch exists in the Eclipse system. 
An asterisk (*) in this column indicates that a sell matrix cell exists. 

4. Review and edit the data in the Rebate Cost view, to set the cost rebate for stock sales of the 
designated products to the designated customers. 
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The vendor contract designates either a net cost, which displays with a dollar sign ($), or a 
formula for calculating the cost rebate. Enter the Eclipse cost basis the system uses to calculate 
the rebate amount. 

Field Description 
Error Move your cursor over the icon in this field to display the error for the line 

item. This field is blank for items received without errors. 

Group/Product Eclipse description of the product sell group or product. 

Cost Basis Eclipse cost basis to use in calculating the rebate amount. You cannot enter 
Ord COGS or Ord Comm as the cost basis in this field as they apply to sell 
prices only. 
This field is required. 

Note: If the vendor specifies a net cost rebate, the system does not use the cost 
basis entered here, but the program still requires you to enter one. 

Cost Net cost rebate, which displays with a dollar sign ($), or a formula for 
calculating the cost rebate. Discounts are identified with a minus sign (-). 
Data from the 845 populates this field. 

Price Date Price sheet date that determines the value of the cost basis used in the formula 
for calculating the cost rebate. 
Data from the 845 populates this field, only if the vendor provides the data. If 
this field is left blank, the system does not upload a date into the matrix. 
You can edit this field, if needed. 

Effective Date Start date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Expiration Date End date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Matrix Indication whether a sell matrix cell for this product or product group exists in 
the Eclipse system. 
An asterisk (*) in this column indicates that a sell matrix cell exists. 

5. If the pricing contract includes cost rebates for direct orders, review and edit the data in the 
Direct Cost view. 

Use this view only if the contract offers you a cost rebate for direct orders. 

The vendor contract designates either a net cost, which displays with a dollar sign ($), or a 
formula for calculating the cost rebate. In either case, enter the Eclipse cost basis the system uses 
to calculate the rebate amount. 

Field Description 
Error Move your cursor over the icon in this field to display the error for the line 

item. This field is blank for items received without errors. 

Group/Product Eclipse description of the product sell group or product. 
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Field Description 
Cost Basis Eclipse cost basis to use in calculating the rebate amount. 

Eclipse cost basis to use in calculating the rebate amount. You cannot enter 
Ord COGS or Ord Comm as the cost basis in this field as they apply to sell 
prices only. 
This field is required. 

Note: If the vendor specifies a net cost rebate, the system does not use the cost 
basis entered here, but the program still requires you to enter one. 

Cost Net cost rebate, which displays with a dollar sign ($), or a formula for 
calculating the cost rebate. Discounts are identified with a minus sign (-). 
Data from the 845 populates this field. 

Price Date Price sheet date that determines the value of the cost basis used in the formula 
for calculating the cost rebate. 
Data from the 845 populates this field, only if the vendor provides the data. If 
this field is left blank, the system does not upload a date into the matrix. 
You can edit this field, as needed. 

Effective Date Start date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Expiration Date End date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Matrix Indication whether a sell matrix cell for this product, product group, customer, 
and branch exists in the Eclipse system. 
An asterisk (*) in this column indicates that a sell matrix cell exists. 

6. If the vendor specifies the contract sell price or if you want to adjust your standard selling price 
for the customer, use the Sell Price view. 

Note: If you want to create cost only matrix cells for the contract, use this view to set the 
Cost column (Override Cost Only flag) to Yes. 

Field Description 
Error Move your cursor over the icon in this field to display the error for the line 

item. This field is blank for items received without errors. 

Group/Product Eclipse description of the product sell group or product. 



Solar Eclipse Electronic Data Interchange (EDI) 

171 

Field Description 
Cost Indication whether the matrix type for this line item's sell matrix cell is 

Override Cost Only. The system populates this field with the value entered in 
the Cost Only field on the Contract Upload Settings window for this contract in 
Customer Maintenance or the Cost Only Matrix field on the trading partner's 
Additional Doc Info window for the 845 in Trading Partner Maintenance. The 
field in Customer Maintenance takes precedence over the field in the additional 
doc info. 
• Yes - The matrix cell the system creates will an O type matrix, which 

does not allow you to set a selling price. When you set this field to 
Yes, you cannot access the Formula field. 

• No - The matrix cell the system creates will be a N type matrix, which allows 
you to set the selling price as well as the cost. 

Note: If you change an N to Y, the system clears the Formula field. 

Price Basis Eclipse price basis used in calculating the selling price. Enter Ord COGS to 
use the cost of goods sold price basis which is the true cost of merchandise that 
includes any expense you incurred to sell the product. 
Enter Ord Comm to use the commissions cost basis. 
This field is required. 

Note: The system validates this field with the price basis associated with the 
price line to which the product belongs. 

Formula Formula for calculating the selling price for the product. 
This system populates this field as follows: 
• The system uses data from the 845, if the vendor sends a formula for 

calculating the selling price. 
• If the vendor does not send a formula, the system uses the value entered in the 

Formula field on the Contract Upload Settings window for the generic 
customer contract record in Customer Maintenance. 

• If the Formula field is blank, the system uses the value entered in the 
Default Selling Formula field on the EDI Add'l Doc Info window for the 
845 defined for the group profile in Trading Partner Maintenance. 

• You can also populate this field with your own formula. 

Price Date Price sheet date that determines the value of the price basis used with the 
formula for calculating the selling price. 
Data from the 845 populates this field, only if the vendor provides the data. If 
this field is left blank, the system does not upload a date into the matrix. 
You can edit this field, as needed. 

Effective Date Start date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Expiration Date End date of the sell matrix cell the system creates for this line item. 
Data from the 845 populates this field and is view only. 

Matrix Indication whether a sell matrix cell for this product, product group, customer, 
and branch exists in the Eclipse system. 
An asterisk (*) in this column indicates that a sell matrix cell exists. 
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6. To delete rows from the contract, select the row or rows you want to delete, right-click and select 
Delete Row. 

When you close the Contract Detail window, select Yes to the save prompt to make the deletions 
permanent. If you select No, the system returns the items you deleted to the contract. 

8. Save your changes and exit the window. 

Note: After returning to the EDI 845 Contract Upload Queue screen, use the Update 
Items hot key to process the changes you entered. 

More Options When Reviewing and Editing EDI 845 Pricing Contract Detail 

The Contract Detail window also offers the following options for reviewing and editing 845 pricing 
contract details: 

To... Use this menu option... 
copy the value in the selected field to the end of the column. Use this 
hot key to quickly enter the same value in multiple fields. 
For the Basis field, the Copy to End function only copies to the end 
of the column, within a single price line. 

Edit > Copy to End 

display a selection list of views, which change the fields displayed Options > Change View 

display the selected product in Product Maintenance, if you are 
authorized 

Edit > Product Maint 

displays the sell matrix cell for the selected contract in Sell Matrix 
Maintenance, if you are authorized. 

Edit > Matrix Maint 
This menu option is only available 
for line items with a valid matrix. 

display the errors that prevented the system from creating a sell matrix 
cell for the selected line item. 

View > View Errors 

Note: This menu option is active for 
any given line item only after the 
update for the 845 is run and only if 
errors exist. 

You can also identify lines with 
errors using the icon  in the Error 
field. Move your cursor over the icon 
to display the error message. You can 
also select the item in error and select 
View > View Error messages. Use 
the Error icon as a way to scan the 
list for the items that require your 
attention before updating the 
contracts. 

search for a product listed on the window using keywords View > Find 
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Reprocessing EDI 845 Pricing Contracts 
The EDI 845 Review Queue displays pricing contracts received by EDI. As you receive and review 845 
contracts, you may find it necessary to requeue a contract after you resolve customer contract or 
product/group not found errors. You can requeue all or a portion of an 845 contract directly from the EDI 
845 Contract Upload Queue. You can also requeue a specific contract, or requeue all contracts that fall 
within a date range. 

For example, you receive an 845 that contains a product not found error. After reviewing the contract, you 
decide to add the product in Product Maintenance. After you add the product to the system, requeue the 
contract to determine if the line items match. 

Note: You can set up the system to automatically renew contracts, if needed. For more 
information, see Automatically Renewing 845 SPA Contracts in this 
documentation. 

Users must be assigned the EDI.IN.REVIEW authorization key to access the review queue. 

To reprocess an EDI 845 pricing contract: 

1. Display the Selection Criteria window in one of the following ways and enter the selection 
criteria: 

• From the System > System Programming > EDI > EDI Review Queues menu, select EDI 
845 Review Queue. 

• From the Purchase >Queues menu, select EDI 845 Review Queue. 

2. Review EDI 845 contracts in the EDI 845 Review Queue and make any necessary changes to the 
contract detail or to your system records. 

3. Select the contract that you want to requeue and select Edit > Requeue to display the Requeue 
Entry window. 

Note: If you want to requeue all the contracts in the queue, it is not necessary to select a 
specific contract prior to selecting Edit > Requeue. 

4. Enter the following selection criteria and click OK to reprocess the contract. The system updates 
the Last Received date and time to reflect the current day. 

Field Description 
All or Remaining 
Items 

Select All to requeue all the items on the contract, or select Remaining to 
requeue only those items that have not yet been updated in the system. 

Current Line or 
Date Range 

Select Current Line to requeue only the contract that was selected when you 
selected Edit > Requeue, or select Date Range to requeue contracts that you 
received with in a specific period of time. Use the Start Date and End Date 
fields to enter the date range. 

Start Date If you selected Date Range in the Current Line or Date Range field, enter 
the first day on which you want to requeue contracts. For example, if you 
want to requeue all contracts for the first seven days of August 2007, enter 
08/01/07 in the Start Date field and 08/07/06 in the End Date field. 
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Field Description 
End Date If you selected Date Range in the Current Line or Date Range field, enter 

the last day on which you want to requeue contracts. For example, if you want 
to requeue all contracts for the first seven days of August 2007, enter 
08/01/07 in the Start Date field and 08/07/06 in the End Date field. 

A message displays if the system cannot process any items in the 845. Review the contract detail 
again, make any updates, and reprocess. 
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Entering Additional 845 Document Information 
Use additional documentation information to define additional parameters required to process an 845 
pricing contract for an EDI trading partner. 

To enter additional 845 document information: 

1. Display pricing contracts in the 845 Contract Upload Queue. 

2. Select a line from a vendor whose 845 document information you want to update. 

3. From the Edit menu, select EDI Additional Document Information to display the EDI 
Additional Document Information window for the vendor. 

4. Enter the following information: 

Note: Use the Product Matching hot key to define how you want the EDI 845 to 
determine matching priorities on the product data. This is new in Release 9.0.5. 

Field Description 
Grp/User to 
Review Received 
Document 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Grp/User to be 
Notified of 
Document 

Enter the ID of the person or message group to notify when an EDI 
transaction is received. 

Alternate 
Interchange ID 

Identify a test ID (or alternate production ID) for your trading partner. It 
follows the same format as the group number. Use this field instead of 
setting up a separate profile for the purpose of testing with your partner.   

Note: When entering EDI Trading Partner Maintenance and entering a 
Trading Partner ID number, the IDs listed include this Alternate 
Interchange ID. We recommend that you always choose the main profile 
and get to the Alternate Interchange ID through the main profile, not by 
selecting the alternate interchange at this point. 

Cost/Price Matrix Select from the following options for how you want to handle matrix 
creations based on the incoming document from your trading partner: 
• C - Cost Only Matrix - This option creates a cost-only matrix with 

matrix type 'O.'   
• P - Price Only Matrix - This option creates a price-only matrix 

which restricts cost values from EDI. 
• B - Cost and Price Matrix - This option creates a matrix with both 

options. This is the default. 

Default Selling 
Formula 

Enter the pricing formula, if the vendor always uses the same formula for 
determining your selling price for 845 pricing contracts. 
The system populates the Formula column in the Sell Price view on the 
845 Contract Detail with this formula. 
You can override the formula for individual customers in the Formula 
field on the Contract Upload Settings screen in Customer Maintenance or 
for individual 845s in the Formula column of the Sell Price view of the 
845 Contract Detail. 
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Field Description 
Update COMM-
COST on Sell 
Matrix 

Indicate whether the system should upload and update the COMM-cost in 
addition to the COGS cost. 
If set to Yes, the system applies the formula and basis for the rebate cost 
of goods sold (COGS) to the rebate COMM cost, and from the direct 
COGS to the direct COMM cost. 

Invert Multiplier Specify whether the vendor sends straight multipliers or an inverse 
multiplier in their inbound 845 documents. The multiplier is a number 
that the vendor sends in the 845 that is used in the pricing matrix formula 
to calculate the rebated cost that is applied to a product when it is sold. 
The vendor can send the multiplier in one of two formats: 
• Actual multiplier - For example, the formula is sent as 0.55 and 

the value used in the pricing matrix formula is the exact same 
value. In this case, set this field to No to indicate in the formula 
that you want to use 55% of the amount. 

• Inverse multiplier - For example, the formula is sent as 0.55, but it 
needs to be inverted to 0.45. In this case, set this field to Yes to indicate 
in the formula that you want to use 55% off the amount. 

Auto Create 845 
Renewal SPA 

Enter Y to let the system create renewals automatically for special pricing 
agreements (SPA). The system conducts the same checks as if you were 
processing it manually through the 845 Contract Upload Queue. 

Default Global 
SPA COGS Basis 

Enter the cost-of-good-sold (COGS) basis you want the system to use 
when automatically processing SPA agreements. 

Default Global 
SPA Direct COGS 
Basis 

Enter the direct cost-of-good-sold (COGS) basis you want the system to 
use when automatically processing SPA agreements. 

Sell Groups Use the Sell Groups hot key to display the Sell Group Translation screen, 
where you list the vendor's product groups and map them to Eclipse sell 
groups. 
• In the Vendor Group column, enter the vendor's product groups. 
• In the Sell Group column, for each vendor group, select or enter the 

corresponding Eclipse sell group. 
• Use the Group Matrix hot key, as needed, to display the Buy/Sell 

Group Maintenance screen, where you can create new Eclipse sell 
groups. 

Enable Product 
Matching Priorities 
New in Release 
9.0.5 

Indicate if you want to match your products when receiving EDI 845 
documents by other parameters than by UPC or EAN codes.  
You can decide which options on which to match and in what order 
giving you more control over your product matching priorities. Set this 
option to Yes to activate the Product Matching hot key. For more 
information about this option, see Defining Product Matching Priorities 
for EDI. 
By leaving this set to No, the system works as designed prior to Release 
9.0.5 using the UPC and EAN codes on 845 documents. 
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Field Description 
Ignore Purpose 
Code for Auto 
Creation 

In conjunction with the Auto Create 845 Renewal SPA option above, 
you can set this option to Yes to only bypass the EDI 845 Contract 
Review Queue and automatically update the sell matrix records. This 
requires the second field value in the Beginning Segment for Price 
Authorization Acknowledgement/Status (BPA) be set to 04. 

The default is No. 

If this option is set to Yes, the system addresses the following: 
• If Sell Matrix records already exist for the specified contract and 

product, then the system automatically sets the existing records to 
expire the day before the new contract records are set to take effect, 
and creates new Sell Matrix records for the updated contract 
information. 

• If Sell Matrix records do not already exist for the specified contract 
and product, then the system  automatically creates new Sell Matrix 
records for the contract information. 

• If the system is unable to match a part number (UPC or vendor 
catalog) in the 845 data, then the 845 contract information for only 
the product(s) that the system was unable to match goes to the EDI 
845 Contract Review Queue.  

5. Save your changes and exit the window. 

To enter sell groups for the vendor: 

1. From the EDI Additional Document Information window, select Sell Groups from the Edit 
menu to display the EDI Sell Group Translation window, where you list the vendor's product 
groups and map them to Eclipse sell groups. 

2. In the Vendor Group column, enter the vendor's product groups. 

3. In the Sell Group column, enter the corresponding Eclipse sell group. 

4. If you need to create new sell groups, select Edit > Group Maintenance to display the Buy/Sell 
Group Maintenance window. 

5. Save your changes and exit the window. 
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Automatically Assigning EDI 845 Pricing Contracts by 
Branch or Territory 
Use the EDI 845 Vendor/Territory Cross Reference window to help you maintain the branch or territory-
level pricing contracts you have with your vendors. 

Updating the pricing contract information in this window keeps the EDI 845 Review Queue up to date. 
When the EDI 845 is received, Eclipse checks the EDI 845 Vendor/Territory Cross Reference Table and 
populate the EDI 845 Review Queue with the defined branches and territories. You can change the branch 
information in the EDI 845 Review Queue for each contract. 

 Important: You must have an EDI Trading Partner defined in EDI Trading Profile 
Maintenance for the vendor for which you want to add cross-reference values. 
The system alerts you if no trading partner is associated and does not open the 
window. 

Displayed and accessible branches for this window are dependent on the User Accessible Branches 
settings. Only branches for which the logged in user are authorized display. Likewise, territories are 
limited to those that contain only the user's authorized branch. 

To review an 845 pricing contract: 

1. From the Maintenance menu, select Vendor to display Vendor Maintenance. 

2. Display the vendor for which you need to review pricing contracts by branch. 

3. From the Additional > EDI menu, select EDI 845 Vendor/Territory Cross Reference. 

Note: The system alerts you if no trading partner is associated and does not open the 
window. 

4. Do one of the following: 

• Add a line - Use the empty line at the bottom of the Br/Territory column to add a new branch 
or territory contract for this vendor. 

• Delete a line - Select the branch or territory which no longer has a valid contract. 

• Update a line - Adjust the branch, territory, or contract number for the vendor 

• Add a Create Date - For new contracts enter the date the contract was created. The create date 
lets users see how old contracts are and delete ones that are no longer needed. 

Note: The Contract Number field has a maximum of 30 characters and can be 
alphanumeric, as needed. 

5. Save your changes and exit the window. 
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Automatically Renewing 845 SPA Contracts 
If you frequently have special pricing agreements that do not change and just need to be renewed, you can 
set up the system to automatically renew the contract and create the new matrix cell. You can use the SPA 
Matrix Review Queue to review any updates or pricing changes, as needed. The system handles errors, 
such as when products are not found, but universal product codes (UPCs) are located. You can fix errors 
and adjust pricing as needed. The system also leverages your product data warehouse (PDW) to locate 
product and the corresponding UPCs. 

Note: You can create a widget for both the SPA Matrix Review Queue and the 845 
Contract Upload Queue, if you monitor either of them on a regular basis. 

To automatically renew a SPA agreement, setup a trading partner with the correct parameters. Then you 
can use the SPA Matrix Review Queue to renew at a glance, the contracts that come through EDI to your 
system. 

When contracts are automatically renewed, the system expires the old matrix, copies the sell information 
to a new matrix and populates the information accordingly. 
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To setup a trading partner to automatically renew a special pricing agreements: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select a group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Select the 845 document number and use the Add'l Doc Info hot key to display the EDI Add'l 
Doc Info screen. 

4. In the Auto Create 845 Renewal SPA field, enter Y to activate the automatic renewals. 

5. In the Default Global SPA COGS Basis field, enter the cost-of-good-sold (COGS) basis you 
want the system to use when automatically processing SPA agreement renewals. 

6. In the Default Global SPA Direct COGS Basis, enter the direct cost-of-good-sold (COGS) basis 
you want the system to use when automatically processing SPA agreement renewals. 

7. Press Esc to save your changes and exit the screen. 

8. From the Purchase > Queues menu, select EDI 845 Review Queue to display the contract 
upload queue. 

9. Review 845 Contract Upload Queue. 

The system creates an 04 document and checks the Trading Partner Connect file to see if the 
auto-renewal is flagged. If the auto-renewal is not flagged, the system places the file into the 
standard 845 Contract Upload Queue. 

To review pricing agreements: 

1. From the Purchase > Queues menu, select SPA Matrix Review Queue. You can also double-
click the contract matrix from Quick Sell Matrix Maintenance. 

Note: This queue is only available in the Solar application. 

2. Use the header fields to filter the information you need to display and click Update. 

Field Description 
Branch/Tr/All Enter the pricing branch for which you want to view the SPA matrix. 

Inside Sales Enter the sales person responsible for inside sales if you want to view only those 
contracts for a particular salesperson. Leave blank to run for all sales people. 

Outside Sales Enter the sales person responsible for outside sales if you want to view only 
those contracts for a particular salesperson. Leave blank to run for all outside 
sales personnel. 

Vendor Enter the vendor responsible for fulfilling the contract agreement. Leave blank to 
run for all vendors. 

The system displays the current matrix information for each branch by branch. 



Solar Eclipse Electronic Data Interchange (EDI) 

181 

3. Review the matrix queue columns. 

Field Description 
Branch* The branch to which the SPA applies. 

Vendor* The vendor with whom the SPA has been made. 

Customer/Contract* The auto-assigned contract number or the customer number as found 
in Customer Maintenance. 

SPA Number* The auto-assigned SPA number. 

Effective Date The date on which the SPA takes effect. 

Expire Date The date on which the SPA no longer applies. 

Source The location from which the information has come to place the SPA 
in the queue. 

Receive Date* The date the SPA renewal request has been received. 

* View Only 

Note: Use the View menu to display other columns. 

4. Use the check boxes to select which contracts you want to remove from the queue, if any. 

5. From the Edit menu, select Remove. 

This action permanently removes that contract information from the queue. The contract is still 
accessible through the EDI 845 Contract Upload Queue. 

6. Use the Matrix Review Queue to review and make changes, as needed. 

7. Save your changes and exit the window. 
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Handling *Product Not Found* Errors from the EDI 845 
Review Queue 
When new special pricing agreement (SPA) contracts on products are received, sometimes those products 
are not defined in the product file. The system produces a ***Product Not Found*** error message in the 
EDI 845 Review Queue for each product. By using the EDI 845 Review Queue, you can save these 
products to a file so the information is not lost. 

The system checks to see if all the information needed to create a matrix is defined. If not, an error 
message displays with the additional information that is required, such as Basis Not Defined. After the 
information is saved off to a file the ***Product Not Found*** errors can be removed from the EDI 845 
Review Queue. 

If the product is created through Sales Order Entry using the Non-Stock Product Entry feature and has the 
same universal product code (UPC) as a product saved off to the file, the system automatically creates the 
contract matrix and uses it on the sales order. This new SPA contract then populates the SPA Matrix 
Review Queue for pricing review. 

To handle *Product Not Found* Errors: 

1. From the Purchase > Queues menu, select EDI 845 Review Queue to display the EDI 845 
Review Queue. 

2. Set the heading parameters to find the contracts you want to review. 

3. Select the row with *Product Not Found* that you want to save the information for. 

4. From the Edit menu, select Contract Detail to display the Contract Detail window. 

When viewing the ***Product Not Found*** Errors, any line that has a net price uses the cost 
basis defined at the Vendor Trading Partner level, if defined.  Since the system does not have all 
the information to determine the local basis, the field populates with the current default basis, 
such as *Auto* DFLT-COST. 

5. From the Edit menu, select Save Contract Information. 

The system can then reference this saved information when products are added by UPC code. 
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Receiving EDI 846 Inventory Advice Documents 
In response to an 846 Inventory Advice document from an EDI customer, the system creates a 
consignment sales order with an order status of Invoice and print status P. The system places the order in 
the Remote Order Entry Review Queue and sends a message to the user responsible for reviewing 
incoming orders. 

This process allows the system to relieve the consignment inventory. The system does not send an 
invoice. The invoice only bills for usage to relieve consignment inventory at the appropriate location. 

Before the system can process an 846, set up the system as follows: 

• Set the Incoming EDI 846 Status control maintenance record to P for Preview. 

• All the ship-tos in the 846 must be set up in the receive code table in the trading partner group 
profile. 

• For all the ship-tos that an 846 uses, select the Consignment Inventory? check box field on the 
Additional Customer Information window. Otherwise, the system sends the document to the EDI 
Error Queue with the following message: To EDI Administration: EDI Customer : <Customer 
Name> - Consignment Flag Not Set For 846 -ECIERR - EDI ERROR#5021 
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Receiving EDI 849 Rebate Responses Overview 
In response to an 844 Product Transfer Account Adjustment (Rebate Request) that you send to a vendor 
using EDI, the vendor sends back an EDI 849 Response to Product Transfer Account Adjustment (Credit 
Memo), which indicates the rebate the vendor has approved. 

You can receive an 849 with or without using the Book Letter of Credit feature. When the system uses the 
Book Letter of Credit feature and generates the 844, it creates a negative purchase order for the total 
rebate amount and stores detailed information about each product rebate request in the Rebate Detail file. 
When the system receives the 849 reply from the vendor, it adds the vendor's rebate detail to the file. 

Before the system can process an 849, set up the system and the vendor record for EDI processing. How 
you set up your system determines which mapper the system uses to process the 849 you receive. 

• When not using the book letter of credit feature, the system places the 849 document in the Hold 
file and sends you a message. 

• When the system determines that the 849 being sent back is tied to a rebate purchase order created 
using the Book Letter of Credit feature, the system updates that purchase order’s rebate detail 
information in the Rebate Detail file, and sends you a message. 

To set up the system, do the following: 

• Create a trading partner profile for which an inbound 849 document is defined. 

• If the vendor is a Book Letter of Credit vendor, in the EDI Group Profile Global Info Table for 
the trading partner group profile, enter Y in the Book Letter of Credit Vendor field. In this 
case the system uses a different mapper for processing the 849. 

• On the EDI Add'l Doc Info screen for the 849, complete the following fields, as needed: 

• Grp/User to Review Received Document 

• Grp/User to be Notified of Document 

• Alternate Interchange ID 

• Assign the vendor account from which you receive the 849 to a group profile defined for the EDI 
trading partner profile. 
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Receiving EDI 849 Rebate Responses 
Use one of the EDI 849 Rebate Queues (Detail or Summary) to review EDI 849 Response to Product 
Transfer Account Adjustments (Credit Memos), which a rebate vendor sends to you in response to an 844 
Product Transfer Account Adjustment (Rebate Request). The 849 indicates the rebate the vendor has 
processed. The system can receive an 849 with or without using the Book Letter of Credit feature. 

• Not Using Book Letter of Credit - When not using the book letter of credit feature, the system 
places the 849 document in the Hold file and sends you a message. 

• Using Book Letter of Credit - When the system determines that the 849 being sent back is tied to a 
rebate purchase order created using the Book Letter of Credit feature, the system updates that 
purchase order’s rebate detail information in the Rebate Detail file, and sends you a message. Use 
the Using the EDI 849 Rebate Detail Queue to review the 849 detail. 

To review an EDI 849 that does not use the Book Letter of Credit feature: 
Note: The system sends you a message when it receives an 849 document. 

1. View the 849 document in Your Report Queue (Your Hold Files). 

2. Resolve any differences you may have with the vendor, as needed. 

3. Create a payable (negative invoice) for the rebate amount. 

To review an EDI 849 that uses the Book Letter of Credit feature: 
Note: The system sends you a message when it receives an 849 document. The message 

contains the ID of the Eclipse rebate purchase order associated with the 849. 

1. From the Purchase > Queues menu, select one of the following: 

• EDI 849 Rebate Detail Queue - Provides extended details for the orders, such as customer 
numbers, catalog IDs, payable IDs and invoice numbers. 

• EDI 849 Rebate Summary Queue - Displays only the payable, the proposed and accepted costs 
and their differences. Use this queue to resolve those differences. 

2. Exit the queue. 
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Reviewing Book Letter of Credit EDI 849 Rebate Detail 
Differences 
Use the Rebate Detail Maintenance window to create a spreadsheet on your computer, where you can 
review the detail differences between the a rebate request sent to a vendor in an EDI 844 using the Book 
Letter of Credit feature and the approved rebate in the EDI 849 response sent back from the vendor. 

When the system generates the 844, it creates a negative purchase order for the total rebate amount and 
stores detailed information about each product rebate request in the Rebate Detail file. When the system 
receives the 849 reply from the vendor, it adds the vendor's product-level rebate detail to the Rebate 
Detail file. 

To review the data in the file, you need to export the data to a spreadsheet on your computer. You can use 
the Export option to export the entire file or you can use the Export Exceptions option to export just the 
line items that contain discrepancies between the requested and approved rebate amounts. 

The primary purpose of the spreadsheet is to allow you to review the details of a rebate request and rebate 
reply, so you can see where the discrepancies occur. All but four fields on the spreadsheet are view-only. 

• If you understand the discrepancies but do not want to make any changes, you can return to the 
Rebate Detail Maintenance window. 

• If you adjust your rebate costs so that your rebate detail matches the vendor's, then you can import 
the updated detail back into the Rebate Detail file. 

To review rebate detail differences: 

1. From the Purchase > Queues menu, select Rebate Detail Maintenance to display the Rebate 
Detail Maintenance window. 

2. In the P/O Number field, press F10, select the purchase order associated with the 849, and press 
Enter. 

3. Use one of the following menu options to copy data from the Rebate Detail file to a spreadsheet 
program on your computer: 

• File > Export - Copies the entire detail file. 

• Edit > Export Exceptions - Copies only the product line items that contain discrepancies 
between the requested and approved rebate amounts. 

The system prompts you to assign a file name and directory location for the spreadsheet, and then 
displays the spreadsheet, which shows the following information. 

4. Review the rebate detail, resolve differences with the vendor as needed, and enter edits when 
appropriate. 

Note: All fields are view-only, except for the four fields flagged with an asterisk (*). 

Field Description 
P/O#~Line Number Purchase order and line on which you requested the rebate for the 

designated product. 

Invoice # Invoiced sales order on which the designated product was sold. 

Description Product description. 
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Field Description 
Quantity Product quantity sold. 

Rebate Cost Eclipse product rebate cost. 

Override Rebate Cost * Override for Eclipse product rebate cost. 
To change the Eclipse rebate cost to match the vendor's rebate cost, copy 
the value from the Vendor Rebate Cost field on the spreadsheet and enter 
it here. 

Cost Eclipse product cost. 

Rebate Amount Eclipse requested rebate amount. 

Cat # Vendor's product catalog number stored in the Eclipse Product file. 

Dispute * ANSI code on the 849, indicating why the vendor disputes your rebate 
request for the designated product. 
Although it is unlikely that you would need to change this code, you can 
edit this field. 

Notes Entered * Personal notes. 
Enter notes for your personal use in this field. 

Accepted * Indication from the vendor that designates whether they accepted your 
rebate request. 
• Y - Accepted. 
• N - Not accepted. 
If you have resolved a rebate difference with the vendor, you can change 
the N to a Y. 

Contract # Eclipse pricing contract number. 

Customer ID # Eclipse customer ID number. 

UPC Product UPC code. 

Customer Name Eclipse customer name. 

Vendor Part # Vendor's part number for the product. 

Line # Line on which the product is listed on the sales invoice. 

Ship Date Date the product shipped. 

Branch Branch from which the product shipped. 

Stock or Direct Indication whether the product sold was from stock or a direct order. 

Vendor Quantity Product quantity from the 849. 

Vendor Cost Product cost on the 849. 

Vendor Rebate Cost Product rebate cost on the 849. 

Product Number Eclipse product ID number. 

Credit Memo Vendor's ID for credit memo issued for the rebate amount. 

Vendor Proposed 
Rebate Amount 

Rebate amount the vendor plans to pay. If this value is present, the system 
uses this value to calculate the rebate amount. 
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Field Description 
Resubmit Indication from the vendor whether you should correct and resubmit a 

rejected rebate request. 
• Y - You should correct and resubmit this rebate request. 
• N - The rebate request was approved, so there is no need to resubmit the 

request. 

5. Do one of the following: 

• If you understand the discrepancies but do not want to make any changes, return to the Rebate 
Detail Maintenance window. 

You can delete or archive the spreadsheet on your PC. 

• If you edited fields on the spreadsheet and want to update the Rebate Detail file, do the 
following: 

• On the Rebate Detail Maintenance window, select File > Import hot key to copy the 
updated rebate detail from the spreadsheet back to the file. 

• The system prompts you to select the spreadsheet file from your PC and populates the 
Enter DOS Path Name field on the prompt screen with the selected file name. 

• Click OK to import the data. 

• If you entered values in any of the Override Rebate Cost fields, the system updates the 
P/O Value field on the Rebate Detail Maintenance window accordingly. 

 Important: The import function only imports changes to the following fields: Override 
Rebate Cost, Dispute, Notes Entered, and Canceled. Any entry in the 
Canceled column on the spreadsheet removes the amount from the Detail 
Value field since it signifies a canceled item. 

• Delete or archive the spreadsheet on your PC. 

6. Complete the receiving process for the 849, as described in Receiving EDI 849 Responses to 
Product Transfer Account Adjustments. 
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Using the EDI 849 Rebate Summary Queue 
After creating negative purchase orders for a vendor for Booking Letter of Credit processes, the system 
populates the information to the EDI 849 Rebate Detail Queue. This queue lets you review the 
information and handle the rebate claims that do not match. You can manage these exceptions and adjust 
the pricing on the purchase order. You can then export the information, as needed, to a spreadsheet. 

Review the proposed and actual costs and decide what to do with any differences that may remain. 

For a more detailed queue with information down to the line number level including quantities, invoice 
numbers, and payable IDs, see Using the EDI 849 Rebate Detail Queue. 

Note: You can only update the following fields from the queue: Override Amount, 
Notes, Dispute Reason, and Accepted flag. You can also update these fields 
using the import tool. 

To use the EDI 849 Rebate Summary Queue: 

1. From the Purchase > Queues menu, select EDI 849 Rebate Summary to display the EDI 849 
Rebate Summary Queue window. 

2. Use the header fields to set the parameters you want to review for the queue. 

Parameter Description 
Branch/Tr/All Enter the branch, branches, or territories by which you want to limit 

the queue. The system uses the branch the purchase order used when 
creating the book letter of credit option. Each branch that is filing and 
creating the book letter of credit displays the branch in the rebate 
detail file. 

Vendor Enter the vendor by which you want to limit the queue. The vendor 
on the purchase order. 

Rebate Status Enter which rebates you want to display: Resolved, Unresolved, or 
Pending. 

Start Ship Date Define the time frame by shipping dates that you want to review for 
rebates. End Ship Date 

3. Use the queue columns to review the rebate data and make sure items match. 

Column Description 
P/O Number The purchase order number assigned by the system for the payable you 

are using to send to the vendor. 

Vendor Name The vendor name either limited to the vendor selected in the header or 
each vendor within the defined parameters of the header information if 
you set the Vendor field to All. 
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Column Description 
Vendor Proposed 
Rebate Total 

The rebate amount approved by the vendor using the following 
conditions: 

• If the vendor has sent a Proposed Rebate Amount in the 849, that value 
is used here. 

• If there is an Override Rebate Cost in the 849, that value is used here. 
• If there is a Vendor Rebate Cost in the 849 and it does not match the 

cost in your system, the Vendor Rebate Cost is used here. 
• If none of the above exist, the rebate amount in your system is used 

here. 

Purchase Order Rebate 
Total 

The rebate amount you requested for the purchase order. 

Rebate Difference The difference, if any, between the requested and approved amounts. 
Use the Rebate Difference column on the queue to decide how you want 
to handle any difference displayed, such as writing it off in your accounts. 

3. Review the value in the Difference field and address the amount, as per your company 
guidelines: 

If the 
Difference 
is... 

And... Then... 

Zero (0)   The vendor-approved rebate is the same as the rebate you requested, 
and you do not need to review the rebate detail. Do the following: 
1. Exit the window. 
2. Create a payable for the rebate amount. 

Non-zero You are 
willing to 
accept the 
vendor rebate 
amount and 
do not want 
to review the 
differences in 
the rebate 
detail file. 

1. Do one of the following: 
• From the File menu, select Update to revise your P/O amount to 

match the vendor rebate amount, then exit the Rebate Detail 
Maintenance window. 

• Exit the Rebate Detail Maintenance screen without using the 
Update option, then post the Difference amount to a general ledger 
account. 

2. Create a payable for the rebate amount. 



Solar Eclipse Electronic Data Interchange (EDI) 

191 

If the 
Difference 
is... 

And... Then... 

Non-zero You want to 
review the 
differences in 
the rebate 
detail file. 

1. From the File menu, select Export or from the Edit menu, select 
Export Exceptions, as needed, to export the rebate detail or the 
exceptions to a spreadsheet program on your computer, review the 
differences in the requested and approved detail, make changes as 
needed, and import the data back into the rebate detail file. See 
Reconciling Rebate Detail Differences. 
 
Important: The import function only imports changes from the 
following columns: Override Rebate Cost, Dispute, Notes 
Entered, and Canceled. Any entry in the Canceled column on the 
spreadsheet removes the amount from the Detail Value field since 
it signifies a canceled item. 

2. Do one of the following: 
• From the File menu, select Update to revise your P/O amount to 

match the vendor rebate amount, then exit the Rebate Detail 
Maintenance window. 

• Exit the Rebate Detail Maintenance window without using the 
Update option, then post the Difference amount to a general ledger 
account. 

3. Create a payable for the rebate amount. 

5. Use the following to manage the purchase order rebates in the queue: 

To... From the Edit menu, select... 
view invoice information for the payable for 
the selected line item. 

View Payable Invoice to display the invoice in A/P 
Entry. 

change the totals on a purchase order using 
the Totals tab. 

Update P/O Totals to display the purchase order in the 
Totals tab. 

send the rebate detail from the queue out to 
a spreadsheet format to make changes to the 
fields. 

Export to display the data in your default spreadsheet 
program, such as MS Excel. 

sent only the exceptions from the rebate 
detail queue out to a spreadsheet format to 
make changes to the fields 

Export Exceptions to display the data in your default 
spreadsheet program, such as MS Excel. 

view or edit the purchase order View or Edit to display the purchase order. You receive a 
warning if the payable has already been processed. 

update the rebate detail file with changes 
made to the spreadsheet after you exported 
it. 

Import 

Important: The Import functionality imports only those 
changes from the  Override Rebate Cost, Dispute, Notes 
Entered, and Accepted columns from the spreadsheet. 

Any entry in the Canceled column on the spreadsheet 
removes the amount from the Vendor Proposed Rebate 
Total field since it signifies a canceled item. 

view the EDI 849 Rebate Detail for the 
specified order 

View Detail 
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To... From the Edit menu, select... 
delete the detail for the specified purchase 
order from the Rebate Detail file 

Delete Items 
Important: The Delete Items functionality purges only 
the line item detail for the purchase order that is currently 
selected in the queue. If you have a large number of 
purchase orders to purge from the Rebate Detail file, see 
Purging the Rebate Detail File in the Purchasing 
documentation. 

6. Exit the window. 
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Using the EDI 849 Rebate Detail Queue 
After creating negative purchase orders for a vendor for Booking Letter of Credit processes, the system 
populates the information to the EDI 849 Rebate Detail Queue. This queue lets you review the 
information and handle the rebate claims that do not match. You can manage these exceptions and adjust 
the pricing on the purchase order. You can then export the information, as needed, to a spreadsheet. 

The following detail queue provides information down to the line number level including quantities, 
invoice numbers, and payable IDs. For a more high-level view, see Using the EDI 849 Rebate Summary 
Queue. 

Note: You can only update the following fields from the queue: Override Amount, 
Notes, Dispute Reason, and Accepted flag. You can also update these fields 
using the import tool. 

To use the EDI 849 Rebate Detail Queue: 

1. From the Purchase > Queues menu, select EDI 849 Rebate Detail to display the EDI 849 
Rebate Detail Queue window. 

2. Use the header fields to set the parameters you want to review for the queue: 

Parameter Description 
Branch/Tr/All Enter the branch, branches, or territories by which you want to limit the 

queue. The system uses the branch the purchase order used when creating 
the book letter of credit option. Each branch that is filing and creating the 
book letter of credit displays the branch in the rebate detail file. 

Vendor Enter the vendor by which you want to limit the queue. The vendor on the 
purchase order. 

Rebate Status Enter which rebates you want to display: Resolved, Unresolved, or 
Pending. 

Start Ship Date Define the time frame by shipping dates that you want to review for 
rebates. End Ship Date 

3. Use the queue columns to review the rebate data and make sure items match. 

Column Description 
P/O Number The purchase order number assigned by the system for the payable you are 

using to send to the vendor. 

Invoice # The invoice number including the generation. 

Line # The line on which the product displays on the purchase order. 

Product Description The short description of the product as found in Product Maintenance. 

Quantity The amount billed for to the customer. 

Rebate Amount The extended amount of the rebate for the entire line item. 

Vendor Quantity The quantity for which the vendor will provide rebates. 

Vendor Proposed 
Rebate Amount 

The rebate offered by the vendor for the entire line. 
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Column Description 
Override Rebate Cost The override for the cost per item, if any, that has been negotiated. 

Payable ID The corresponding accounts payable ID for the purchase order. The system 
uses the following icons to indicate the status of the payable: 

- Indicates the payable has been created, but needs to be reconciled to 
the invoice manually. 
• - Indicates the payable has been created and automatically approved 

based on preset parameters. 
• Red highlight - Indicates a mismatch from the purchase order to the 

invoice. 
• Blank - No payable created based on over and short parameters. 

3. Use the View Manager  button to display other view options. For full descriptions, see More 
View Options at the bottom of this topic. Add additional column views, if needed, with User-
Defined View Maintenance. 

4. Use the following to manage the purchase order rebates in the queue: 

Note: For a quick summary and to view the difference between proposed and accepted 
costs, see Using the EDI 849 Rebate Summary Queue. 

To... From the Edit menu, select... 
view invoice information for the payable for 
the selected line item. 

View Payable Invoice to display the invoice in A/P 
Entry. 

change the totals on a purchase order using 
the Totals tab. 

Update P/O Totals to display the purchase order in 
the Totals tab. 

send the rebate detail from the queue out to a 
spreadsheet format to make changes to the 
fields. 

Export to display the data in your default spreadsheet 
program, such as MS Excel. 

sent only the exceptions from the rebate detail 
queue out to a spreadsheet format to make 
changes to the fields 

Export Exceptions to display the data in your default 
spreadsheet program, such as MS Excel. 

view or edit the purchase order View or Edit to display the purchase order. You 
receive a warning if the payable has already been 
processed. 

update the rebate detail file with changes 
made to the spreadsheet after you exported it. 

Import 

Important: The Import functionality imports only 
those changes from the Override Rebate Cost, 
Dispute, Notes Entered, and Accepted columns from 
the spreadsheet. 

Any entry in the Canceled column on the spreadsheet 
removes the amount from the Vendor Proposed 
Rebate Total field since it signifies a canceled item. 

5. Exit the window. 
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More View Options for the EDI Rebate Detail Queue 

The following view options are available in the EDI Rebate Detail Queue. Columns in the queue are view 
only. Double-click a line item to access the related transaction, such as the invoice. 

• Customer Information 

Column Description 
Invoice # The invoice number assigned for the bill going out for the items your 

customer ordered. 

Catalog # The number associated in Product Maintenance. This field populates 
when the Book Letter of Credit runs through the Customer Sales 
Rebate Report. 

Notes Entered Free-form field for user notes about the transaction. 

Customer ID # The customer ID as assigned in Customer Maintenance. 

UPC The universal product code (UPC) for the item being billed as listed 
in Product Maintenance. 

Customer Name The name of the customer on the sales order. 

Vendor Part # The part number for the items being billed. 

Line Reference The Line # of the item on the order. For example, when the 844 is 
sent, the invoice # will be S1234567.001.1 where the last digit 
should match this column. 

Ship Date The date the items ships from your customer. 

• Vendor Information 

Column Description 
Vendor Name The vendor name as listed in Vendor Maintenance. 

Stock or Direct Indicates if the item is a stock item or nonstock and shipped directly 
from the vendor. 

Vendor Quantity The quantity for which the vendor will provide rebates. 

Vendor Cost The cost of the item for the vendor. 

Vendor Rebate Cost The agreed vendor rebate cost for the item. 

Product Number The product number as assigned in Product Maintenance. 

Credit Memo Credit memo, if any, for the transaction. Populated by the 849 
document when it runs. 

Vendor Proposed 
Rebate Amount 

Amount of rebate the vendor proposes to you. 

Dispute The reject code from the 849 if the item is not accepted. 

FIFO Reference # The number to refer to for first-in-first-out warehouse setup. 
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Column Description 
Kit Components Eclipse truncates this field on the invoice # for components when the 

Book Letter of Credit from the Customer Sales Rebate Report runs 
for kit/components. For example, on an invoice with the number 
S1234567.001.1.1 the last digit is the number of the line in the kit. 

Note: When kits are in an 849 transaction, the system uses the UPC# 
to match the item, instead of the invoice #. 

Accepted Indicates if the vendor rebate proposal was accepted. 
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Receiving EDI 850 Purchase Orders Overview 
When a client submits an EDI order to you, the system receives an 850 Purchase Order document. The 
system processes incoming 850 documents and creates orders. In some cases the system creates a report 
instead of an order. 

The following topics explain how to handle inbound 850s: 

• Reviewing Inbound EDI 850 Purchase Orders 

• How the System Processes EDI 850s 
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Reviewing Inbound EDI 850 Purchase Orders 
When an EDI customer submits a purchase order to your company, the system does the following: 

• Creates a sales order with the initial order status set in the Initial Order Status field when defining 
additional document information for the incoming 850. The status is typically Bid. 

If an item on the order is backordered, the system sets the order status to the customer's default 
backorder status and the ship date set to the earliest date that all of the requested quantity of the 
backordered item will be available. 

• Places the order in the Remote Order Entry Review Queue. 

If an item on the order is backordered, the system assigns the BkOrd status to the queue entry. 

• Sends a message to the user responsible for reviewing incoming orders. 

The user reviews the order, makes any needed edits, such as replacing ***EDI Product Not Found*** 
items, and then changes the order status to an open status. Enter this user on the 850 Additional Doc Info 
screen in EDI Group Profile Maintenance. If you do not designate a user to review this order type, the 
system sends the message to the EDI.ADM message group. 

Optionally, the person reviewing the order can enter the corresponding EDI acknowledgment type codes 
and send the customer an EDI 855 Purchase Order Acknowledgement. 

To review an inbound EDI 850 purchase order: 

1. Display an EDI bid on the SOE Body tab in one of the following ways: 

• From the Orders > Queues menu, select Remote Order Entry Review to display the Remote 
Order Entry Review Queue window. Select the bid and from the Order menu, select Edit 
Order. 

• From the System > Message System menu, select Message Queue. If necessary, set the mode 
to Received. Select the bid and from the Message menu, select View Item. 

2. Edit the order, as needed. 

For example, overwrite any ***EDI Product Not Found*** items with the correct item. The line 
item comments for these products contain the detail received for the product in the 850. As you 
overwrite these line items with products in your product file, the system maintains the original 
line item comments. This allows you to validate your pricing information against what your 
customers sent in 850. 

Do not delete a product-not-found item or insert any new items into the order, because the 
information given in the purchase order needs to be repeated back on the 855 Purchase Order 
Acknowledgement and the 810 Invoice. 

3. Display the Status tab of the order. 

4. Change the order status to an open status, such as Call When Complete. 

5. Enter a ship date in the Ship Date field and a ship via in the Ship Via field of each generation. 

6. If all items on the order are accepted and will be shipped as ordered, type EDI in the Print field 
to send an EDI 855 Purchase Order Acknowledgement notifying the customer that the order was 
accepted and will be shipped on the dates specified. 

7. Save the order and exit the window. 
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Note: To remove an order from the Remote Order Entry Review Queue, select the order 
and from the Edit menu, select Clear Review. 
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How the System Processes EDI 850s 
When an EDI customer submits a purchase order to your company, the system does the following: 

• By default the 850 mapper creates a sales order with a Bid status. 

The system sends a message to the user responsible for reviewing incoming orders. Specify this 
user when defining additional document information for the 850 in EDI Group Profile 
Maintenance. This person reviews the order, makes any needed edits, and then changes the order 
status to an open status. 

If you do not specify a user, the system sends the message to the EDI.ADM message group. 

• If the BEG08 field in the 850 transaction contains INR for Invoice Not Required, the system 
creates an order and sends the following message to the user responsible for reviewing the order: 
INR Purchase Order (PO#) from EDI Customer: (EDI CUSTOMER) has been received. 

• If the BEG01 field in the 850 contains 06, the document is an order confirmation and the system 
does one of the following: 

• By default the system creates an order and adds the following message to the sales order 
header: “*** Confirming Order - DO NOT DUPLICATE ***. The Store EDI Order 
Confirmation Message In control maintenance record determines whether the system places 
the message in the Shipping Information or Internal Notes field. 

• If you prefer to create a report rather than an order, set the Create A Report For Zero Quantity 
Or Confirming EDI Orders control maintenance record to Yes. In this case, the system creates 
a report and sends it to the Hold file. 

• If the 850 has a quantity of zero, the system does one of the following: 

• By default the system sends the 850 transaction to the EDI Error Queue. 

• If you prefer to have the system create a report, set the Create A Report For Zero Quantity Or 
Confirming EDI Orders control maintenance record to Yes. In this case, the system creates a 
report and sends it to the Hold file. 
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Receiving EDI 855 P/O Acknowledgments Overview 
After an EDI vendor receives an order from you, they can send an 855 P/O Acknowledgment. The system 
processes incoming 855 documents and places them in the EDI 855 P/O Acknowledgment Queue. Use 
the queue to review 855 documents that you receive from vendors. 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

The 855 can update the expected receipt date of the ordered items and flag pricing discrepancies. Use the 
855 to resolve pricing discrepancies prior to receiving the invoice. 

If you have vendor managed inventory (VMI), the vendor sends an 855 P/O Acknowledgment in response 
to an 852 Product Activity Report. In this case, the system creates an open purchase order. For additional 
information, see EDI 855 VMI P/O Acknowledgments and Vendor Managed Inventory Overview. 

Before the system can receive an 855, set up the system as follows: 

• Create a trading partner profile for which an 855 inbound document is defined. 

• Assign the vendor from whom you are receiving the 855 to this profile. 

The following topics explain how to handle inbound 855s: 

• Reviewing Inbound EDI 855 P/O Acknowledgments 

• Entering EDI 855 and 856 Selection Criteria 

• How the System Processes EDI 855s 

• EDI 855 P/O Acknowledgment Match Levels 
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Reviewing Inbound EDI 855 P/O Acknowledgments 
After an EDI vendor receives an order from you, they can send an 855 P/O Acknowledgment. The system 
processes incoming 855 documents and places them in the Active view of the EDI 855 P/O 
Acknowledgment Queue. Use the queue to review 855 documents that you receive from vendors. 

The 855 can update the expected receipt date of the ordered items and flag pricing discrepancies. Use the 
855 to resolve pricing discrepancies prior to receiving the invoice. After the invoice has been received, 
delete the 855 entry from the queue. 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

To display the EDI 855 P/O Acknowledgment Review Queue: 

1. Do one of the following to display the EDI Review Queue Selection window: 

• From the System > System Programming > EDI > EDI Review Queues menu, select 855 
P/O Acknowledgment (Inbound). 

• From the Purchase > Queues menu, select EDI 855 P/O Acknowledgment. 

2. Enter selection criteria and click OK to populate the EDI 855 P/O Acknowledgement Review 
Queue. 

The summary information for each acknowledgement displays. 

Column Description 
Reference # System-assigned sequential number that identifies the acknowledgment in the 

review queue. 
The system displays a caret (^) to the left of the reference number when the 
number of items shipped is more than the number ordered. 

Purchase Order Purchase order number that the 855 is acknowledging. 
Click the Message icon in the Message column to view the message attached to 
the acknowledgement. 

Vendor Vendor who received the purchase order and sent the acknowledgment. 

Match Level The level of success, or match level, the system had in matching the 855 
acknowledgement to a purchase order. Click the Message icon in the Message 
column to view an explanation of the status. 
In addition to the match level, a dollar sign ($) indicates a price mismatch and a 
pound sign (#) indicates a quantity mismatch. 

Post Date Using information from the 855, the system sets the purchase order generation 
ship date. If the 855 specifies multiple ship dates, the system creates separate 
generations for each ship date. 

Branch Ship branch of the purchase order, if the branch is noted in the 855 and is valid. 

Shipping Carrier Carrier handling the shipment, if noted in the 855. 

Note: To refine or change your search, select Edit > Select and enter new selection 
criteria. 
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3. From the Edit menu, select Clear Matches to clear all entries that have a Perfect match level 
from the Active view and move them to the Cleared view of the queue. 

To research unsuccessful P/O acknowledgements: 

1. Display the EDI 855 P/O Acknowledgement Review Queue. 

2. Use any of the following options to research any unsuccessful P/O acknowledgements: 

To... Select this menu option... 

display the associated purchase order View > View PO 

display the formatted acknowledgement data View > Vendor Item Detail 

display the raw data from the 855 View > Archive Detail 

3. Exit the EDI 855 P/O Acknowledgement Review Queue. 

To delete items from the queue that no longer require your attention: 

1. Display the EDI 855 P/O Acknowledgement Review Queue. 

2. Use the following options to delete items from the queue that no longer require your attention: 

To... Select this menu option... 
delete the selected 855 from the Active view of the 
queue and move it to the Cleared view. 

Edit > Delete 

delete 855 documents older than a designated date 
from the Active view of the queue and move them 
to the Cleared view. At the prompt, enter a date. 

Edit > Delete by Date 

  

Note: Deletions are immediate. The system does not prompt you to confirm deletions. 

3. Exit the EDI 855 P/O Acknowledgement Review Queue. 
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Entering EDI 855 and 856 Selection Criteria 
The system displays a selection window when you access the EDI 855 P/O Acknowledgment Review 
Queue or EDI 856 Advance Ship Notice Review Queue. Use this window to filter the items displayed in 
the queue. 

To enter EDI 855 or 856 selection criteria: 

1. Display the EDI Review Queue Selection window in one of the following ways: 

• From the System > System Programming > EDI > EDI Review Queues menu, select 855 
P/O Acknowledgment (Inbound). 

• From the Purchase > Queues menu, select EDI 855 P/O Acknowledgment. 

• From the System > System Programming > EDI > EDI Review Queues menu, select 856 
Advance Ship Notice (Inbound). 

• From the Purchase > Queues menu, select EDI 856 Advance Ship Notice. 

2. Complete any of the following fields to select purchase order acknowledgements: 

In this field... Enter... 
Select Sort By Sort order of selected items. The default is Ascending By Date. 

Select from the following options: 
• Ascending By Date - Sorts the 855s or 856s from oldest to newest by the 

received date for invoices or by the ship date for acknowledgements and 
ASNs. 

• Descending By Date - Sorts the 855s or 856s from newest to oldest by 
the received date for invoices or by the ship date for acknowledgements 
and ASNs. 

• Ascending By Trading Partner - Sorts the 855s or 856s in alphabetical 
order by trading partner name. 

• Descending By Trading Partner - Sorts the 855s or 856s in reverse 
alphabetical order by trading partner name. 

Select User ID User ID of the user assigned to review incoming 855s or 856s. 
This field defaults to your user ID. To review 855s or 856s for all users, 
leave this field blank. 
You must have Level 1 authorization in the EDI.IN.REVIEW authorization 
key to view your own entries in the review queues. Level 2 authorization is 
required to view other user's entries. 

Select Ship Branch Branch or territory to which the vendor has shipped the items on a purchase 
order. 

Select Vendor Vendor entered here is the vendor that shipped items on a purchase order to 
you. 
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In this field... Enter... 
Select View Displays 855s or 856s based on one of the following statuses: 

• Active - 855s or 856s requiring review that have not been cleared from 
the queue. 

• Cleared - Reviewed 855s or 856s that have been cleared from the queue. 
• Archived - 855s or 856s older than the number of days specified in the 

Archive EDI Review Queue Documents After (Days) control 
maintenance record. At the Dir prompt, press F10 and select the directory 
to access. 

Select Start Date First date for which to view 855s or 856s. For example, if you want to 
review all 855s and 856s received in July 2006, enter 07/01/06 in this field 
and 07/31/06 in the Select End Date field. 

Select End Date Last date for which to view 855s or 856s. For example, if you want to 
review all 855s or 856s received in July 2006, enter 07/01/06 in the Select 
Start Date field and 07/31/06 in the Select End Date field. 

Select PO # Purchase order number associated with the 855s or 856s. 
The system searches for all generations of the purchase order number you 
enter. For example, if you want to see only 855s or 856s received that match 
generations of purchase order P1067075, enter P1067075 in this field. 
To search all purchase orders in the system, leave this field blank. 

3. Press Esc to display the selected documents in the queue. 
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How the System Processes EDI 855s 
How the system processes an 855 depends on which of the following relationships you have with your 
vendors: 

• Vendor Managed Inventory - The 855 informs you of a purchase order the vendor created for 
you. For more information, see How the System Processes EDI 855s for VMI. 

• Standard - The 855 acknowledges a purchase order that you sent to the vendor. 

Standard Processing 
An 855 acknowledges and updates a purchase order that your system generated and sent to the vendor. 
This type of 855 requires the vendor to send back the same purchase order number they received, and you 
may receive multiple 855s for a particular purchase order. The 855 can update the expected receipt date of 
the ordered items and flag pricing discrepancies. 

If you set the Process Multiple Stock PO Ack 855s field when defining additional document information 
for the 855 to Yes, the system merges and splits purchase order generations based on the quantity and 
ship date information received. 

Use the 855 to reconcile pricing discrepancies prior to receipt of the invoice. 

The system processes an incoming 855 as follows: 

1. If the acknowledgment (ACK) code on the 855 contains an R for rejection, the system: 

• Halts further processing. 

• Sends the 855 to the review queue without a match level code. 

• Sends the following message to the Grp/User to be Notified: Received PO Rejection From 
Vendor. PO# [purchase order number]. 

Otherwise, the system adds the 855 document to the EDI 855 P/O Acknowledgment Review 
Queue with an active status. 

2. The system tries to match the items on the 855 to the purchase order by looking at all open 
generations for the purchase order. The system compares the 855 to the purchase order, looking at 
the total number of line items and quantities for matching line items. 

The system compares any price variance to the values set in the Allowed Pricing Variance field 
in Vendor Maintenance. This field defines the percentage or dollar amount by which a price on 
the 855 can vary from the corresponding price on the purchase order to which it is being matched 
without the system flagging the transaction for review due to a pricing discrepancy. If all pricing 
discrepancies fall within the pricing variance, and the total number of line items and quantities 
match, the system treats the 855 as a perfect match. 

3. Depending on the results of the matching, the system sets the 855 match levels. 

4. Using information from the 855, the system sets the purchase order generation ship date. If the 
855 specifies multiple ship dates, the system creates separate generations for each ship date. 

Note: If there is an entry in the Freight Days field in the Additional Vendor Information 
window, that number of days is added to the ship date on the 855 to determine the 
expected arrival date of the shipment. For example, if the projected ship date is 
09/03/2005 and the number of freight days is 3, the revised ship date is 
09/06/2005. 
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5. If the match level is Perfect, Good, or Some, the system posts the following message to the 
purchase order change log: EDI Created PO Acknowledgment Gen. 

6. If the match level is Perfect, the system clears the entry from the queue and moves it the Cleared 
view of the queue. 
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EDI 855 P/O Acknowledgment Match Levels 
Match levels indicate the success the system has in matching items and quantities on an 855 
acknowledgment to items and quantities on an open generation of the purchase order. The system 
automatically clears items with a perfect match from the review queue at the time they are received. 

• If a pound sign (#) displays next to a match code, line item quantities and/or units of measure for 
items on the purchase order and acknowledgment do not match. 

• If a dollar sign ($) displays next to a match code, the price of one or more items on the purchase 
order and 855 do not match. The system takes into account the allowed pricing variance specified 
in the vendor record for the trading partner. 

The system displays the following match levels in the EDI 855 P/O Acknowledgment Review Queue: 

Level Description 
No Matches No match, for any of the following reasons: 

• The 855 contains an invalid purchase order number. 
• There are no open generations on the purchase order. 
• There is an open generation on the purchase order, but it is locked by another process 

or user. 
• The system cannot match any items and quantities on the 855 with items and quantities 

on the purchase order. 

Some Line Items 
Matched 

Some items and quantities match. 

Good Match but 
number of items is 
less than PO 

All items and quantities on the 855 match, but the purchase order generation contains 
more items than those listed on the 855 acknowledgement. 

Perfect Match All items and quantities match the purchase order generation.  If the Override Perfect 
Match Auto-Clearing field in the EDI Add'l Doc Info screen is set to N, purchase orders 
with a perfect match are automatically cleared from the review queue. 

Note: In the Allowed Pricing Variance field in the Additional Vendor Information 
window, select and enter the percentage or dollar amount by which a price on the 855 
can vary from the corresponding price on the purchase order to which it is being 
matched, without the system flagging the transaction for review due to a pricing 
discrepancy. If all pricing discrepancies fall within the pricing variance, the system treats 
the 855 as a perfect match. 

  

Note: Click the Message icon in the Message column key to view the system-generated 
message associated with the match level. 
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Receiving EDI 856 Advance Ship Notices Overview 
When an EDI vendor ships an order to you, they can send an 856 Advance Ship Notice through EDI. Use 
this document to review the items on the shipment before the invoice arrives. The 856 attempts to create a 
vendor ship notice generation on the referenced purchase order. The 856 can also update the purchase 
order by transferring quantities from open generations to a newly created vendor ship generation. 

A vendor can ship multiple purchase orders in a container and multiple containers in a pallet, in which 
case an 856 Advance Ship Notice can include the pallet and container bar codes. When you scan the bar 
code in RF Receiving, the system changes the status of the associated purchase order to “In Process.” 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

Before the system can receive an 856, set up the system as follows: 

• Create a trading partner profile for which an 856 inbound document is defined. 

• Assign the vendor from whom you are receiving the 856 to this profile. 

The following topics explain how to handle inbound 856s: 

• Reviewing Inbound EDI 856 Advance Ship Notices 

• How the System Processes EDI 856s 

• EDI 856 Advance Ship Notice Match Levels 



Reviewing Inbound EDI 856 Advance Ship Notices 

210 

Reviewing Inbound EDI 856 Advance Ship Notices 
When an EDI vendor ships an order to you, they can send an 856 Advance Ship Notice via EDI. This 
notice lists the items from the original purchase order that the vendor shipped. The system processes the 
document and stores it in the Active view of the EDI 856 Advance Ship Notice Review Queue. Use this 
document to review the items on the shipment before the invoice arrives. 

The 856 attempts to create a vendor ship notice generation on the referenced purchase order. The 856 can 
also update the purchase order by transferring quantities from open generations to a newly created vendor 
ship generation. 

A vendor can ship multiple purchase orders in a container and multiple containers in a pallet, in which 
case an 856 Advance Ship Notice can include the pallet and container bar codes. When you scan the bar 
code in RF Receiving, the system changes the status of the associated purchase to "In Process.” 

Note: Users must be assigned the EDI.IN.REVIEW authorization key to access the 
review queue. 

To display the EDI 856 Advance Ship Notice Review Queue: 

1. Display the Selection Criteria window in one of the following ways: 

• From the System > System Programming > EDI > EDI Review Queues menu, select 856 
Advance Ship Notice (Inbound). 

• From the Purchase > Queues menu, select 856 Advance Ship Notice. 

2. Enter the selection criteria and click OK to populate the EDI 856 Advance Ship Notice Review 
Queue with ASNs that match the criteria. 

The summary information for each ASN displays. 

Field Description 
Reference # System-generated sequential number that identifies the shipping notice in the 

review queue. 
A caret (^) displayed to the left of the reference number indicates that the 
number of items shipped was more than the number ordered. 

Purchase Order Purchase order number that the 856 references. 
Click the icon in the Message column to view more information about the 
purchase order and its generations. 

Vendor Vendor who received the purchase order from you, and who is shipping you 
the items. 

Match Level The level of success, or match level, the system had in matching the 856 to the 
purchase order. 
Click the icon in the Message  column to view an explanation of the status. 

Ship Date Date your vendor shipped items on the purchase order to you. 

Branch Branch that placed the purchase order and is receiving the items. 
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Field Description 
Shipping Carrier Carrier handling the shipment of the order from your vendor to your 

warehouse, or to the your customer's ship-to address for direct orders, if noted 
in the 856 document. 

Note: To refine or change your search, select Edit > Select and enter new selection 
criteria. 

3. From the Edit menu, select Clear Matches to clear all entries that have a match level of Perfect 
from the Active view and move them to the Cleared view. 

4. From the Edit menu, select Clear Received POs to move all entries whose entire purchase order 
has been received from the Active view and move them to the Cleared view. 

To retrieve the tracking information for the order: 

1. Display the EDI 856 Advance Ship Notice Review Queue. 

2. Locate the order you want to review. 

3. From the View menu, select View PO. 

4. From the File menu on the order, select View Change Log. 

5. In the Comment column, locate the tracking information and click Locate Via Google to display 
the tracking information in your default browser. 

To research unsuccessful ASN matches: 

1. Display the EDI 856 Advance Ship Notice Review Queue. 

2. Use any of the following options to research unsuccessful ASN matches in the queue: 

To... Select this menu option... 
display the associated purchase order View > View PO 

display the advance ship notice formatted data View > Vendor Item Detail 

displays the raw data from the 856 notice View > Archive Detail 

3. Exit the EDI 856 Advance Ship Notice Review Queue. 

To delete items from the queue that no longer require your attention: 

1. Display the EDI 856 Advance Ship Notice Review Queue. 

2. Use the following options to delete items from the queue: 

To... Select this menu option.. 
delete the selected 856 from the Active view of the 
queue and moves it to the Cleared view 

Edit > Delete 

delete 856 documents older than a designated date 
from the Active section and move them to the 
Cleared section of the queue. 

Edit > Delete by Date 
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Note: Deletions are immediate. The system does not prompt you to confirm deletions. 

3. Exit the EDI 856 Advance Ship Notice Review Queue. 
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How the System Processes EDI 856s 
After an EDI vendor ships an order, they can send an 856 Advance Ship Notice. This notice lists the items 
that the vendor shipped. When an EDI 856 Advance Ship Notice arrives, the system does the following: 

1. Adds the 856 to the EDI 856 Advance Ship Notice Review Queue with an Active status. 

2. Locates the purchase order number referenced in the notice and tries to match the items on the 
856 to an open generation on the purchase order. The system looks at the total number of line 
items and quantities for matching line items. 

3. Depending on the results of the matching, the system sets the 856 match levels. 

• If the system finds an exact match, it changes the generation status from Open to Vendor 
Shipment Notification. 

If there is an entry in the Freight Days field on the Miscellaneous Vendor Information I 
window, the system adds that number of days to the ship date on the 856 to determine the 
expected arrival date of the shipment. The system retrieves the freight days value from the bill-
to customer if no freight days are specified on ship-to customer record. 

• If the system does not find an exact match, it transfers the matched items from the open 
generation to a new Vendor Shipment Notification generation. 

4. Posts the following message to the P/O change log, if the match level is Perfect or Some Items 
Match: EDI Creating Vendor Ship Notification. 

Tracking 856 Shipments 
As of Release 9.0.4, you have the ability to update tracking numbers on a purchase order or sales orders 
for direct orders when the number is sent by EDI 856 document and relay that information to the 
customers. Using the Change Log, you can locate the tracking number. When you click the link, the 
Shipping Info window displays a new Locate via Google option that displays the shipping information 
for the carrier site, such as UPS, in a browser.  

Note: As of this release, if tracking numbers come through an EDI 810, the system does 
not capture those tracking numbers. 

You can use the Shipment Notification Activity Trigger for the customer set to an Email Ship Tracking 
Info HTML to send the notification information when the EDI 856 is received. Use the email address ** 
AUTO ** for the system to select the email to which notifications should be sent based on the following 
hierarchy:  

1. The Email Address field in sales order header. 

2. The Ordered By field to see if that field has an email for an associated contact. 

3. The customer record for an assigned email contact address. 

4. View the Activity Log to find the tracking information. 

Important: For Eterm, you must have the Shipping URL Maintenance information set up to activate the 
Shipping hot key and enable the system to launch a browser for the tracking numbers.. 
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EDI 856 Advance Ship Notice Match Levels 
Match levels indicate the success the system has in matching items and quantities on an 856 notice to 
items and quantities on an open generation of the purchase order being acknowledged. 

The system displays the following match levels in the EDI 856 Advance Ship Notice Review Queue: 

Level Description 
No Matches No match, for any of the following reasons: 

• The 856 contains an invalid purchase order number. 
• There are no open generations on the purchase order. 
• There is an open generation on the purchase order, but it is locked by 

another process or user. 
• The system cannot match any items and quantities on the 856 with 

items and quantities on an open generation of the purchase order. 

Some Line Items Matched Some items and quantities match. 

Perfect Match Perfect match. All items and quantities match. 

  

Note: Click the Message icon in the Message field of the line item in the queue to view 
the system-generated message associated with the match level. 
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Linking Carriers to Freight Vendors in EDI 
Use the Freight Vendor Lookup feature to cross-reference your internally freight carriers to the freight 
vendors set up in Eclipse. By using this table, when EDI 856s come in the system can assign the correct 
freight vendor and translate that onto the associate bill of lading accordingly. 

To link a carrier to a freight vendor: 

1. Display a trading partner profile on the EDI Trading Partner Profile Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. Select Group ID and use the Group Profile Maintenance hot key to display the EDI Group 
Profile Maintenance screen. 

3. Select an EDI 856 Incoming document. 

4. Use the Edit Tables hot key and select Freight Vendor Lookup. 

5. In the Trading Partner Carrier column, enter the carrier, such as United Postal Service, 
assigned by the trading partner. 

6. In the corresponding line in the Eclipse Freight Vendor column, enter the ship via Eclipse 
should use when receiving and 856 document in the system, such as UPS. 

7. Press Esc to save your changes and return to the EDI Group Profile Maintenance screen 
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Receiving EDI 860 Purchase Order Change Requests 
An EDI 860 Purchase Order Change Request is a document your customer may send to inform you of 
changes they want to make to a prior purchase order. 

Before the system can receive an 860, set up the system as follows: 

• Create a trading partner profile for which an 860 inbound document is defined. 

• Assign the vendor from whom you are receiving the 860 to this profile. 

You can set up your trading partner profiles to process incoming 860s in one of the following ways: 

• Run the EDI.860.PRINT.DOC program, which formats the data and sends the report to your Hold 
file. 

• Run the EDI.PRINT.DOC program, which translates the raw data and places an unformatted report 
in your Hold file. 

• Install a mapper that has been customized to create a tracker in the user's job queue. 

After making the requested changes, you can send an EDI 865 Purchase Order Acknowledgement With 
Change in response. The system transmits purchase order acknowledgements with change to customers 
using EDI when you set the print status of the order to EDI. 

Note: Eclipse gathers the EDI ID for the 860 transaction from the order's bill-to/ship-to 
customer information rather than the Trading Partner Profile information. 
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Receiving EDI 862 Shipping Schedules 
A customer sends an EDI 862 Shipping Schedule to report on consignment items they have shipped. 
Depending on the codes transmitted in the 862, you system creates a consignment or regular sales order. 

You can also use the data received from an 862 shipping schedule to create a bar code label and pick 
ticket. 

Before the system can receive an 862, set up the system as follows: 

• Create a trading partner profile for which an 862 inbound document is defined. 

• Assign the customer from whom you are receiving the 860 to this profile. 

• Have EDI Support customize the mapper used to receive the 862. 
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Receiving EDI 997 Functional Acknowledgments 
An incoming EDI 997 Functional Acknowledgment is a document that your trading partner sends to 
acknowledge that they received a document you sent to them. 

In EDI Group Profile Maintenance, where you define the documents you exchange with a trading partner, 
you can flag outgoing documents to remain in the Outgoing Status Review Queue until the system 
receives a 997 acknowledgment from the trading partner. 

When the system receives a 997, it removes the matching document from the Outgoing Status Review 
Queue. 
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Vendor Managed Inventory Overview 
Vendor Managed Inventory (VMI) is a process whereby the vendor manages your inventory of selected 
products. VMI reduces the cost of inventory control by having the vendor assume more of the 
responsibility for maintaining optimal inventory levels at a branch or central distribution center (CDC). 

In a VMI relationship you send the vendor an 852 Product Activity Data document, which contains sales 
quantities and inventory levels for items they supply to you. In return, the vendor sends you an 855 
Purchase Order Acknowledgment (Inbound), from which your system creates an open purchase order. 

For the system to handle vendor managed inventory, you must do the following: 

• Create a trading partner profile for which an 852 document is defined. 

On the EDI Add'l Doc Info screen for the 855, do the following: 

• In the Initial Order Status field, select O to create an open order. 

• In the Use Partner's Pricing on VMI Orders field, enter Y to copy the line item pricing from 
the 855 to the purchase order. 

• Assign the vendor to whom you are sending the 852 and from whom you are receiving the 855 to 
this profile. 

• To designate an acceptable pricing variance for incoming 855s, complete the Allowed Pricing 
Variance% field on the Additional Vendor Information window. 

• Reserve a block of valid, unused Eclipse purchase order numbers for the vendor to assign to the 
purchase orders they create. For example, you might reserve all the numbers that begin with 9, 
starting with P9000001. 

• Flag products as vendor managed inventory. 
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Flagging Products as Vendor Managed Inventory 
For products whose replenishment is managed by vendors, you need to identify the branches in which the 
product is vendor-managed. 

The following procedure describes a manual process for setting up a single product. Use the Mass Load 
program to enter inventory parameters for groups of products. 

To flag products as vendor managed inventory: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display the product record for the product you want to change. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance window. 

4. From the Edit menu, select EDI/VMI Maintenance to display the Product EDI/VMI 
Maintenance window. 

5. From the File menu, select Hierarchy and enter the hierarchy branch to view the settings for a 
specific branch and where those settings came from. 

All territories that contain that branch display in the Branch column in the Product EDI/VMI 
Maintenance window in territory priority order. For more information, see Branch Hierarchy 
Details. 

6. In the Managed column for each branch, enter one of the following: 

• Yes - The EDI vendor manages the product.   

• No - The EDI vendor does not manage the product. 

• blank - The EDI vendor manages stock items by default. 

The following table shows the status transmitted to the vendor for stock and nonstock items in an 
852 report: 

Product Status VMI Flag Status Transmitted 
Stock Blank A - Active. 

Stock Yes A - Active. 

Stock No X - Do not manage. 

Nonstock Blank X - Do not manage. 

Nonstock Yes D - Do not stock. Manage only in a backorder situation. 

Nonstock No X - Do not manage. 

7. Save your changes and return to the previous window. 

You must exit Product Maintenance for changes to take effect. 
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EDI 852 Product Activity Reports Overview 
An EDI 852 Product Activity Report shares information about the activity of items in your Product file 
with an EDI vendor who manages your inventory. The vendor uses this information to determine when 
and how much of each item to replenish. In return, the vendor sends you an 855 Purchase Order 
Acknowledgment (Inbound), from which your system creates an open purchase order. 

After you determine and flag the products a vendor will manage, run the 852 to create a base report and 
repository of data for all the products the vendor manages. After you create the initial repository of data, 
you can send 852s that only report on products with activity. 

Set the Include 'Catalog' Items field on the EDI Add'l Doc Info screen for outbound 852s to Y to 
accumulate catalog index items as well as primary index items for the report. 

About 852 Calculations 
In a central warehouse, the system does not roll order point and line point information or 
minimum/maximum information for all branches in the network for 852 reports. The system only pulls 
this information from the parent branch. In a central warehouse and distributive warehouse, only the 
system reports the calculated values for minimum only, order point, and line point int the OP/OQ 
parameters and pass the minimum only in the QL. The QM should be zero (0). 

In a central purchasing warehouse, if the branches have no minimum/maximum/only values set, the 
system reports the summed information of the OP/LP as OP/OQ and QL/QM should be zero (0). If there 
is a combination of these values, the system sums up the information for all of these and reports it as 
OP/OQ, but the QL/QM should still be zero (0). If there is only minimum/maximum/only values, then the 
system sums up and reports the information as QL/QM and the OP/OQ should be zero (0). 
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Sending EDI 852 Product Activity Reports 
An EDI 852 Product Activity Report shares information about the activity of items in your Product file 
with an EDI vendor who manages your inventory. The report includes products whose order points and 
line points are less than the minimum quantity required to have on hand, and includes the minimum and 
maximum values for the vendor's reference. The vendor uses this information to determine when and how 
much of each item to replenish. 

After you determine and flag the products a vendor manages, run the 852 report using the Complete 
Refresh (All Items) option. Selecting this option generates an 852 report for all items within the selected 
price or buy line with activity back to the start date identified on the setup screen. This creates a base 
report and repository of data for each selected product. 

After running the initial report, schedule the 852 report to run at regular intervals using the Changes 
Only option. Using this option, the system only reports on items with activity since the last time the 852 
was run. Activity includes changes in the available, sold, purchased, committed, received, transferred, 
order point, line point, min, max, reserved, backordered quantities, quantity transferred or quantity in 
transit, or changes in the UPC or Catalog# fields due to product updates. 

Use the Item Activity Refresh option if your vendor requests a report of all items with activity between 
the current date and a start date. 

To send an 852 product activity report: 

1. From the System Programming > EDI > EDI Generate Reports > EDI 852 Product Activity 
Report Maintenance menu, select 852 Product Activity Report to display the EDI 852 Product 
Activity Setup screen. 

Note: If prompted, log on to the character-based system. 

2. In the Trading Partner field, enter the name of the trading partner to whom you are sending the 
852 report. 

3. In the Branch/Territory field, enter the branch or territory for which you want to generate the 
852 report. You can enter multiple branch numbers separated by commas without spaces. For 
example, you might enter 1,2,3. 

Keep in mind the following: 

• If you are reporting for a hub, list the hub branch followed by the branches that report to it. 

• If you are reporting for a central distribution center (CDC), list just the CDC branch. 

4. In the Product Status (Stk/Nstk) field, select which products to report. Select from the following 
options: 

• Stock - Reports on stock items. 

• Nonstock - Reports on nonstock items. 

• Both - Reports on stock and nonstock items. 

The value in the Stock column on the Primary Inventory Maintenance window determines 
whether an item is stock or nonstock. 
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The following table shows the status transmitted to the vendor for stock and nonstock items in an 
852 report, depending on how the product is flagged: 

Product Status VMI Flag Status Transmitted 
Stock Blank A - Active. 

Stock Y A - Active. 

Stock N X - Do not manage. 

Nonstock Blank X - Do not manage. 

Nonstock Y D - Do not stock. Manage only in a backorder situation. 

Nonstock N X - Do not manage. 

5. In the Product Selection Type field, press F10 and select how to select the products. 

• Price Line - Select products from designated price lines. 

• Buy Line - Select products from designated buy lines. 

• Item - Select designated products. 

6. Use the Products hot key to identify the price lines, buy lines, or items for which to generate the 
report. Press Esc after entering the selections. 

7. In the 852 Reporting Model field, select one of the following reporting models: 

• Branch - Creates a report for each selected branch. 

• Sum of Branches - Creates one cumulative report for all the selected branches. 

• CDC - Creates one report for the CDC warehouse group. 

8. In the 852 Handling Status field, select one of the following handling statuses: 

• Notification Only - The vendor is only monitoring activity. 

• Plan Orders and Ship - The vendor will be replenishing your inventory. 

9. In the 852 Accumulation Type field, select one of the following options: 

• Complete Refresh - Accumulates data for all selected items between the current date and a 
start date. At the Start Date prompt, enter the date from which the report should reflect 
activity. Use this option to create a report of all the products the vendor manages. 

• Changes Only - Accumulates data for all selected items with activity since the last time the 
852 was run. 

• Item Activity Refresh - Accumulates data for all selected items with activity between the 
current date and a start date. At the Start Date prompt, enter the date from which the report 
should reflect activity. Vendors that manage a large number of products often prefer this 
option. 

10. Schedule the 852 to run as follows: 

• Use the Opts hot key to display the Phantom Scheduler screen, where you can schedule this 
report to run at regular intervals. Schedule the 852 to run after hours, when item activity is 
quiet. 
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• After you press Esc to exit the Phantom Scheduler screen and return to the EDI 852 Product 
Activity Setup screen, use the Hold hot key. When the phantom runs the report, it sends the 
report to your Hold file. 
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Performing an EDI 852 Complete Item Refresh 
Use the EDI 852 Complete Refresh option in the 852 Product Activity Report Setup to purge all the 
records from the file the 852 Product Activity Report uses, so the next scheduled report using the 
Changes Only option generates for all selected items. 

To perform an EDI 852 complete item refresh: 

1. From the System > System Programming > EDI > EDI Generate Reports > EDI 852 Product 
Activity Report Maintenance menu, select 852 Product Activity Report to display the EDI 
852 Product Activity Setup screen. 

Note: If prompted, log on to the character-based system. 

2. Complete the options on the report, as necessary. For more information, see Sending EDI 852 
Product Activity Reports. 

3. In the 852 Accumulation Type field, select Complete Refresh and enter the date from which the 
purge should begin in the Start Date field. 

4. Schedule the 852 to run as follows: 

• Use the Opts hot key and select scheduling to display the Phantom Scheduler screen, where 
you can schedule this report to run at regular intervals. Schedule the 852 to run after hours, 
when item activity is quiet. 

• After you press Esc to exit the Phantom Scheduler screen and return to the EDI 852 Product 
Activity Setup screen, use the Hold hot key to schedule the job. 
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Purging EDI 852 Sales Transmissions 
The system keeps a log of every sale reported on 852s to prevent duplicate reporting. When an item ships, 
the system reports the order on an 852 and adds the order to the log. If the ship date on a sale changes, the 
system refers to this log before adding the sale to another 852. 

For example, when an order is placed on a manifest, the system sets the ship date, sends an 852, and logs 
the order. If the delivery driver waits until the following day to upload the signatures he captured, the 
system updates the ship date. Because the sale has already been logged, the system does not send another 
852. About a week after sending an 852, the system no longer has a need for the information stored in the 
log. 

We recommend that you schedule this program to run on a weekly basis, and purge log entries older than 
one week. 

To purge an EDI 852 sales transmission: 

1. From the System Programming > EDI > EDI Generate Reports > EDI 852 Product Activity 
Report Maintenance menu, select Purge 852 Sales Transmissions to display the EDI 852 Item 
Transmission Purge screen. 

Note: If prompted, log on to the character-based system. 

2. In the Purge Date field, enter the cutoff date for purging data from the 852 log. 

The system purges all data older than, but not including, the purge date. 

Note: We recommend that you enter MO/-7/YR to purge anything older than 7 days. 

3. Use one of the following hot keys to run the purge: 

• Begin - Initiates the purge process immediately. 

• Schedule - Displays the Phantom Scheduler screen, where you can schedule the purge to run at 
another time. After you exit the Phantom Scheduler, use the Begin hot key on this screen to 
schedule the purge. 
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EDI 855 VMI P/O Acknowledgments 
In a vendor managed inventory (VMI) relationship, the system converts an incoming 855 P/O 
Acknowledgment into an open purchase order. 

Pricing Method 
When creating a purchase order from an 855 VMI P/O Acknowledgment, the system can use the line item 
prices from the 855 the vendor sends or prices from system matrixes or price sheets. To determine which 
method the system uses, enter Y or N in the Use Partner's Pricing on VMI Orders field on the EDI 
Add'l Doc Info screen. 

Allowed Pricing Variance 
Regardless of which pricing method you select for creating the order, the system compares the prices on 
the 855 to your system prices for each line item. You can designate an allowed variance for line item 
prices in the Allowed Pricing Variance% field in Vendor Maintenance. The system does one of the 
following: 

• If line item price differences exist and they fall within your allowed variance, the system creates 
the open order. 

• If line item price differences exist and they exceed your allowed variance or you have not specified 
an allowed variance, the system places the order in the Remote Order Entry Review Queue with a 
Bid status. 

For example, set the Allowed Pricing Variance% field to P for percentage and enter 10.0 percent. If one 
or more line items vary by more than 10 percent, the order goes to the Remote Order Entry Review Queue 
with a Bid status and Price error. The Error Detail screen, viewed from the queue using the Error Detail 
hot key, shows the pricing discrepancies. 

Freight Days 
When creating a purchase order for an 855 VMI P/O Acknowledgement, the system adds the number of 
days defined in the Freight Days field on the Miscellaneous Vendor Information I screen for the vendor 
to the ship date and the required date of the purchase order. 
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How the System Processes EDI 855s for VMI 
In a VMI relationship you send the vendor an 852 Product Activity Data document, which contains sales 
quantities and stock levels for items they supply to you. In return, the vendor sends you an 855 
Acknowledgment (Inbound), from which your system creates an open purchase order. 

The system processes an incoming VMI 855 as follows: 

1. Creates an open purchase order in one of the following ways: 

• Uses the purchase order number supplied by the vendor. You should reserve a block of valid, 
unused Eclipse purchase order numbers for the vendor to assign to 855s. 

• Uses the next available purchase order number generated by Eclipse. You must have the Use 
Next Available PO# for VMI Orders option on the EDI Add'l Doc Info screen set to Yes to 
use this feature. The VMI transaction program then uses the next available purchase order 
number and populates the Order ID field on the purchase order Header tab, with the 
automatically generated number. 

2. Checks the prices and product numbers on the 855 with those stored in your system. 

• If there are no discrepancies, the system sets the order status to Open. 

• If there are discrepancies, the system sets the order status to Bid and adds the order to the 
Remote Order Entry Review Queue, where you can view the error detail. 

If your site is using Virtual Supplier and the Enable Auto-Routing On Creation Of Sales Order 
control maintenance record is set to Y for a branch, when the system receives an inbound 855 
Acknowledgement it creates an entry in the review queue for each order generation. If no 
branches on the order are enabled for auto-routing, the system creates a single review queue entry 
for the order. In this scenario, the stocking branch must also be flagged in the Define Routing Vs. 
Sourcing control maintenance record. 

3. The system adds any days set in the Freight Days field in Vendor Maintenance for the vendor to 
the ship date and the required dates on the purchase order. 
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Solar Eclipse Interface for Use with WIT Overview 
The Eclipse Interface for Use With WIT is a companion product that distributors can use to exchange EDI 
transactions with the WIT buying group. 

WIT-NET is an Internet VAN (value added network) connection that you can use to exchange EDI 
transactions with WIT vendors. This Internet-based connection replaces the dial-up VAN connection. 
Using WIT-NET, you receive invoices without having to connect to a VAN or pay VAN charges. You 
can also send purchasing activity reports and remittance advice documents using this connection. 

Use the WIT interface to process the following transactions: 

• Incoming 810 invoices. 

• Outgoing 820 remittance advice documents. 

• Outgoing 820B purchasing activity reports. 

As of Release 9.0.2, the WIT interface also processes the following transactions: 

• Outgoing 850 purchase orders. 

• Incoming 855 purchase order acknowledgements. 

• Incoming 856 advanced shipping notifications (ASN). 
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Setup Requirements for the WIT Interface 
Before you can use the WIT Interface, the following setup requirements must be completed. 

Distributor Prerequisites 
Before Eclipse can install the WIT interface, do the following: 

• Ensure that the version of Eclipse installed on your system is 7033 or higher. 

• Obtain the following information from WIT and give this information to the Eclipse installation 
team to add to the WIT network configuration profile: 

• Your company's WIT user name. 

• Your company's WIT password. 

• Your company's DUNS+4 number. 

Note: If your company has more than one DUNS+4 number, you need to provide the one 
that WIT recognizes. 

Installation Requirements 
Eclipse personnel are responsible for accomplishing the following tasks: 

• Install the WIT Interface and related EDI programs on your system. 

Note: As of Release 9.0.2, you can upgrade your WIT interface, if needed. The upgrade 
includes new transaction support, but requires you to requires changing the 
transmission method to FTP for the respective training partner. We recommend 
contacting EDI Support for assistance to coordinate this upgrade. 

• Add the WIT-NET DUNS+4 attribute to the VEND.CLASS file. 

• Set up WIT as an EDI trading partner in Eclipse, and identify the documents they exchange. 

• Set up the network configuration profile for WIT. 

Distributor Requirements 
Before you can use the WIT interface, you need to: 

• Obtain the WIT-NET DUNS+4 numbers for each WIT vendor. 

The DUNS+4 number is a 13-digit number consisting of the 9-digit DUNS number assigned by 
Dunn & Bradstreet followed by the 4-digit WIT vendor number. 

• Set up your WIT vendors in Vendor Maintenance. 
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Setting Up WIT Vendors 
When you purchase product from a WIT vendor, you receive invoices from and send your payments to 
WIT. Even though all payments go to WIT, you still need it specify the vendor to whom to direct the 
payment by setting up a unique vendor pay-to record for each ship-from vendor. 

Create a vendor record for each ship-from vendor, such as MOEN or KOHLER, and for each pay-to 
vendor, such as WIT-MOEN or WIT-KOHLER. 

To set up a WIT vendor: 

1. From the Maintenance menu, select Vendor to display the Vendor Maintenance window. 

2. In the Vendor/New field, enter the name of the vendor for which you want to enter WIT data. 

3. Ensure that the Pay To and Ship From flags are correctly set. 

4. From the File menu, select Classify to display the User Defined Data window. 

5. In the Input column for the WIT-NET DUNS4 prompt, enter the pay-to vendor's DUNS+4 
number. 

6. From the File menu, select Save and close the window. 

7. Save the vendor record and close the Vendor Maintenance window. 
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Sending EDI 820B Purchasing Activity Reports to WIT 
The 820B Purchasing Activity Report is a non-standard EDI document that represents purchasing activity 
over a specified period, such as year-to-date. The report shares information with a WIT vendor about the 
items you have purchased from them. The vendor uses this information to determine the year-end rebate 
to which you are entitled. 

Note: This report is available if you have purchased the Solar Eclipse Interface for Use 
with WIT. 

To send an 820B purchasing activity report: 

1. From the System > System Programming > EDI > EDI Generate Reports menu, select WIT-
NET Purchasing Activity Report to display the EDI 820B Purchasing Summary for WIT-NET 
screen. 

Note: If prompted, log on to the character-based system. 

2. In the Start Date field, enter the first day of the year. For example, enter 01/01/YR. 

3. In the End Date field, enter the current date. For example, enter MO/DA/YR. 

4. Do one of the following to run the report: 

• Use the Generate hot key to run the report now. 

• Use the Schedule hot key to schedule the report to run at another time. 

The system generates purchase activity reports for each WIT vendor and places them in the EDI 
Outgoing Status Queue. The system transmits the reports to WIT during the next scheduled WIT-
NET transmission. 

Note: In the EDI Outgoing Status Queue, you can identify a purchase activity report by 
the number 845 in the Doc column and 820B-Ven#nnnnn in the Reference ID 
column. 

The system sends a message to the user set up as the EDI administrator, similar to the following 
example: 

To EDI ADMINISTRATION: 3 WIT-NET 820B Purchasing Summary Report Document(s) 
created for period: 01/01/2004 to 12/31/2004. They will be sent during the next WIT-NET 
transmission. 
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EDI Archive Maintenance Overview 
The system archives every inbound and outbound EDI transaction. The archives are permanent 
repositories for EDI transactions and maintenance is not required. Use the EDI Archive Maintenance 
screens to view documents and envelopes stored in the archives. 

Documents and envelopes are stored in the active archives for a specified number of days. After this time, 
they move to the inactive archives. Documents and envelopes in the inactive archives are stored in 
directories by month and year. 

Active and inactive archives exist for inbound documents, inbound envelopes, and outbound envelopes. 

Use the Months Before Purge Of EDI Archives control maintenance record and the Purge Archive 
Documents program to clear the archives of data you no longer need to reference. 

Inbound Documents 
The Archive EDI Inbound Documents After (Days) control maintenance record determines the number of 
days an inbound document stays in the active archive before moving to the inactive archive. 

• EDI Inbound Document Archive contains individual documents that have been received within 
the specified number of days. 

• EDI Inactive Inbound Document Archive contains inbound documents that are more than the 
specified number of days old.   

Inbound Envelopes 
The Archive EDI Inbound Envelopes After (Days) control maintenance record determines the number of 
days an inbound envelope stays in the active archive before moving to the inactive archive. 

• EDI Inbound Envelope Archive contains enveloped EDI data that has been received within the 
specified number of days. An inbound envelope may contain multiple documents from multiple 
trading partners. 

• EDI Inactive Inbound Envelope Archive contains inbound envelopes that are more than the 
specified number of days old. Each envelope may contain multiple documents from a trading 
partner. 

Outbound Envelopes 
The Archive EDI Outbound Envelopes After (Days) control maintenance record determines the number 
of days an outbound envelope stays in the active archive before moving to the inactive archive. 

• EDI Outbound Envelope Archive contains enveloped EDI data that has been sent within the 
specified number of days. An outbound envelope may contain multiple documents from multiple 
trading partners. 

• EDI Inactive Outbound Envelope Archive contains enveloped EDI data that has been sent more 
than the specified number of days ago. Each envelope may contain multiple documents to a trading 
partner. 
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Viewing EDI Archived Documents 
The system archives all active and inactive inbound documents. The screens used for viewing archived 
documents have the same layout and hot keys. The following procedure explains how to view these 
archives. 

To view EDI archived documents: 

1. From the System > System Programming > EDI > EDI Maintenance > EDI Archive 
Maintenance menu, select one of the following: 

• Inbound Document Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating a document. When you press Esc, the EDI 
Inbound Document Archive Maintenance screen displays. 

• Inactive Inbound Document Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Inbound 
Document Inactive Archive Maintenance screen displays. 

Note: If prompted, log on to the character-based system. 

2. The screen displays the following information about each archived document: 

Field Description 
Date Received Range Time span, first and last dates, during which the selected documents were 

received. 

Trading Partner Name of the trading partner. 

Doc Document type number, such as 850 or 852. 

ISA Control # Reference ID for the ISA (Interchange Control Header) envelope. 

GS Control # Reference ID for the GS (Functional Group Header) envelope. 

ST Control # Reference ID for the designated transaction set. 

Rec Date Date the document was received from the trading partner. 

3. Use the following hot keys as needed: 

Hot Key Description 
View Displays the EDI Archive Data Viewing screen, where you can view the data in the 

document. 

Delete Deletes the document from the archives.   

Note: We recommend that you not use this hot key. 

Select Displays the Selection Criteria screen, where you can define selection criteria for 
filtering the list of displayed documents. 

997 ID Displays the 997 ID for documents that are functional acknowledgements. 
Use this hot key in conjunction with the 997 ID hot key on the  EDI Outgoing Status 
Queue screen. If the system does not clear an item off the EDI Outgoing Status Queue 
when the functional acknowledgment is received, use these hot keys to compare the 
required ID with the received ID. 
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4. Press Esc to exit the screen. 

Defining Document Selection Criteria 
Use the Selection Criteria screen to filter the list of documents displayed from an archive. This screen 
appears when you access the active archive or when you use the Select hot key on the archive 
maintenance screen. 

To define document selection criteria: 

1. From the archive maintenance screen, use the Select hot key to display the Selection Criteria 
screen. 

Note: When you access the EDI Inbound Document Archive, the system displays the 
Selection Criteria screen so you can enter selection criteria before listing the 
documents in the archive. 

2. Enter data in any of the following fields or leave the screen blank to display all documents in the 
archive: 

Field Description 
Select Start Date First date for which to select documents. 

Select End Date Last date for which to select documents. 

Select Interchange ID ID of a designated envelope. 

Select Group ID ID of a functional group within an envelope. 

Select ISA Control # Reference ID for a specific ISA envelope. 

Select GS Control # Reference ID for a specific group of transactions. 

Select ST Control # Reference ID for a specific transaction set. 

Select Document Type Document type, such as 850 or 852. 

3. Press Esc to make the selections and return to the archive maintenance screen. 
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Viewing EDI Archived Document Data 
From a document archive, you can select a document and view the raw data in the EDI Archive Data 
Viewing window. From this window, you can complete the following tasks: 

• Reprocess the EDI document data. 

• Display the data in report format and print the report. 

• Delete the entry from the queue. 

You can access archived EDI document data directly from each EDI review queue, the Inbound 
Document Archive, and the Inactive Inbound Document Archive. 

To view EDI archived document data from the EDI review queues: 

1. Display data in one of the following queues: 

• EDI 810 Invoice Review Queue 

• EDI 855 P/O Acknowledgement Review Queue 

• EDI 856 Advance Ship Notice Review Queue 

2. Select the item for which to view the archived data, and select View > Archive Detail to display 
EDI Archive Data Viewing window. 

3. Use any of the following menu options, as needed: 

To... Use this menu option... 
send the displayed data 
back to the EDI program 
for complete reprocessing 

Options > Requeue 

Note: Requeuing a document from archived data can create a duplicate 
order. For example, if the data has already been processed and has 
created an order, reprocessing it will create an identical order. 
Alternately, if you have made changes to your mapper, you can reprocess 
the order to have the system create a corrected order. 

display the formatted 
document data on the Hold 
Entry Pre-View screen 

Options > Print 
When you to exit this window, the system prompts you to save the report 
in the Hold file and then returns you to the EDI Archive Data Viewing 
screen. You can print a copy of the formatted data from the Hold file. 

delete the document data 
from the archive 

Options > Delete 

Note: We recommend that you do not delete data from the archive. 

To view EDI archived document data from the Document Archives: 

1. From the System > System Programming > EDI > EDI Maintenance > EDI Archive 
Maintenance menu, select one of the following: 

• Inbound Document Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating a document. When you press Esc, the EDI 
Inbound Document Archive Maintenance screen displays. 
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• Inactive Inbound Document Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Inbound 
Document Inactive Archive Maintenance screen displays. 

Note: If prompted, log on to the character-based system. 

2. Use the View hot key to display the EDI Archive Data Viewing screen. 

This screen displays the raw data in the EDI document. 

3. Complete the following tasks, as needed: 

To... Use this hot key... 
send the displayed data back 
to the EDI program for 
complete reprocessing 

Requeue 

Note: Requeuing a document from archived data can create a 
duplicate order. For example, if the data has already been processed 
and has created an order, reprocessing it will create an identical order. 
Alternately, if you have made changes to your mapper, you can 
reprocess the order to have the system create a corrected order. 

display the formatted 
document data on the Hold 
Entry Pre-View screen 

Print 
When you press Esc to exit this screen, the system prompts you to 
save the report in the Hold file and then returns you to the EDI 
Archive Data Viewing screen. You can print a copy of the formatted 
data from the Hold file. 

delete the document data 
from the archive 

Delete 

Note: We recommend that you do not delete data from the archive. 

4. Press Esc to exit the screen. 
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Viewing EDI Archived Envelopes 
The system archives all active inbound, active outbound, inactive inbound, and inactive outbound 
envelopes. The screens used for viewing archived envelopes have the same layout and hot keys. The 
following procedure explains how to view these archives. 

Use the following procedures to: 

• View EDI archived envelopes. 

• Define envelope selection criteria. 

To view EDI archived envelopes: 

1. From the System > System Programming > EDI > EDI Maintenance > EDI Archive 
Maintenance menu, select one of the following: 

• Inbound Envelope Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating an envelope. When you press Esc, the EDI 
Inbound Envelope Archive Maintenance screen displays. 

• Outbound Envelope Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating an envelope. When you press Esc, the EDI 
Outbound Envelope Archive Maintenance screen displays. 

• Inactive Inbound Envelope Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Inbound Envelope 
Inactive Archive Maintenance screen displays. 

• Inactive Outbound Envelope Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Outbound 
Envelope Inactive Archive Maintenance screen displays. 

Note: If prompted, log on to the character-based system. 

2. The screen displays the following information about each archived envelope: 

Field Description 
Date Received (Sent) 
Range 

Time span, first and last dates, during which the selected inbound 
documents were received or outbound envelopes were sent. 

Network Network provider for the record. 

Date Recd (Sent) Date the envelope was received from or sent to the trading partner. 

Time Recd (Sent) Time the envelope was received from or sent to the trading partner. 

Note: The date and time field names are different for inbound and outbound envelopes. 

3. Use the following hot keys as needed: 

Hot Key Function 
View Displays the EDI Enveloped Data Viewing screen, where you can view the data in the 

envelope. 
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Hot Key Function 
Delete Deletes the envelope from the archives.   

Note: We recommend that you not use this hot key. 

Select Displays the Selection Criteria screen, where you can define selection criteria for 
filtering the list of displayed envelopes. 

4. Press Esc to exit the screen. 

Defining Envelope Selection Criteria 
Use the Selection Criteria screen to filter the list of envelopes displayed from an archive. This screen 
appears when you access an active archive or when you use the Select hot key on an archive maintenance 
screen. 

To define envelope selection criteria: 

1. From the archive maintenance screen, use the Select hot key to display the Selection Criteria 
screen. 

Note: When you access the EDI Inbound Envelope Archive or EDI Outbound Envelope 
Archive, the system displays the Selection Criteria screen so you can enter 
selection criteria before listing the envelopes in the archive. 

2. Complete one or both dates or leave the screen blank to display all envelopes in the archive. 

Field Description 
Select Start Date First date for which to select envelopes. 

Select End Date Last date for which to select envelopes. 

3. Press Esc to make the selections and return to the archive maintenance screen. 
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Viewing EDI Archived Envelope Data 
From an envelope archive, you can select an archive entry and view the raw data in the envelopes 
associated with that entry on the EDI Enveloped Data Viewing screen. 

From this screen, you can use the hot keys to: 

• View documents in an envelope. 

• Display the document data in report format and print the report. 

To view EDI archived envelope data: 

1. From the System > System Programming > EDI > EDI Maintenance > EDI Archive 
Maintenance menu, select one of the following: 

• Inbound Envelope Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating an envelope. When you press Esc, the EDI 
Inbound Envelope Archive Maintenance screen displays. 

• Outbound Envelope Archive - The system displays the Selection Criteria screen, which you 
can use to define selection criteria for locating an envelope. When you press Esc, the EDI 
Outbound Envelope Archive Maintenance screen displays. 

• Inactive Inbound Envelope Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Inbound Envelope 
Inactive Archive Maintenance screen displays. 

• Inactive Outbound Envelope Archive - The system prompts you to select a directory. At the 
prompt, press F10 to display the archive directories and select one. The EDI Outbound 
Envelope Inactive Archive Maintenance screen displays. 

Note: If prompted, log on to the character-based system. 

2. Use the View hot key to display the EDI Enveloped Data Viewing screen. 

This screen displays the raw data in the EDI document. 

3. Complete the following tasks, as needed: 

To... Do this... 
display the previous envelope, if there are 
multiple envelopes 

Previous Envelope 

display the next envelope, if there are multiple 
envelopes 

Next Envelope 

display the formatted envelope data on the Hold 
Entry Pre-View screen 

Print 
When you press Esc to exit this screen, the system 
prompts you to save the report in the Hold file and 
then returns to the EDI Enveloped Data Viewing 
screen. You can print a copy of the formatted data 
from the Hold file. 

4. Press Esc to exit the screen. 
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Purging EDI Archives 
Use the EDI Archive Purge program to specify the number of months of archived EDI data to retain and 
then purge any data that is older. Reducing the size of archived files reduces the amount of time required 
to perform system backups and restores. 

To purge EDI archives: 

1. From the System > System Programming > EDI > EDI Maintenance >EDI Archive 
Maintenance menu, select Purge Archive Documents to display the EDI Archive Purge screen. 

Note: If prompted, log on to the character-based system. 

The system populates the fields with the defaults entered in the Months Before Purge Of EDI 
Archives control maintenance record. 

2. Override the defaults, as needed, to designate the number of months of archive data the system 
should keep when the purge program runs. 

For example, if you enter 12 in a field, the system preserves the most recent 12 months of 
archived data and deletes everything that has been in the archive longer than 12 months. If you 
leave a field blank, the system does not delete records from that archive. If you enter zero (0), the 
system deletes all the records in the archive. 

3. Use one of the following hot keys to run the purge: 

• Begin - Purges archived records now. 

• Schedule - Schedules the purge for another time. 
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EDI Testing and Troubleshooting Overview 
Prior to beginning the exchange of production EDI data, you should thoroughly test all documents that 
you plan to send and receive.. Testing ensures that the intended party receives the transmitted data and 
that the data meets the needs of both you and your trading partner. 

The following topic provides information that can assist you in testing EDI inbound and outbound 
documents: 

• Testing Inbound and Outbound EDI Documents 

The following troubleshooting topics provide information to assist you in resolving EDI transmission 
problems: 

• Troubleshooting EDI System Errors - Provides information regarding EDI system errors. 

• Troubleshooting Transmission Failures - Provides information about transmission error messages. 
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Testing Inbound and Outbound EDI Documents 
Prior to beginning the exchange of production EDI data, you should thoroughly test all documents that 
you plan to send and receive. Testing ensures that the intended party receives the transmitted data and that 
the data meets the needs of both you and your trading partner. There are prerequisites to consider prior to 
vendor or customer testing. 

Note: We strongly recommend that you complete the EDI 101 training prior to doing any 
testing. 

Prerequisites 
After your company has made the decision to use EDI, you need to set up your system for handling EDI 
transactions. This includes the following: 

• Initiating the EDI process. 

• Entering company EDI information. 

• Entering customer EDI information. 

• Entering vendor EDI information. 

Initiating the EDI Process 
For each EDI trading partner you need the following information from them: their VAN, FTP, or HTTP 
method, qualifier, ISA and Group IDs, any test IDs, the EDI documents they use, and the version of EDI 
they are using. 

Note: Eclipse maintains generic maps for most documents for versions 003020 and 
004010. We recommend using version 004010. 

For more information, see Initiating the EDI Process. 

VAN Interconnect 
You must also contact your VAN and request that they create an interconnect between your VAN and 
your trading partner’s VAN. If the interconnect is not present, documents are not delivered. 

You must provide the following information to your VAN: 

• Your company’s qualifier and ISA ID. 

• Your trading partner's VAN, qualifier, and ISA ID. 

Trading Partner Profiles 
Before you can begin testing you must set up a trading partner profile for the customer or vendor with 
whom you are exchanging documents. 

Note: Trading Partner setup is also explained in the EDI 101 training materials and the 
Trading Partner EDI Implementation document. 

Your trading partners may require that a Y be sent in the ISA 15 field to signify that the document is a 
test. The figure below shows the location on the EDI Trading Partner Profile Maintenance screen where 
the Y is entered. The default test status is N. 
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Note:  When testing is complete ensure that this field is set to N.   

For all non-specific trading partner fields, you can use the F10 key to display all possible entries for that 
field. 

Note: You must list a vendor or customer name and account number or you will not be 
able to send documents via EDI. 

For more information, see Trading Partner Profile Overview. 

Group Profile Maintenance 
Ensure that the correct mappers are in place on the Group Profile Maintenance screen and that the 997 
flag is set correctly for each document. 

• For inbound documents, set the 997 flag to Y, in order to return a 997 Functional 
Acknowledgment. 

• For outbound documents: 

• If you are expecting a 997 from your trading partner acknowledging your outbound document, 
set the 997 flag to N so that your outbound document remains on the EDI Outgoing Status 
Queue until the received 997 clears it off. 

• If your trading partner will not be sending 997s, set the 997 flag to Y so that your outbound 
document is cleared from the EDI Outgoing Status Queue as soon as it is successfully 
transmitted to your VAN. 

Entering Document-Specific Information 
If your trading partner utilizes a test ID, enter the test ID in the Alternate Interchange ID field on the 
EDI Add'l Doc Info screen for the document being tested. 

Tip: Setting the Default Outgoing Transmission Status field for an outbound test document to HOLD 
allows you to control when the EDI program transmits the outbound test document. Set this flag on the 
EDI Add’l Doc Info screen for the document being tested. 

For more information, see Entering Additional EDI Document Information. 

Vendor Testing 
Generally, the first document to test is the outbound 850 purchase order. After you test the 850 purchase 
order, you can test inbound documents such as the 810, 855, and 856 using the data sent in the purchase 
order. 

Creating an Outbound 850 Document 
Create an outbound test 850 document, as follows. 

Note: For information on entering quotes and contracts, see Entering Quote or Contract 
Numbers on 850s. 

To create an 850 purchase order test document:   

1. From the Purchase menu, select Purchase Order Entry and create a purchase order for the 
trading partner. 
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Note: The system provides functionality for sending quote and contract numbers to your 
vendors. See Entering Quote or Contract Numbers on 850s. 

2. Click the Status tab to display the Status of the order. 

3. In the Print field, enter EDI or press F10 and select EDI from the menu. 

If you cannot change the print status to EDI, do the following: 

• Display the trading partner's record in Vendor Maintenance. 

• From the Additional menu select Additional Vendor Information to display the Additional 
Vendor Information window. 

• In the Print Status Override field, enter an E for EDI. 

• Save your changes and exit the vendor record. 

4. Save and exit the order. 

The system places the document in the Outgoing Status Queue. Unless previously coordinated it 
is recommended that you notify the trading partner prior to sending the test document. The 
document must be in Send status. 

Sending the Test Document 
If you set the Default Outgoing Transmission Status flag for the outgoing document to HOLD in the 
trading partner profile, you need to change the status of the document to Send status in the EDI Outgoing 
Status Queue. For more information, see Maintaining the EDI Outgoing Status Queue. 

If the network call to the trading partner does not occur automatically on a scheduled basis, manually 
place the network call. If network calls are scheduled, but you want to send the test before the next 
scheduled call, make a network call now. There are two options: a background call and a foreground call. 
We recommend making a background call, which allows you to continue working in Eclipse. The 
foreground call displays a status screen detailing what is taking place during the call and prevents the user 
from accessing other Eclipse screens until the call has completed. 

Receiving Inbound Documents 
After you test the 850 purchase order, you can test additional documents such as the 810, 855, and 856 
using the data sent in the purchase order. The system has a review queue for each of these each 
documents, which you can access from the System > System Programming > EDI > EDI Review 
Queues menu. For more information see, EDI Review Queues Overview. 

A training class called EDI Review Queues is also available on the Eclipse website. 

Customer Testing 
Normally, the first document tested is the inbound 850 purchase order. When the system receives an 
inbound 850, it creates a sales order. After you process the sales order created from the 850, you can 
create the other test documents using the data received in the test document. 

Note: You must have a trading partner profile set up for the company being tested, and 
within the trading partner profile define the documents that you want to create. 
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Processing a Received 850 Purchase Order 
Access a received 850 purchase order from either the Remote Order Entry Review Queue or the EDI 
Activity Log. Use the following procedures to: 

• Access the order from the Remote Order Entry Review Queue. 

• Access the order from the EDI Activity Log. 

• Process the order. 

• Set up Eclipse for automatic 810 creation upon invoicing. 

To access the order from the Remote Order Entry Review Queue: 

1. From the Orders > Queues menu, select Remote Order Entry Review. to display the Remote 
Order Entry Review Queue window. 

2. In the Branch/Terr/All field, enter the branch or All. 

3. In the Source field, enter or select EDI and click Update to display the orders matching the 
search criteria. 

4. Select the test order and then select Order > View Order to display the order in Sales Order 
Entry. 

To access the order from the EDI Activity Log: 

1. From the System > System Programming > EDI > EDI Maintenance menu, select EDI 
Activity Log Viewing to display the EDI Activity Log Viewing screen. 

Note: If prompted, log on to the character-based system. 

2. Select the order and using the Edit hot key to display the order in Sales Order Entry. 

To process the sales order: 

1. From the Remote Order Entry Review Queue or the EDI Activity Log, select the order and 
display the order in Sales Order Entry. 

2. Click the Status tab to display the Sales Order Entry Status window. 

Note:  The trading partner must contain the map for the document that you are attempting 
to create. 

3. To create an 855, do the following: 

• Change the order status to one of the open statuses, such as Call When Complete or Ship When 
Specified. 

Note: The 855 is not a valid document if the order is in a Bid, Cancel, or Pick Up Now 
status. 

• Press Esc to process the order. 

The system places the document on the EDI Outgoing Status Queue. 

4. To create an 810 and 856, do the following: 

• Change the order status to Invoiced. 
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• In the Print field, enter or select EDI. 

• From the File menu, select Save.. 

• At the prompt, select whether to send an 810, 856, or both. 

The system places the documents on the EDI Outgoing Status Queue. 

Note: If the system does not accept EDI in the Print field, you need to make sure that the 
customer account is attached to an EDI profile with that outbound document set 
up in Group Maintenance. 

To set up automatic 810 creation upon invoicing: 

After the relationship is put into production, if you want to send 810 invoices automatically upon invoice 
printing from the Print Invoices menu (Orders > Printing > Print Invoices), add that functionality to the 
customer record file by entering E in the Invoice Fax Copies field. 

1. From the Maintenance menu, select Customer and display the customer record you want to flag 
for EDI invoices. 

2. From the Pricing menu, select Price Information to display the Customer Pricing Information 
window. 

3. In the Invoice Fax Copies field, press F10 and select E for EDI. 

Note: For this option to be available, the customer must be assigned to an EDI trading 
partner. 

4. Save your changes and exit the customer record. 

The system sends the invoice to the Invoice Preview Queue. After approved, the system sends a 
copy of the invoice to the customer through EDI. 
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Troubleshooting EDI System Errors 
The following EDI Error Glossary provides information regarding EDI system errors that display on the 
following screens: 

• EDI Error Queue 

• EDI Activity Log 

• Order Entry in SOE or POE 

• EDI Trading Partner Maintenance 

Please reference the screen name when communicating errors to Eclipse EDI Support. 

For each program that produces error messages, the glossary shows: 

• The message as it appears on the terminal screen. 

• A definition of the message. 

• The recommended course of action. 

EDI Error Queue Maintenance Screen Errors 
The following errors display on the EDI Error Queue Maintenance screen. 

CANNOT OPEN EDI.OUT.STATUS -E9PERR 

The EDI.OUT.STATUS file does not exist, or permissions are incorrect. Contact Eclipse EDI Support for 
assistance. 

5 - MAP SUBR -ECIERR: XXX.XXX.XXX.X NOT CATALOGED : XXX 

Mapping subroutine defined in EDI Group Profile Maintenance for this trading partner and document 
does not exist or has not been compiled. Verify that the mapping subroutine that has been defined is 
correct. If it is not, correct it and requeue this document. If the routine is correct, contact Eclipse EDI 
Support so the mapper can be made available to you. 

5 - NO MAPPING FOUND -ECIERR: XXX 

A mapping subroutine is not defined on the EDI Group Profile Maintenance screen for this trading partner 
and document type. You must set up and define a mapper for this document on the EDI Group Profile 
Maintenance screen for this trading partner. Then requeue this document. 

5 - Partner Sub-ID Not Found -ECIERR : XXXX-XXX 

The bill-to or ship-to (N1-BT/N1-ST) data specified in the error message was not found in the EDI Group 
Profile Receive Code Info Table accessed from the EDI Group Profile Maintenance screen. You need to 
enter the bill-to or ship-to (N1-BT/N1-ST) data specified in the error message into the Receive Code Info 
Table screen for this trading partner. Use the Add Sub-ID hot key to enter the correct customer data and 
then requeue this document. 

Doc Type Undefined -ECIERR: XXX 

Received document is an invalid or undefined type. Verify that the document type being sent to you is 
correct and that it is defined for this trading partner. After verification, if the problem still exists, contact 
Eclipse EDI Support for assistance. 

EDI Customer/Vendor : XXXX not on file -ECIERR 
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No customer or vendor account was found for the specified trading partner. The customer or vendor who 
is defined on the EDI Trading Partner Profile Maintenance screen for this trading partner must be 
corrected. Then requeue this document. 

EDI Bill-To -ECLERR: XXXX not found 

The account specified on the EDI Trading Partner Profile Maintenance screen cannot be found. The 
customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for this trading 
partner must be corrected. Then requeue this document. 

EDI Customer : XXXX not on file -ECLERR 

The account specified on the EDI Trading Partner Profile Maintenance screen cannot be found. The 
customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for this trading 
partner must be corrected. Then requeue this document. 

EDI Customer Xref not found -ECLERR 

No customer Xref account was found for the specified trading partner. The customer/vendor who is 
defined on the EDI Trading Partner Profile Maintenance screen for this trading partner must be corrected. 
Then requeue this document. 

EDI Pay-To : XXXX not found -ECLERR 

The account specified on the EDI Trading Partner Profile Maintenance screen cannot be found. The 
customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for this trading 
partner must be corrected. Then “requeue” this document. 

EDI Vendor : XXXX not on file -ECLERR 

No vendor account was found for the specified trading partner. The customer/vendor who is defined on 
the EDI Trading Partner Profile Maintenance screen for this trading partner must be corrected. Then 
requeue this document. 

Invalid Ship-From Br - ECLERR 

The account specified on the EDI Trading Partner Profile Maintenance screen is not flagged as a ship-
from account. The customer/vendor who is defined on the EDI Trading Partner Profile Maintenance 
screen for this trading partner must be corrected. Then requeue this document. 

No EDI items found -ECLERR 

No valid line items were found on the received EDI order. The most likely cause for this error is that the 
individual line items on the incoming EDI document have a zero quantity or no part number. Determine if 
the problem is related to the quantity or part number and then contact your trading partner to have the 
problem corrected and the document resent. 

Non Bill-To specified -ECLERR: XXXX 

The account specified on the EDI Trading Partner Profile Maintenance screen is not flagged as a bill-to 
account. The customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for 
this trading partner must be corrected. Then requeue this document. 

Non Pay-To specified -ECLERR 

The account specified on the EDI Trading Partner Profile Maintenance screen is not flagged as a pay-to 
account. The customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for 
this trading partner must be corrected. Then requeue this document. 

Non Ship-To specified -ECLERR: XXXX 
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The account specified on the EDI Trading Partner Profile Maintenance screen is not flagged as a ship-to 
account. The customer/vendor who is defined on the EDI Trading Partner Profile Maintenance screen for 
this trading partner must be corrected. Then requeue this document. 

*** Bad Qty : XX - Set to 1 -ECLERR *** 

The received quantity specified in the quantity field of the line item is not a number. Contact your trading 
partner and have them correct the data that they are sending. 

1 Entity ID not found. -OCLERR 

The entity specified on the EDI Trading Partner Profile Maintenance screen was not found. Contact 
Eclipse EDI Support for assistance. 

2 No Items found. -OCLERR (Zero Qty) 

No items were found for which to create a ledger record. This is a possible mapper problem. Contact 
Eclipse EDI Support for assistance. After fixing the problem, you can requeue the document from the 
Inbound Document Archive. 

3 Ledger Record not found. -OCLERR 

The ledger record specified by the EDI document does not exist. Contact Eclipse EDI Support for 
assistance. 

4 Ledger GEN not found. -OCLERR 

The generation specified by the EDI document does not exist. Contact Eclipse EDI Support for assistance. 

5 Ledger Record locked. -OCLERR 

The requested ledger record is locked by another process and is not available. Contact Eclipse EDI 
Support for assistance. 

6 Purchase Order # Wrong Format. -OCLERR 

The purchase order number specified by the EDI document is not in the correct format to be received by 
Eclipse. The purchase order number that your trading partner is sending you, which should be in Eclipse 
format, is not in the correct format. Contact your trading partner and have them correct the data they are 
sending. 

7 Purchase Order # Already Exists. -OCLERR 

The purchase order number that the EDI document tried to create already exists on Eclipse. This could be 
caused by your trading partner trying to reuse a previously used purchase order number or resending a 
previously sent order. Contact your trading partner to have problem corrected. 

1 - DOCUMENT TYPE   XXX NOT FOUND -ECUERR 

The document type specified by this document was not found on the EDI Trading Partner Profile 
Maintenance screen for this trading partner. Before you can process this type of document for this trading 
partner, you must define it on the EDI Group Profile Maintenance screen for this trading partner. 

1 - FUNCTIONAL GROUP XX NOT FOUND -ECUERR 

The functional group type received in the GS segment was not found in the EDI tables. Verify that your 
trading partner is sending a valid functional group type. 

1 - NO TRADING PARTNER PROFILE FOUND -ECUERR: XXXX 

No trading partner profile could be found for the given interchange ID. Set up a trading partner profile for 
the given interchange ID. 
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1 - NON-NUMERIC CONTROL NO -ECUERR: XXXX 

The given control number cannot be updated because it is not in numeric format. Contact your trading 
partner and tell them that you can only accept numeric control numbers. 

0 - BAD ISA -EUNERR 

There was something other than ISA found where the interchange control header was expected to start. 
This typically indicates that your network is performing blocking and padding between ISA envelopes 
with spaces. Call your network and verify whether or not they have blocking turned on for your mailbox. 
If they do, have them turn it off. Harbinger does not do blocking. This error also indicates data corruption 
during transmission if all segments are not present. After determining and fixing the problem, have your 
trading partner resend the document. 

2 - BAD GE SEGMENT -EUNERR 

There was something other than GE found where the group footer was expected to start. This typically 
indicates the receipt of corrupted data from the network. The document must be resent by the trading 
partner or reprocessed by the VAN. 

2 - BAD GS SEGMENT -EUNERR 

There was something other than “GS” found where the group header was expected to start. This typically 
indicates the receipt of corrupted data from the network. The document must be resent by the trading 
partner or reprocessed by the VAN. 

2 - BAD TS COUNT IN GE SEGMENT -EUNERR XXXX/XXXX 

The number of transactions indicated in the “GE” segment does not match the number of transactions 
actually counted. This typically indicates the receipt of corrupted data from the network. The document 
must be resent by the trading partner or reprocessed by the VAN. 

2 - GROUP CONTROL# MISMATCH GS/GE -EUNERR:  XXXX/XXXX 

The control number in the group header does not match the control number that was last received from 
your trading partner. This may indicate that you have missed a transmission from your trading partner. It 
often indicates that your trading partner does not send control numbers sequentially. Verify with your 
trading partner whether or not they send sequentially numbered control numbers, and proceed from there. 

3 - NO SE FOUND -EUNERR 

There was no transaction footer found. This typically indicates the receipt of corrupted data from the 
network. The document must be resent by the trading partner or reprocessed by the VAN. 

3 - NO ST FOUND -EUNERR 

There was no transaction header found. This typically indicates the receipt of corrupted data from the 
network. The document must be resent by the trading partner or reprocessed by the VAN. 

3 - SEG COUNT MISMATCH IN SE -EUNERR: XXXX/XXXX 

The number of segments indicated in the “SE” segment does not match the number of segments actually 
counted. This typically indicates the receipt of corrupted data from the network. The document must be 
resent by the trading partner or reprocessed by the VAN. 

3 - TS CONTROL# MISMATCH ST/SE -EUNERR: XXXX/XXXX 

The control number in the transaction header does not match the control number that is in the transaction 
footer. This typically indicates the receipt of corrupted data from the network. The document must be 
resent by the trading partner or reprocessed by the VAN. 
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4 - Duplicate Recv Doc -EUNERR: XXX 

Duplicate control numbers have been received from a particular trading partner for a specific document 
type. Contact your trading partner and tell them which control numbers have been received in duplicate. 
Then ask them to verify whether or not it is a duplicate. If the document that was sent was not a duplicate, 
they must resend it with control numbers that have not yet been used. 

IEA FG COUNT # GROUP COUNT -EUNERR: XXXX-XXXX 

The number of functional groups indicated in the “IEA” segment does not match the number of functional 
groups actually counted. This typically indicates the receipt of corrupted data from the network. The 
document must be resent by the trading partner or reprocessed by the VAN. 

Interchange Control# ISA/ISE mismatch -EUNERR: XXXX/XXX 

The control number in the interchange control header does not match the control number that is in the 
interchange control footer. This typically indicates the receipt of corrupted data from the network. The 
document must be resent by the trading partner or reprocessed by the VAN. 

No IEA Segment found !!! -EUNERR 

There was no interchange control footer found. This typically indicates the receipt of corrupted data from 
the network. The document must be resent by the trading partner or reprocessed by the VAN. 

Unexpected File Name 

The system did not recognize the file as an EDI file for processing. 

EDI Activity Log Viewing Screen Errors 
The following errors display on the EDI Activity Log Viewing screen. 

Mapping Subroutine not Cataloged -ECDERR 

The mapping subroutine specified on the EDI Group Profile Maintenance screen does not exist or has not 
been compiled. Recheck the mapping subroutine you are using on the EDI Group Profile Maintenance 
screen. Make sure each zero and letter O is in the right place. 

No Mapping Defined -ECDERR 

No mapping subroutine entered for the specified EDI document on the EDI Group Profile Maintenance 
screen. Enter the appropriate mapping subroutine on the EDI Group Profile Maintenance screen for the 
trading partner. 

No Trading Partner Profile Defined -ECDERR 

A trading partner profile has not been set up on the EDI Trading Partner Profile Maintenance screen. Set 
up a trading partner profile for this trading partner. 

Trade Partner : XXXX not on file -ECDERR 

The trading partner does not exist on Eclipse. The customer/vendor who is defined on the EDI Trading 
Partner Profile Maintenance screen for this trading partner must be corrected. 

Error in 852 Transmission -EP8ERR: XXX 

An error occurred while creating the 852 document. Contact Eclipse EDI Support for assistance. 
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Order Entry Screen (SOE or POE) Errors 
The following errors display on the Status screen of Sales Order Entry or Purchase Order Entry after 
changing the status to E and pressing Esc. 

Ledger Record not found -ECOERR: XXXXXXX 

The ledger record specified by EDI does not exist on Eclipse. Contact Eclipse EDI Support for assistance. 

Mapping Subroutine not Cataloged -ECOERR 

The mapping subroutine specified on the EDI Group Profile Maintenance screen for this trading partner 
does not exist or has not been compiled. Recheck the mapping subroutine you have entered on the EDI 
Group Profile Maintenance screen. Make sure each zero and letter O is in the right place. 

No Mapping Defined -ECOERR 

No mapping subroutine has been defined on the EDI Group Profile Maintenance screen for the specified 
trading partner. Enter the appropriate mapping subroutine on the EDI Group Profile Maintenance screen 
for the trading partner. 

No Trading Partner Profile Defined -ECOERR 

No trading partner profile has been found in Trading Partner Profile Maintenance for the account 
specified on this order. Set up a trading partner profile for this trading partner. 

Transmission Aborted!!! -ECOERR 

The system returns this message if No is the response to the following prompt: This document has already 
been Transmitted - Continue (Y/N). No action is necessary. 

No Document specified -EDSERR 

No document type has been specified for the attempted transaction. Enter the appropriate document type 
on the EDI Group Profile Maintenance screen for the trading partner. 

No Mapping Defined -EDSERR 

No mapping subroutine has been defined on the EDI Group Profile Maintenance screen for the specified 
trading partner. Enter the appropriate mapping subroutine on the EDI Group Profile Maintenance screen 
for the trading partner. 

No Trading Partner Profile Defined -EDSERR 

No trading partner profile has been found in Trading Partner Profile Maintenance for the account 
specified on this order. Set up a trading partner profile for this trading partner. 

CANNOT OPEN EDI.STND.DE -EPDERR 

The EDI.STND.DE file does not exist, or permissions are incorrect. This file contains ANSI data element 
information. Contact Eclipse EDI Support for assistance. 

CANNOT OPEN EDI.STND.SEG -EPDERR 

The EDI.STND.SEG file does not exist, or permissions are incorrect. This file contains ANSI segment 
information. Contact Eclipse EDI Support for assistance. 

CANNOT OPEN EDI.STND.TS -EPDERR 

The EDI.STND.TS file does not exist, or permissions are incorrect. This file contains ANSI transaction 
set information. Contact Eclipse EDI Support for assistance. 

Branch EDI Group ID is not Defined -ESDERR 
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The “GS” interchange ID is not defined in the EDI OUTGOING ID record in Control File Maintenance 
for the specified branch. Set up the interchange ID for the specified branch in Control File Maintenance 
under EDI OUTGOING ID. 

Branch EDI ISA ID is not Defined -ESDERR 

ISA interchange ID is not defined in Control File Maintenance under EDI OUTGOING ID for the 
specified branch. Set up the interchange ID for the specified branch in Control File Maintenance under 
EDI OUTGOING ID. 

Trading Partner not found -ESDERR: XXXX 

No trading partner profile was found in Trading Partner Profile Maintenance for the account specified on 
this order. Set up a trading partner profile for this trading partner. 

Trading Partner Maintenance Screen Errors 
The following errors display on the EDI Trading Partner Profile Maintenance screen. 

Ascii decimal value must be 255 or less 

The three digit decimal value entered in the Separator/Sub-Separator field cannot be greater than 255. 
Re-enter the separator or sub-separator in the correct format. 

Entity already assigned to EDI group 

An entity can only be assigned to one EDI group. Enter a different entity or find the current trading 
partner profile that is linked to that entity and delete it. 

Multiples Entities Are Only Allowed For Vendors 

Customers cannot have multiple entities set up for a single group. Do not enter multiple entities for 
Customers. 

Single character or 3 digit decimal value for ascii character 

The value placed in the Separator/Sub-Separator field must be either the character used as the separator 
or its three-digit decimal-value ascii equivalent. Re-enter the separator or sub-separator in the correct 
format. 

There Are Still Active Groups. Delete Them First 

You cannot delete a trading partner profile until all groups belonging to that profile have been deleted. Go 
to the EDI Group Profile Maintenance screen and delete all groups. Then go back to the EDI Trading 
Partner Profile Maintenance screen and delete the profile. 

Wrong Format. Use Qualifier Tilde ID. ex 01~12345 

The trading partner ID number must be entered in this format. Enter the trading partner ID number in the 
correct format. 

You Must Delete Through Group Maintenance. Press <Enter> 

A group cannot be deleted from the EDI Trading Partner Profile Maintenance screen. Go to the EDI 
Group Profile Maintenance screen to delete the group. 

Group is not in file. 

When using the Copy Profile command, the group profile you are attempting to copy must exist. Verify 
that the group ID you are entering exists in a trading partner profile. 

ISA ID is not in file. 
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When using the Copy Profile command, the ISA ID you are attempting to copy must exist. Verify that the 
ISA ID you are entering exists in a trading partner profile. 

You cannot copy a group from itself 

When using the Copy Profile command, you must enter the group whose profile you are copying, not the 
group receiving the profile. Verify the source group and target group. 

Duplicate <Press Enter> 

The entity being entered has already been entered. Enter a different entity. 

Entity already assigned to EDI group 

An entity can only be assigned to one EDI group. Enter a different entity. 
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Troubleshooting EDI Transmission Failures 
Check for EDI transmission problems if the EDI.ADM message group receives a transmission failure 
message or the associated document remains in the EDI Outgoing Status Queue with a status of 
ENVELOPED for an extended period of time. What constitutes an extended period of time depends on: 

• How often you dial into the network. 

• How much mail (EDI documents) is waiting to come back from the network. 

• How much mail is waiting to send to the network. 

• The network to which you subscribe. Keep in mind that some are slower than others. 

If you decide that a document has been in the EDI Outgoing Status Queue with a status of ENVELOPED 
for an extended period of time, display the EDI Activity Log and review the messages in the 
Transmission Summary Report. 

Transmission Messages Associated With a Problem 
Transmission messages that indicate a problem can refer to: 

• Connection failure. 

• Logon failure. 

• Transmission failure. 

• Receive failure. 

• A Network Call Complete and Network Call Started with no Transmission Summary Report in 
between. 

Connection Failure 
Messages 

The following messages are associated with a connection failure: 

• Connect Failed 

• Logon Failed 

• Transmit Nothing 

• Receive Unsuccessful 

Cause 

The attempt to connect to the network failed. 

Solution 

1. Verify that the EDI modem is turned on. 

2. Verify that the cables between the modem and computer and the modem and wall jack are 
securely connected. 

3. Verify that the telephone line is plugged into the jack on the modem that says Line or Telco, not 
Phone. 
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4. Verify that the telephone line is active. If necessary, connect a telephone to the jack labeled 
Phone on the back of the modem to confirm that the line is active and you get a dial tone. 

5. If one of the previous steps does not isolate the problem, try resetting the modem by turning it off 
for 10 seconds and then turning it back on. 

6. If none of these actions fixes the problem, your network or telephone company may be the source 
of the problem. 

Logon Failure 
Messages 

The following messages are associated with a logon failure: 

• Connect Okay 

• Logon Failed 

• Transmit Nothing 

• Receive Failed 

Cause 

The network did not return the appropriate prompts associated with the logon procedures for your 
network. 

Solution 

1. Wait a few minutes and try again. 

2. If retrying does not fix the problem, your network or telephone company is probably the source of 
the problem. 

Transmission Failure 
Messages 

The following messages are associated with a transmission failure: 

• Connect Okay 

• Logon Okay 

• Transmit Failed 

• Receive Failed 

Cause 

The transmission of EDI documents to the network was not successfully completed. 

Note: The documents enveloped for the failed transmission attempt will remain 
enveloped until a successful transmission is made. 

Solution 

1. Wait a few minutes and try again. 

2. If retrying does not fix the problem, your network or telephone company is probably the source of 
the problem. 
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Receive Failure 
Messages 

The following messages are associated with a receive failure. 

• Connect Okay 

• Logon Okay 

• Transmit Okay (or Transmit Nothing) 

• Receive Failed 

Cause 

The transmission of EDI documents from the network was not successfully completed. 

Solution 

1. Wait a few minutes and try again. 

2. If retrying does not fix the problem, your network or telephone company is probably the source of 
the problem. 

Network Call Complete and Network Call Started With No Transmission Summary Report 
The entry in the EDI Activity Log for a successful transmission starts with Network Call Complete and 
the name of your network, is followed by a Transmission Summary Report, and ends with Network Call 
Started and the name of your network. 

The EDI Activity Log reports an occurrence of Network Call Complete and Network Call Started with no 
Transmission Summary Report. If you only see "Network Call Complete: (the name of your network)" 
followed by "Network Call Started: (the name of your network)," one of the following may be the cause 
of and solution to the transmission problem: 

Cause of the Problem Solution 
The tty that the EDI modem uses may be enabled 
and have a getty running on it. 

If the tty has a getty, the configuration for the tty in smit may 
be incorrect. If so, the login for the tty should be disabled and 
the tty pdisabled. If you need assistance, call Eclipse Support. 

If the tty has no getty, the problem may be caused 
by the tty having a lock on it. 

The tty should not have a lock in /etc/locks. If you need 
assistance, call Eclipse Support. 

The tty to which the EDI modem is connected 
may not be the same one that is defined to EDI. 
This may happen if a cable is inadvertently 
disconnected and then reconnected to the wrong 
location, or if ttys are changed. 

If a cable gets disconnected and you know where to reconnect 
it, do so. If you do not know where to reconnect it, or if ttys 
are changed, call Eclipse Support for assistance. 
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EDI Disaster Recovery Planning Guidelines 
Use the information in this topic and the referenced topics to help you develop an EDI disaster recovery 
plan. Preparing for data recovery in the event of a disaster, such as a natural disaster, a disk failure, or 
electrical outage, includes having a regularly scheduled backup or archive process. Every business has its 
own guidelines for how long files remain active and archived, and if files are ever purged. For more 
information about defining time frames to keep active and archived files, see Setting Up EDI Parameters. 

In the event of a disaster or data loss, contact the Eclipse Customer Support group to help you restore 
your EDI data, including active and archived EDI files, from a backup tape. Your backup data returns the 
system to the state just before the last nightly backup ran. 

Any EDI documents that you received or sent between the time your last backup ran and the time your 
system is up and running again are not available on the backup tape. At this time, Eclipse does not contain 
a way to report EDI activity within a certain period. For example, if an evacuation order is given and you 
do not have time to run a backup, there is currently not a way in Eclipse to reporting what EDI activity 
has occurred since the last backup. You can recover these files from your value added network (VAN). 

Inform your VAN of the time of the last backup and the time your system is restored. They can resend 
any inbound documents that you would have received during the outage and report any documents that 
you sent out during that time as well. After you know what documents were sent out, you can recreate 
them on your restored system. 
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EDI File Locations 
Depending on the Eclipse release you are running, the EDI files are located in different locations. Use the 
following information to determine where to find active and archived EDI files, based on your release. 

Eclipse Release 8040.4 and Later 
For sites on 8040.4 or later, EDI files are located in the following directories: 

• Active EDI files - /u2/eclipse 

• Archive files - /u2/edi 

If you have a multiple-account Eclipse box, for example you have both Eclipse and Train accounts on one 
box, the system stores the archive files in account-specific directories, such as /u2/edi/eclipse and 
/u2/edi/train. 

By default, all active and archived EDI files are backed up nightly. However, the inactive archives can 
grow quite large and increase the time it takes to backup the directories. On high-volume EDI sites, a 
nightly backup can take several hours because the inactive archives have grown in size. If needed, Eclipse 
can change your nightly backup script to exclude the /u2/edi directory. You can schedule special backups 
to include only the /u2/edi directory. For  example, you may decide that your site needs to only backup 
inactive files once a month. 

Release 8040.4 and later also includes an EDI file purge utility you can use to purge the archive directory 
of files that you no longer need. 

Eclipse Release 8040.3 and Earlier 
Prior to the changes in 8040.4, EDI files could be placed in several different locations. As the EDI 
product has evolved and we have tracked how files are used, Eclipse has changed where the EDI files 
should be located. If you are running Eclipse Release 8040.3 or earlier, contact EDI Support to determine 
where your EDI files are located. 

If your backups are taking too long, you can contact Eclipse for an upgrade to 8040.4 or higher, giving 
you the ability to purge old files or exclude the archive files from the nightly backups, if needed. 

Windows NT/2000/2003 Systems 
On Windows systems, all EDI files are backed up nightly by default and are located in the following 
directories:: 

• Active files - \edi\edi 

• Archive files - \edi\arch 
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