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EGraph Overview 
The EGraph application is an MS Windows®-based tool you will use to view or print the graphs 
you create using the character-based Eclipse Information System (EIS) application. You will 
select a series of graph options on the Eclipse Information System screen, and when you click 
the category for which to graph data, such as a bill-to customer, a pay-to vendor, a sales 
representative, a price line, or a sales source, the system creates a graph and displays it in the 
Eclipse Egraph window. 

This application can also be used to create graphs from the data on the Business Summary screen 
and the A/R Inquiry screen. 

Once you have displayed a graph, you can change its format. For example, if you would rather 
view the data as a pie chart instead of as a bar graph, you can click a button and EGraph changes 
the graph into a pie format. You can change the text style, color, and size to be consistent with a 
presentation you are giving. You can even drill down into a subset of the data and display it on 
the graph, if needed. 

Important: This help system assumes that you have a working knowledge of 
the Windows operating system. 
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Setup Requirements for EGraph 
The EGraph application is a companion to the Eclipse Information System (EIS) and must be 
installed on the computer of any employee who will create graphs from EIS. Your company 
should have received the EGraph executable file when EIS was installed on your system. If you 
did not, call Eclipse Technical Support to obtain a copy. 



Rel. 8.6.4 (Eterm) EGraph 

© 2008  Activant Solutions Inc. All rights reserved. 3 

Starting the Eclipse EGraph Application 
Before you can work with graphs, you must start the application. You can use any of the 
following three methods to do this: 

To start the Eclipse 
EGraph 
application from... 

Do this... 

Windows From the Start menu, select Programs > Eclipse > EGraph. 

ETerm Select graph options on the Eclipse Information System screen. When 
you select a value in the Sales Graphs or Purchases Graphs area, the 
system creates the graph and displays the Eclipse EGRAPH window. 

an EGraph graph (.grf 
extension) 

Double-click a file that has a .grf extension. This will not open the 
file, only the application. 

Note: The first time you do this, Windows will ask you to identify the 
program to use to open the graph. Click the Browse button, select the 
Eclipse folder under the Program Files folder, select the EGraph 
folder, and double-click egraph.exe to return to the Open With 
window. Select the Always use the selected program to open this 
kind of file check box, if needed, and click OK to display the Eclipse 
EGRAPH window. 
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Saving Graphs 
After you create a graph in EIS, you may want to save it for further review or comparison 
purposes. If you have made changes to it, such as a different graph format, you will not be 
prompted to save that format when you close the graph. You must deliberately save the graph if 
you want to maintain that format. 

To save a graph: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph As to display the Save Graph As window. 

3. In the File name field, enter a file name that will help you to quickly identify the graph. 

You may want to include the as of date in the file name for comparison purposes. 

4. Click Save to save the graph with a .grf extension. 
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Saving Graph Collections 
If you have created a series of related graphs, you may want to maintain them in a group. When 
you do this, any time you want to display the graphs, they all open at the same time. If you close 
the collection, all of the graphs in the collection are closed at the same time. You can add or 
remove graphs from the collection at any time. 

To save a collection of graphs: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection As to display the Save Collection As 
window. 

3. In the File name field, enter a file name that will help you to quickly identify the graph 
collection. 

You may want to include the as of date in the file name. 

4. Click Save to save the group of graphs with a .col extension. 
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Displaying Saved Graphs 
If you save a graph or a collection of graphs you created using EIS, you can open and display 
them in the Eclipse EGraph window. 

Note: This instruction is based on the functionality of Microsoft Windows XP 
2002. While the buttons may differ in your version of Windows, the 
essence of the instruction should still assist you in completing this task. If 
not, consult the MS Windows® online help for additional assistance. 

To display a saved graph or collection of graphs: 

1. From the File menu, select Open Collection/Graph to display the Open 
Graph/Collection window. 

2. Browse to the folder in which your graphs are stored, if needed. 

Note: The application remembers the last place you stored graphs and opens that 
folder in subsequent sessions. 

3. Select a graph (.grf extension) or a collection (.col extension) and click Open to display 
the requested file in the Eclipse EGraph window. 
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Viewing Multiple Graphs 
When you have multiple graphs open in the Eclipse EGRAPH window, you can use the options 
under the Window menu to arrange them in such a way as to view more than one simultaneously. 

To view multiple graphs in the Eclipse EGraph window: 

1. Display two or more graphs in the Eclipse EGraph window. 

2. From the Window menu, select one of the following options: 

To... Select this menu option... 
stack the graphs so that you can view each of their titles Cascade Windows 

arrange the graphs top to bottom Horizontal Tile 

arrange the graphs side by side Vertical Tile 

3. To display a graph full size, select it and do one of the following: 

• Double-click the title bar. 

• From the Window menu, select Default Tile. 
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Saving Changes to Graphs 
After you have saved a graph, if you make changes to it that you want to keep, you need to save 
it again. You can save the changes in the original file or create a new file so that the original file 
is unaffected by the change. 

To save the changes to the original file: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph. 

The application saves the changes to the current file. 

To save the changes to a new file: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph As to display the Save Graph As window. 

3. In the File name field, change the file name to distinguish it from the original. 

4. Click Save to save the graph with a .grf extension. 
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Saving Changes to Graph Collections 
After you have saved a collection of graphs, if you make changes to any of the graphs in it that 
you want to keep, you need to save the collection again. You can save the changes in the original 
file or create a new file so that the original file is unaffected by the change. 

To save the changes to the original file: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection. 

The application saves the changes to the current file. 

To save the changes to a new file: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection As to display the Save Collection As 
window. 

3. In the File name field, change the file name to distinguish it from the original graph 
collection. 

4. Click Save to save the group of graphs with a .col extension. 
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Printing Graphs 
If you want to present a graph in a meeting, you may want to print it so that everyone can have a 
copy of it. If you are writing a report, sometimes having a graphical representation of the sales 
figures can help get your point across more effectively. 

To print a graph: 

1. If you have more than one graph open, bring the one you want to print to the forefront. 

Note: You cannot print all of the graphs in a collection at the same time. You 
must print them individually. 

2. From the File menu, select Print Graph to display the Print window. 

3. Make changes to the print settings, as needed. 

Note: For best results, select a color printer. 

4. Click Print to send the graph to the printer. 
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Closing Graphs 
When you have finished viewing a graph, you can close it without exiting out of the application, 
if needed. 

To close a graph: 

1. If you have more than one graph displayed in the Eclipse EGraph window, click the 
graph to close to select it. 

2. Save changes to the graph, as needed. 

3. Do one of the following: 

• Click the X in the upper right corner of the graph's window. 

Important: Do not click the X in the upper right corner of the application window. 
This closes the entire program. 

• From the File menu, select Close Graph. 

If you made any unsaved changes to the graph, you will not be prompted to save them 
before it closes. 
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Closing Graph Collections 
If you have opened several graphs, you can close them as a group without exiting the application, 
if needed. 

To close a collection of graphs: 

1. If you opened a series of related graphs and want to maintain them together, save them as 
a collection. 

2. Save changes to the individual graphs within the collection, as needed. 

3. From the File menu, select Close Collection. 

If you made unsaved changes to any of the graphs, the application does not prompt you to 
save them. 
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Closing All Displayed Graphs and Collections 
To clear the EGraph window of all open graphs and collections of graphs, use the Clear function. 

Note: The application does not save changes made since your last save. 

To close all displayed graphs and collections: 

1. Save changes to any graphs or collections, as needed. 

2. From the Clear menu, select All. 

3. At the confirmation message, click OK. 

All graphs and collections close, and changes made after your last save are rejected. 
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Exiting the Eclipse EGraph Application 
When you have finished working with graphs, close the Eclipse EGraph window. 

To exit the Eclipse EGraph application: 

1. Save graphs or collections, as needed. 

2. Do one of the following: 

• Click the X in the upper right corner of the application window. 

• From the File menu, select Exit. 
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Exporting Graph Data to Text Files 
If you would like to manipulate the data from a graph outside of Eclipse EGraph, you can export 
the graph data to a text file. You have the option to select a character to use to separate the 
individual pieces of data, and you can export the row and column labels needed. 

To export graph data to a text file: 

1. Create or display the graph to export. 

2. From the File menu, select Export Data to display the Export window. 

3. In the Delimiter area, select one of the following options to determine the character to 
use to separate the individual pieces of data: 

• Tab  

• Space  

• Comma  

• Semicolon  

• Other  
4. In the Options area, select or deselect the following check boxes, as needed: 

• Include Row Labels – Adds the row labels from the graph as a row header in the 
data file. 

• Include Series Labels – Adds the series labels from the graph as a column header in 
the data file. 

5. Click Save As to display the Enter a filename for the exported data file window. 

6. Browse to the folder in which to store the text file. 

7. In the File name field, enter a file name that will help you to quickly identify the graph 
data. 

8. Click Save to create a file with a .txt extension. 

Note: If you want to open the text file in MS Excel®, be sure to use the same 
delimiter you selected in step 3 to format the data in the spreadsheet. 
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Copying Graphs to Other Applications 
If you want to use a graph for a presentation or report, you can copy it from the Eclipse EGraph 
window and paste it into another application, such as MS Word or MS PowerPoint. 

To copy a graph in EGraph: 

1. Create or display a graph in the Eclipse EGraph window. 

2. From the Edit menu, select Copy. 

3. Open the application to which to copy the graph. 

4. Press Ctrl+V to paste the graph into the document. 
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Increasing the Size of Graphs 
The Eclipse EGraph window has no zoom feature. When you create a graph, it displays at 
maximum size. However, when you save and close it, and then re-open it, it shrinks to about 
one-fourth of its original size. This instruction shows how to return it to its maximum size. 

To increase the size of a graph: 

1. Display a saved graph. 

2. From the Edit menu, select Show/Hide ToolBar. The graph displays at full size. 

3. To return the toolbar to its previous view mode, select Show/Hide ToolBar again. 
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Selecting Graph Data Subsets 
The Cross Tab table is a grid with one dimension of the graph (such as months) listed down the 
left side and the other dimension (such as years) listed across the top. The grid is then populated 
with the actual values that are plotted on the graph. 

You cannot change any of the values or labels in a cross tab table and you cannot print or copy 
the data in this spreadsheet format, but you can change what is displayed on a graph by selecting 
certain subsets of the data in the table.  

For example, if you create a chart that has more than one set of data, such as a "this year vs. last 
year" sales comparison, if you change the format to a pie chart, EGraph can graph only one set of 
data at a time, so it selects the first set of data. You can graph the other sets of data by selecting 
other columns in cross tab view. 

To select a data subset to graph: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following to display the cross tab view: 

• Click the  button. 

• From the Graph menu, select Cross Tab. 

3. Do one of the following: 

To select... Do this... 
a column of data Click a column heading. 

several consecutive columns of data Click the first column heading, press and hold the 
Shift key, and click the last column heading. 

a row of data Click a row heading. 

several consecutive rows of data Click the first row heading, press and hold the 
Shift key, and click the last row heading. 

several contiguous cells of data Position the mouse pointer over the first cell to 
select, press and hold the left mouse button, drag 
the pointer diagonally to the opposite corner of 
the group of cells, and then release the mouse 
button. 

display all data, provided the intended graph 
format supports it 

Click the first cell in the table. 

Note: You cannot select non-consecutive rows or columns. 

4. Click a graph format to display the selected data. 
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Changing the Graph Formatting Toolbar View Mode 
The graph formatting toolbar is located on the upper left side of the Eclipse EGRAPH window. 
However, all of the options on the toolbar are also available under the Graph menu, so if you 
want to maximize the space in the EGRAPH window, you can hide the tool bar. If you find that 
the toolbar makes your life easier, you can always bring it back. For more information about the 
toolbar, see Graph Formatting Toolbar Features. 

To change the view mode of the graph formatting toolbar: 

1. To hide the toolbar, from the Edit menu, select Show/Hide ToolBar. 

To change the graph format while the toolbar is hidden, from the Graph menu, select any 
of the menu items. 

2. To re-display the toolbar, from the Edit menu, select Show/Hide ToolBar. 
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Creating Line Charts 
A line chart (by default) uses dots connected by a line to indicate the data points in the graph. 
Each data set of information is represented by a line with a different color. The three-
dimensional chart lines have a tape-like depth. 

To create a line chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional line chart format 

• Click the   button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Line Chart. 

• Click the   button and select the Line button. 

three-dimensional line chart format 
• Click the   button on the graph formatting 

toolbar. 
• From the Graph menu, select 3D Line Chart. 

• Click the   button, click the 3D Gallery tab, 
and select the Tape button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add sticks, lines, or symbols to a two-dimensional graph Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional graph 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the graph Background 

4. Save your changes. 
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Creating Area Charts 
An area chart uses dots connected by a line to represent the data points in the graph, and then 
fills in the area below the line. Each data set of information is represented by an area with a 
different color. The three-dimensional area chart adds depth to the area. Each data set of 
information is represented by an area with a different color. 

To create an area chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional area chart format 

• Click the   button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Area Chart. 

• Click the   button and select the Area button. 

three-dimensional area chart format 
• Click the   button on the graph formatting 

toolbar. 
OR 
• From the Graph menu, select 3D Area Chart. 

• Click the   button, click the 3D Gallery tab, 
and select the Area button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
further define the area chart style Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional graph 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the graph Background 

4. Save your changes. 
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Creating Bar Charts 
A bar chart uses a bar to represent each data point in the graph. Each data set is represented by 
bars of a different color. The three-dimensional bar chart uses columns to represent each data 
point in the graph. Each data set is represented by a different column color. This type of graph is 
good for showing the relationships between two or more data sets of information. 

To create a bar chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph 
data in a... 

Select one of these methods... 

two-dimensional bar chart 
format • Click the   button on the graph formatting toolbar. 

• From the Graph menu, select 2D Bar Chart. 

• Click the   button and select the Bar button. 

three-dimensional bar chart 
format • Click the   button on the graph formatting toolbar. 

• From the Graph menu, select 3D Bar Chart. 

• Click the   button, click the 3D Gallery tab, and select the Line 
button. 

Note: This is the type of chart the system creates initially when you 
run the Eclipse Information System program. 

3. Set any of the following options, as needed: 

To... Click this tab... 
further define the bar chart style Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional 
graph 

3D 

Note: You can also click the left, right, up, or 
down arrow buttons in the lower left corner of the 
graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that 
identify the data points or data sets 

Markers 

change the style of the background elements on 
the graph 

Background 
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Creating Pie Charts 
In a pie chart, the data points in the graph are represented as sections of a circle. This type of 
graph can be used for a single data set only. The three-dimensional pie chart adds thickness to 
the pie slices. 

To create a pie chart from a graph with multiple data sets, first display your data in the Cross Tab 
format. In the Cross Tab, select the data set to graph, then select the Pie Chart format to display 
the graph. 

The pie chart styles affect the labels on the slices of the pie. 

To create a pie chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional pie chart format 

• Click the   button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Pie Chart. 

• Click the   button and, under the 2D Gallery 
tab, select Pie. 

three-dimensional pie chart format 
• Click the   button on the graph formatting 

toolbar. 
• From the Graph menu, select 3D Pie Chart. 

• Click the   button, click the 3D Gallery tab, 
and select Pie. 

If the graph has more than one set of data points, the application selects the first set of 
data for the pie chart. To use a different set of data, see Selecting Graph Data Subsets. 

3. Set any of the following options, as needed: 

To... Click this tab... 
change the appearance of the pie chart labels Style 

work with the graph data Data 

edit the chart titles Titles 

change the appearance of a three-dimensional chart 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the chart Fonts 
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To... Click this tab... 
change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Polar Charts 
The polar chart is essentially a line chart drawn on a circular grid. The line relates values to 
angles. Like logarithmic graphs, polar graphs are useful primarily in mathematical and statistical 
applications. In a polar graph, the independent variable is charted on the angular axis, based on 
an origin (zero point) of three o'clock. The dependent variable is charted on the radial axis, with 
the origin at the center of the circle. Polar graphs can chart multiple data sets, each represented 
by a single line, with as many data points as are meaningful. 

If you don't supply an angular position for each data point, the Graph control automatically 
places the first point at an angle of 0, with subsequent points at increments of 360 (degrees) 
divided by the total number of points. 

To create a polar chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Polar button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Polar button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add sticks, lines, or symbols to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Bubble Charts 
The bubble graph lets you chart three variables in two dimensions. It is a special form of the 
scatter graph in which the size of a circular marker (the bubble) for a data point is used to 
represent a value. For example, the size of a bubble might represent a product's percentage of 
gross sales; the bubble's position along the Y axis might represent market size; and the position 
along the X axis might represent the number of competing products. 

In a bubble graph, all three variables are independent. You can choose which variable to show on 
the X axis, which to show on the Y axis, and which to show by the size of the bubble. 

You must supply values for the X position, Y position, and bubble size for each point. If you 
have access to the Data property page, you can set these values by pressing the X and Y Position 
button (the top row of the dialog contains the X positions and the bottom row the Y positions) 
and the Bubble Size button. 

Note: You can't draw curves on a bubble graph. 

To create a bubble chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Bubble button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Bubble button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Scatter Charts 
The 2D scatter graph consists of plotted points "scattered" around an X-Y grid. The pattern may 
reveal a relationship between the two variables measured by the X and Y axes. Scatter graphs 
can chart multiple data sets, each having any number of data points. Each set can be represented 
by a different symbol. You can display scatter plots alone, curves alone, or both together. 

To create a scatter chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional area chart format 

• Click the   button and click the Scatter button. 
• From the Graph menu, select Options, and then, 

under the 2D Gallery tab, click the Scatter button. 

three-dimensional area chart format 
• Click the   button, click the 3D Gallery tab, 

and click the Scatter button. 
• From the Graph menu, select Options, and then, 

under the 3D Gallery tab, click the Scatter button. 

 

3. Set any of the following options, as needed: 

To... Click this tab... 
add symbols to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

enhance the three-dimensional features 3D 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating GANTT Charts 
The Graph control's Gantt chart is a specialized version of the horizontal bar graph in simple or 
stacked form. It is used almost exclusively to show a project schedule, with each bar or bar 
segment marking the start time, duration, and completion time of a task. 

Depending on your needs, you can have each bar represent either a single task (one solid bar) or 
a sequence of tasks (stacked bar). 

Gantt charts are made up of at least two data sets. The first set contains the values for the start 
point of each bar, and subsequent sets contain the end points of each bar segment. Unlike bar 
graphs, Gantt charts are always drawn horizontally and only in 2D form. The Graph control 
automatically places Gantt bars along the Y axis at increments of 1, starting at 1. 

In default form, Gantt chart bars are drawn with no spaces between them. You can add spaces if 
you choose. Go to the Style property page and select the Spaced option. You can't show negative 
data points on a Gantt chart. 

To create a GANTT chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Gantt button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Gantt button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add spaces between the bars on the chart Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating High-Low Close Charts 
The high-low-close (HLC) graph lets you chart a range of values on an X-Y grid. The range is 
shown as a vertical bar, with horizontal crossbars for the high, the low, and a normative value 
usually called the close. An alternate version, the open-high-low-close (OHLC) graph, adds a 
fourth crossbar for another normative value usually called the open. 

When you click the High-Low icon on the 2D Gallery property page, you get an HLC graph by 
default. To get an OHLC graph, go to the Style property page and select the 'Open' Values 
option. 

An HLC graph must have three data sets (high, low, and close values), and an OHLC graph must 
have four data sets (open, high, low, and close values). There's no limit on the number of data 
points you can graph, but each data set should have the same number. 

You can optionally draw the graph without the open and close bars, without the high and low 
bars, or with no bars at all.  These options are available in the Style property page. 

To create a high-low close chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the High-Low button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
High-Low button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
show or hide open values, high/low ticks, and open/close 
ticks 

Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Candlestick Charts 
The candlestick graph is an alternative to the open-high-low-close graph. It consists of a series of 
boxes, with lines extending up and down from the ends, drawn on an X-Y grid. The top and 
bottom of each box indicate the open and close values. If the open value is higher, the box is 
filled with a color; if the close value is higher, the box is filled with white. The ascending and 
descending lines indicate the high and low values for that point. 

The candlestick graph requires four data sets (open, high, low, and close values), each of which 
should have the same number of data points. 

If you don't supply an X position for each data point, the Graph control automatically places 
points at increments of 1, starting at 0. 

No style variants are available. 

To create a candlestick chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Candlestick button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Candlestick button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Box-Whisker Charts 
The box-whisker graph illustrates the spread of data groups around their medians, using a "box" 
and "whiskers" to break down each data group by percentile. 

In creating a box-whisker graph, you can either specify the seven percentile parameters for each 
symbol (provide "parametric" data) or supply a group of "raw" data for the Graph control to 
process and graph. 

With raw data, you supply as many sets of data as you want and the Graph control computes 
percentile parameters. For example, if you are graphing the scores achieved by 24 students on 
five tests, you need 24 sets of data with five points per set. The control will analyze the data and 
draw five box-whiskers, one for each test. Each box-whisker will show the percentile distribution 
of scores for a single test. 

With parametric data, you compute percentile data yourself and send it to the Graph control as 
exactly seven data sets, which specify the values at percentiles of 5, 10, 25, 50 (the median), 75, 
90, and 95. The number of points within each set determines how many box-whiskers are drawn. 

To create a box-whisker chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Box-Whisker button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Box-Whisker button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
determine the source of the data to display Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Time Series Charts 
Unlike other graphs, the time series graph shows open-ended streams of data, rather than finite 
data sets. This graph is ideal for plotting real-time data. 

A time series graph is drawn on a dynamic X-Y grid. Points are added one at a time to the right-
hand edge. When the graph reaches the limit of points it can show, the oldest data begins to drop 
off the left edge.  As a result, the graph appears to move on the screen. 

Time series graphs can chart multiple data sets, each represented by a single sequence of 
symbols. 

Because time series graphs represent continuous streams of data, they must be displayed on 
screen to show all the data.  Printouts of time series graphs can show only freeze-frames of the 
graph captured at particular times. 

The data for a time series graph must be provided by the application. You cannot enter data for 
this type of graph from the property pages. 

To create a time series chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Time Series button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Time Series button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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Creating Surface Charts 
The surface graph lets you represent data topographically in three dimensions. The graph uses an 
X-Z grid drawn at regular increments in the X and Z directions, with one Y value for each X-Z 
intersection. The color scale of the graph is automatically keyed to the height of points, helping 
the viewer differentiate between higher and lower values. 

A surface graph represents a minimum of two data sets and usually at least three. Each data set 
holds the Y values of a row of points along the X axis. The first set applies to the row of points 
perpendicular to the Z origin (the "back" of the graph), and subsequent sets apply to additional 
rows. 

All panels of the surface graph (the rectangles formed by the X and Z grids) are colored 
according to their height. You specify the colors at the maximum and minimum points of the 
axis, and the Graph control interpolates colors between these points. 

In drawing a surface graph, you can use lines to show the edges of each panel, fill each panel 
with a solid color, or use both lines and fills. You can also add side walls to the front and right 
edges of the graph if you choose. All of these options are available in the Style property page. 

To create a surface chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button, click the 3D Gallery tab, and then click the Surface button. 

• From the Graph menu, select Options, and then, under the 3D Gallery tab, click the 
Surface button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add markers, color grades, and sidewalls to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

enhance three-dimensional features 3D 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

4. Save your changes. 
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