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Eclipse Information System Overview 
The Eclipse Information System (EIS) is a fully integrated, online analytical processing (OLAP) 
companion product that gives you a real-time, graphical representation of your sales and 
purchasing business data. You get instant access to multi-dimensional data that lets you quickly 
identify valuable business trends. You can examine your business data from a "Top-10" 
summary perspective, or drill down to the transaction level and analyze your data in greater 
detail. 

Each evening the sales and purchasing data is collected in EIS. This data is then available for you 
to evaluate and graph, to share or distribute, as needed. You can run extensive searches on data 
without sending requests to dynamic information, thereby speeding up the search process. In 
addition, when the build runs each evening, the data is added to the current information so that 
the information is comprehensive and not just a snapshot of a day. 

Features and Benefits 
You can analyze your sales and purchasing data. 

• Graph business data for customers, vendors, price lines, buy lines and more for any range 
of dates. 

• Drill down from summary-level data to item-level detail in seconds. 

• Compare one period against another period, side-by-side in graphical format. 

• Analyze both favorable and unfavorable trends in your business by viewing the extremes 
from a top-down or bottom-up perspective. 

• View your business data in different graphical formats, such as line charts, bar charts, and 
pie charts. 

• Quickly switch back and forth between graphs and charts, and the EIS report builder. 

You can also investigate your business data from different perspectives using a variety of 
inquiries. For more information, see the Management Inquiries Overview. 

See Also: 
Setup Requirements for the Eclipse Information System 
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Setup Requirements for the Eclipse Information 
System 
Following are the setup requirements for the Eclipse Information System. No control 
maintenance records or authorization keys exist for this product. 

User Maintenance 
Identify the EIS groups for which each user is authorized to generate graphs. 

Management Inquiries 
If you plan to analyze sales statistics using various categories, ensure that those categories are 
assigned to your customers and products, or are being used during sales order entry. 

Customer Maintenance 
Assign the following to each of your customers, as needed: 

• Customer type 

Customer types are defined in the Valid Customer Types control maintenance record. 

• Customer select code 

Customer select codes are defined in the Valid Customer Select Codes control 
maintenance record. 

G/L Sales Source Maintenance 
Define your sales sources in the system. 

Terminal Setup 
Assign a sales source to each of your terminals, as needed. 

Note: If a terminal does not have a sales source assigned, the sales representative 
will select from a list of sales sources during sales order entry. 

Ship Via Maintenance 
Define your methods of transportation in the system. 

Note: Ship vias are assigned during sales order entry. 

Price Maintenance 
Assign the following to pricing matrix cells, as needed: 

• Sell groups 

Sell groups are defined in the Buy/Sell Group Maintenance window. 

• Buy groups 

Buy groups are defined in the Buy/Sell Group Maintenance window. 
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Product Maintenance 
Assign the following to each of your products, as needed: 

• Price line 

Price lines are defined in the Price Line Maintenance window. 

• Buy line 

Buy lines are defined in the Buy Line Maintenance window. 

• G/L product type 

G/L product types are defined in the G/L Product Type Maintenance window. 

• Product select code 

Product select codes are defined in the Valid Product Select Codes control maintenance 
record. 

• Product status 

Product statuses are system-defined and cannot be added or changed. 

• Commodity code 

Commodity codes are defined in the Valid Product Commodity Codes control 
maintenance record. 

• Budget group 

Budget groups are defined in the Sales Budget Group Maintenance window. 

EIS Build Sales/Purchases 
Build the EIS sales/purchases datafile. 

Important: Never use the phantom scheduler to schedule the initial build, and do not 
build it during business hours or during system backup. 

Phantom Scheduler 
You may want to schedule the EIS Incremental Sales/Purchases process to run daily. 

See Also: 

Creating EIS Graphs 

Graphing Overview 
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Building the EIS Sales/Purchases Datafile 
The EIS Sales Datafile Build driver is a reporting tool that builds a cross-indexed file, based on 
the type of information you want to graph. The file that is built is independent of the system 
database. You must specify the hours when it is safe to run the build, because the build is 
processor-intensive and can affect system performance if too many other programs are running. 
For this reason, we recommend running the build during off-hours, such as nights or weekends. 
Keep in mind that if you change information in your database, you must run the datafile build 
again before you create new graphs. 

To build the sales and purchases datafile: 
1. From the Reprts > Eclipse Information System (EIS) > EIS Maintenance > EIS 

Sales/Purchases menu, select EIS Build/Sales Purchases to display the EIS Sales 
Datafile Build screen. 

The system populates the Build Status field with the status of the EIS datafile build and 
the Build Mode field with the mode in which your build will begin. 

2. For each day on which the EIS datafile will be built, enter the following information: 

Column Description 
Morning Stop The time to stop building the EIS datafile. 

Evening Start The time to begin building the EIS datafile. 

 

3. Do one of the following: 

To... Use this hot key... 
begin building the EIS datafile at the time 
specified in the Evening Start field for 
today's day of the week. 

Begin 
Important: Use this method when performing the initial 
build. 

schedule the EIS datafile build to begin on 
a different day of the week 

Schedule 
The Phantom Scheduler screen displays. 

 

4. Press F12 to exit the screen. 
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Updating EIS Sales and Purchasing Transactions 
This function runs nightly during the scheduled hours for the datafile build. When finished, it has 
gathered all the information up to the previous day's business. We recommend that you run this 
program daily. 

To update EIS sales transactions: 

1. From the Reprts > Eclipse Information System (EIS) > EIS Sales/Purchases menu, 
select EIS Incremental Sales/Purchases to display the Update EIS Sales Transactions 
screen. 

2. Do one of the following: 

To... Use this hot key... 
begin building the EIS datafile now Begin Now 

schedule the EIS datafile build to begin at a 
future date or time 

Schedule 
The Phantom Scheduler screen displays. 

 

The system exits the screen. 
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Stopping the EIS Sales/Purchases Build 
This function allows you to make a clean exit from the datafile build. Use it before you reboot 
your system. 

To stop an EIS sales/purchases build: 

1. From the Reprts > Eclipse Information System (EIS) > EIS Sales/Purchases menu, 
select Stop EIS Sales Build to display the Stop EIS Sales Build screen. 

2. Use the Proceed hot key to stop the sales build. 

3. At the EIS Sales build set to stop the next time it starts message, press Enter to exit 
the screen. 

See Also: 

Restarting a Stopped EIS Sales/Purchases Build 
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Restarting a Stopped EIS Sales/Purchases Build 
This function allows you to restart a datafile build that was stopped in error. 

To restart a stopped sales/purchases build: 

1. From the Reprts > Eclipse Information System (EIS) > EIS Sales/Purchases menu, 
select Stop EIS Sales Build to display the Stop EIS Sales Build screen. 

2. Use the Cancel hot key to cancel the stop build request. 

3. At the Request to stop EIS Sales build has been cancelled message, press Enter to exit 
the screen. 

See Also: 

Stopping the EIS Sales/Purchases Build 
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Creating EIS Graphs 
After you set up your system to work with graphs, use the Eclipse Information System screen to 
select the type of information you want to your graphs to display and to choose the format for 
your graphs. The graphs are created using the EGraph application. 

A number of customer, pricing, and product categories must be in use to optimize the 
functionality available in this program and the related management inquiries. See Setup 
Requirements for the Eclipse Information System. 

To create an EIS graph: 

1. From the Reprts > Eclipse Information System (EIS) menu, select Eclipse 
Information System to display the Eclipse Information System screen. 

2. In the Br/Tr/ALL field, enter the branches or territories for which to select data. Enter 
commas between codes. To select data for all branches, enter ALL. 

3. Change the information in any of the following fields, as needed: 

To change the 
value in this 
field... 

Use this hot key... 

Br/Tr/ALL Branch 
The cursor moves to the Br/Tr/ALL field. Type the new branch or territory 
codes and press Enter to update. 

As of Date Date 
The cursor moves to the As of Date field. Type the date as of which to graph 
sales or purchasing data and press Enter to update. 

Detail Detail 
The cursor moves to the Detail field. Type the size of the data sample to 
include on the graph and press Enter to update. The default is 10. 
For example, if you want to view data for the top five bill-to customers only, 
enter 5. If you select a bar graph, five bars will display on the graph. If it is a 
comparison graph, ten bars will display on the graph, grouped in twos, each bar 
representing the specified periods to compare. 
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To change the 
value in this 
field... 

Use this hot key... 

Transactions Trans 
The Transactions selection list displays. Select one of the following values to 
determine the type of sales data to display on the graph: 
• Net Stock&Direct – Shows sales after taxes for all stock and direct orders. 
• All – Shows stock and direct sales before taxes, less any item returns. 

Note: Because miscellaneous charge items have no cost associated with them, 
they tend to artificially distort the profit margin upward. For this reason, they 
are excluded from the calculations. 

• Stock&Direct Sales – Shows sales before taxes for all stock and direct 
orders. 

• Stock Sales – Shows sales before taxes for orders shipped from your 
inventory to the customer. 

• Direct Sales – Shows sales before taxes for orders shipped from the vendor's 
inventory to the customer. 

• Misc Sales – Shows sales before taxes for miscellaneous charges such as 
restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for returned stock 
and direct items. 

• Stock Returns – Shows negative dollar amounts for items returned by the 
customer to your inventory. 

• Direct Returns – Shows negative dollar amounts for items returned by the 
customer to the vendor's inventory. 

• Misc Returns – Shows negative dollar amounts for miscellaneous charges 
credited to the customer. 

• Net Stock – Shows sales after taxes for orders shipped from your inventory 
to the customer. 

• Net Direct – Shows sales after taxes for orders shipped from the vendor's 
inventory to the customer. 

• Net Misc – Shows sales after taxes for miscellaneous charges such as 
restocking fees or labor charges. 

Sortby Sortby 
The Sortby selection list displays. To show the highest dollar values first, select 
Descending; otherwise, select Ascending. 
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To change the 
value in this 
field... 

Use this hot key... 

Period Period 
The Period selection list displays. Select one of the following values to 
determine what type of period detail to display on the graph: 
• Last 12 Months – Shows data for the twelve months preceding the date you 

entered in the As Of Date field in the Solar EIS window. 
• Year To Date – Shows data for the months from the beginning of the current 

calendar year through the date you entered in the As Of Date field. 
• Last12-Prior12 Months – Shows data for the twelve months preceding the 

date you entered in the As Of Date field in the Solar EIS window and the 
twelve months before that. 

• This Year-Last Year – Shows a side-by side sales comparison of sales or 
purchases made as of the date you entered in the As Of Date field in the 
Solar EIS window and the same date a year before that, shown with this 
year's data displaying first. 

• Last Year-This Year – Shows a side-by side sales comparison of sales or 
purchases made as of the date you entered in the As Of Date field in the 
Solar EIS window and the same date a year before that, shown with the 
previous year's data displaying first. 

• Last 4 Quarters – Shows data for the four quarters preceding the date you 
entered in the As Of Date field in the Solar EIS window. 

• Fiscal Month – Shows data for the month specified in the As Of Date field. 
• This Month-Last Month – Shows a side-by-side comparison of sales or 

purchases made this month and last month. 
• This Month-Same Month – Shows a side-by-side comparison of sales or 

purchases made this month and the same month last year. 

Graph Data Graph Data 
The EIS Sales Graph Data screen displays.  

 

4. In the Graph Groups area, click one of the following to determine which type of 
statistics to graph: 

• Sales  

• Purchases  

5. If you selected Sales, to add or change the value in the Graph Data field, click it or use 
the Graph Data hot key to display the EIS Sales Graph Data screen. Select the sales, 
cost, and gross profit data to display on the graph. 

Note: If you selected Purchases, the only valid value is Purchases $. 
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6. Do one of the following: 

If you selected... Do this... 
Sales Click one of the following values: 

• All Sales – Shows all sales for the selected period as of the selected date. 
• Parent Customer – Shows sales from any customer that either has multiple 

billing and shipment addresses or that receives all bills and shipments at the 
same location. 

• Billto Customer – Shows sales from any customer that remits payment for 
multiple shipment addresses. 

• Shipto Customer – Shows sales for shipment addresses. 
• Customer Type – Shows sales according to the customers' type of business, 

such as plumbing or electrical. 
• Customer Select Code – Shows sales according to the customers' industry 

segment. 
• Inside Salesperson – Shows sales credited to the sales representative 

responsible for generating subsequent sales for the customer. 
• Outside Salesperson – Shows sales credited to the sales representative 

responsible for acquiring new customers. 
• Writer – Shows sales generated by the employee who wrote the sales orders. 
• Sales Source – Shows sales by the location or origination point of the sale, 

for example, inside sales, counter sales, or showroom sales. 
• Ship Via – Shows sales based on the method used to transport the items to 

the customer. 

Purchases Click one of the following values: 
• All Purchases – Shows all purchases for the selected period as of the selected 

date. 
• Payto Vendor – Shows purchases from any vendor to whom you remit 

payments for purchases made from multiple shipment addresses. 
• Shipfrom Vendor – Shows purchases from vendor shipment addresses. 
• Vendor Type – Shows purchases according to the vendors' type of business, 

such as plumbing or electrical. 
• Writer – Shows purchases based on the employee who wrote the purchase 

order. 
• Ship Via – Shows purchases based on the method used to transport the items 

from the vendor. 
• Buy Line – Shows purchases based on the buy line of the products. 
• Buy Group – Shows purchases based on the costing rules for the products. 
• Price Line – Shows purchases based on the price line of the products. 
• Sell Group – Shows purchases based on the pricing rules set for the products. 
• GL Type – Shows purchases based on the product category, such as 

electrical or plumbing. 

 

The system launches the EGraph application and displays the requested data. 

7. When you have finished creating graphs, press Esc to exit the screen. 
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Selecting EIS Graph Revenue and Cost Options 
Before you create a graph, you may want to select a specific type of revenue or cost to display in 
it. Use the EIS Sales Graph Data screen to select the type of dollar amounts or percentages for 
which to view graph data. 

To select EIS graph revenue and cost options: 

1. From the Reprts > Eclipse Information System menu, select Eclipse Information 
System to display the Solar EIS screen. 

2. Select the initial graph parameters. 

3. Use the Graph Data hot key to display the EIS Sales Graph Data screen. 

4. Do any of the following, as needed: 

To... Do this... 
clear the values from the Graph Data 
area 

Use the Clear hot key. 

add revenue or cost types to the Graph 
Data area 

Use any of the following hot keys: 
• Sales $ – Shows the dollar amount of the sales generated. 
• COGS $ – Shows the cost of goods sold. 
• COGS GP$ – Shows the amount of profit your company 

receives, based on the cost of goods sold. 
• COGS GP% – Shows the percentage of the sales dollars 

generated that your company has received as profit, 
based on the cost of goods sold. 

• Comm $ – Shows the dollar amount of the cost used to 
calculate commissions. 

• Comm GP$ – Shows the amount of profit your company 
receives, based on the commission cost. 

• Comm GP% – Shows the percentage of the sales dollars 
generated that your company has received as profit, 
based on the commission cost. 

clear a specific revenue or cost type from 
the Graph Data area 

Use the hot key that corresponds to the type of revenue or 
cost. 
For example, to remove the cost of goods sold dollar 
amount value, use the COGS $ hot key. 

save the selected values Use the Save hot key or press Esc. 
The system returns you to the Eclipse Information System 
screen and populates the Graph Data field with your 
selections. 
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Management Inquiries Overview 
Use EIS management inquiries to view high-level management information and track critical 
distribution data. In addition, you can monitor sales trends month over month, quarter over 
quarter, and year over year so that you can better forecast your inventory levels. These inquiries 
provide a real-time snapshot of your business without you having to build and compile individual 
reports. 

The following inquiries are available: 

• Monthly Sales Inquiry 

• Monthly Sales Type Inquiry 

• Branch Manager Sales Inquiry 

• Salesperson Sales Inquiry 

• Sales Category Inquiry 

• Price Line Sales Inquiry 

• Customer/Price Line Inquiry 
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Viewing Summarized Financial Information 
To view summarized financial information for one or more branches or territories within your 
company, run the Branch Summary Inquiry. You can review your total sales, accounts 
receivable, accounts payable, purchases, and inventory as of a specific date. This inquiry gives 
you the total picture of how your business is doing. 

To view only sales information, run the Branch Sales Inquiry. This inquiry compiles more 
quickly because it does not include accounting or inventory statistics. 

To view a summary of a branch's financial information: 

1. From the Reprts > Management Inquiries menu, select Branch Summary Inquiry to 
display the Branch Summary Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view financial information. Enter commas between codes. To view financial 
information for all branches, enter ALL. 

3. In the Bookings field, enter one of the following values: 

• Original – Shows the totals for all sales orders written during the specified period. 
This includes orders that were bids only. 

Note: This total may also include amounts entered in error. For example, if the sales 
representative entered a price of $10000, but meant to enter $100.00, the $10,000 
amount is reflected in the original booking total, even if the sales representative later 
corrects the total to be $100.00. 

• Net – Shows the totals for all sales orders written during the specified period, 
including any adjustments made to those orders since they were first written. 

4. In the As of Date field, enter the date as of which to view financial information. 

5. With the cursor in the As of Date field, press Enter to display financial information 
based on your selection criteria. 

Note: You can view the progress of the data compilation on the status bar. 
Compiling may take a few minutes. 
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6. Review the following information for each order type: 

Column Description 
Order Type The types of orders for which to view dollar amounts and gross profit: 

• Warehouse – Shows the totals for orders shipped from the selected branch's 
warehouse. 

• Credits – Shows the totals for credits issued against orders shipped from the 
selected branch's warehouse. 

• Directs – Shows the totals for orders written at the selected branch but 
shipped from a vendor's warehouse. 

• Dir Credit – Shows the totals for credits issued against orders written at the 
selected branch but shipped from a vendor's warehouse. 

• TOTAL – The total amounts for all categories by column. 

MTD Booked$ The total dollar amount of all sales orders written during the specified period. 
This shows all items ever entered on an order even if the price was changed or 
the order was canceled. 

GP % The percentage of the total dollar amount the selected branch would receive as 
gross profit during the specified period if all written sales orders were invoiced. 

Sales $ The total dollar amount of all sales orders actually invoiced or shipped during 
the specified period. 

GP $ The total dollar amount the selected branch receives as profit from all sales 
orders actually invoiced or shipped during the specified period. 

GP % The percentage of the total dollar amount the selected branch receives as gross 
profit during the specified period for all sales orders invoiced or shipped during 
the specified period. 

Open $ The total dollar amount of all open sales orders, not only those that have not 
been shipped as of the specified date. 

GP % The percentage of the total dollar amount the selected branch would receive as 
gross profit during the specified period if all open sales orders were invoiced. 

 

7. In the Accounts Receivable area, review the following information, as needed: 

Field Description 
Open The total dollar amount of all invoiced sales orders. 

Cash Receipts The total dollar amount of all payments received. 

Inv to print The total dollar amount of sales orders that have not been billed to the customer. 

 

8. In the Accounts Payable area, review the following information, as needed: 

Field Description 
Open The total dollar amount of invoices that have not yet been paid. 

Unbilled The total dollar amount owed to vendors for purchases the branch has made for 
which you have not yet been billed. 
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Field Description 
TOTAL The total dollar amount of all accounts payable, including both open and 

unbilled payables. 

 

9. In the Open Purchases area, review the following information, as needed: 

Field Description 
Whse The total dollar amount owed to vendors for orders received at the selected 

branch's warehouse. 

Dir The total dollar amount owed to vendors for orders written at the selected 
branch but shipped from a vendor's warehouse. 

Ret The total dollar amount of purchases made at the selected branch that were 
returned to the vendor for credit. 

TOT The total dollar amount of open warehouse and direct shipment purchases, 
minus returns. 

 

10. In the Inventory Valuation area, review the following information, as needed: 

Field Description 
G/L The general ledger balance for the selected branch's inventory. 

Avg The total value of all items in the selected branch's inventory, based on the average 
cost paid for each item. 

Dflt The value of all items in the branch's inventory, based on replacement cost. 

Last The value of the selected branch's inventory, based on the last price paid for the 
items. 

COGS The dollar amount of your cost of goods sold. 

 

11. When you have finished reviewing information, press Esc to exit the screen. 

See Also: 
Management Inquiries Overview 
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Viewing Branch Sales Information 
To view sales information for one or more branch locations, run the Branch Sales Inquiry. You 
can view the totals for all sales orders written, invoiced, or open, and compare sales between 
branches. 

To view sales information by branch: 

1. From the Reprts > Management Inquiries menu, select Branch Sales Inquiry to 
display the Branch Sales Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales information. Enter commas between codes. To view sales information for 
all branches, enter ALL. 

3. In the Month field, enter the first three letters of the month for which to view sales 
information. 

4. In the Year field, enter the year for which to view sales information. 

5. With the cursor in the Year field, press Enter to display sales information based on your 
selection criteria. 

6. Review the following information for each branch, as needed: 

Column Description 
Branch The name of the pricing branch for which to view sales data. 

Booked $ The total dollar amount of all sales orders written, including any adjustments made 
to those orders since they were first written. 

<Booked>GP % The percentage of the total dollar amount the branch would receive as gross profit 
if all written sales orders were invoiced. 

Sales $ The total dollar amount of all sales orders invoiced or shipped. 

<Sales> GP $ The total dollar amount the selected branch receives as profit from all sales orders 
actually invoiced or shipped. 

<Sales> GP 
% 

The percentage of the total dollar amount the selected branch receives as gross 
profit for all sales orders actually invoiced or shipped. 

Open $ The total dollar amount of all open sales orders, not only those that have not been 
shipped. 

<Open> GP 
% 

The percentage of the total dollar amount the selected branch would receive as 
gross profit if all open sales orders were invoiced. 

 

7. When you have finished reviewing information, press Esc to exit the screen. 
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More Options for Working With Sales Information 

The Branch Sales Inquiry window also offers these options: 

To... Select this menu option... 
view a graphical representation of the data on the 
table 

File > Create Graph 
The Graph Options for Branch Sales Inquiry 
dialog box displays. 

export the data to an Excel spreadsheet File > Save as Excel 
The Save dialog box displays. 

print the table File > Print Table 
The Print Table dialog box displays. 

See Also: 
Management Inquiries Overview 

Viewing Summarized Financial Information 
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Comparing Yearly Sales by Month 
To compare this year's sales and gross profit to last year's sales and gross profit on a month-by-
month basis, run the Monthly Sales Inquiry. This inquiry also shows you the percentage of 
increase or decrease in sales year over year. 

To compare yearly sales by month: 

1. From the Reprts > Management Inquiries menu, select Monthly Sales Inquiry to 
display the Monthly Sales Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales and gross profit data. Enter commas between codes. To view data for all 
branches, enter ALL. 

3. In the Date field, enter the date as of which to view the sales data. The default is today's 
date. 

4. In the Sales Type field, enter one of the following values to determine the type of sales 
data to view: 

• Net Stock&Direct – Shows sales and profit after taxes for all stock and direct orders. 

• All – Shows stock and direct sales and profit before taxes, less any item returns. 

Note: Because miscellaneous charge items have no cost associated with them, 
they tend to artificially distort the profit margin upward. For this reason, 
they are excluded from the calculations. 

• Stock&Direct Sales – Shows sales and profit before taxes for all stock and direct 
orders. 

• Stock Sales – Shows sales and profit before taxes for orders shipped from your 
inventory to the customer. 

• Direct Sales – Shows sales and profit before taxes for orders shipped from the 
vendor's inventory to the customer. 

• Misc Sales – Shows sales and profit before taxes for miscellaneous charges such as 
restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for returned stock and 
direct items. 

• Stock Returns – Shows negative dollar amounts for items returned by the customer 
to your inventory. 

• Direct Returns – Shows negative dollar amounts for items returned by the customer 
to the vendor's inventory. 

• Misc Returns – Shows negative dollar amounts for miscellaneous charges credited to 
the customer. 



Eclipse Information System Rel. 8.6.2 (Eterm) 

20 © 2007  Activant Solutions Inc. All rights reserved. 

• Net Stock – Shows sales and profit after taxes for orders shipped from your inventory 
to the customer. 

• Net Direct – Shows sales and profit after taxes for orders shipped from the vendor's 
inventory to the customer. 

• Net Misc – Shows sales and profit after taxes for miscellaneous charges such as 
restocking fees or labor charges. 

5. In the Period field, enter one of the following values: 

• Last 13 – Shows sales data for the thirteen months preceding the date you entered in 
the Date field. 

• Last 12 – Shows sales data for the twelve months preceding the date you entered in 
the Date field. 

• Fiscal YTD – Shows sales data for the months from the beginning of the current 
fiscal year through the date you entered in the Date field. 

6. With the cursor in the Period field, press Enter to display sales and gross profit data 
based on your selection criteria. 

7. Review the following information for each month, as needed: 

Column Description 
Month The month and year for which to view sales data. 

For example, OCT 06 indicates that you are viewing data for the month of October 
in the year 2006. 

Sales The total net or gross sales generated during the selected month, or the total dollar 
amount for returned goods. 

GP The amount of gross or net profit received for sales generated during the selected 
month, or the amount of profit lost from returned goods. 

GP% The percentage of the sales your company receives as gross or net profit, or the 
percentage lost from returned goods. 

Prior Sales The gross or net sales generated during the selected month in the prior year. 

Prior GP The amount of gross or net profit received during the selected month in the prior 
year. 

P GP% The percentage of the sales generated during the selected month in the prior year that 
the company received as gross or net profit. 

% Chng The percentage sales increased or decreased from the previous year to the current 
year for the selected month. 

 

8. When you have finished viewing information, press Esc to exit the screen. 
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More Options for Working With Sales Information 

The Monthly Sales Inquiry screen also offers these options: 

To... Use this hot key... 
change the branch or territory code Branch 

The cursor moves to the Br/Tr/ALL field. Type 
the new value and press Enter to update the 
screen. 

change the date as of which to view the sales 
information 

Date 
The cursor moves to the Date field. Type the new 
value and press Enter to update the screen. 

change the sales type Sales Type 
The Sales Type selection list displays. Select the 
new value and press Enter to update the screen. 

change the period over which to view sales 
information 

Period 
The Period selection list displays. Select the new 
value and press Enter to update the screen. 

See Also: 

Management Inquiries Overview 

Comparing Stock and Direct Monthly Sales 
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Comparing Stock and Direct Monthly Sales 
To compare monthly sales and profits for stock orders against direct shipment orders, run the 
Monthly Sales Type Inquiry. You can view statistics for sales, returns, or sales less returns as of 
a specific date. You can quickly compare month-to-month sales and monitor seasonal sales and 
different types of sales. 

To compare monthly sales for stock orders against direct shipment orders: 

1. From the Reprts > Management Inquiries menu, select Monthly Sales Type Inquiry 
to display the Monthly Sales Type Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales and gross profit data. Enter commas between codes. To view data for all 
branches, enter ALL. 

3. In the Date field, enter the date as of which to view the sales data. The default is today's 
date. 

4. In the Sales Type field, enter one of the following values: 

• All –  Shows data for sales less returns. 

• Sales – Shows data for sales only. 

• Returns – Shows data for returned goods only. 

5. In the Period field, enter one of the following values: 

• Last 13 – Shows sales data for the thirteen months preceding the date you entered in 
the Date field. 

• Last 12 – Shows sales data for the twelve months preceding the date you entered in 
the Date field. 

• Fiscal YTD – Shows sales data for the months from the beginning of the current 
fiscal year through the date you entered in the Date field. 

6. With the cursor in the Period field, press Enter to display sales and gross profit data for 
stock and direct orders based on your selection criteria. 

7. For each month, review the following information: 

Column Description 
Month The name of the month in which the sales occurred. 

Stock The total sales for the selected month of items shipped from your inventory. 

S GP% The percentage of the total dollar amount the selected branch receives as gross profit for 
all stock sales orders invoiced or shipped. 

% Sls The percentage of the monthly sales received from stock sales orders. 

Direct The total sales for the selected month of items written at the selected branch but shipped 
from a vendor's warehouse. 
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Column Description 
D GP% The percentage of the total dollar amount the selected branch receives as gross profit for 

all direct sales orders invoiced or shipped. 

% Sls The percentage of the monthly sales received from direct sales orders. 

 

8. When you have finished viewing information, press Esc to exit the screen. 

More Options for Working With Sales Information 

The Monthly Sales Type Inquiry screen also offers these options: 

To... Use this hot key... 
change the branch or territory code Branch 

The cursor moves to the Br/Tr/ALL field. Type 
the new value and press Enter to update the 
screen. 

change the date as of which to view the sales 
information 

Date 
The cursor moves to the Date field. Type the new 
value and press Enter to update the screen. 

change the sales type Sales Type 
The Sales Type selection list displays. Select the 
new value and press Enter to update the screen. 

change the period over which to view sales 
information 

Period 
The Period selection list displays. Select the new 
value and press Enter to update the screen. 

See Also: 
Management Inquiries Overview 

Monthly Sales Inquiry 
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Viewing Monthly Sales Trends by Branch 
To view the monthly sales for one or more branches over a specific period, run the Branch 
Manager Sales Inquiry. This inquiry shows the total sales for each month, along with the amount 
of profit received, both by dollar amount and percentage of sales. In addition, it shows how much 
of the total revenue for the period was earned during each month. This helps you to determine 
trends so that you can better plan to increase or decrease inventory levels to coincide with typical 
demand. 

To view monthly sales for one or more branches: 

1. From the Reprts > Management Inquiries menu, select Branch Manager Sales 
Inquiry to display the Branch Manager Sales Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales and gross profit data. Enter commas between codes. To view data for all 
branches, enter ALL. 

3. In the Date field, enter the date as of which to view the sales data. The default is today's 
date. 

4. In the Sales Type field, enter one of the following values to determine the type of sales 
data to view: 

• All – Shows stock and direct sales and profit before taxes, less any item returns. 

Note: Because miscellaneous charge items have no cost associated with them, 
they tend to artificially distort the profit margin upward. For this reason, 
they are excluded from the calculations. 

• Stock&Direct Sales – Shows sales and profit before taxes for all stock and direct 
orders. 

• Stock Sales – Shows sales and profit before taxes for orders shipped from your 
inventory to the customer. 

• Direct Sales – Shows sales and profit before taxes for orders shipped from the 
vendor's inventory to the customer. 

• Misc Sales – Shows sales and profit before taxes for miscellaneous charges such as 
restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for returned stock and 
direct items. 

• Stock Returns – Shows negative dollar amounts for items returned by the customer 
to your inventory. 

• Direct Returns – Shows negative dollar amounts for items returned by the customer 
to the vendor's inventory. 
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• Misc Returns – Shows negative dollar amounts for miscellaneous charges credited to 
the customer. 

5. In the Period field, enter one of the following values: 

• Last 13 – Shows sales data for the thirteen months preceding the date you entered in 
the Date field. 

• Last 12 – Shows sales data for the twelve months preceding the date you entered in 
the Date field. 

• Fiscal YTD – Shows sales data for the months from the beginning of the current 
fiscal year through the date you entered in the Date field. 

6. With the cursor in the Period field, press Enter to display sales and gross profit data 
based on your selection criteria. 

7. Review the following information for each month, as needed: 

Column Description 
Month The name of the month in which the sales occurred. 

Sales The dollar amount of the revenue received for products or services. 

Gross Profit The dollar amount of the revenue received as profit. 

GP% The percentage of the revenue your company received as profit. 

% Total 
Sales 

The percentage of the total revenue received that was received during the selected 
month. 

 

8. When you have finished viewing information, press Esc to exit the screen. 

More Options for Working With Sales Information 

The Branch Manager Sales Inquiry screen also offers these options: 

To... Use this hot key... 
change the branch or territory code Branch 

The cursor moves to the Br/Tr/ALL field. Type 
the new value and press Enter to update the 
screen. 

change the date as of which to view the sales 
information 

Date 
The cursor moves to the Date field. Type the new 
value and press Enter to update the screen. 

change the sales type Sales Type 
The Sales Type selection list displays. Select the 
new value and press Enter to update the screen. 

change the period over which to view sales 
information 

Period 
The Period selection list displays. Select the new 
value and press Enter to update the screen. 



Eclipse Information System Rel. 8.6.2 (Eterm) 

26 © 2007  Activant Solutions Inc. All rights reserved. 

See Also: 

Management Inquiries Overview 
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Viewing Sales by Sales Representative 
To compare how your sales representatives are performing over a specified period, run the 
Salesperson Sales Inquiry. This inquiry shows the total sales dollars and gross profit percentages 
for each sales representative, and splits out the stock and direct ship sales so that you can see 
how the sales representatives are doing with each type. 

To view sales for individual sales representatives: 

1. From the Reprts > Management Inquiries menu, select Salesperson Sales Inquiry to 
display the Salesperson Sales Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales data. Enter commas between codes. To view data for all branches, enter 
ALL. 

3. In the Date field, enter the date as of which to view the sales data. The default is today's 
date. 

4. In the Sales Type field, enter one of the following values: 

• All –  Shows data for sales less returns. 

• Sales – Shows data for sales only. 

• Returns – Shows data for returned goods only. 

5. In the Period field, enter one of the following values: 

• Month – Shows sales data for the month you entered in the Date field. 

• Last 12 – Shows sales data for the twelve months preceding the date you entered in 
the Date field. 

• Fiscal YTD – Shows sales data for the months from the beginning of the current 
fiscal year through the date you entered in the Date field. 

6. In the Salesperson field, enter one of the following values: 

• Outside – Shows sales data for the outside sales representatives. 

• Inside – Shows sales data for the inside sales representatives. 

• Writer – Shows the sales generated by the employee who wrote the sales orders. 

7. In the Sort field, enter the column name by which to sort the information. Valid values 
include: 

• Person – Sorts alphabetically from A to Z by the sales representative's first name. 

• Stock – Sorts from highest dollar amount to lowest. 

• Direct – Sorts from highest dollar amount to lowest. 

• Total – Sorts from highest dollar amount to lowest. 
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8. With the cursor in the Sort field, press Enter to display sales and gross profit data for 
stock and direct orders based on your selection criteria. 

9. For each sales representative, view the information in the following columns: 

Column Description 
Salesperson The name of the employee who receives a commission for the sale. 

Stock The dollar amount of items for which the sales representative receives a commission 
that shipped from the branch's warehouse. 

S GP% The percentage of the dollar amount your company receives as profit for goods shipped 
from the branch's warehouse. 

Direct The dollar amount of items for which the sales representative receives a commission 
that shipped from the vendor to your customer. 

D GP% The percentage of the dollar amount your company receives as profit for goods shipped 
from the vendor to your customer. 

Total The total dollar amount of stock and direct ship items for which the sales representative 
receives a commission. 

T GP% The percentage of the total dollar amount your company receives as profit for stock and 
direct ship items sold. 

 

10. When you have finished viewing information, press Esc to exit the screen. 

More Options for Working With Sales Information 

The Salesperson Sales Inquiry screen also offers these options: 

To... Use this hot key... 
change the branch or territory code Branch 

The cursor moves to the Br/Tr/ALL field. Type 
the new value and press Enter to update the 
screen. 

change the date as of which to view the sales 
information 

Date 
The cursor moves to the Date field. Type the new 
value and press Enter to update the screen. 

change the sales type Sales Type 
The Sales Type selection list displays. Select the 
new value and press Enter to update the screen. 

change the period over which to view sales 
information 

Period 
The Period selection list displays. Select the new 
value and press Enter to update the screen. 

change the type of sales representative for which 
to review sales 

Salesperson 
The Salesperson selection list displays. Select the 
new value and press Enter to update the screen. 

change the primary column on which to sort the 
information 

Sort 
The Sort selection list displays. Select the new 
value and press Enter to update the screen. 
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See Also: 

Management Inquiries Overview 

Sales Category Inquiry 
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Viewing Sales Information by Category 
To view sales data by category types, run the Sales Category Inquiry. You can view sales in a 
number of different ways, such as customer type, by sales representative, or by a variety of 
different product selection methods. You can view revenue, costs, gross profit dollars, or gross 
profit percentages. In addition, you can compare any of these values between months, quarters, 
or years to help you analyze the growth or decline of various markets. 

To view sales information for a specific category: 

1. From the Reprts > Management Inquiries menu, select Sales Category Inquiry to 
display the Sales Category Inquiry screen. 

2. In the Br/Tr/ALL field, enter the codes that identify the branches or territories for which 
to view sales and gross profit data. Enter commas between codes. To view data for all 
branches, enter ALL. 

3. In the Date field, enter the date as of which to view the sales data. The default is today's 
date. 

4. In the Category field, enter one of the following values: 

• Parent Customer – Shows sales from any customer that either has multiple billing 
and shipment addresses or that receives all bills and shipments at the same location. 

• Billto Customer – Shows sales from any customer that remits payment for multiple 
shipment addresses. 

• Shipto Customer – Shows sales for shipment addresses. 

• Customer Type – Shows sales according to the customers' type of business, such as 
plumbing or electrical. 

• Customer Select Code – Shows sales according to the customers' industry segment. 

• Outside Salesperson – Shows sales credited to the sales representative responsible 
for acquiring new customers. 

• Inside Salesperson – Shows sales credited to the sales representative responsible for 
generating subsequent sales for the customer. 

• Writer – Shows sales generated by the employee who wrote the sales orders. 

• Sales Source – Shows sales by the location or origination point of the sale, for 
example, inside sales, counter sales, or showroom sales. 

• Ship Via – Shows sales based on the method used to transport the items to the 
customer. 

• Price Line – Shows sales based on the price line of the products sold. 

• Sell Group – Shows sales based on the pricing rules set for the products sold. 

• Buy Line – Shows sales based on the buy line of the products sold. 
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• Buy Group – Shows sales based on the costing rules for the products sold. 

• Product GL Type – Shows sales based on the product category, such as electrical or 
plumbing. 

• Product Select Code – Shows sales based on a user-defined product selection code. 

• Product Status – Shows sales based on the inventory status of the products, such as 
stock, nonstock, miscellaneous charge, or lot item. 

• Commodity Code – Shows sales based on the material type or commodity 
classification. 

• Product Budget Group – Shows sales based on the sales budget group of the 
products sold. 

5. In the Display field, enter one of the following values: 

• Sales $ – Shows the dollar amount of the sales generated. 

• COGS $ – Shows the cost of goods sold. 

• COGS GP$ – Shows the amount of profit your company receives, based on the cost 
of goods sold. 

• COGS GP% – Shows the percentage of the sales dollars generated that your 
company has received as profit, based on the cost of goods sold. 

• Comm $ – Shows the dollar amount of the cost used to calculate commissions. 

• Comm GP$ – Shows the amount of profit your company receives, based on the 
commission cost. 

• Comm GP% – Shows the percentage of the sales dollars generated that your 
company has received as profit, based on the commission cost. 

6. In the Columns field, select one of the following column views: 

• Month/YTD/LYTD/% Chg 

• YTD/LYTD/% Chg 

• Last 12/Prior 12/% Chg 

• Month/Prior Mth/% Chg 

• Month/Month LY/% Chg 

• Quarter/Prior Qtr/% Chg 

• Quarter/Qtr LY/% Chg 

7. In the Sort Column field, enter the column by which to sort the information. 

Note: Selections vary depending on the value selected in the Columns field. 

8. In the Sales Type field, enter one of the following values to determine the type of sales 
data to view: 
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• Net Stock&Direct – Shows sales and profit after taxes for all stock and direct orders. 

• All – Shows stock and direct sales and profit before taxes, less any item returns. 

Note: Because miscellaneous charge items have no cost associated with them, 
they tend to artificially distort the profit margin upward. For this reason, 
they are excluded from the calculations. 

• Stock&Direct Sales – Shows sales and profit before taxes for all stock and direct 
orders. 

• Stock Sales – Shows sales and profit before taxes for orders shipped from your 
inventory to the customer. 

• Direct Sales – Shows sales and profit before taxes for orders shipped from the 
vendor's inventory to the customer. 

• Misc Sales – Shows sales and profit before taxes for miscellaneous charges such as 
restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for returned stock and 
direct items. 

• Stock Returns – Shows negative dollar amounts for items returned by the customer 
to your inventory. 

• Direct Returns – Shows negative dollar amounts for items returned by the customer 
to the vendor's inventory. 

• Misc Returns – Shows negative dollar amounts for miscellaneous charges credited to 
the customer. 

• Net Stock – Shows sales and profit after taxes for orders shipped from your inventory 
to the customer. 

• Net Direct – Shows sales and profit after taxes for orders shipped from the vendor's 
inventory to the customer. 

• Net Misc – Shows sales and profit after taxes for miscellaneous charges such as 
restocking fees or labor charges. 

9. In the Sort Order field, to sort from lowest value to highest, enter Ascending; otherwise, 
enter Descending. 

10. With the cursor in the Sort Order field, press Enter to display sales data based on your 
selection criteria. 

11. Review sales information based on the value selected in the Columns field. 

12. When you have finished viewing information, press Esc to exit the screen. 
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More Options for Working With Sales Information 

The Sales Category Inquiry window also offers these options: 

To... Use this hot key... 
change the branch or territory code Branch 

The cursor moves to the Br/Tr/ALL field. Type 
the new value and press Enter to update the 
screen. 

change the date as of which to view the sales 
information 

Date 
The cursor moves to the Date field. Type the new 
value and press Enter to update the screen. 

change the sales category Category 
The Category selection list displays. Select the 
new value and press Enter to update the screen. 

change the type of price or cost information that 
displays 

Display 
The Display selection list displays. Select the new 
value and press Enter to update the screen. 

change to a different column view Columns 
The Columns selection list displays. Select the 
new value and press Enter. 
If your selection in the Sort Column field no 
longer applies, the Sort Column selection list 
displays. Select a new value and press Enter to 
update the screen. 

change the primary sort column Sort C 
The Sort Column selection list displays. Select 
the new value and press Enter to update the 
screen. 

change the sales type Sales Type 
The Sales Type selection list displays. Select the 
new value and press Enter to update the screen. 

change the sort order Sort O 
The Sort Order selection list displays. Select the 
new value and press Enter to update the screen. 

See Also: 

Management Inquiries Overview 

Comparing Monthly or Yearly Customer-Specific Sales 
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Comparing Monthly or Yearly Customer-Specific Sales 
To compare monthly and yearly sales for a specific customer, run the Customer/Price Line 
Inquiry. While the window name implies that the inquiry is specifically for price lines, you can 
also review sales for the customer by a variety of other categories as well, such as buy line, 
commodity code, or product status. You can use the inquiry to compare the customer's buying 
habits from month to month or year to year. You can also drill-down into the sales or inventory 
details for the customer, if needed. 

To compare sales figures for a specific customer: 

1. From the Reprts > Management Inquiries menu, select Customer/Price Line Inquiry 
to display the Customer/Price Line Inquiry screen. 

2. In the Br/Tr/All field, enter the codes that identify the branches or territories for which to 
view sales data. Enter commas between codes. To view data for all branches, enter ALL. 

3. In the Category field, enter one of the following values: 

• Price Line – Shows sales based on the price line of the products sold. 

• Buy Line – Shows sales based on the buy line of the products sold. 

• Sell Group – Shows sales based on the pricing rules set for the products sold. 

• Commodity Code – Shows sales based on the material type or commodity 
classification. 

• Select Code – Shows sales based on a user-defined product selection code. 

• Sales Type – Shows sales based on the category of product, such as electrical or 
plumbing. 

• Product Status – Shows sales based on the inventory status of the products, such as 
stock, nonstock, miscellaneous charge, or lot item. 

• Ship Via – Shows sales based on the method used to transport the items to the 
customer. 

• Sales Source – Shows sales by the location or origination point of the sale, for 
example, inside sales, counter sales, or showroom sales. 

4. In the Customer field, enter the name of the customer whose sales statistics you want to 
review. 

5. In the As Of Date field, enter the date as of which to view sales information. The default 
is today's date. 

6. With the cursor in the As Of Date field, press Enter to display sales information based 
on your selection criteria. 

7. Review the following information, as needed: 
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Note: The inquiry shows all sales less returns. To view only a certain type of 
sales, such as Net Direct, use the Sales Type hot key. 

Column Description 
<Category> The values associated with the category selected in the Category field. The system 

sorts the report in ascending order by this column. To sort by a different column, 
use the Sort hot key. 
Note: In most cases, the column name reflects only the second word in the 
category, such as Line to represent the price line or buy line. The only exception is 
the ship via, which displays as Ship Via. 

MTD$ Shows the sales generated for the month specified in the As Of Date field. 

<MTD GP%> Shows the percentage of the sales dollars your company received as profit for the 
month specified in the As Of Date field. 

LYMTD$ Shows the sales generated for the month specified in the As Of Date field, but in 
the previous year. 

<LYMTD 
GP%> 

Shows the percentage of the sales dollars your company received as profit for the 
month specified in the As Of Date field, but in the previous year. 

Diff% The percentage of increase or decrease in sales between the month you entered in 
the As Of Date field and the same month in the previous year. 

YTD$ Shows the sales generated for the year specified in the As Of Date field. 

<YTD GP%> Shows the percentage of the sales dollars your company received as profit for the 
year specified in the As Of Date field. 

LYTD$ Shows the sales generated for the year preceding the year specified in the As Of 
Date field. 

<LYTD GP%> Shows the percentage of the sales dollars your company received as profit for the 
year preceding the year specified in the As Of Date field. 

Diff% The percentage of increase or decrease in sales between the year you entered in the 
Date field and the previous year. 

 

8. When you have finished viewing information, press Esc to exit the screen. 

More Options for Working With Sales Information 

The Customer/Price Line Inquiry screen also offers these options: 

To... Use this hot key... 
view the results for a different 
date 

As Of Date 
At the Enter new date prompt, enter the numerical two-digit 
month and two-digit year and press Enter to update the screen. 
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To... Use this hot key... 
change the type of sales data that 
displays 

Sales Type 
The Sales Type selection list displays. Select one of the following 
values to determine the type of sales data to view: 
• All – Shows stock and direct sales before taxes, less any item 

returns. 

Note: Because miscellaneous charge items have no cost 
associated with them, they tend to artificially distort the profit 
margin upward. For this reason, they are excluded from the 
calculations. 

• Net Stock&Direct – Shows sales after taxes for all stock and 
direct orders. 

• Stock&Direct Sales – Shows sales before taxes for all stock 
and direct orders. 

• Stock Sales – Shows sales before taxes for orders shipped from 
your inventory to the customer. 

• Direct Sales – Shows sales before taxes for orders shipped 
from the vendor's inventory to the customer. 

• Misc Sales – Shows sales before taxes for miscellaneous 
charges such as restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for 
returned stock and direct items. 

• Stock Returns – Shows negative dollar amounts for items 
returned by the customer to your inventory. 

• Direct Returns – Shows negative dollar amounts for items 
returned by the customer to the vendor's inventory. 

• Misc Returns – Shows negative dollar amounts for 
miscellaneous charges credited to the customer. 

• Net Stock – Shows sales after taxes for orders shipped from 
your inventory to the customer. 

• Net Direct – Shows sales after taxes for orders shipped from 
the vendor's inventory to the customer. 

• Net Misc – Shows sales after taxes for miscellaneous charges 
such as restocking fees or labor charges. 

view the sales history for the 
selected customer 

Detail 
Select Sales History by Customer from the list to display the 
Sales History Summary by Customer screen. 

view the inventory history for the 
selected customer 

Detail 
Select Customer Inventory History Ledger from the list to 
display the Customer Inventory History Ledger screen. 

sort the inquiry by a different 
column 

Sort 
The Sort By selection list displays. Select a value to display the 
data by that value. Alphanumeric values sort alphabetically from 
A to Z, whereas numeric values sort from highest amount to 
lowest. 
Values vary based on the value entered in the Category field. 
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To... Use this hot key... 
change the sales category Category 

The Category selection list displays. Select a value and press 
Enter to update the screen. 

See Also: 
Management Inquiries Overview 

Viewing Sales Information by Category 

Comparing Yearly Sales by Price Line 
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Comparing Yearly Sales by Price Line 
To view the sales and gross profit generated during the year for a specific price line and compare 
the sales performance with other years, run the Price Line Sales Inquiry. This inquiry shows you 
a month-by-month picture of how much revenue you brought in, and tells you what your gross 
profit percentage was. In addition, you can determine how much more or less you made this year 
as opposed to the previous year. 

To compare this year's with last year's sales for a specific price line: 

1. From the Reprts > Management Inquiries menu, select Price Line Sales Inquiry to 
display the Price Line Sales Inquiry screen. 

2. In the Br/Tr/All field, enter the codes that identify the branches or territories for which to 
view sales and gross profit data. Enter commas between codes. To view data for all 
branches, enter ALL. 

3. In the Price Line field, enter the price line for which to view sales data. 

Note: Price lines are defined in the Price Line Maintenance window and assigned 
to products in Product Maintenance. 

4. With the cursor in the Price Line field, press Enter to display sales and profit data based 
on your selection criteria. 

5. Review the following information for each month, as needed: 

Column Description 
Month The month in which the sales activity occurred. 

Year <last year> Shows the sales generated for the year preceding the current year. For 
example, if the current year is 2007, this column displays sales generated 
during 2006. 

GP% Shows the percentage of the sales dollars your company received as profit for 
the year preceding the current year. 

Year <current 
year> 

Shows the sales generated for the current year. 

GP% Shows the percentage of the sales dollars your company received as profit for 
the current year. 

% Diff The percentage of increase or decrease in sales dollars between the previous 
year and the current year. 

 

6. When you have finished viewing information, press Esc to exit the screen. 
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More Options for Reviewing Sales Information 

The Price Line Sales Inquiry window also offers these options: 

To... Select this menu option... 
view sales generated during an 
earlier year 

< (Change Year) 

return to the current year 
information after viewing sales for 
an earlier year 

> (Change Year) 

change the type of sales data that 
displays 

Sales Type 
The Sales Type selection list displays. Select one of the 
following values to determine the type of sales data to view: 
• All – Shows stock and direct sales and profit before taxes, less 

any item returns. 

Note: Because miscellaneous charge items have no cost 
associated with them, they tend to artificially distort the profit 
margin upward. For this reason, they are excluded from the 
calculations. 

• Stock&Direct Sales – Shows sales and profit before taxes for 
all stock and direct orders. 

• Stock Sales – Shows sales and profit before taxes for orders 
shipped from your inventory to the customer. 

• Direct Sales – Shows sales and profit before taxes for orders 
shipped from the vendor's inventory to the customer. 

• Misc Sales – Shows sales and profit before taxes for 
miscellaneous charges such as restocking fees or labor charges. 

• Stock&Direct Returns – Shows negative dollar amounts for 
returned stock and direct items. 

• Stock Returns – Shows negative dollar amounts for items 
returned by the customer to your inventory. 

• Direct Returns – Shows negative dollar amounts for items 
returned by the customer to the vendor's inventory. 

• Misc Returns – Shows negative dollar amounts for 
miscellaneous charges credited to the customer. 

• Net Stock – Shows sales and profit after taxes for orders 
shipped from your inventory to the customer. 

• Net Direct – Shows sales and profit after taxes for orders 
shipped from the vendor's inventory to the customer. 

• Net Misc – Shows sales and profit after taxes for miscellaneous 
charges such as restocking fees or labor charges. 

See Also: 
Management Inquiries Overview 

Comparing Monthly or Yearly Customer-Specific Sales 
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EGraph Overview 
The EGraph application is an MS Windows®-based tool you will use to view or print the graphs 
you create using the character-based Eclipse Information System (EIS) application. You will 
select a series of graph options on the Eclipse Information System screen, and when you click 
the category for which to graph data, such as a bill-to customer, a pay-to vendor, a sales 
representative, a price line, or a sales source, the system creates a graph and displays it in the 
Eclipse Egraph window. 

This application can also be used to create graphs from the data on the Business Summary screen 
and the A/R Inquiry screen. 

Once you have displayed a graph, you can change its format. For example, if you would rather 
view the data as a pie chart instead of as a bar graph, you can click a button and EGraph changes 
the graph into a pie format. You can change the text style, color, and size to be consistent with a 
presentation you are giving. You can even drill down into a subset of the data and display it on 
the graph, if needed. 

Important: This help system assumes that you have a working knowledge of the 
Windows operating system. 

See Also: 
Setup Requirements for EGraph 
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Setup Requirements for EGraph 
The EGraph application is a companion to the Eclipse Information System (EIS) and must be 
installed on the computer of any employee who will create graphs from EIS. Your company 
should have received the EGraph executable file when EIS was installed on your system. If you 
did not, call Eclipse Technical Support to obtain a copy. 

See Also: 

EGraph Overview 
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Starting the Eclipse EGraph Application 
Before you can work with graphs, you must start the application. You can use any of the 
following three methods to do this: 

 

To start the Eclipse 
EGraph 
application from... 

Do this... 

Windows From the Start menu, select Programs > Eclipse > EGraph. 

ETerm Select graph options on the Eclipse Information System screen. When 
you select a value in the Sales Graphs or Purchases Graphs area, the 
system creates the graph and displays the Eclipse EGRAPH window. 

an EGraph graph (.grf 
extension) 

Double-click a file that has a .grf extension. This will not open the 
file, only the application. 

Note: The first time you do this, Windows will ask you to identify the 
program to use to open the graph. Click the Browse button, select the 
Eclipse folder under the Program Files folder, select the EGraph 
folder, and double-click egraph.exe to return to the Open With 
window. Select the Always use the selected program to open this 
kind of file check box, if needed, and click OK to display the Eclipse 
EGRAPH window. 

See Also: 
EGraph Overview 

Setup Requirements for EGraph 
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Saving Graphs 
After you create a graph in EIS, you may want to save it for further review or comparison 
purposes. If you have made changes to it, such as a different graph format, you will not be 
prompted to save that format when you close the graph. You must deliberately save the graph if 
you want to maintain that format. 

To save a graph: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph As to display the Save Graph As window. 

3. In the File name field, enter a file name that will help you to quickly identify the graph. 

You may want to include the as of date in the file name for comparison purposes. 

4. Click Save to save the graph with a .grf extension. 

See Also: 

Closing Graphs 
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Saving Graph Collections 
If you have created a series of related graphs, you may want to maintain them in a group. When 
you do this, any time you want to display the graphs, they all open at the same time. If you close 
the collection, all of the graphs in the collection are closed at the same time. You can add or 
remove graphs from the collection at any time. 

To save a collection of graphs: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection As to display the Save Collection As 
window. 

3. In the File name field, enter a file name that will help you to quickly identify the graph 
collection. 

You may want to include the as of date in the file name. 

4. Click Save to save the group of graphs with a .col extension. 

See Also: 

Saving Graphs 
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Displaying Saved Graphs 
If you save a graph or a collection of graphs you created using EIS, you can open and display 
them in the Eclipse EGraph window. 

Note: This instruction is based on the functionality of Microsoft Windows XP 
2002. While the buttons may differ in your version of Windows, the 
essence of the instruction should still assist you in completing this task. If 
not, consult the MS Windows® online help for additional assistance. 

To display a saved graph or collection of graphs: 

1. From the File menu, select Open Collection/Graph to display the Open 
Graph/Collection window. 

2. Browse to the folder in which your graphs are stored, if needed. 

Note: The application remembers the last place you stored graphs and opens that 
folder in subsequent sessions. 

3. Select a graph (.grf extension) or a collection (.col extension) and click Open to display 
the requested file in the Eclipse EGraph window. 

See Also: 

EGraph Overview 

Starting the Eclipse EGraph Application 
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Viewing Multiple Graphs 
When you have multiple graphs open in the Eclipse EGRAPH window, you can use the options 
under the Window menu to arrange them in such a way as to view more than one simultaneously. 

To view multiple graphs in the Eclipse EGraph window: 

1. Display two or more graphs in the Eclipse EGraph window. 

2. From the Window menu, select one of the following options: 

To... Select this menu option... 
stack the graphs so that you can view each of their titles Cascade Windows 

arrange the graphs top to bottom Horizontal Tile 

arrange the graphs side by side Vertical Tile 

 

3. To display a graph full size, select it and do one of the following: 

• Double-click the title bar. 

• From the Window menu, select Default Tile. 
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Saving Changes to Graphs 
After you have saved a graph, if you make changes to it that you want to keep, you need to save 
it again. You can save the changes in the original file or create a new file so that the original file 
is unaffected by the change. 

To save the changes to the original file: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph. 

The application saves the changes to the current file. 

To save the changes to a new file: 

1. If you have more than one graph open, bring the one you want to save to the forefront. 

2. From the File menu, select Save Graph As to display the Save Graph As window. 

3. In the File name field, change the file name to distinguish it from the original. 

4. Click Save to save the graph with a .grf extension. 
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Saving Changes to Graph Collections 
After you have saved a collection of graphs, if you make changes to any of the graphs in it that 
you want to keep, you need to save the collection again. You can save the changes in the original 
file or create a new file so that the original file is unaffected by the change. 

To save the changes to the original file: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection. 

The application saves the changes to the current file. 

To save the changes to a new file: 

1. Do any of the following, as needed: 

• Close any open graphs that do not belong in the collection. 

• Create any additional graphs that should be in the collection. 

• Display any saved graphs that should be in the collection. 

2. From the File menu, select Save Collection As to display the Save Collection As 
window. 

3. In the File name field, change the file name to distinguish it from the original graph 
collection. 

4. Click Save to save the group of graphs with a .col extension. 
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Printing Graphs 
If you want to present a graph in a meeting, you may want to print it so that everyone can have a 
copy of it. If you are writing a report, sometimes having a graphical representation of the sales 
figures can help get your point across more effectively. 

To print a graph: 

1. If you have more than one graph open, bring the one you want to print to the forefront. 

Note: You cannot print all of the graphs in a collection at the same time. You 
must print them individually. 

2. From the File menu, select Print Graph to display the Print window. 

3. Make changes to the print settings, as needed. 

Note: For best results, select a color printer. 

4. Click Print to send the graph to the printer. 
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Closing Graphs 
When you have finished viewing a graph, you can close it without exiting out of the application, 
if needed. 

To close a graph: 

1. If you have more than one graph displayed in the Eclipse EGraph window, click the 
graph to close to select it. 

2. Save changes to the graph, as needed. 

3. Do one of the following: 

• Click the X in the upper right corner of the graph's window. 

Important: Do not click the X in the upper right corner of the application window. 
This closes the entire program. 

• From the File menu, select Close Graph. 

If you made any unsaved changes to the graph, you will not be prompted to save them 
before it closes. 

See Also: 
Closing Collections of Graphs 

Displaying Saved Graphs 
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Closing Graph Collections 
If you have opened several graphs, you can close them as a group without exiting the application, 
if needed. 

To close a collection of graphs: 

1. If you opened a series of related graphs and want to maintain them together, save them as 
a collection. 

2. Save changes to the individual graphs within the collection, as needed. 

3. From the File menu, select Close Collection. 

If you made unsaved changes to any of the graphs, the application does not prompt you to 
save them. 

See Also: 

Closing Graphs 

Displaying Saved Graphs 
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Closing All Displayed Graphs and Collections 
To clear the EGraph window of all open graphs and collections of graphs, use the Clear function. 

Note: The application does not save changes made since your last save. 

To close all displayed graphs and collections: 

1. Save changes to any graphs or collections, as needed. 

2. From the Clear menu, select All. 

3. At the confirmation message, click OK. 

All graphs and collections close, and changes made after your last save are rejected. 
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Exiting the Eclipse EGraph Application 
When you have finished working with graphs, close the Eclipse EGraph window. 

To exit the Eclipse EGraph application: 

1. Save graphs or collections, as needed. 

2. Do one of the following: 

• Click the X in the upper right corner of the application window. 

• From the File menu, select Exit. 
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Exporting Graph Data to Text Files 
If you would like to manipulate the data from a graph outside of Eclipse EGraph, you can export 
the graph data to a text file. You have the option to select a character to use to separate the 
individual pieces of data, and you can export the row and column labels needed. 

To export graph data to a text file: 

1. Create or display the graph to export. 

2. From the File menu, select Export Data to display the Export window. 

3. In the Delimiter area, select one of the following options to determine the character to 
use to separate the individual pieces of data: 

• Tab  

• Space  

• Comma  

• Semicolon  

• Other  
4. In the Options area, select or deselect the following check boxes, as needed: 

• Include Row Labels – Adds the row labels from the graph as a row header in the 
data file. 

• Include Series Labels – Adds the series labels from the graph as a column header in 
the data file. 

5. Click Save As to display the Enter a filename for the exported data file window. 

6. Browse to the folder in which to store the text file. 

7. In the File name field, enter a file name that will help you to quickly identify the graph 
data. 

8. Click Save to create a file with a .txt extension. 

Note: If you want to open the text file in MS Excel®, be sure to use the same 
delimiter you selected in step 3 to format the data in the spreadsheet. 
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Copying Graphs to Other Applications 
If you want to use a graph for a presentation or report, you can copy it from the Eclipse EGraph 
window and paste it into another application, such as MS Word or MS PowerPoint. 

To copy a graph in EGraph: 

1. Create or display a graph in the Eclipse EGraph window. 

2. From the Edit menu, select Copy. 

3. Open the application to which to copy the graph. 

4. Press Ctrl+V to paste the graph into the document. 
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Increasing the Size of Graphs 
The Eclipse EGraph window has no zoom feature. When you create a graph, it displays at 
maximum size. However, when you save and close it, and then re-open it, it shrinks to about 
one-fourth of its original size. This instruction shows how to return it to its maximum size. 

To increase the size of a graph: 

1. Display a saved graph. 

2. From the Edit menu, select Show/Hide ToolBar. The graph displays at full size. 

3. To return the toolbar to its previous view mode, select Show/Hide ToolBar again. 
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Selecting Graph Data Subsets 
The Cross Tab table is a grid with one dimension of the graph (such as months) listed down the 
left side and the other dimension (such as years) listed across the top. The grid is then populated 
with the actual values that are plotted on the graph. 

You cannot change any of the values or labels in a cross tab table and you cannot print or copy 
the data in this spreadsheet format, but you can change what is displayed on a graph by selecting 
certain subsets of the data in the table.  

For example, if you create a chart that has more than one set of data, such as a "this year vs. last 
year" sales comparison, if you change the format to a pie chart, EGraph can graph only one set of 
data at a time, so it selects the first set of data. You can graph the other sets of data by selecting 
other columns in cross tab view. 

To select a data subset to graph: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following to display the cross tab view: 

• Click the  button. 

• From the Graph menu, select Cross Tab. 

3. Do one of the following: 

To select... Do this... 
a column of data Click a column heading. 

several consecutive columns of data Click the first column heading, press and hold the 
Shift key, and click the last column heading. 

a row of data Click a row heading. 

several consecutive rows of data Click the first row heading, press and hold the 
Shift key, and click the last row heading. 

several contiguous cells of data Position the mouse pointer over the first cell to 
select, press and hold the left mouse button, drag 
the pointer diagonally to the opposite corner of 
the group of cells, and then release the mouse 
button. 

display all data, provided the intended graph 
format supports it 

Click the first cell in the table. 

 

Note: You cannot select non-consecutive rows or columns. 

4. Click a graph format to display the selected data. 
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Changing the Graph Formatting Toolbar View Mode 
The graph formatting toolbar is located on the upper left side of the Eclipse EGRAPH window. 
However, all of the options on the toolbar are also available under the Graph menu, so if you 
want to maximize the space in the EGRAPH window, you can hide the tool bar. If you find that 
the toolbar makes your life easier, you can always bring it back. For more information about the 
toolbar, see Graph Formatting Toolbar Features. 

To change the view mode of the graph formatting toolbar: 

1. To hide the toolbar, from the Edit menu, select Show/Hide ToolBar. 

To change the graph format while the toolbar is hidden, from the Graph menu, select any 
of the menu items. 

2. To re-display the toolbar, from the Edit menu, select Show/Hide ToolBar. 
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Creating Line Charts 
A line chart (by default) uses dots connected by a line to indicate the data points in the graph. 
Each data set of information is represented by a line with a different color. The three-
dimensional chart lines have a tape-like depth. 

To create a line chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional line chart format 

• Click the  button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Line Chart. 

• Click the  button and select the Line button. 

three-dimensional line chart format 
• Click the  button on the graph formatting 

toolbar. 
• From the Graph menu, select 3D Line Chart. 

• Click the  button, click the 3D Gallery tab, 
and select the Tape button. 

 

3. Set any of the following options, as needed: 

To... Click this tab... 
add sticks, lines, or symbols to a two-dimensional graph Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional graph 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the graph Background 

 

4. Save your changes. 
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Creating Area Charts 
An area chart uses dots connected by a line to represent the data points in the graph, and then 
fills in the area below the line. Each data set of information is represented by an area with a 
different color. The three-dimensional area chart adds depth to the area. Each data set of 
information is represented by an area with a different color. 

To create an area chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional area chart format 

• Click the  button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Area Chart. 

• Click the  button and select the Area button. 

three-dimensional area chart format 
• Click the  button on the graph formatting 

toolbar. 
OR 
• From the Graph menu, select 3D Area Chart. 

• Click the  button, click the 3D Gallery tab, and 
select the Area button. 

 

3. Set any of the following options, as needed: 

To... Click this tab... 
further define the area chart style Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional graph 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the graph Background 
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4. Save your changes. 
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Creating Bar Charts 
A bar chart uses a bar to represent each data point in the graph. Each data set is represented by 
bars of a different color. The three-dimensional bar chart uses columns to represent each data 
point in the graph. Each data set is represented by a different column color. This type of graph is 
good for showing the relationships between two or more data sets of information. 

To create a bar chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional bar chart format 

• Click the  button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Bar Chart. 

• Click the  button and select the Bar button. 

three-dimensional bar chart format 
• Click the  button on the graph formatting 

toolbar. 
• From the Graph menu, select 3D Bar Chart. 

• Click the  button, click the 3D Gallery tab, and 
select the Line button. 

Note: This is the type of chart the system creates 
initially when you run the Eclipse Information System 
program. 

 

3. Set any of the following options, as needed: 

To... Click this tab... 
further define the bar chart style Style 

work with the graph data Data 

edit the graph titles Titles 

change the appearance of a three-dimensional graph 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the graph Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 



EGraph 

© 2007  Activant Solutions Inc. All rights reserved. 63 

To... Click this tab... 
change the style of the background elements on the graph Background 

 

4. Save your changes. 
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Creating Pie Charts 
In a pie chart, the data points in the graph are represented as sections of a circle. This type of 
graph can be used for a single data set only. The three-dimensional pie chart adds thickness to 
the pie slices. 

To create a pie chart from a graph with multiple data sets, first display your data in the Cross Tab 
format. In the Cross Tab, select the data set to graph, then select the Pie Chart format to display 
the graph. 

The pie chart styles affect the labels on the slices of the pie. 

To create a pie chart: 
1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional pie chart format 

• Click the  button on the graph formatting 
toolbar. 

• From the Graph menu, select 2D Pie Chart. 

• Click the  button and, under the 2D Gallery 
tab, select Pie. 

three-dimensional pie chart format 
• Click the  button on the graph formatting 

toolbar. 
• From the Graph menu, select 3D Pie Chart. 

• Click the  button, click the 3D Gallery tab, and 
select Pie. 

 

If the graph has more than one set of data points, the application selects the first set of 
data for the pie chart. To use a different set of data, see Selecting Graph Data Subsets. 

3. Set any of the following options, as needed: 

To... Click this tab... 
change the appearance of the pie chart labels Style 

work with the graph data Data 

edit the chart titles Titles 
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To... Click this tab... 
change the appearance of a three-dimensional chart 3D 

Note: You can also click the left, right, up, 
or down arrow buttons in the lower left 
corner of the graph window. 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Polar Charts 
The polar chart is essentially a line chart drawn on a circular grid. The line relates values to 
angles. Like logarithmic graphs, polar graphs are useful primarily in mathematical and statistical 
applications. In a polar graph, the independent variable is charted on the angular axis, based on 
an origin (zero point) of three o'clock. The dependent variable is charted on the radial axis, with 
the origin at the center of the circle. Polar graphs can chart multiple data sets, each represented 
by a single line, with as many data points as are meaningful. 

If you don't supply an angular position for each data point, the Graph control automatically 
places the first point at an angle of 0, with subsequent points at increments of 360 (degrees) 
divided by the total number of points. 

To create a polar chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Polar button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Polar button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add sticks, lines, or symbols to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Bubble Charts 
The bubble graph lets you chart three variables in two dimensions. It is a special form of the 
scatter graph in which the size of a circular marker (the bubble) for a data point is used to 
represent a value. For example, the size of a bubble might represent a product's percentage of 
gross sales; the bubble's position along the Y axis might represent market size; and the position 
along the X axis might represent the number of competing products. 

In a bubble graph, all three variables are independent. You can choose which variable to show on 
the X axis, which to show on the Y axis, and which to show by the size of the bubble. 

You must supply values for the X position, Y position, and bubble size for each point. If you 
have access to the Data property page, you can set these values by pressing the X and Y Position 
button (the top row of the dialog contains the X positions and the bottom row the Y positions) 
and the Bubble Size button. 

Note: You can't draw curves on a bubble graph. 

To create a bubble chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Bubble button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Bubble button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Scatter Charts 
The 2D scatter graph consists of plotted points "scattered" around an X-Y grid. The pattern may 
reveal a relationship between the two variables measured by the X and Y axes. Scatter graphs 
can chart multiple data sets, each having any number of data points. Each set can be represented 
by a different symbol. You can display scatter plots alone, curves alone, or both together. 

To create a scatter chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

To display the graph data in a... Select one of these methods... 
two-dimensional area chart format 

• Click the  button and click the Scatter button. 
• From the Graph menu, select Options, and then, 

under the 2D Gallery tab, click the Scatter button. 

three-dimensional area chart format 
• Click the  button, click the 3D Gallery tab, and 

click the Scatter button. 
• From the Graph menu, select Options, and then, 

under the 3D Gallery tab, click the Scatter button. 

 

3. Set any of the following options, as needed: 

To... Click this tab... 
add symbols to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

enhance the three-dimensional features 3D 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating GANTT Charts 
The Graph control's Gantt chart is a specialized version of the horizontal bar graph in simple or 
stacked form. It is used almost exclusively to show a project schedule, with each bar or bar 
segment marking the start time, duration, and completion time of a task. 

Depending on your needs, you can have each bar represent either a single task (one solid bar) or 
a sequence of tasks (stacked bar). 

Gantt charts are made up of at least two data sets. The first set contains the values for the start 
point of each bar, and subsequent sets contain the end points of each bar segment. Unlike bar 
graphs, Gantt charts are always drawn horizontally and only in 2D form. The Graph control 
automatically places Gantt bars along the Y axis at increments of 1, starting at 1. 

In default form, Gantt chart bars are drawn with no spaces between them. You can add spaces if 
you choose. Go to the Style property page and select the Spaced option. You can't show negative 
data points on a Gantt chart. 

To create a GANTT chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Gantt button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Gantt button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add spaces between the bars on the chart Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating High-Low Close Charts 
The high-low-close (HLC) graph lets you chart a range of values on an X-Y grid. The range is 
shown as a vertical bar, with horizontal crossbars for the high, the low, and a normative value 
usually called the close. An alternate version, the open-high-low-close (OHLC) graph, adds a 
fourth crossbar for another normative value usually called the open. 

When you click the High-Low icon on the 2D Gallery property page, you get an HLC graph by 
default. To get an OHLC graph, go to the Style property page and select the 'Open' Values 
option. 

An HLC graph must have three data sets (high, low, and close values), and an OHLC graph must 
have four data sets (open, high, low, and close values). There's no limit on the number of data 
points you can graph, but each data set should have the same number. 

You can optionally draw the graph without the open and close bars, without the high and low 
bars, or with no bars at all.  These options are available in the Style property page. 

To create a high-low close chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the High-Low button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
High-Low button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
show or hide open values, high/low ticks, and open/close 
ticks 

Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Candlestick Charts 
The candlestick graph is an alternative to the open-high-low-close graph. It consists of a series of 
boxes, with lines extending up and down from the ends, drawn on an X-Y grid. The top and 
bottom of each box indicate the open and close values. If the open value is higher, the box is 
filled with a color; if the close value is higher, the box is filled with white. The ascending and 
descending lines indicate the high and low values for that point. 

The candlestick graph requires four data sets (open, high, low, and close values), each of which 
should have the same number of data points. 

If you don't supply an X position for each data point, the Graph control automatically places 
points at increments of 1, starting at 0. 

No style variants are available. 

To create a candlestick chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Candlestick button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Candlestick button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Box-Whisker Charts 
The box-whisker graph illustrates the spread of data groups around their medians, using a "box" 
and "whiskers" to break down each data group by percentile. 

In creating a box-whisker graph, you can either specify the seven percentile parameters for each 
symbol (provide "parametric" data) or supply a group of "raw" data for the Graph control to 
process and graph. 

With raw data, you supply as many sets of data as you want and the Graph control computes 
percentile parameters. For example, if you are graphing the scores achieved by 24 students on 
five tests, you need 24 sets of data with five points per set. The control will analyze the data and 
draw five box-whiskers, one for each test. Each box-whisker will show the percentile distribution 
of scores for a single test. 

With parametric data, you compute percentile data yourself and send it to the Graph control as 
exactly seven data sets, which specify the values at percentiles of 5, 10, 25, 50 (the median), 75, 
90, and 95. The number of points within each set determines how many box-whiskers are drawn. 

To create a box-whisker chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Box-Whisker button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Box-Whisker button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
determine the source of the data to display Style 

work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Time Series Charts 
Unlike other graphs, the time series graph shows open-ended streams of data, rather than finite 
data sets. This graph is ideal for plotting real-time data. 

A time series graph is drawn on a dynamic X-Y grid. Points are added one at a time to the right-
hand edge. When the graph reaches the limit of points it can show, the oldest data begins to drop 
off the left edge.  As a result, the graph appears to move on the screen. 

Time series graphs can chart multiple data sets, each represented by a single sequence of 
symbols. 

Because time series graphs represent continuous streams of data, they must be displayed on 
screen to show all the data.  Printouts of time series graphs can show only freeze-frames of the 
graph captured at particular times. 

The data for a time series graph must be provided by the application. You cannot enter data for 
this type of graph from the property pages. 

To create a time series chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button and then click the Time Series button. 

• From the Graph menu, select Options, and then, under the 2D Gallery tab, click the 
Time Series button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
work with the chart data Data 

edit the chart titles Titles 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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Creating Surface Charts 
The surface graph lets you represent data topographically in three dimensions. The graph uses an 
X-Z grid drawn at regular increments in the X and Z directions, with one Y value for each X-Z 
intersection. The color scale of the graph is automatically keyed to the height of points, helping 
the viewer differentiate between higher and lower values. 

A surface graph represents a minimum of two data sets and usually at least three. Each data set 
holds the Y values of a row of points along the X axis. The first set applies to the row of points 
perpendicular to the Z origin (the "back" of the graph), and subsequent sets apply to additional 
rows. 

All panels of the surface graph (the rectangles formed by the X and Z grids) are colored 
according to their height. You specify the colors at the maximum and minimum points of the 
axis, and the Graph control interpolates colors between these points. 

In drawing a surface graph, you can use lines to show the edges of each panel, fill each panel 
with a solid color, or use both lines and fills. You can also add side walls to the front and right 
edges of the graph if you choose. All of these options are available in the Style property page. 

To create a surface chart: 

1. Create or display a graph in the Eclipse EGraph window. 

2. Do one of the following: 

• Click the  button, click the 3D Gallery tab, and then click the Surface button. 

• From the Graph menu, select Options, and then, under the 3D Gallery tab, click the 
Surface button. 

3. Set any of the following options, as needed: 

To... Click this tab... 
add markers, color grades, and sidewalls to the chart Style 

work with the chart data Data 

edit the chart titles Titles 

enhance three-dimensional features 3D 

change the style and size of the text on the chart Fonts 

change the colors, patterns, or symbols that identify the 
data points or data sets 

Markers 

change the style of the background elements on the chart Background 

 

4. Save your changes. 
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