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Disclaimer 
This document is for informational purposes only and is subject to change without notice. This document and its 
contents, including the viewpoints, dates and functional content expressed herein are believed to be accurate as of its 
date of publication. However, Epicor Software Corporation makes no guarantee, representations or warranties with 
regard to the enclosed information and specifically disclaims any applicable implied warranties, such as fitness for a 
particular purpose, merchantability, satisfactory quality or reasonable skill and care. As each user of Epicor software 
is likely to be unique in their requirements in the use of such software and their business processes, users of this 
document are always advised to discuss the content of this document with their Epicor account manager. All 
information contained herein is subject to change without notice and changes to this document since printing and 
other important information about the software product are made or published in release notes, and you are urged to 
obtain the current release notes for the software product. We welcome user comments and reserve the right to revise 
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any time, without notice. The usage of any Epicor software shall be pursuant to an Epicor end user license 
agreement and the performance of any consulting services by Epicor personnel shall be pursuant to Epicor's standard 
services terms and conditions. Usage of the solution(s) described in this document with other Epicor software or 
third party products may require the purchase of licenses for such other products. Where any software is expressed 
to be compliant with local laws or requirements in this document, such compliance is not a warranty and is based 
solely on Epicor's current understanding of such laws and requirements. All laws and requirements are subject to 
varying interpretations as well as to change and accordingly Epicor cannot guarantee that the software will be 
compliant and up to date with such changes. All statements of platform and product compatibility in this document 
shall be considered individually in relation to the products referred to in the relevant statement, i.e., where any 
Epicor software is stated to be compatible with one product and also stated to be compatible with another product, it 
should not be interpreted that such Epicor software is compatible with both of the products running at the same time 
on the same platform or environment. Additionally platform or product compatibility may require the application of 
Epicor or third-party updates, patches and/or service packs and Epicor has no responsibility for compatibility issues 
which may be caused by updates, patches and/or service packs released by third parties after the date of publication 
of this document. Epicor® is a registered trademark and/or trademark of Epicor Software Corporation in the United 
States, certain other countries and/or the EU. All other trademarks mentioned are the property of their respective 
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Forecasting Overview 
The system uses the process of forecasting to predict how much of a product customers will purchase in 
the future based on past sales. Forecasting requires you to define parameters for a product or a period of 
time which the system uses to make these forecasting predictions. The system also must filter demand to 
create an accurate forecast picture. This filtering requires considering exceptional sales, lost sales, and 
trend, such as water heaters that are seasonal products and normally sold in the winter months. 

Forecasting must also take into account the hits of a product, safety days, order points, line points defined 
and the economic order quantity (EOQ). The Update Demand Forecast program provides information 
necessary about how often a product sells per day or the average number of units sold per day. The 
system uses these demand calculations for the Suggested Purchase Order Queue, Suggested Auto 
Transfer, and Product Ranking programs. 

These values determine the amount of inventory to stock in your warehouse. In a multiple-branch 
warehouse company, these values also determine the amount of inventory to transfer to branches. 

Forecast Parameters and Periods 
Before the system calculates order points, line points, and EOQ, it needs a "clean" demand sample. That 
is, as accurate an estimation of demand as possible, despite the unpredictability of the future. To help 
clarify demand, the system gives you the ability to: 

• Use variable forecasting periods. 

• Eliminate exceptional sales. 

• Compensate for lost sales and exceptional sales. 

• Consider trends in demand. 

• Handle seasonal and non-seasonal products. 

Forecast parameters exist at the branch, buy line, and product levels, providing broad to detailed control 
over your inventory. 
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Setup Requirements for Forecasting 
Following are the control maintenance records used for forecasting. Set the following control 
maintenance records: 

• Assign Demand Forecast To Price/Ship Branch Or By Zip Code 

• Control Forecast Parameters Maintenance 

• Branch Fields Required To Add Product Demand 

• Default Lead Time Days If Product And Buy Line Have None 

• Default Lead Time Factor If Product And Buy Line Have None 

• Demand Hit Definition 

• Do Not List Item More Than Once On Add Demand Screen 

• Exclude Exceptional Sales From Customer Demand Index 

• Exclude MiscChrg Products From Customer Demand Index 

• Forecast Parameters For Demand Calculation 

• Global Hits Definition 

• Minimum Hits 

• Minimum Lead Samples 

• Number Of Years To Be Included In Customer Demand Index 

• Respect Item Min/Max For Suggested Transfers 
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Setup Requirements for Exceptional Sales 
Following are the control maintenance records and authorization key used for exceptional sales. 

Control Maintenance Records 
The following control maintenance records affect exceptional sales: 

• Demand Hit Definition 

• Exclude Exceptional Sales From The Customer Demand Index 

Authorization Key 
The following authorization key affects exceptional sales: 

• OE.PRODUCT.TYPE.EDIT 



Setup Requirements for Lead Time Parameters 

4 

Setup Requirements for Lead Time Parameters 
Following are the control maintenance records used for lead time parameters. 

Control Maintenance Records 
Set the following control maintenance records: 

• Default Lead Time Days If Product And Buy Line Have None 

• Default Lead Time Factor If Product And Buy Line Have None 

• Minimum Lead Samples 

Authorization Keys 
• PRODUCT.MAINT.LEVEL 
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Setup Requirements for Order Points and Line Points 
Following are the control maintenance records and authorization key used for order points and line points. 

Control Maintenance Records 
Set the following control maintenance records: 

• Default For Excess Grace In Buy Line Maint 

• Default Lead Time Days For Branch Procurement 

• Default Lead Time Days If Product And Buy Line Have None 

• Default Lead Time Factor If Product And Buy Line Have None 

• Minimum Lead Samples 

• Minimum Order Cycle Days For Suggested P/O 

• Percentage Of Mother Branch's OP Protected In Suggested Transfer 

• Warn About Additional Lead Time During OE 

Authorization Key 
Set the following authorization keys: 

• PRODUCT.MAINT 
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Entering Forecast Parameters for Products 
Forecast parameters filter transactions to determine product demand so that the demand forecast is 
accurate. Forecast parameters define boundaries for how the system suggests when to replenish products 
in your warehouse. For example, based on the product history, the system uses the settings you define to 
determine how much you need to keep on hand to fulfill expected sales. 

Forecast parameters are set at the product, branch, or buy line level. Set forecast parameters at the product 
level to override settings at the branch or buy line level. Assign forecast parameters at the product level to 
filter demand, set the forecast method and forecast period, and to calculate a product's economic order 
quantity (EOQ). 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To enter forecast parameters for a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

5. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

8. Complete the following fields: 

To... Use this field... 
Whether the system uses the standard or median forecasting method for 
this product. If left blank, the default is standard. 

Forecast Method 

Whether the product sells more at certain times of the year than at other 
times. Select Demand Parameters from the File menu to define the 
forecast period parameters. 

Seasonal 

The maximum number of days in the forecast period that the system uses 
to increase an item's raw demand to compensate for lost sales of a product. 

Lost Sales 

The exceptional sales percentage for the product. The system eliminates 
from demand forecasting any sale exceeding the percentage difference 
between the two largest sales in the forecast period. 

Exceptional Sales % 

The positive or negative percent to change the calculated demand forecast 
in anticipation of a trend increasing or decreasing the demand. 

Note: You can enter negative numbers, if needed, such as to account for 
 declining sales on a buy line. 

Trend % 

Enter the backorder tolerance quantity above which a hit is not included in 
the demand forecast calculation. 

BTQ 
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To... Use this field... 
Enter the minimum number of most-recent purchase orders the system 
samples to calculates the lead time for the product. 

Minimum Lead Factor 

Define how the system calculates lead time for the product: 
• If greater than 0 (zero), this is the maximum number of most-recent 

purchase orders the system samples to estimate the lead time for the 
product. 

• If 0 (zero), the automatic calculation of lead time for the product is 
turned off and the system uses the value of Lead Days for the lead time. 

• If null (blank), the system uses the lead factor set for the product's buy 
line. 

Note: Seasonal products use a lead time calculated for the season. 

Lead Factor 

The lead time for the product. This field updates when Lead Fctr is greater 
than 0 (zero). 

Lead Days 

The theoretical cost of reordering and restocking a single item, used in 
calculating the EOQ. 

EOQ $ 

The carry cost percentage used in calculating the EOQ of this item. EOQ % 

9. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

More Options for the Product Forecast Parameters Dialog Box 

The Product Forecast Parameters dialog box also offers these options: 

To... Select this menu option... 

Enter forecast period parameters File > Demand Parameters 
The Product Demand Parameters dialog box displays. 

Define minimum and maximum stocking 
levels and add service stock 

Edit > User Control Parameters 
The Product User Control Parameters dialog box displays. 

View the default cost for a product 
Edit > Default Cost 
The Product Default Cost dialog box displays. 

Adjust the product's lead time Edit > Override Lead Time 
The Override Lead Time Maintenance dialog box displays. 

View product availability and inventory 
information 

Inquiry > Inventory Inquiry 
The Inventory Inquiry window displays. 

Audit the demand calculation Inquiry > Audit 
The Demand Calculation Audit dialog box displays. 
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Entering Forecast Period Parameters 
Demand patterns for products selling an average of 10 times a month are different from those for products 
selling an average of 10 times a year. Therefore, the system forecasts product demand based on variable 
forecast periods. 

On average, the following is true: 

• Fast-moving items use shorter forecast periods because most recent sales are the best for predicting 
future demand. 

• Slow-moving items use a longer forecast period, because you need more time and purchase for 
accurate predictions. 

• Seasonal products, which are in greater demand at certain times of the year than for non-seasonal 
products, use the demand history from the prior year's season. 

In addition to setting forecast period parameters at the product level, you can also set these parameters at 
the branch or buy line level. Parameters set at the product level override those set at the buy line and 
branch level. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters for groups of products. 

To enter product demand parameters: 

1. Enter forecast parameters. 

2. In the Product Forecast Parameters dialog box, from the File menu, select Demand Parameters 
to display the Product Demand Parameters dialog box. 

3. From the File menu, select Insert Branch to display the Product Demand Parameters dialog box. 

4. In the Enter new branch or territory field, enter the branch or territory ID. 

5. Click OK to return the ID to the Branch field in the Product Demand Parameters dialog box. 

6. To enter non-seasonal demand parameters for a branch, under the Regular column, complete the 
following information: 

Column Description 
Hits The number of hits the system looks for within the regular Minimum Days 

and Maximum Days range to calculate the number of days of sales history 
used to calculate a non-seasonal product's demand. 

Minimum Days Minimum days used with regular Hits to determine the number of days of 
sales history used to calculate a non-seasonal product's demand. 

Maximum Days Maximum days used with regular Hits to determine the number of days of 
sales history used to calculate a non-seasonal product's demand. 

Note: If the date of the first transaction for a product is less than the maximum days, the 
demand history calculation program populates the Maximum Days field with that 
date. If the date of the first transaction for a product is also less than the minimum 
days, the program also populates the Minimum Days field with that date. 
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7. To enter seasonal forecast parameters for a branch, under the Seasonal column, complete the 
following information: 

Column Description 
Hits The number of hits the system looks for within the regular Minimum Days and 

Maximum Days range to calculate the number of days of sales history used to 
calculate a seasonal product's demand. 

Minimum Days Minimum days used with regular Hits to determine the number of days of sales 
history used to calculate a seasonal product's demand. 

Maximum Days Maximum days used with regular Hits to determine the number of days of sales 
history used to calculate a seasonal product's demand. 

Note: If the date of the first transaction for a product is less than the maximum days, the 
demand history calculation program populates the Max Days field with that date. 
If the date of the first transaction for a product is also less than the minimum days, 
the program also populates the Min Days field with that date. 

8. Enable the automatic trend calculation, if needed. 

9. Include direct shipments in the demand calculation, if needed. 

10. Save the information and exit the window. 

Changes take effect when you exit Product Maintenance. 

More Options in the Product Demand Parameters Dialog Box 

The Product Demand Parameters dialog box also offers these options: 

To... Select this menu option... 
remove a branch from the Product 
Demand Parameters dialog box, select 
the branch and 

File > Clear Branch 

find a branch that is not currently 
visible in the dialog box 

File > Find Branch 
The Product Demand Parameters dialog box displays. In the Enter 
branch or territory to find field, enter the branch or territory ID and 
click OK to return to the Product Demand Parameters dialog box. The 
cursor moves to the requested branch. 

toggle between prompting for a branch 
to display branch-specific parameters 
and displaying all branches 

File > Toggle Hierarchy 
The Product Demand Parameters dialog box displays. In the Enter 
hierarchy branch field, enter the branch or territory ID to which you 
want to toggle and click OK to return to the Product Demand Parameters 
dialog box. 

Enable the automatic trend calculation Edit > Auto Trend 
The Product Auto Trend Maintenance dialog box displays. 
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Entering Control Forecast Parameters 
Forecast parameters filter transactions to determine product demand so the system can make a more 
accurate demand forecast. The Forecast Parameters For Demand Calculation control maintenance 
record defines the system-wide forecast parameters. 

You can assign forecast parameters at the branch level that apply to all products in that branch, unless 
overridden at the buy line or the product level. These include parameters to filter demand, set the forecast 
method and forecast period, and to calculate a product's economic order quantity (EOQ). 

To enter system default forecast period parameters: 

1. From the System > System Files menu, select Control Maintenance to display the Control 
Maintenance window. 

2. In the Keyword field, enter forecast parameters for demand to display the Control Forecast 
Parameters Maintenance dialog box. 

3. Double click the INVM control maintenance record that displays. 

4. In the Branch field, select the branch, branches, or territories for which you want to apply control 
forecast parameters. 

5. Complete the main fields to apply to the branch. 

Field Value 
Forecast Method Whether the system uses the standard or median forecasting method for this 

product. 
Lost Sale The maximum number of days in the forecast period that the system uses to 

increase an item's raw demand to compensate for lost sales of a product. 
Exceptional % The exceptional sales percentage for the product. The system eliminates from 

demand forecasting any sale exceeding the percentage difference between the two 
largest sales in the forecast period. 

Trend % The positive or negative percent to change the calculated demand forecast in 
anticipation of a trend increasing or decreasing the demand. 
Note: You can enter negative numbers, if needed. 

EOQ $ The theoretical cost of reordering and restocking a single item, used in calculating 
the EOQ of the product. We recommend using 1.00 for $1.00. 

EOQ % The carry cost percentage used in calculating the EOQ of the product. We 
recommend using 28 for 28%. 

6. In the Auto-Trend area, select to apply an automatic trend for seasonal products. The system 
calculates and applies a trend based on recent demand compared to the previous year's demand. 

• Max Decrease% - The maximum negative trend to apply to the demand forecast for the 
product. This parameter only applies to seasonal products when the Auto-Trend check box is 
selected. 

• Max Increase% - The maximum positive trend to apply to the demand forecast for the 
product. This parameter only applies to seasonal products when the Auto-Trend check box is 
selected. 
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7. Select Include Directs to include direct shipments in the demand calculation for the branch 
demand calculations. 

8. Select Seasonal if you have products in the branch that sell more at certain times of the year than 
at other times.  For example, you may count furnaces as a seasonal product because you sell more 
during winter months. 

9. In the Regular section, enter non-seasonal product forecast parameters. 

Field Description 
Hits The number of times an item sold within the regular Min Days and Max Days range. 

The system uses hits to calculate the forecast period for calculating demand for a 
non-seasonal product. 
The Demand Hit Definition control maintenance record determines how the system 
calculates hits based on sales orders. 

Min Days Minimum days used with regular Hits to determine the forecast period for calculating 
demand for a non-seasonal product. 

Max Days Maximum days used with regular Hits to determine the forecast period for 
calculating demand for a non-seasonal product. 

Note: If the date of the first transaction for a product is less than the defined Max Days, 
the system uses the date of the first transaction as Max Days. If the date of the 
first transaction for a product is also less than the defined Min Days, the program 
uses the date of the first transaction as Min Days. 

10. In the Seasonal section, enter seasonal product forecast parameters. 

Field Description 
Hits The number of times an item sold within the seasonal Min Days and Max Days range. 

The system uses hits to calculate the forecast period for calculating demand for a 
seasonal product. 
The Demand Hit Definition control maintenance record determines how the system 
calculates hits based on sales orders. 

Min Days Minimum days used with seasonal Hits to determine the forecast period for calculating 
demand for a seasonal product. 

Max Days Maximum days used with seasonal Hits to determine the forecast period for calculating 
demand for a seasonal product. 

Note: If the date of the first transaction for a product is less than the defined Max Days, 
the system uses the date of the first transaction as Max Days. If the date of the 
first transaction for a product is also less than the defined Min Days, the program 
uses the date of the first transaction as Min Days. 

11. In the Days Out Calculation Parameters area, select Exclude Ship From Different Branch to 
eliminate including the days out calculation from another branch. 

For example, a customer orders 20 garbage disposals. You have none in your warehouse, but 
have them in branch 2. You have them directly shipped to the customer, but do not want to 
consider that you have them on-hand in your days out calculation although you can get them to 
the customer. Select this option to exclude shipping from them from a different branch in the 
calculation of on-hand. 



Entering Control Forecast Parameters 

12 

12. Click OK to save changes and exit the window. 
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Forecast Parameters for Buy Lines 
The system forecasts product demand (trend) for both seasonal and non-seasonal products. You have the 
flexibility of setting your own forecast parameters. For complete information about setting these forecast 
parameters, see Setting Forecast Parameters for Buy Lines in the Purchasing online documentation. 
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Setting Product User Control Parameters 
Use the Product User Control Parameters dialog box to enter specialized product-level inventory 
parameters, to: 

• Estimate product demand for a new branch 

When you have a new branch that has no product history, use the Min, Max, Exp Date, and Calc 
Dmnd fields to define minimum and maximum stocking levels for the products until there is 
sufficient product history for the demand calculation to take over. 

You can estimate the minimum and maximum stocking levels for a new product until the product 
accrues enough demand history for the system to begin forecasting. As the system monitors a 
product's demand, you can set an expiration date after which the system will stop using estimated 
minimum and maximum levels for suggested purchasing, and begin forecasting demand for regular 
product order points and line points. 

• Add service stock to the demand 

Use the Service Stock and Serv Stock Exp Date fields to add service stock, to the product's order 
point and line point calculations. This adjustment, also known as manual safety stock, is a quantity 
of stock above your normal stocking level that you have committed to keep on the shelf at a branch 
for a set period. 

For example, assume the following it true: 

• You run a promotion on an item, guaranteeing that you will have it in stock. 

• A contractor requests that you keep an item in stock in case he or she needs one in an 
emergency. 

• Your branch utilizes items for its own maintenance and you do not want your use of the items 
to count towards the item's demand. 

When you assign service stock, the system assigns the additional quantities to the order point and 
line point calculations. When you reach the expiration date of the service stock the system 
removes the additional quantities from the order point and line point calculations. 

You can set service stock for a branch or for a customer at a branch using the Product User 
Control Parameters dialog box. 

Use the Customer Service Stock menu option to add customer service stock to the product's 
normal demand. Customer service stock is a quantity of stock above your normal stocking level 
that you have committed to keep on the shelf for a set period, as a courtesy to a customer. After 
entering customer service stock information for a product, the total requirements display in the 
CusServ Stock field. The system adds the additional stock requirements to the product's order 
point and line point calculations. 

The following procedure is a manual process for a single product. Use the Mass Load program to enter 
inventory parameters to groups of products. 

To set User Control Parameters for a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 
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2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select User Controls to display the Product User Control Parameters 
window. 

5. Do one of the following: 

• From the File menu, select Hierarchy to display the Product User Control Parameters dialog 
box. In the Enter hierarchy branch field, enter the branch or territory ID. 

• From the File menu, select Add Branch. In the Enter Branch field, enter the branch or 
territory ID you want to view. 

Important: Only stocking branches are allowed. 

6. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

7. For each branch or territory, complete the User Control Parameter columns, as needed. 

Field View Description 
Min (ea) All The estimated minimum quantity to stock: 

• Purchasing branches use this quantity in place of a calculated order point 
until the expiration date. 

• When the Respect Item Min/Max For Suggested Transfers control 
maintenance record is set to Y, child branches use this quantity in place of 
a calculated transfer point until the expiration date. 

• Enter 0 (zero) if the branch does not stock the item, or enter the actual 
quantity that should ever be stored at the child branch when using this field 
with the Calculate Demand field.                                                                

If a product has a min setting but no max setting, the order point and the line 
point quantity are equal to the value in the Min field unless the system 
calculated line point quantity is greater than the minimum. In this case, the 
system uses the calculated line point quantity. Any child branches inherit the 
minimum only setting. 

Note: If you use vendor managed inventory and generate EDI 852s, the MIN 
only should only report if it is greater than the OP. If it is greater than the 
order point, it should net to the Available and report the difference between 
the MIN and the available as the quantity reserved (QD). If the order point is 
10 and MIN only is 15 and available is 5, then report 10 as quantity reserved 
(QD). If the order point is 10 and MIN only is 15 and available is 20, then 
report nothing, as the product has enough available to cover the MIN only. 
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Field View Description 
Max (ea) All The estimated maximum quantity to stock: 

• Purchasing branches use this quantity in place of a calculated order point 
until the expiration date. 

• When the Respect Item Min/Max For Suggested Transfers control 
maintenance record is set to Y, child branches use this quantity in place of 
a calculated transfer point until the expiration date. 

• Enter 0 (zero) if the branch does not stock the item, or enter the actual 
quantity that should be stored at the child branch when using this field with 
the Calculate Demand field. 

If a product has a min setting but no max setting, the order point and the line 
point quantity are equal to the value in the Min field unless the system 
calculated line point quantity is greater than the min. In this case, the system 
uses the calculated line point quantity. Any child branches inherit the 
minimum only setting. 

Expiration 
Date 

All The date after which the values in the Min and Max fields are no longer 
valid. We recommend that you use an expiration date six months from the 
current date. 

Calculate 
Demand 

All To calculate demand from dependent selling branches for use at purchasing 
branches, select the check box in the selling branch rows; otherwise, leave it 
empty. 
If you use a minimum-only order point for your newer products, ensure that 
the Calculate Demand field is deselected. For more information, see Setting 
Minimum and Maximum Stocking Levels for New Products. 

Service 
Stock 

Service 
Stock 

The quantity of the product to reserve as service stock. 

Service 
Stock 
Expiration 
Date 

Service 
Stock 

The date the system stops adding the service stock quantity to the product's 
order point and line points. 

Customer 
Service 
Stock 

Service 
Stock 

The system populates this field with the total quantity of service stock 
reserved for selected customers. The total quantity only includes those 
quantities within their respective effective date and expiration date. The 
effective and expiration dates are for reporting purposes only and do not 
affect automated purchasing or automated transfers. For more information, 
see Customer Service Stock Report. 
When a branch or territory appears on the User Inventory Control window 
without a value in the CusServ Stock field, this indicates that a customer 
contract stock quantity is set. For more information, see Viewing 
Customer/Vendor Specific Part Number Details. 
This field is view-only. 

Product 
Lifecycle 

Service 
Stock 

Select the product lifecycle to classify the product you are adding. For 
information about product lifecycles, see Creating Product Lifecycles in 
Product Maintenance. 
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Field View Description 
Vendor 
Return 
Allowed 

Product 
Returns 

Select one of the following: 
• Always - Allow returns regardless of return type. 
• RGA - Allow returns only if customer has Return Goods Authorization 

number provided by the vendor. Users must be assigned the 
SOE.RGA.REQUIRED authorization key to return any products without 
an RGA number, but flagged with this setting. 

• Never - Disallows all returns from this vendor. This setting can be used for 
items like remnants that you cannot take back into inventory. Products 
flagged as non-returnable are not included in the Suggested PO Return 
Queue. Users must be assigned the SOE.NONRETURN.PROCESS 
authorization key to return any products with this setting. 

Customer 
Return 
Allowed 

Product 
Returns 

Select one of the following: 
• Always - Allow returns regardless of return type. 
• Defective - Allow returns only if product is broken or otherwise defective. 
• Never - Disallows all returns from this customer. Users must be assigned 

the SOE.ALLOW.NONRETURN authorization key to return any products 
with this setting. 

Economic 
Amount 

Product 
Returns 

Enter the amount below which the system recommends not returning items to 
inventory. If the value of the item being returned falls short or below this 
amount, the system recommends the item not be returned to inventory 
because the processing costs outweigh the actual value of the item. For more 
information, see Determining the Economic Return Amount in the 
Purchasing documentation. 

Auto 
Generate 
Return? 

Product 
Returns 

Indicate if you want to allow the system to automatically generate a return. 

Auto 
Return 
Ship Via 

Product 
Returns 

Select the ship via that the system should use when automatically creating a 
return for products. 

Auto 
Return 
Status 

Product 
Returns 

Select the order status that the system should use when automatically creating 
a return for products. 

Auto 
Return 
Days for 
Ship Date 

Product 
Returns 

Select the number of days allowed for the customer to return the selected 
product. 

7. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

More Options for the Product User Control Parameters Dialog Box 

The Product User Control Parameters dialog box also offers these options: 

To... Select this menu option... 
view inventory details about the product in all 
branches 

Inquiry > Inventory Inquiry 
The Inventory Inquiry window displays. 
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To... Select this menu option... 
view information pertaining to the calculation 
of the product's demand 

Inquiry > Audit 
The Demand Calculation Audit dialog box displays. 

add the demand history of discontinued 
products to their replacements 

Additional Controls > Add Demand 
The Add Demand dialog box displays. 

define hits-related inventory parameters for 
each branch 

Additional Controls > Hits Maintenance / Max Days 
Supply 
The Hits Control Maintenance dialog box displays. 
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How Standard and Median Forecasting Works 
The system offers two different methods for forecasting product demand. The default is Standard. Use: 

• Standard for products with larger demand histories. 

• Median for products with smaller demand histories. 

Use the Forecast Parameters For Demand Calculation control maintenance record to define how you 
want the standard forecasting to calculate. For more information about these settings, see Entering 
Control Forecast Parameters in this documentation. 

Note: For options in advanced forecasting, see How Advanced Demand Forecasting 
Works which works independently as a complement to this process. 

Standard Forecasting Method 
• The system identifies and eliminates from demand forecasting any sales exceeding the back order 

tolerance quantity (BTQ) during the forecast period. 

• After eliminating sales exceeding the BTQ, the system eliminates from demand forecast in any sale 
exceeding the exceptional sale percent during the forecast period. 

• The system adds the remaining sales quantities together and divides the sum by the number of days 
in the forecast period. 

• This demand per day is then multiplied by 30 to produce a monthly demand. The system rounds up 
to the nearest unit. 

For example, Product A does not have a BTQ set. The exceptional sales percent equals 50%. Product A 
sells ten times in a forecast period of 365 days in the following quantities: 200, 100, 9, 8, 7, 6, 5, 4, 3, and 
2. The sale of 200, being 50% more than the second largest sale of 100, is considered exceptional and 
eliminated from demand forecasting. The system adds the remaining quantities together 
(100+9+8+7+6+5+4+3+2=144) and divides the sum by the days in the demand period (144/365=0.394). 
The system then multiplies the daily demand by one month to produce a monthly demand of 12 units 
(0.394*30=11.82). 

Consider that if Product A had a BTQ set to 100, the sale of 200 would be eliminated and the sale of 100, 
being 50% more than the second largest sale of 9, would be considered an exception and eliminated from 
demand forecasting. Adding the remaining quantities together (9+8+7+6+5+4+3+2=44), dividing by the 
days in the demand period (44/365=0.12), and multiplying by 30 days would produce a monthly demand 
of only 4 units (0.12*30=3.61). 

Median Forecasting Method 
• The system identifies and eliminates from demand forecasting, any sales exceeding the BTQ and 

the exceptional sale percent during the forecast period. 

• The system identifies the median quantity of the remaining sales and multiplies this quantity by the 
number of hits counted in the forecast period. 

• This daily demand is multiplied by 30 days to produce a monthly demand. The system rounds up to 
the nearest unit. 

For example, Product A does not have a BTQ set. The exceptional sales percent equals 50%. Product A 
sells ten times in a forecast period of 365 days in the following quantities: 200, 100, 9, 8, 7, 6, 5, 4, 3, and 
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2. The sale of 200 is proven to be exceptional and eliminated from demand forecasting. The median of the 
remaining quantities (100, 9, 8, 7, 6, 5, 4, 3, 2) is 6. The system multiplies the median quantity by the 
number of hits counted (6*9=54) and divided by the days in the forecast period (54/365=.148). The 
system then multiplies the daily demand by 30 days to produce a monthly demand of 5 units (.148 x 
30=4.4). 
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Including Direct Shipments in the Demand Calculation 
Include direct shipments from the vendor in the demand calculation for the product when the majority of 
your direct shipments are the result of not having enough of the item on the shelf. 

Forecast parameters set at the product level override those set at the branch or buy line level. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To include direct shipments from the vendor in demand calculations: 

1. Enter forecast parameters. 

2. In the Product Forecast Parameters dialog box, from the File menu, select Demand Parameters 
to display the Product Demand Parameters dialog box. 

3. From the File menu, select Insert Branch to display the Product Demand Parameters dialog box. 

4. In the Enter new branch or territory field, enter the branch or territory ID. 

5. Click OK to return the ID to the Branch field in the Product Demand Parameters dialog box. 

6. In the Include Directs column, enter Yes next to the branch or territory for which to include 
direct shipments in the demand calculation for the product. 

7. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 
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Viewing the Default Cost for Products 
If you have authorization, you can view the default cost used in the economic order quantity (EOQ) 
calculation for the product at the sales branch. This cost comes from Global Basis name matching the Dflt 
Cost Prompt, set in the Global Buy/Sell Basis Names control maintenance record. Assign costs to 
products through Product Price Sheet Maintenance or Price Line Maintenance. 

Users must the COST.VIEW and COGS.VIEW authorization key to view the default cost. Otherwise, the 
column displays asterisks (****). 

To view the default cost for a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

3. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

4. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

5. In the Enter hierarchy branch field, enter the branch or territory ID. 

Note: Use the Find option as necessary to locate a branch that is in the list, but not in the 
viewable area. Use Alt-Insert to add a branch or territory to the list. The new 
branch or territory inherits the settings of the previous entry. Use Alt-Delete to 
remove a branch or territory from the list. 

6. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

7. From the Edit menu, select Default Cost to display the Product Default Cost dialog box. 

8. Review the default cost for each branch. 

9. Click OK to exit the dialog box. 
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Advanced Demand Forecasting Overview 
By default, Eclipse uses standard and median forecasting when calculating demand to help you determine 
what products you need to purchase and how often you need to purchase them. Starting in Release 8.7.8, 
Eclipse provides additional, or advanced, forecasting methods to help you best determine how to 
categorize your products and thereby maximizing your purchasing power. 

Note: These forecasting methods are used in addition to the standard forecasting 
methods. This process is to complement the original process and help you 
determine the best forecast to use. 

Eclipse analyzes the product history to determine the demand by looking at minimum hits and history, 
smoothing factors, and automatic trends. Use the Advanced Demand Forecast Parameters control 
maintenance record to define these forecasting factors for the system to estimate future needs to create 
purchasing suggestions. Meaning, the current demand levels can be used to determine future demand. 

This means, Eclipse uses your selected group and goes back the number of weeks indicated in the 
Advanced Demand Forecast Parameters control maintenance record to gather the most recent sales 
history on your buy line or product set. The system stores the most recent 52 weeks' worth of data. Then, 
using that information applies your selected advanced forecast method. 

Smoothing Factors 
In forecasting inventory, smoothing refers to finding the demand by removing the random variations that 
may occur in the purchasing history. This helps determine demand patterns more accurately, so that you 
do not purchase for those exceptional sales or exceptional periods in the life of the warehouse. For 
standard forecasting calculations, this means taking an average of your sales. With Advanced Demand 
Forecasting, Eclipse applies base level, trend level, and seasonal level. In formalized forecasting manuals, 
this refers to Alpha, Beta, and Gamma factors. For ease of explanation we refer to them as Base, Trend, 
and Seasonal. 

• Base - Known as the Alpha factor. The recent demand period versus the prior demand period. This 
field must be set between 0.05 and 0.25. If left blank, the system uses 0.15. 

• Trend - Known as the Beta factor. Must be set between 0.05 and 0.25. If left blank, the system 
uses 0.15. 

• Seasonal - Knows as the Gamma factor. Must be set between zero (0) and 0.5. If left blank, the 
system uses 0.5. For example, if the seasonal score for this week is 100% of normal, but actual 
sales were 200% of normal, the forecast adjusts the score up for next year. A higher gamma means 
a higher adjustment. A gamma of .25 would in that instance have the score as 125% for the 
following year. 

Once calculated, Eclipse automatically calculates smoothing factors for each item. If the calculation is 
above the maximum value set in the Advanced Demand Forecast Parameters control maintenance record, 
then the system uses the control maintenance record values. 

Note: Eclipse uses weekly forecasts, meaning 52 weeks' worth of data. Due to this type 
of calculation, Eclipse limits your maximum smoothing factor values to prevent 
these factors from including outlying values. This keeps your smoothing factors 
addressing the most useful data and giving you the best values for managing 
trends. 
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The system uses the smoothing factor, the most recent period's calculated demand, and the most recent 
period's forecast to create and exponential smoothing calculation. This calculation takes into account the 
previous period and goes back in the demand periods for you and the output represents all the previous 
period demand. In Eclipse, the default is 24 months of product history, but it can use whatever history 
your company stores in the Eclipse files. 

Using the Advanced Demand Forecast Parameters control maintenance record enables you to customize 
the calculations for your business. 

In addition, the system can use those exceptional sales and help determine if they truly are exceptional or 
are actually seasonal product sales. For more information see How Eclipse Test for Seasonality below. 

How Eclipse Tests for Seasonality 
In order for Eclipse to know which advanced forecast method to apply, the system must first test your 
branches and products in combination for seasonality. This means, the system considers specific 
parameters or factors to determine if a product should be considered seasonal. By marking a product 
seasonal limits when you purchase the products. 

Eclipse uses the most recent years of history as defined in the Advanced Demand Forecast Parameters 
control maintenance record for every product and branch combination. 

The demand information is gathered four-week groupings culminating in thirteen groups per calendar 
year. Using this method avoids the influence variations in month length or weekday periods throughout 
the year. For example February, in comparison to other months, is 7-8% shorter. In addition, months of 
equal length, such as 30 days, can have an unequal number of weekdays depending on how the months 
fall in a calendar year. Eclipse then passes the calculated demand value through a Autocorrelation 
Function (ACF) to determine if the correlation over a one-year period and the 50% confidence level. The 
system then uses a moving average method for this time series and calculations. If the determined 
correlation is greater than 0.3 and outside the 50% confidence interval, the item is treated as seasonal. 

Note: The seasonal tests do not prove if an item is seasonal, but to show that is more 
likely seasonal than non-seasonal to have seasonal forecasting methods applied. 
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Setting Up Advanced Demand Forecasting 
Use the Advanced Demand Forecast Parameters control maintenance record to define these forecasting 
factors for the system to estimate future needs to create purchasing suggestions. Meaning, the current 
demand levels can be used to determine future demand. 

Enter the forecasting and seasonality levels you want to apply for advanced forecasting.  

Field Description / Options 
Forecasting • Min Hits - Minimum hits needed for an item to qualify for advanced demand 

forecasting. The system compares this to the current forecast period hits by branch to 
determine if this has been met. 

• Max Years History - This field must be set between 3 and 10 years. The more years you 
select the longer the forecast program may run, but the more years you use the more 
accurate your forecasting values. 

Note: You are restricted to the number of years' activity based on the Number Of Years 
Sales In PSUB File control maintenance record. 

Smoothing 
Factors 

• Max Level (Alpha) - This field must be set between 0.05 and 0.25. 
• Max Trend (Beta) -  This field must be set between 0.05 and 0.25. 
• Max Seasonal (Gamma) - This field must be set between zero (0) and 0.50. 
For more information about how smoothing factors work, see Advanced Demand 
Forecasting Overview. 

Seasonality • Min Hits - Enter the number of hits an item should have to be included in the seasonality 
pattern test. This number must be greater or equal to the Minimum Hits for Advanced 
Forecasting (above). 

• Min Months History - This field must be set between 13 and 36 months. 
• Exclude Seasonal Forecasts For Non-Seasonal Items - Select the items that are not 

flagged as seasonal and do not have seasonal trending that you want to exclude from the 
seasonal forecasting calculations. 

• Include Seasonal Forecasts For Non-Seasonal Items - Select to include all items in the 
seasonal forecasting calculations regardless of their classification. 

Important: Using this setting may increase the amount of time the system requires to run 
the Update Demand Forecast. 

Outcome of 
setting this 
control record 

Eclipse uses these settings to calculate demand forecast and seasonality testing. 

Default Value(s) Advanced Forecasting Defaults: 
• Min Hits: 10 
• Max History in years: 5 
• Max Alpha: 0.15 
• Max Beta: 0.15 
• Max Gamma: 0.5 

Advanced Forecasting Defaults for Seasonality: 
• Min Hits: 10 
• Min History in months: 24 

Dependencies Update Demand Forecast program should be addressed. 
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Field Description / Options 
Using the Exclude Negative Quantities From Item Demand Calculations control 
maintenance record will eliminate any negative quantities, but does not eliminate the 
system actually calculating a negative demand. This means if you use Holt or Holt-Winters 
and your sales have actually gone down over the specified period, the system will show a 
negative demand. 

Action if set to 
Null 

None. 

Additional 
Information 

Complete the Update Demand Forecast program. 
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About Advanced Forecasting Calculations 
Advanced forecasting calculations complement the current forecasting to help you delve more deeply into 
how your products should be managed for replenishment. The system looks through the sales history 
going back a specified amount of time. Eclipse uses your selected group and goes back 52 weeks to 
gather the most recent sales history on your buy line or product set. Then, using that information applies 
your selected advanced forecast method. The system records the values by product for each of these 
methods with the product's file. Demand Calculation Audit updates with the current method. 

Note: You can add advanced forecasting method results to a user-defined queue using the 
BR_BEST_FIT and BR_ADV_FRCST dictionaries. For more information about 
user-defined views and user-defined queues, see Creating User-Defined Views 
and Creating User-Defined Queues. 

See Assigning Advanced Demand Forecast Methods to indicate which method you want to use. 

Single Exponential Smoothing Method 
In forecasting inventory, smoothing refers to finding the demand by removing the random variations that 
may occur in the purchasing history. This helps determine demand patterns more accurately, so that you 
do not purchase for those exceptional sales or exceptional periods in the life of the warehouse. For more 
information about smoothing factors, see How Advanced Demand Forecasting Works in this 
documentation. 

The simplest form of exponential smoothing is given by the following formula: 

 
Where α  is the smoothing factor and 0 < α  < 1.  This means that the smoothing is a weighted average of 
the previous data and the previous smoothed statistic. For Eclipse, this means the system uses the 
previously calculated smoothing factor and the previously calculated demand within the specified time 
frame and uses the average to determine the demand. Exponential refers to the fact that you use the 
smoothing factor back into itself on each subsequent demand calculation. Therefore, it changes 
exponentially. 

Holt Method 
The Holt method calculates the same way as the single exponential smoothing, but calculates using the 
trending factor in addition to the smoothing factor. The formula calculations are as follows: 
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Holt-Winters Method 
The Holt-Winters method calculates the same way as the standard Holt method, but uses seasonality in 
addition to the since exponential smoothing and trending factors. To initialize the Holt-Winters 
calculations, the system uses back-casting. This allows the system to handle a wider variety of sales 
patterns without producing inaccurate forecasts. 

The year is broken into 52 buckets, or 52 weeks' worth of data. For Holt-Winters, each bucket is adjusted 
according to its seasonal score. This means the system provides a "at this time of year, the sales are x% of 
normal." The seasons score for that bucket is updated according to the gamma value.  

For items that pass the seasonality test, the system runs the Holt-Winters method. 

 
Note: Holt-Winters calculations are not made with less than three years demand history. 

Monthly Demand Calculations 
For both Single Exponential Smoothing and Holt methods, the system uses a weekly demand divided by 
seven multiplied by 30 to get the monthly demand value: 

monthly demand = (weekly demand / 7) x 30 

For Holt Winters method, because the forecast is more than a single week, Eclipse uses four 2/7ths of a 
week and make that the monthly demand. Eclipse divides that value by 30 to find the daily demand. 

Best Fit Calculations 
Runs as if the product is set to standard method for each method (above) individually and without relying 
on information from the other calculations. For more about how the system creates and manages best fit 
calculations, see How Eclipse Calculates Best Fit. 
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Using Advanced Update Demand Forecasting 
Advanced Update Demand Forecasting does not replace the current, standard and median Eclipse 
forecasting methods or the standard Update Demand program. These calculations complement the current 
forecasting to help you delve more deeply into how your products should be managed for replenishment. 
The system looks through the sales history going back a specified amount of time. 

Eclipse calculates demand, finds the current forecast, and then applies the new forecasting. By default, the 
system uses a 5-year period to calculate demand unless a value is set in the Advanced Demand Forecast 
Parameters control maintenance record. Eliminates slow moving items that would not generate accurate 
demand. Smoothing factors for calculating the forecast behind-the-scenes then populate the factors after 
running the program. With the new methods the system tests seasonality on all products that meet the 
minimum hits and minimum history for the calculations. By default, the system uses 24 months. Then, 
Eclipse uses your selected group and goes back the number of weeks indicated in the Advanced Demand 
Forecast Parameters control maintenance record to gather the most recent sales history on your buy line 
or product set. 

Important: If running the advanced forecasting for all products or all branches, we recommend 
running the calculations off-hours so as not to impact system performance. If 
running the forecast for a single product or branch, system performance should not 
be affected. 

Set these parameters using the Advanced Demand Forecast Parameters control maintenance record. 

For more information about advanced forecasting methods, see About Advanced Forecasting Methods in 
this documentation. 

To run the advanced update demand program: 

1. From the Purchase > Forecasting menu, select Update Advanced Demand Forecast to display 
a selection list. 

2. In the Select Group field, select one of the following: 

Option Selects... 
All* All products in inventory. 
Changed* Only those products that have sold since the last time you ran the Update Forecast 

Demand program. 
The system also tests products that, in a given period of time, have decreased in sales 
activity as compared to the average period between past sales. The system does this to 
include products in the "changed" group that might be experiencing a decrease in 
demand. 

Buy Line Only those products within a buy line. This option activates the Line or Product field, 
where you define the buy line. 
Use this option when you know that significant changes have been made to the 
products in a given buy line. 

Product Only a specified product. This option activates the Line or Product field, where you 
define the product. 
For example, if you correct an error on a transaction that affects a product's sales 
history, use this option to recalculate the product's demand. 

* If you select Changed or All, the Line / Product field does not display. 
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3. In the Branch field, enter a branch to define the branches for which to run the update. To run the 
report for all branches, enter All. 

4. In the Line / Product field, enter the specific buy line or product for which you want to run the 
forecasting. 

Note:  The field name changes based on your selection in the Select Group field.  

5. In the As of Date field, enter the actual or system variable date on which the forecast is based. 

Note: When using the Phantom Scheduler to run a program at regular intervals, enter a 
variable date in this field; otherwise, each time the program runs, it will use the 
same as of date you enter now. 

6. Select the forecast method or methods you want to use for advanced update demand: 

Note: Current forecasting methods cannot be deselected. 

• Single Exponential Smoothing - Standard smoothing factors for forecasting. 

• Holt - The standard smoothing and includes trending calculations. 

• Holt-Winters - The standard smoothing and trending calculations, and adds seasonality 
calculations. Holt-Winters calculations are not made with less than three years demand history. 

Note: For more information about these methods and their calculations, see About 
Advanced Forecasting Methods in this documentation. 

6. Set the Auto Set Best Fit field to Yes to automatically use the best fit method for advanced 
demand forecasting. The report indicates this setting in the header of the report. 

7. Do one of the following: 

• From the File menu, select Begin to run the program immediately. You can also use the 
Run button to run the calculations immediately. 

• From the Options menu, select Schedule to display the Phantom Scheduler, where you can 
schedule the program to run at a defined date and time. 
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Analyzing Advanced Demand Forecast Methods 
After running the Advanced Demand Forecast Program, you can retrieve visual results using the 
Advanced Demand Forecast Analysis. The analysis provides the results for each selected for product or 
line and the selected methods. 

You can use this information to study the difference between the demand calculated by the current 
method compared to the demand that would be used with other forecast methods and if the advanced 
demand forecast is a more viable or reliable solution. you can use the table display that Eclipse provides, 
or graph the forecast or sales options, to review the information more closely. 

You can run the forecast programs and display this information based on the last forecast that was run. 
After running your demand program, the system alerts you that the program is complete. You can then 
review the latest information through the Advanced Demand Forecast Analysis window. 

Note: Eclipse uses the closest Saturday before the day when the report runs. The system 
considers the As of Date (that Saturday) to be the Date Last Calculated from the 
audit window. Therefore the Date Analyzed field matches the date the report 
runs. 

Important: If the seasonality test of a product fails without returning an ACF score or if a product has 
less hits than the minimum hits to test seasonality as defined in the Advanced Demand 
Forecast Parameters control maintenance record, then the system calculates a standard 
demand forecast. Meaning, no advanced demand forecast calculations are made on the 
product. You can check this information by using the audit screen in Primary Inventory 
Maintenance. 

To analyze your demand forecast methods: 

1. From the Maintenance menu, select Product to display Product Maintenance. 

2. In the Product field, enter the product or line you want to review. 

3. From the Inventory menu, select Primary Inventory Maintenance. 

4. From the Edit menu, select Advanced Demand Forecast Analysis. 

5. Use the Inquiry menu to do one of the following: 

• Display weekly and monthly calculated values for the selected product in the selected branch. 

• Display the Product Sales History. 

These options display in new windows. 
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About the Analysis Window 
The Analysis window is broken into sections so you can see at-a-glance what your current forecast 
method looks like compared to what is determined a best fit, or other forecasting methods. 

Important: Using the Exclude Negative Quantities From Item Demand Calculations control 
maintenance record will eliminate any negative quantities, but does not eliminate the 
system actually calculating a negative demand. This means if you use Holt or Holt-
Winters and your sales have actually gone down over the specified period, the system will 
show a negative demand. 

  

 
Following are the sections and options available in the Advanced Demand Forecast Analysis window: 

Number 
/ Section Description 

1 Description of the product for which you have run the Advance Demand Forecast. 
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Number 
/ Section Description 

2 If running for a product, the Buy Line the product is contained in, indication if you have the product 
marked as seasonal, the current Vendor Target, and the date the product was analyzed. 

3 ACF Scores. Auto-correlation Function. Displays visually how the seasonal and non-seasonal scores 
were determined. For more information, see About ACF Scores below. 

4 Product image, if available, as entered in the product maintenance file. 
5 The Saturday date for the last full week of sales. 

6 Option to exclude the product when the update forecast method selected calculates demand based on 
when Eclipse forces the Advanced Demand Forecast best-fit analysis. 

7 

For each forecast method, both current and advanced, the system displays the following values: 
• Mean Squared Error (Annual) - The metric that compares actual sales to past forecasted demand. 

For more information, see How Eclipse Calculates Best Fit  in this documentation. 
• Daily Demand - The current daily demand the system determined when running demand 

forecasting.. 
• Monthly Demand - The current monthly demand the system determined when running the demand 

forecast. 
• Best Fit - The system selects the forecast method that best fits the product sales using the Mean 

Squared Error. The lowest mean squared error considering the most recent year, makes it the best 
fit. For more information, see How Eclipse Calculates Best Fit in this documentation. 

• Current Method - Indicates the current forecast method you are using for the selected product. 
If a row displays as blank, that forecast method was not selected to calculate demand in the Advanced 
Demand Forecast setup parameters. 

8 

Graphing options for the selected forecast methods. Select from the following: 
• Current & Best Fit Methods - Graphs only your current forecast method and the best fit analysis. 
• All Methods - Graphs all values as displays regardless of selected methods. 
• Weekly / Monthly - Indicate which values you want to display the last week or the last month's 

forecasting. 
• Graph It - Click to display the graph. 

9 

Graphing options for the selected sales. Select from the following: 
• Weekly / Monthly - Indicate which values you want to display the last week or the last month's 

sales. 
• Years to Display - Indicate the number of previous years for which you want to display 

information. 
• Graph It - Click to display the graph. 

About ACF Scores 
The auto-correlation function (ACF) displays visually how the seasonal and non-seasonal scores were 
determined. Calculating your seasonal items is vital to maintaining your warehouse stock. While 
forecasting is never perfect, the ACF scores helps you see how Eclipse has calculated your seasonal 
products to you can better plan and prepare. 

The ACF chart represents time spans depending on how you have the Advanced Demand Forecast 
Parameters control maintenance record parameters set.  

The graph provides a visual to see where in the seasonality spectrum your products are falling. You can 
then address the Advanced Demand Forecast Parameters, if you feel that the results are not accurate. 
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To view the ACF score: 

1. From the Maintenance menu, select Product to display Product Maintenance. 

2. In the Product field, enter the product or line you want to review. 

3. From the Inventory menu, select Primary Inventory Maintenance. 

4. From the Edit menu, select Advanced Demand Forecast Analysis. 

5. Next to the ACF Score field, click the question mark icon to display the graph. 
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How Eclipse Calculates Best Fit 
Eclipse calculates demand forecasting on a regular basis. With the advanced forecast methods, you may 
not know which of the advanced methods historically is closest to the actual sales. The traditional Eclipse 
forecasting is a flat demand-per-day calculation. The Advanced Demand Forecasting Analysis window 
displays these best fit selections. 

To know whether or not you are using the best forecast method for your products, Eclipse runs on stock 
products you select, such as specific buy line, and allows you to compare your previous demand forecast 
to what the system calculates as the best fit. The system runs as if the product is set to standard method 
for each method individually and without relying on information from the other calculations. 

Eclipse uses a Mean Squared Error (MSE) calculation to determine the best fit demand forecast for your 
product(s). 

(Sales - Forecast)2 

This MSE compares the past 52 weeks of demand forecast to actual sales. If the system does not find 52 
weeks worth of data, the system uses as many weeks as are available. For each available week, the lowest 
calculated MSE is the best fit. 

Automatically Assigning Best Fit Calculations 
Use the Auto Set Best Fit option on the Advanced Demand Forecasting window to automatically use the 
best fit calculation for the selected products. This means if Eclipse finds that a different forecast method is 
a better fit for a specific product or product line, then the system overrides that forecast method over the 
one that has been selected. These settings are at the branch level. Review your product settings carefully 
before using this option. 

Run the demand for each week back for 52 weeks for each demand forecast method to get a full year's 
worth of information for comparing the values. The system then performs the same check for the three 
advanced methods. The system can then display which of the six methods is a best fit for your demand 
forecasting. 

Note: Eclipse considers a standard week for calculations is Sunday to Saturday. 
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How the System Filters Demand for Forecasting 
Demand is a filtered forecast of products being sold to the customers. The calculation of demand answers 
this question: "How much of the product is being demanded by customers?"  eliminate exceptional sales. 

Note: If the Enable Exclusion Of Matrix Cells From Demand Calculations control 
maintenance record is set, the system excludes products priced using sell matrix 
cells flagged for exclusion in the demand calculation.   

To produce a clean data sample for the demand forecast calculation, the system does the following in the 
order listed: 

• Examines all sales occurrences within a data sample to use for a forecast period, based on the 
Demand Hit Definition control maintenance record, and determines the largest sale of an item. 

• Examines the remaining sales occurrences in the data sample and determines whether the largest 
sale exceeds the Excpt % (Exceptional Sales Percent) value. If so, the system does not use the 
largest sale in the data sample. 

• Examines all sales occurrences for the item and eliminates those sales exceeding the Back Order 
Tolerance Quantity (BTQ) value. 

For example, use a BTQ for promotional sales when you require customers to purchase the item 
in large quantities. The BTQ prevents these large purchase quantities from being considered in 
the demand forecast calculation. 

• Compensates for lost sales and applies any identified trend. 

• Uses the remaining sales occurrences with the chosen Forecast Method as the data sample to 
calculate item demand. 
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Customer Demand 
Demand is a filtered forecast of products being sold to the customers. The calculation of demand answers 
this question: "How much of the product is being demanded by customers?" 

The system uses demand calculation to set order points, line points, and transfer points. In addition, 
demand determines surplus for the Suggested Purchase Order Queue and the Suggested Auto Transfer 
program. 

For more information on order and line points, see the following topics: 

• Order Points and Line Points Overview 

• How the System Calculates Order Points 

• How the System Calculates Line Points 

Demand is calculated when the Update Demand program runs. You can audit the Update Demand 
program by accessing an individual product in the Product Maintenance window. 

This topic provides information about the following: 

• Demand History Period 

• Using the Add Demand Window 

• Using Demand Override 

Demand History Period 
To determine the amount of sales history to use to calculate demand, the Update Demand program first 
determines the number of hits for each product in each branch. 

Then, the following rules apply to establish the amount of sales history appropriate to a product's rate of 
sale. 

If a product has... then... 
25 or more hits in the past 91 
days the system uses the sales of the last 91 days to determine usage. 

less than 25 hits in 91 days 
but more than 25 hits in the 
past year 

the system totals the sales back to the occurrence on the day of the 25th hit. 

If more than one hit occurred on the day of the 25th hit, all sales on that day are 
included. 

less than 25 hits in the past 
year the sales for the past year are totaled together. 

Items that sell frequently are more predictable over short periods of time. By setting the Seasonal field to 
using Mass Load, you can identify items that have a seasonal sales character. The same rules apply to 
seasonal items, except that the system starts from a date beginning one year previous and moving forward 
to the present date. 

Using the Add Demand Window 
Use the Add Demand window to add the demand history of one or more discontinued products to its 
replacement product or add a product's demand history in one branch to another branch. For example, you 
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receive notice from your vendor that the furnace Model 721A is being replaced with Model 721B. You do 
not want to lose the sale history for the furnace. Transfer the demand history from the discontinued model 
to the new model. 

Note: The Days Out calculation remains the same even if the customer is a Subtract 
Demand Customer as set up in the Add Demand program. 

To display the Add Demand window: 

1. From the File menu, select Product. 

2. Enter the number of the product for which you want to view the Add Demand window. 

3. From the Inventory menu, select Inventory Maintenance to display the Product Maintenance 
window. 

4. From the Edit menu, select User Controls to display the Primary Inventory Maintenance 
window. 

5. From the Additional Controls menu, select Add Demand to display the Add Demand window. 

• Use the Branch Fields Required To Add Product Demand control maintenance record to 
limit the branch fields you want the Add Demand program to use.  

• Use the Do Not List Item More Than Once On Add Demand Screen to indicate if you want 
to list products more than once on the Add Demand window.  

6. Update the demand information as needed and exit the window to save your changes. 

7. Exit the Product User Control Parameters window. 

8. Exit the Primary Inventory Maintenance window. 

9. Save your changes and exit the window. 

For more information, see Adding Demand History to Products and Adding the Demand from a 
Dependent Selling Branch to a Purchasing Branch. 

Using Branch Demand Override 
The Assign Demand Forecast To Price/Ship Branch Or By Zip Code control maintenance record 
defines where the demand should flow. For example, if you have an order that is a pricing branch 1 and a 
shipping branch 2, you need to decided if  the replenishment of that product goes to branch 1 or 2. 

You can override this setting at the customer level. Use Miscellaneous Customer Information to change 
the Branch Demand Override field to the selected branch. If this field is not set, the system uses the 
setting at the control maintenance level. 

To change the Branch Demand Override: 

1. From the Maintenance menu, select Customer to display the Customer Maintenance window. 

2. In the Customer/New field, enter the customer name for which you want to override the branch 
demand and press Enter to display the customer record . 

3. From the Additional menu, select Additional Customer Information. 

4. In the Branch Demand Override/UET Parameters area, enter the branch number you want to 
use in the Branch Demand Override field. 
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5. Save your changes and exit the window. 

6. Exit the Customer Maintenance window. 
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Managing How the System Applies Demand 
One of the biggest assets to how the purchasing process works is the way the system calculates demand 
based on products purchased and sold. The demand is a filtered forecast of products being sold to the 
customers. The calculation of demand answers this question: "How much of the product is being 
demanded by customers?" The system uses this calculation to help you project what to buy and how to 
replenish your warehouses. 

For information about additional forecasting methods, see How Standard and Median Forecasting Works 
and Advanced Demand Forecasting Methods. 

However, you must decide who gets the credit for the demand that the system calculates. Should the 
demand be credited to the branch who prices the product, ships the product, or the region from which the 
product sells? 

Use the Assign Demand Forecast To Price/Ship Branch Or By Zip Code control maintenance record 
to indicate how you want to apply the demand credit. 

If you use the pricing branch or the shipping branch, the system applies the demand calculated to the 
branch indicated. If you select Zip Code, then the system uses Branch Zip Code Maintenance to 
determine how to apply the calculated demand. You can group zip codes into regions and apply the 
demand results to areas rather than narrowing it down to a particular branch. For example, you can group 
all your branches in Florida in one group and apply the demand to them all by associating them with a 
single branch. 

To set up the zip code branch maintenance table: 

1. From the Maintenance > Zip Code menu, select Branch Zip Code Maintenance to display the 
Branch Zip Code Maintenance window. 

Note: If prompted, log on to the character-based system. 

2. In the Starting Zip Code column, enter the zip code with which you want to start the range, such 
as 32000. 

3. In the Ending Zip Code column, enter the zip code with which you want to end the range, such 
as 32999. 

4. In the Br column, assign a branch to which you want to associate the zip codes indicated, such as 
2. 

5. Press Esc to apply the codes you have indicated. 
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Adding Demand History to Products 
Use the Product User Control Parameters to add demand from one product to another. You can copy 
existing demand history from one or more products to a new product with the Add Demand window. 
Demand history can be in units, weight, or load factor depending on the item and need. This choice 
enables you to create demand history for new product when: 

• A new product replaces a discontinued product. You can assume that the demand for the new item 
is similar to that of the old item. For example, you Product A Model 100 is being replaced by 
Product A Model 200. Use the demand for the old product to predict the demand of the new 
product. 

Note: Change the discontinued item's product status to something other than Stock. 
Otherwise, the system continues suggesting that you purchase both items. 

• A new product is sold that combines several items. The demand of the multiple products is totaled 
and added to the new product. For example, you sell individual tools. You now provide three tools 
in a one set. Use the demand for the individual tools to calculate the history for the set. 

• You must know how much material one product uses from its component parts. Copy the demand 
history based on the relationship between the components over to the finished product. For 
example, you must know how much sheet metal to order to manufacture duct work. By combining 
the monthly demand in weight of your duct-work components, you can estimate how much sheet 
metal you need each month. 

Use the Add Demand dialog box to: 

• Add the demand history of one or more discontinued products to their replacement. 

• Add a product's demand history in one branch to another branch. 

• Add or subtract a customer's demand history from one product to another. 

To add demand history to a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box 

4. From the Edit menu, select User Controls to display the Product User Control Parameters dialog 
box. 

5. From the File menu, select Hierarchy to display the Product User Control Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

8. From the Additional Controls menu, select Add Demand to display the Add Demand dialog 
box. 

Note: Use the Branch Fields Required To Add Product Demand control maintenance 
record to limit the branch fields you want the Add Demand program to use.  
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9. In the Include the following products' demand with the product above based on field, enter 
one of the following measurement types: 

• Units - Includes demand based on the number of items. 

• Weight - Includes demand based on the weight, in pounds, of the item. 

• Load - Includes demand based on the load factor for the item. 

10. Complete the following fields for each product from which to add demand: 

Field Description 
Products The product from which to copy demand history to the new product 

Use the Do Not List Item More Than Once On Add Demand Screen to indicate if 
you want to list products more than once on the Add Demand window.  

Expire Date The date after which to stop adding the demand of the product to the demand of the 
new product. 

To Branch The branch that will use the demand history. 
From Branch The branch from which to obtain the demand history. 

Add PIL Select if you want the projected inventory level (PIL) of the old product to flow 
through to the replacement product. 
When you add the demand of another product to a new or replacement product that 
has no inventory, the system purchases the replacement product before you have 
sold off what is left of the old product. Using the Add PIL option stops the 
replacement product from being suggested to purchase. As the PIL of the old 
product is reduced then the replacement product comes up to purchase once it is 
below the order point. 

Note: The PIL of the replacement product displays in bold after selecting this 
option. 

11. Add or change a customer's demand for a product, as needed. 

12. Save the information and exit the dialog box. 
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Filtering Demand for Exceptional Sales 
Use the exceptional sales percent inventory parameter in Product Maintenance to identify an exceptional 
sale. The system eliminates from demand forecasting any sale exceeding the percentage amount between 
the largest sale and the next largest sale in the forecast period. 

For example, an exceptional sales percent of 50 would flag any sale with a quantity that is 50% more than 
the quantity of the second largest sale. If the largest sale was 13 and the second largest sales was 8, any 
quantity greater than 12 becomes an exceptional sale. Therefore, 13 would be considered exceptional and 
not be included in the demand calculation. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To set inventory parameters for identifying exceptional sales: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

5. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

8. In the Exceptional Sales % column, enter a percentage for the branch or a territory. 

For items that sell... To eliminate exceptional sales, use a... 
Frequently Higher percentage 
Infrequently Lower percentage 

9. Enter other forecast parameters, if needed. 

10. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 
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Setting the Backorder Tolerance Quantity 
Use the backorder tolerance quantity (BTQ) to exclude orders with unusually large quantities of the 
product -- even larger than exceptional sales -- from the demand calculation. This value is the maximum 
order quantity for the product on one order. Any order with a quantity greater than this amount is 
excluded from the demand calculation. 

When filtering orders for the demand calculation, the system first eliminates from the demand calculation 
those orders with products above the BTQ, before determining whether an order qualifies as an 
exceptional sale. Unlike the exceptional sales inventory parameter, which changes depending on the 
second largest sale made in the forecast period, the BTQ is a fixed amount. 

For example, Product A normally sells 1 or 2 each per month. The exceptional sales inventory parameter 
is set to 200% and the backorder tolerance quantity is set to 6. A contractor orders a quantity of 24 of 
Product A for a large job, and schedules shipments in groups of 8 every month for the next 3 months. 
Whether you define hits by the order (one order of 24) or the generation (3 generations of 8), the system 
does not consider this order when calculating demand. Furthermore, consider that to be an exceptional 
sale, the highest order quantity must be 200% of the second highest order quantity, AFTER eliminating 
orders greater than the BTQ. Therefore, any sale of Product A in a quantity over (6 / 200% = 3) 3 is 
considered exceptional. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To set the backorder tolerance quantity for identifying exceptional quantities: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

5. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

8. In the BTQ column for each branch, type in the maximum order quantity considered normal for 
this product. 

9. Enter other forecast parameters, if needed. 



Solar Eclipse Forecasting 

45 

Marking Processed Orders as Exceptional 
Mark orders that have shipped or invoiced as exceptional so that the system does not include them in the 
demand calculation. Not marking orders as exceptional can distort your demand calculations. Use the 
Inventory History Ledger window to flag order generations as exceptional sales that might have been 
missed during order creation. 

Note: You must have the OE.PRODUCT.TYPE.EDIT authorization key assigned to 
change stock transactions to exceptional in the Inventory History Ledger window. 

Direct shipments do not affect the demand forecast calculation. You cannot flag direct shipment order 
generation as being an exceptional sale generation because the inventory does not come into your 
warehouse. 

To mark an entire order as exceptional from the order, see Entering Additional Sales Order Header 
Information in the Sales Management online documentation. 

To indicate a processed order as being exceptional: 

1. From the Orders > Inquiries menu, select Inventory History Ledger to display the Inventory 
History Ledger window. 

2. In the Product field, enter the product for which to view transaction history. 

3. For each exceptional sale, in the Type column, select the transaction to flag as exceptional and 
enter Except. 

4. Exit the window to save the changes. 
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Marking Sales Orders as Exceptional 
On new or existing sales orders, you can flag either entire order generations or individual line items as 
being exceptional sales. 

Direct shipments do not affect the demand forecast calculation. You cannot flag a direct shipment order 
generation as being an exceptional sale generation because the inventory does not come into your 
warehouse. 

To indicate that an entire order generation is an exceptional sale: 

1. From the Orders menu, select Sales Order Entry to display the Initial Order Entry dialog box. 

2. Display the sales order for which to mark generations or line items as exceptional. 

3. Click the Header tab to display the header view. 

4. From the Edit menu, select Additional Information to display the Additional Header 
Information dialog box. 

5. Select the Exceptional Sale check box. 

6. Save the information and exit the dialog box. 

The system now considers all items related to this order generation to be exceptional sales. When 
the order is processed, the stock location code for the exceptional sale items change from S 
(Stock) to E (Exceptional). 

To indicate that an individual line item is an exceptional sale: 

1. From the Orders menu, select Sales Order Entry to display the Initial Order Entry dialog box. 

2. Display the sales order for which to mark generations or line items as exceptional. 

3. Click the Detail Scheduling tab to display the scheduling view. 

You cannot flag tagged quantities as exceptional sales. 

4. From the Options > Line Options menu, select Schedule to display the Line Item Scheduling 
dialog box. 

5. In the Qty Type column for a ship date that corresponds with a ship quantity, enter E 
(Exceptional). 

The system now considers this line item to be an exceptional sale. 

6. Save the information and exit the dialog box. 
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Marking Purchase Orders as Exceptional 
On new or existing purchase orders, you can flag either entire order generations or individual line items as 
being exceptional. The system omits the exceptional purchase order from the lead factor median 
calculation. This omission is useful when procuring stock from a source with a shorter lead time that 
might distort the calculated lead time of your regular vendor. 

Direct shipments do not affect the demand forecast calculation. You cannot flag direct shipment order 
generation as being an exceptional generation because the inventory does not come into your warehouse. 
For more complete information, see Including Direct Shipments in the Demand Calculation. 

To indicate that an entire order generation is an exceptional sale: 

1. From the Purchase menu, select Purchase Order Entry to display the Initial Order Entry 
window. 

2. Display the purchase order for which to mark generations or line items as exceptional. 

3. Click the Header tab to display the Purchase Order Entry Header dialog box. 

4. From the Additional menu, select Additional Header Info to display the POE Additional Data 
dialog box. 

5. In the Exceptional Order field, enter Yes. 

6. Click OK to exit the dialog box. 

The system now considers all items related to this order generation to be exceptional purchases. 
When the order is processed, the stock location code for the exceptional sale items change from S 
(Stock) to E (Exceptional). 

To indicate that an individual line item is an exceptional sale: 

1. From the Purchase menu, select Purchase Order Entry to display the Initial Order Entry 
window. 

2. Display the purchase order for which to mark generations or line items as exceptional. 

3. Click the Detail Scheduling tab to display the Purchase Order Entry Scheduling view. 

You cannot flag tagged quantities as being exceptional purchases. 

4. From the Options > Line Options menu, select Schedule to display the Line Item Scheduling 
dialog box. 

5. In the Type column for a received date that corresponds with a order quantity, enter E 
(exceptional). 

The system now considers this line item to be an exceptional purchase. 

6. Save the information and exit the dialog box. 
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Lost Sales Overview 
A lost sale occurs when a customer wants to purchase an item, but there is insufficient stock to fulfill the 
request and the customer does not want to place a backorder or calls to cancel an order that has been 
placed. The system can calculate out-of-stock periods, estimate the lost sales during these periods, and 
increase demand to prevent future lost sales. 

For example, an item is out of stock for one month out of the last six months. During the last six months, 
the product sold an average of 100 units per month when the item was in stock. The system estimates that 
100 more could have been sold in the month that the item was out of stock. 

The system also provides a lost sales parameter which helps prevent accumulating surplus inventory. For 
example, a run on inventory causes 30 days supply of an item to sell out in one day. You do not want the 
system to estimate that 30 days supply could be sold in the 29 days the item was out of stock. 

Therefore, the system selects the lesser of two values when calculating lost sales and increasing an item's 
demand: 

• The number of days the item was out of stock during the forecast period. 

• The lost sale parameter multiplied by the number of days in the forecast period. That is, use a 
percentage of the forecast period as the maximum number of days to count as lost sales days. 

For example, in the last 180 days, an item was out of stock for 30 days. The lost sales parameter is 50%. 
50% of 180 days is 90. Because 30 is less than 90, the system uses the 30 out-of-stock days to calculate 
lost sales. 

On the other hand, suppose there was a run on inventory: in the last 180 days, the item was out of stock 
for 150 days. A lost sales parameter of 50% limits the system to using 90 days of the forecast period to 
calculate lost sales. 

When setting the lost sales parameter, consider whether the item sells often and you do not want to be out 
of stock. For fast-moving items, the system uses shorter forecast periods, so use a higher lost sales 
parameter. The system is more likely to select the actual out of stock days and increase demand. 

On the other hand, for slow-moving items, the system uses longer forecast periods, so use a lower lost 
sales parameter. If it is acceptable for the item to be out of stock, the system is more likely to select a 
percentage of the forecast period and decrease demand. 

Preventative measures to eliminate lost sales through inventory parameters differ from tracking lost sales 
through the unquality event tracking (UET) system. Eliminating lost sales affects the forecast demand 
calculation, automated purchasing, and transfers. Tracking lost sales is a sales analysis tool. 
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Increasing Demand to Compensate for Lost Sales 
Enable the lost sales calculation by using the Lost Sale field on the Forecast Parameters window. We 
recommend setting the parameter according to item demand, using one of the following: 

• A higher percentage (80) to increase item demand and compensate for lost sales during out-of-
stock periods. This increase guards against future lost sales on fast-moving items. 

• A lower percentage (20) to limit the increase in item demand of slow-moving items during out-of-
stock periods. This limitation prevents over-purchasing and stock surplus. 

• Zero (0) where you cannot guarantee inventory accuracy for the product or you have less than six 
months of product history. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To assign a lost sales percentage to a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

5. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

8. In the Lost Sales column, enter a lost sale percentage for the branch or territories. 

9. Enter other forecast parameters, as needed. 

10. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 
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How the System Determines Lost Sales for Fast-Moving 
Items 
Fast-moving items with high demand have shorter forecast periods. For items that sell every day, you 
want to include the demand of any day that the item was out of stock to prevent future lost sales. The 
percent that you set determines the number of days by which the system recommends to increase demand. 

To ensure that you are counting the days the item is out of stock, set the Lost Sale parameter to a higher 
percentage. 

The system eliminates exceptional sales from the demand calculation before including lost sales in the 
demand forecast. 

Example 
The system uses the lesser of one of the following values to increase the item's raw demand: 

• The number of days that the item was out of stock during the forecast period. 

• The Lost Sale percentage multiplied by the number of days in the forecast period. 

Compare the effect of two different Lost Sale percentages for fast-moving items: 

Days out of 
stock 

Forecast 
period 

Lost Sale 
percentage 

Forecast period Lost 
Sale % 

Increase item demand 
by... 

25 days 90 days 80 72 days 25 days 
25 days 90 days 20 18 days 18 days 

By setting the Lost Sale percentage to a higher value for fast-moving items, the system increases demand 
by the days the item was out of stock, thereby avoiding future lost sales. 
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How the System Determines Lost Sales for Slow-Moving 
Items 
Slow-moving items with low demand have longer forecast periods. For items that sell only a few times a 
year, you want to keep only the average sale quantity in stock and replenish them when needed. You 
replenish these items when you are ready to purchase them as part of a line buy. The percent that you set 
determines the number of days by which the system recommends to increase demand. 

If you count all the days that a slow-moving item is out of stock as lost sale days and increase the item's 
raw demand, the item demand increases beyond its average sale quantity. This increase results in an 
unnecessary stock surplus. To prevent this, set the Lost Sale parameter to a lower percentage. 

The system eliminates exceptional sales from the demand calculation before including lost sales in the 
demand forecast. 

Example 
The system uses the lesser of one of the following values to increase the item's raw demand: 

• The number of days that the item was out of stock during the forecast period. 

• The Lost Sale percentage multiplied by the number of days in the forecast period. 

Compare the effect of two different Lost Sale percentages for slow-moving items: 

Days out of 
stock 

Forecast 
period 

Lost Sale 
percentage 

Forecast period 
Lost Sale % 

Increase item 
demand by... 

100 days 365 days 80 292 days 100 days 
100 days 365 days 20 73 days 100 days 

By setting the Lost Sale percentage to a lower value for slow-moving items, the system increases demand 
by a percentage of the forecast period, thereby avoiding a stock surplus. 
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Enabling Automatic Trend Calculations 
For seasonal products, use an automatic trend calculation to moderate the demand forecast. The system 
calculates and applies a trend based on recent demand compared to the previous year's demand. Trend is 
represented as a percentage increase or decrease to the calculated demand. 

Define the automatic trend parameters in the Product Auto Trend Percentage Maintenance dialog box. 

In addition to setting automatic trend parameters at the product level, you can also set these parameters at 
the branch or buy line level. Parameters set at the product level override those set at the buy line and 
branch level. 

Note: The following procedure is a manual process for a single product. Use the Mass 
Load program to enter inventory parameters to groups of products. 

To enter forecast period parameters for a product: 

1. Enter forecast parameters. 

2. In the Product Forecast Parameters dialog box, from the File menu, select Demand Parameters 
to display the Product Demand Parameters dialog box. 

3. From the File menu, select Insert Branch to display the Product Demand Parameters dialog box. 

4. In the Enter new branch or territory field, enter the branch or territory ID. 

5. Click OK to return the ID to the Branch field in the Product Demand Parameters dialog box. 

6. In the Auto Trend column, enter Yes next to the branch or territory for which to calculate trend 
for seasonal products. 

7. From the Edit menu, select Auto Trend to display the Product Auto Trend Maintenance dialog 
box. 

8. From the File menu, select Insert Branch to display the Product Auto Trend Maintenance dialog 
box. 

9. In the Enter new branch or territory field, enter the branch or territory ID. 

10. Click OK to return the ID to the Branch/Terr field in the Product Auto Trend Maintenance 
dialog box. 

11. Complete the following fields: 

Field Description 

Max Decrease % 
The maximum negative trend to apply to the demand forecast for the 
product. This parameter only applies to seasonal products with the 
Auto Trend flag enabled. 

Max Increase % 
The maximum positive trend to apply to the demand forecast for the 
product. This parameter only applies to seasonal products with the 
Auto Trend flag enabled. 

12. Save the information and exit the window. 

Changes take effect when you exit Product Maintenance. 
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Seasonal and Non-Seasonal Products 
Demand patterns for products that sell an average of ten times a month are different than those for 
products that sell an average of ten times a year. Items that are seasonal have a greater demand at certain 
times of the year than others. 

Non-Seasonal Products 
The system calculates the demand history based on hits. The system defaults to the following conditions: 

• If a product has 25 or more hits in 91 days or less, then the system uses the last 91 days of sales 
history to determine demand. 

• If a products has less than 25 hits in 91 days, but more than 25 hits in the last 365 days, then the 
system uses the number of days back to the 25th hit to determine demand. For example, if the 
25th hit occurred 180 days ago, the demand history uses the last 180 days. 

Note: If more than one hit occurred on the date of the 25th hit, all hits on that date are 
included. 

• If a product has less than 25 hits in the last year, then the system uses 365 days for the demand 
history. 

The more frequently sold items are statistically more predictable and demand calculations should, when 
possible, use shorter periods of time to reflect recent sales trends. 

Seasonal Products 
Seasonal products are those products that sell more often at certain times of the year. For example, 
heating products such as furnaces, sell more often during winter months. Seasonal forecasting lets you use 
the winter months only as the forecast period to determine appropriate demand. 

• When forecasting the demand of a seasonal product in September 2000, the system checks from 
September 1999 forward to gauge the winter month demand. 

• If there are 10 or more hits in a 45-day period, the system uses those 45 days of the product 
history for the calculation. For example, today is September 1, 2000. The system checks the 
history for Product A and finds 17 hits from September 1, 1999 to October 15, 1999. This 45-day 
period is used for the calculation. 

• If there were less than 10 hits in a 45-day period, but more than 10 hits in a 122-day period, the 
system uses the date of the 10th hit as the end date of the period for the calculation. For example, 
today is September 1, 2001. The system checks the history for Product B and finds that 10 hits 
occurred between September 1, 2000 and November 1, 2000. This 60-day period is used in the 
calculation. 

• If there are less than 10 hits in a 122-day period, the calculation is based on the full 122-day 
period. For example, today is September 1, 2000. The system checks the history for Product C 
and find that only 6 hits occurred between September 1, 1999 and January 1, 2001. The 6th hit 
occurred on December 15, 1999. The full 122-day period is used in the calculation. 
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How the System Calculates Trend for Seasonal Products 
For seasonal products, use the automatic trend calculation to even out the demand forecast according to 
recent trends. The system calculates trend in a hierarchical order. When you enable automatic trend 
calculation, the system calculates a trend factor by comparing the recent demand to that of the prior year, 
and then multiplies the current demand forecast by the factor. Parameters set at the product level override 
those set at the buy line level. Parameters set at the buy line level override those set at the branch level. 

For products with automatic trend calculation enabled, the system does the following: 

1. Calculate the current demand forecast based on the as of date, and note the number of days of 
sales history it took to meet the minimum days or minimum hits forecast parameters. 

2. Determine the recent demand for the product, starting from the as of date and going back the 
number of days noted in Step 1. 

3. Determine the product demand for the same period in the prior year, starting from 365 days 
before the as of date and going back the number of days in Step 1. 

4. Calculate the trend factor by dividing the demand of Step 2 by the demand of Step 3. 

If the system-calculated automatic trend percentage is higher or lower than the Max Increase% 
or Max Decrease%, respectively, then the system defaults to these values. 

If the demand for step 3 is 0 (zero), the Auto Trend factor is set to 1 (one) and the Demand 
Calculation Audit window displays N/A in the Automatic Trend field. 

5. Produce a revised demand forecast by multiplying the current demand determined in Step 1 by 
the trend factor. 

Note: If the product uses non-seasonal forecasting or Auto Trend is set to N, the 
Demand Calculation Audit window displays N/A in the Automatic Trend field. 

For example, the current demand based on the As of Date is 49 days. The recent demand for the product 
is 192.5 each. The product demand for the same period the previous year is 166.1 each. The system 
calculates the trend factor as follows: (1 - (166.1 / 192.5)) = 13.71 or 13.71%. For information on auditing 
demand, see Auditing Demand Calculations. 
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How the System Uses Manual Trend for Products 
Use the Trend% field on the Forecast Parameters Maintenance window to modify the demand forecast in 
anticipation of increases or decreases in demand. Apply a change to a product's calculated demand when 
you expect factors, such as economic conditions, to affect future demand for the product relative to past 
demand. 

Trend is represented as a percentage increase or decrease to the calculated demand. For example, entering 
20 causes the system to add 20% of the calculated demand to the product's demand. Entering -20 causes 
the system to subtract 20% from the product's demand. 

Seasonal Products 
For seasonal products, use the automatic trend calculation feature in the Forecast Parameters dialog box 
rather than this field. For more information, see How the System Calculates Trend for Seasonal Products. 

Non-Seasonal Products 
In order to use this field for non-seasonal products, you must know your market well, monitor the product 
sales, and know when to remove the trend percentage. 
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Lead Time Overview 
Lead time is the number of days it takes for you to prepare and process the purchase order, the vendor to 
ship the material, and your warehouse to receive the material. Every product requires a lead time for 
calculating: 

• Order point / transfer points 

• Line points / child branch surplus points 

• Safety days 

The Update Demand Forecast program calculates a product's lead time based on lead time parameters. In 
order for the system to calculate these items accurately, you must enter parameters for products or buy 
lines. If no parameter is set, the system uses a default setting through the control maintenance record 
program. You can also enter overrides for lead times at the product level and the buy line level. 

Use the following control maintenance records to set parameters: 

• Default Lead Time Days If Product And Buy Line Have None 

• Default Lead Time Factor If Product And Buy Line Have None 

• Minimum Lead Samples 
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How the System Calculates Lead Time 
The Update Demand Forecast program updates each product's lead time, based on lead time parameters 
set at the system, buy line, or product level. Lead time is the number of days it takes for you to prepare 
and process the purchase order, the vendor to ship the material, and your warehouse to receive the 
material. 

Lead time parameters include the following: 

• Lead Factor - Defines the maximum number of processed purchase orders in the forecast period. 

• Minimum Lead Samples - Identifies the minimum number of processed purchase orders in the 
forecast period. 

• Default Lead Time Days - Defines the default lead time set at the buy line and system level. 

Note: The system only checks the transfer order cycle when determining lead time on 
child branches in a central warehouse. 

The system uses a Lead Time Variable in many calculations, such as the safety stock: 

1. If LT < 1, then LTSD = 0 

2. If LT 1 to 15, then LTSD =  (LT + 7) * HRSC 

3. If LT 16 to 60, then LTSD = ((LT/2) + 15) * HRSC 

4. If LT 61 or higher, then LTSD = ((LT/4) + 30) *HRSC 

Note: LT = Lead Time, LTDS = Lead Time Safety Days, HRSC = Hits Related Safety 
Coefficient 

In addition to the lead time variable, the system uses the following steps when calculating the lead time: 

1. Checks for an override and determines which lead time to use. 

2. Determines the range of purchase orders to use for calculating the lead time. 

3. Derives the median lead time from the purchase orders. 

Determining Which Lead Time to Use 
In order to calculate lead time, the system checks for overrides. Overrides can also be set at the system, 
buy line, or product level. For example, your vendor calls you to tell you they are snowed in and it will 
take an additional three days to get the items to you. You can use the override settings to change the lead 
time for those items. 

The system makes several checks to determine the lead time: 
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• The system first checks for a lead time override at the buy line level or the product level. 

If the product 
is... 

Then... 

in a buy line If an override lead time is set in Buy Line Maintenance or Override Lead Time 
Maintenance, the system checks for an expiration date: 
• If no expiration date is set, then the days in the lead time equal the override lead 

time set at the buy line level. 
• If an expiration date is set and the date has not passed, then the days in the lead 

time equal the override lead time set at the buy line level. 
• If an expiration date is set, but that date has passed, the system checks for an 

override lead time at the product level. 
If an override lead time is not set at the buy line level, then the system checks for a 
lead time override at product level. 

not in a buy line check for an override lead time at the product level. 

• You can set a manual override in the Lead Days field in Forecast Parameters Maintenance, or in 
the Ovrd LT Days column in Override Lead Time Maintenance. Setting a value in one field or 
column causes the same value to display in the other field or column. 

Is an override 
set at the 
product level? 

Then... 

Yes check for an expiration date: 
• If no expiration date is set, lead time days equals the override set in the Lead 

Days field, or in the Override Lead Time Days column. 
• If an expiration date is set and the date has not passed, lead time days equals the 

override set in the Lead Days field, or in the Override Lead Time Days 
column. 

• If an expiration date is set, but that date has passed, check the Lead Factor field 
in the Product Forecast Parameters window to determine how the system 
calculates the lead time. 

No check the Lead Factor field in the Product Forecast Parameters window to 
determine how the system calculates the lead time. 

• The Lead Fctr field in Forecast Parameters Maintenance controls how the system calculates the 
lead time for the product. 

If the Lead 
Factor field is 
set to... 

Then... 

null or blank the system uses the Lead Factor in the Buy Line Maintenance window. 
0 the system checks for a value in the Lead Days field: 

• If Lead Days > 0 (zero) then lead time equals the value entered in the Lead 
Days field. The system does not calculate a new lead time for the product until 
Lead Factor is set to a number other than 0. 

• If Lead Factor = 0 (zero) and Lead Days = 0 (zero) or null or a blank, then 
lead time equals the value of the Default Lead Time Days If Product And 
Buy Line Have None control maintenance record. 
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If the Lead 
Factor field is 
set to... 

Then... 

> 0 the system determines the lead time by checking a sample of most-recent purchase 
orders. For more information, see Determining the Range of Purchase Orders to 
Use below. 

 Determining the Range of Purchase Orders to Use 
If there are no overrides at the product or buy line level, the system checks for a minimum and maximum 
number of purchase orders to sample for the lead time. 

Because recent data is more accurate for estimating lead times, the system checks the lead time derived 
from recent purchase orders in the forecast period for the product. The system checks a range of purchase 
orders to derive an accurate median lead time value using the minimum samples up to the lead factor. If 
there are insufficient purchase orders within the forecast period, the program resorts to a default lead time. 
For more information, see How Standard and Median Forecasting Works and Entering Forecast Period 
Parameters to determine your forecast periods. 

The system makes several checks to determine which range to use: 

• Determine the minimum number of purchase orders in the forecast period to use in calculating a 
product's lead time. If the Minimum Lead Factor field in the Product Forecast Parameters 
window is set to null, then the system checks: 

If... Then... 
product is in a buy 
line 

use the value of Minimum Sample in Buy Line Maintenance to determine the 
minimum number of purchase orders to use for calculating lead time. 

product is not in a 
buy line 

use the value of the Minimum Lead Samples control maintenance record to 
determine the minimum number of purchase orders to use for calculating lead 
time. 

Otherwise, the system uses the value of Minimum Lead Factor as the minimum number of 
purchase orders to use for calculating lead time. 

• Determine the maximum number of purchase orders in the forecast period to use in calculating a 
product's lead time. If the Lead Factor field in the Product Forecast Parameters window is not 0, 
then the system checks: 

If the Lead 
Factor is ... 

And the product is in a buy 
line... 

And the product is not in a buy 
line... 

null or blank if the Lead Factor in the Buy Line 
Maintenance window is null or 0, 
lead time is equal to the value of the 
Default Lead Time Days If 
Product And Buy Line Have None 
control maintenance record. 
otherwise, use the Lead Factor in 
the Buy Line Maintenance window 
to determine the number of purchase 
orders within the forecast period to 
use for calculating the product's lead 
time. 

use the value of the Minimum Lead 
Samples control maintenance record to 
determine the number of purchase orders 
within the forecast period to use for 
calculating the product's lead time. 
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Otherwise, use the value of Lead Factor in the Product Forecast Parameters window as the 
maximum number of purchase orders to use for calculating lead time. 

Deriving Median Lead Time from Purchase Orders 
The system then calculates a final lead time based on the determined range of purchase orders. After 
determining the minimum and maximum samples of purchase orders to check, the system calculates the 
median lead time for the product. 

• Compare the number of purchase orders in the forecast period with the minimum lead samples and 
lead factor parameters to be used for the product: 

If the number of purchase 
orders in the forecast period 
is... 

Then... 

less than the minimum lead 
samples 

if the product is in a buy line, the lead time is equal to the default lead 
time the system calculates and displays in the Lead Factor field in 
the Buy Line Maintenance window. 
if the product is not in a buy line, the lead time is equal to the value of 
the Default Lead Time Days If Product And Buy Line Have None 
control maintenance record. 

equal to the minimum lead 
samples 

calculate the lead time days using a number of purchase orders equal 
to the minimum lead samples. 

more than the minimum lead 
samples but less than the lead 
factor 

calculate the lead time days using the available purchase orders within 
the forecast period. 

equal to or greater than the lead 
factor 

calculate the lead time days using a number of purchase orders equal 
to the lead factor. 

Note: The values selected for the lead factor and minimum lead samples can be 
determined at two different levels. For example, the lead factor can be determined 
at the product level and the minimum lead samples can be determined at the buy 
line or system level. 

• Calculate and record the lead time of the selected purchase orders: 

Purchase Order Lead Time = Purchase Order Create Date - Purchase Order Receive 
Date 

• Select the median lead time. 

This value is the calculated lead time entered in the Lead Days field in Product Forecast 
Parameters. 
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Entering Lead Time Parameters 
Lead time is the number of days from the placement of a purchase order to date of its receipt. Lead time 
affects order points, line points, and safety stocks; therefore, accurate lead times are critical to accurate 
purchase planning. 

You can override the lead time by changing the calculated lead days, or by changing the lead factor used 
to calculate the lead time. 

Seasonal products use a lead time for the season. 

Enter lead time parameters for a defined product on the Forecast Parameters Maintenance window. 

In addition to setting lead time parameters at the product level, you can also set these parameters at the 
system or buy line level. 

The following procedure is a manual process for a single product. Use the Mass Load program to enter 
inventory parameters to groups of products. 

To enter lead time parameters for a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Forecast Parameters to display the Product Forecast Parameters 
dialog box. 

5. From the File menu, select Hierarchy to display the Product Forecast Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display forecast parameters for the selected branch in the Product Forecast 
Parameters dialog box. 

8. Complete the following fields: 

Field Description 
Minimum 
Lead Factor 

The minimum number of most-recent purchase orders the system samples to estimate 
the lead time for the product. 

Lead Factor This field controls the automatic calculation lead time for the product. Seasonal 
products use a calculated lead time for the ”r;season” of the product. 
• If greater than 0 (zero), this is the maximum number of most-recent purchase orders 

the system samples to estimate the lead time for the product. 
• If null, the system uses the lead factor set for the product's buy line. 
• Entering 0 (zero) overrides the lead time calculation and the system uses the value of 

Lead Days for the lead time. 

Lead Days The lead time for the product. This field updates when Lead Factor is greater than 0 
(zero). 
You can override the calculated lead time by entering a user-defined lead time in this 
field. 

9. Enter other forecast parameters, if needed. 
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10. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

Overriding the Lead Time for a Product 
You can override the calculated lead time by entering a user-defined lead time in the Lead Days field. 
The system uses this override until the next time you run the Update Demand Forecast program. 

Overriding the Lead Time Calculation for a Product 
Entering 0 (zero) in the Lead Factor field overrides the lead time calculation. The Update Demand 
Forecast program uses the current value of the Lead Days field as the lead time. The program will not 
calculate a new lead time until Lead Factor is set to a number other than 0 (zero). 

Note: If you do not enter a lead time in the Lead Days field, the program uses the current 
value of the Default Lead Time Days If Product And Buy Line Have None 
control maintenance record. 
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Overriding Product Lead Times 
Normally, the system uses a median calculation to determine the lead time for products. However, there 
are circumstances in which the lead time must be manually adjusted. For example, a storm comes through 
the city where your manufacturing supplier has a factory. The building and several machines are 
damaged. The supplier tells you that the products' lead times will be pushed out three weeks until repairs 
can be made. Use the Override Lead Time Maintenance window to adjust and enter an expiration date. 
The override is in effect until the expiration date. 

Overrides set at the product level take precedence over those set at the buy line level. 

You must have the PRODUCT.MAINT.LEVEL authorization key set to edit the override lead time. 

To override the product lead times: 

1. Enter forecast parameters. 

2. In the Product Forecast Parameters dialog box, from the Edit menu, select Override Lead Time 
to display the Override Lead Time Maintenance dialog box. 

3. From the File menu, select Insert Branch to display the Product Demand Parameters dialog box. 

4. In the Enter new branch or territory field, enter the branch or territory ID. 

5. Click OK to return the ID to the Branch field in the Product Demand Parameters dialog box. 

6. In the Override Lead Time Days column, enter the number of override lead time days to use. 

7. In the Expiration Date, enter the date the lead override lead time expires. 

The system resumes calculating the lead time for the product on this date. 

8. Save your information and exit the window. 
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Economic Order Quantity (EOQ) Overview 
The Economic Order Quantity (EOQ) is the most cost-effective quantity of a product for you to purchase 
and hold in inventory. 

The EOQ calculation considers the product's: 

• Daily demand 

• Cost 

• Acquisition costs 

• Carrying costs 

The EOQ is based on approximations. It is an estimate only and one of many factors to consider when 
determining order quantities. 
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How the System Calculates the Economic Order Quantity 
The formula for the Economic Order Quantity (EOQ) is: 

Square root of (24* Monthly Demand of Product * Acquisition Cost) / (Carrying Cost * Cost of 
Product) 

Important: The system uses the REP-COST is recorded in Price Line Maintenance. If there is 
no REP-COST recorded, then the system uses the value listed in the Basis Line #6 
on the Price Line Maintenance window. 

If both the REP-COST and the Basis Line #6 are blank, the system uses a zero (0) 
value. So, you must ensure that you have a value in one of the two fields in Price 
Line Maintenance. 

Example 
Product A has a demand per month of 5 and a unit cost of $12.00. The cost of processing a purchase order 
has been determined to be $1.75 and the cost of carrying the item in inventory is 30%. 

 
In the above example, considering the cost of processing a purchase order and the cost of carrying the 
item in inventory, the most cost-effective quantity of Product A to order at one time is 8 units. 
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Economic Order Quantity Acquisition Cost 
The Economic Order Quantity (EOQ) calculation considers the cost to acquire a product. For example: 

• Clerical/labor cost of processing orders 

• Cost of inspecting and returning products 

• Transportation costs 

• Handling costs 

To estimate the acquisition cost of the item, total the costs to acquire an average product, divide by the 
number of items on a typical purchase order. 

The actual acquisition cost varies per item. For the purpose of calculating and using an EOQ, apply the 
purchasing method used most often for most products within your company. 

Set the EOQ acquisition cost using the EOQ $ field in the Forecast Parameters Maintenance dialog box. 
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EOQ Carrying Cost Percentage 
The Economic Order Quantity (EOQ) calculation considers the cost to hold a product in inventory, known 
as a carrying cost. For example: 

• Rent on warehouse 

• Depreciation and obsolescence of inventory 

• Heating, lighting, security overhead 

• Money tied up in inventory investment (lost opportunity cost) 

• Obsolescence cost 

The carrying cost ranges from 10% to 30% of the cost to replace an item per year. 

The actual carrying cost varies per item. Products that are more subject to damage or that require special 
storage considerations would have higher carrying costs. Lower interest rates also lower carrying costs. 

Set the EOQ carrying cost using the EOQ % field in the Forecast Parameters Maintenance window. 
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How the System Uses EOQ 
The system uses the Economic Order Quantity (EOQ) in suggesting quantities to purchase or transfer. It 
also places restrictions on the use of the EOQ so it does not distort the reality of product demand: 

• The EOQ appears on a suggested purchase orders, but the Suggested P/O program will only 
suggest ordering the EOQ if: the EOQ exceeds the calculated line point for the product, less the 
current projected inventory level. 

• The system does permit an EOQ to exceed six times the monthly demand of a product. 

• If the low sale quantity for an item is greater than the EOQ, the system uses the low sales quantity 
in place of the EOQ. 

This adjustment ensures that products sold in logical quantities are not purchased in quantities less than 
what the customer is likely to request. For example, tires are sold in sets of four, although the EOQ might 
suggest three. 
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Hits Control Maintenance Overview 
The system uses the frequency of sales, known as the number of hits, to determine: 

• The forecast period to use for calculating demand. 

• Whether an item is stock or nonstock in a multi-branch network. 

• When a parent branch needs to replenish a child branch. 

The Demand Hit Definition control maintenance record, set by your system administrator, defines a hit 
for your company. It can be defined as one ordered line item regardless of quantity, one order regardless 
of multiple line items for the same product, or one shipped/invoice generation. 

Hits Control Maintenance Parameters 
Use Hits Control Maintenance to define hits-related inventory parameters for each branch. You can define 
hit control maintenance parameters at three levels: 

• System - Applies to all products unless overridden at the buy line or product level. 

• Buy Line - Applies to all products assigned to the defined buy line and overrides the system 
default parameters. 

• Product - Applies to the product and overrides the buy line and system default parameters. 

In a multi-branch network, the Hits Control Maintenance window to define the central warehouse type 
you want to use for multi-branch stock/nonstock determination and branch replenishment. 
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Defining Hits 
The Demand Hit Definition control maintenance record defines how the system calculate hits when 
running the update demand program. The system bases hits on the entries on a sales order. There are three 
choices: 

• Order 

• Generation 

• Line item 

The system also uses this parameter to recalculate hits when there are credits and returns. 

Once set, the system does not further adjust the demand hit definition. Therefore, select the variable based 
on how your company runs its business. 

The demand hit definition affects how the system calculates exceptional sales and usage for items split 
amongst multiple orders. More exceptional sales are possible when calculating hits on a per order basis, 
than when set to the generation or line item level. 

Order Level 
The system calculates hits on a "per sales order" basis, regardless of how or when you ship the items, or 
how the material is separated on the order. 

For example, a customer purchases 45 lengths of 1-1/2" x 10' PVC pipe and schedules delivery on three 
different dates (or the system schedules three different dates due to back ordering). In this example, 15 
lengths are sold on three generations of sales order S1267176 (S1267176.001, S1267176.002, and 
S1267176.003). 

Because the Demand Hit Definition is set to "order," the system counts 1 hit of 45 items. If the customer 
returns 10 of the 15 items ordered on S127176.003, the system still counts 1 hit, but now of (45-10=35) 
35 items. 

More exceptional sales are possible when calculating hits on a per sales order basis than when using the 
"generation" or "line item" level. 

Now, consider the effect of the Demand Hit Definition of "order" on exceptional sales. If the Excpt% 
field for the 1-1/2" x 10' PVC pipe product was 50%, and the second largest sale to date happened to be 
20, then the sale of 45 would be considered exceptional. 

Generation Level 
The system calculates hits on a "per sales order generation" basis. Each scheduled shipment or generation 
produces a separate hit occurrence. Credits and returns apply to the sales order generation. 

Using the previous example of Sales Order S1267176, the system would now count 3 hits of 15 items 
each. 

Now, consider the effect of the Demand Hit Definition of "generation" on exceptional sales. With the 
Excpt% field for the product at 50%, the largest sale is 20 and the second largest sale happened to be 15. 
Twenty is not 50% or more than 15, so there is no exceptional sale excluded. 
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Line Item Level 
The system calculates hits on a "per line item" basis. Each line item produces a separate hit occurrence. 

For example, a customer requests a blanket order, separated by room or tool crib, and shipped on different 
dates. Product A appears 10 times on Sales Order S0001234.001, 3 items per occurrence. The system 
counts 10 hits of 3 items each. If the customer returns one room's worth of Product A, the system would 
count 9 hits of 3 items per occurrence. 
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Entering Hits Control Maintenance Parameters 
Use the Hits Control Maintenance dialog box to define hits-related inventory parameters for each branch 
in a multi-branch network. The Update Demand Forecast and branch replenishment programs use this 
information in their calculations. 

You can set these parameters at the product and buy line levels. Use the Global Hits Definition control 
maintenance record to set system defaults. 

The following procedure is a manual process for a single product. Use the Mass Load program to enter 
inventory parameters to groups of products. 

To enter Hits Control Maintenance parameters at the product level: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select User Controls to display the Product User Control Parameters dialog 
box. 

5. From the Additional Controls menu, select Hits Maintenance/Max Days Supply to display the 
Hits Control Maintenance dialog box. 

6. If you use a multi-branch network, in the Central Warehouse Type field, enter one of the 
following central warehouse types: 

• Top-down - The central warehouse dictates branch replenishment and automatic 
stock/nonstock determination. 

• Bottom-up - The selling branches dictate branch replenishment and automatic stock/nonstock 
determination. The is the default. 

In a bottom-up central warehouse scheme, the system analyzes and reports the needs of the 
child branches back to the parent branch (central warehouse) so that stock can be purchased to 
bring the child branch back to the greater of its transfer point or its economic order quantity 
(EOQ). 

7. From the File menu, select Insert Branch to display the Hits Control Maintenance dialog box. 

8. In the Enter new branch or territory field, enter the branch or territory ID. 

9. Click OK to return the ID to the Branch field in the Hits Control Maintenance dialog box. 

10. Complete the following fields: 

Field Description 
Branch Hits Minimum hits a product needs at a branch to be considered a stock item. 
Network Hits Minimum hits a product needs throughout the branch network to be considered a 

stock item. 
This field does not apply to single-branch warehouses. 
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Field Description 
Max Days 
Supply 

The maximum number of days' supply of this product that your company permits to 
be maintained in inventory. 
The maximum number of days' supply equals the projected inventory level (PIL) of 
the item divided by its demand per day. 
If no maximum days' supply is set at the product level, the system uses the value set 
at the branch and buy line level. If no value is set at the branch and buy line level, 
the system uses the value set under the Maximum Days Supply control 
maintenance record. 
The maximum days' supply check does not apply to "Misc Charge" products. 
When an item is added to an adjustment, purchase order, sales order, or transfer 
order, the system checks the PIL at that moment and stores the value. When 
appropriate, the system displays a warning message if adding the item to the 
transaction causes the maximum days supply to be exceeded. If an item is removed, 
or if an order deleted, the system compares the PIL at the time of the removal or 
deletion to the stored PIL. If the removal or deletion does not make the PIL higher 
then it was at the time of the addition, no warning displays. 

11. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

More Options in the Hits Control Maintenance Dialog Box 

The Hits Control Maintenance dialog box also offers these options: 

To... Select this menu option... 
remove a branch from the Hits Control 
Maintenance dialog box, select the branch 
and 

File > Clear Branch 

find a branch that is not currently visible in 
the dialog box 

File > Find Branch 
The Hits Control Maintenance dialog box displays. In the Enter 
branch or territory to find field, enter the branch or territory ID 
and click OK to return to the Hits Control Maintenance dialog box. 
The cursor moves to the requested branch. 

toggle between prompting for a branch to 
display branch-specific parameters and 
displaying all branches 

File > Toggle Hierarchy 
The Hits Control Maintenance dialog box displays. In the Enter 
hierarchy branch field, enter the branch or territory ID to which 
you want to toggle and click OK to return to the Hits Control 
Maintenance dialog box. 
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Order Points and Line Points Overview 
Order points and line points determine the amount of inventory to stock in your warehouse. In a multiple 
branch warehouse company, transfer points and transfer surplus points determine the quantities for 
replenishing branches. 

Order Point 
This is the minimum amount of stock you want to have on the shelf for a given item so a warehouse can 
meet demand while waiting vendor replenishment. 

The order point considers the vendor lead time and safety days for the product. When a product's 
projected inventory level (PIL) falls below its order point, the system suggests purchasing back to the line 
point. 

When calculating the order point for a baby branch in a parent/baby relationship, the lead time for the 
baby branch is the greater of the lead time of the parent branch or the transfer cycle from the parent 
branch to the baby branch. This method protects the baby branch from running out of material during the 
transfer cycle. 

Note: You can set a minimum-only order point for a product to make sure the system 
uses the largest line point available. 

Line Point 
This is the upper limit to the amount of stock you want to have on the shelf for a given item so a 
warehouse can meet demand during the order cycle of the product. 

The line point considers the vendor lead time, safety days, and order cycle for the product. The line point 
can vary as the order cycle changes. For more information, see How the System Calculates Line Points 
and How the System Calculates Line Point Safety Days. 

When calculating the line point for a baby branch in a parent/baby relationship, the lead time for the baby 
branch is the greater of the lead time of the parent branch or the transfer cycle from the parent branch to 
the baby branch. This method ensures that the baby branch's order point is not higher than its line point. 

Order Cycle 
The time it takes to sell enough of a product to contribute to meeting the vendor target for the product's 
buy line. The order cycle can vary when some products in a buy line sell faster than others. 

Demand Samples 
Before the system calculates order points, line points, transfer points, and transfer surplus points, it needs 
to start with a "clean" demand sample. To create a clean demand sample, the system use inventory 
parameters to do the following: 

• Use the correct forecast period 

• Compensate for lost sales 

• Consider trends in demand 
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Reviewing Product Order Points and Line Points 
Use the Product Order Points/Line Points dialog box to view or adjust information related to the product's 
order point and line point. You can view this window for nonstock products, but the system does not 
calculate the order point and line point. 

To review a product's order point and line point: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. Select a branch and, from the Edit menu, select Order Points to display the Product Order 
Points/Line Points dialog box. 

5. If you selected an individual branch, change either of the following fields, as needed, to adjust the 
order point and line point: 

Note: If you selected a summary branch, all fields are view-only. 

Field Description 
Safety Factor A value that adjusts the hits related safety coefficient (HRSC) applied to a 

product at an individual branch. For example, if the value in the Hits Adjusted 
Safety Factor field is 0.85, entering 0.8 in the Safety Factor field reduces the 
HRSC by 80 percent, or a value of 0.68. 
The default value is 1. 

Note: The Safety Factor and Projected Service Level fields are mutually 
dependent. Changing one field changes the other's value, too. If safety factors 
are uploaded using Mass Load, then the system updates the projected service 
level regardless if they were previously overridden. 

Projected Gross 
Margin 

Used to adjust the adjusted gross margin for a product at an individual branch. 

Note: Changing the projected gross margin updates the adjusted gross margin. 

Projected Service 
Level 

The service level determines the amount of stock you want to guarantee to be 
in your warehouse. For example, as a hardware store you want AA batteries to 
be available 99.9% of the time. You make the AA batteries an A Ranked 
product with a service level of 99.9% and therefore a safety factor of 3.72. The 
system uses the calculated safety factor to determine demand and how often to 
replenish your warehouse. 

Note: If a service level has never been set for a product, the system uses one 
(1.00). 

Note: The Safety Factor and Projected Service Level fields are mutually 
dependent. Changing one field changes the other's value, too. If projected 
service levels are uploaded using Mass Load, then the system adjusts the safety 
factors to match. 
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6. Review the adjusted amounts and other information in the following fields, as needed: 

Field Description 
Hits Adjusted Safety 
Factor 

The hits related safety coefficient (HRSC) for the product at the branch 
multiplied by the value in the Safety Factor (SF) field. 
The hits adjusted safety factor affects the adjusted gross margin, projected 
service level, projected turns, order point safety days and line point safety days. 

Adjusted Gross 
Margin 

The estimated gross margin, using the value in the Projected Gross Margin 
field, and the estimated turns calculated in this field, and the carrying cost 
percentage on file. The system calculates it as follows: 
ADJ. GM = GROSS MARGIN - (CARRY COST% / TURNS) 

Projected Turns The estimated number of turns, based on the current demand per day 
annualized. It is calculated as: 
TURNS = (365 x annualized demand / day) / average onhand 

7. Review the components used in the calculation of order points and line points for parent 
branches, and for transfer points and transfer surplus points in child branches: 

For the order point or transfer point: 

In a Parent Branch: In a Child Branch: 
Lead time days Transfer cycle days 
Order point safety days Transfer cycle days safety 
Order point days Transfer point days 
Average daily demand Average daily demand 
Service stock or manual safety stock Service stock or manual safety stock 
Order point Transfer point 

For the line point or transfer surplus point: 

In a Parent Branch: In a Child Branch: 
Lead time days Transfer point days 
Order cycle Transfer grace days 
Line point safety days Transfer surplus days 
Line point days Average daily demand 
Average daily demand EOQ 
Service stock or manual safety stock Service stock or manual safety stock 
Line point Transfer surplus point 

Note: If a minimum or maximum amount of quantity to stock is set on the User Inventory 
Controls window and the setting has not expired, then the minimum amount 
setting overrides the order point calculation and the maximum amount setting 
overrides the line point calculation. 

8. Click OK to exit the window. 
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Adding Customer Service Stock 
Customer service stock, also called manual safety stock, is a quantity added to the normal stocking level 
of a product for a period of time, based on: 

• Running a promotion on items, guaranteeing that you will have them in stock. 

• Contractors requesting that you keep an item in stock in case then need one in an emergency. 

• Branches using items, but not wanting this use to count towards the demand calculation. 

When you assign service stock for a customer, the system adds additional quantities to the order point and 
line point calculations. You can also set service stock at the branch level using the Product User Control 
Parameters dialog box. 

Note: The system does not convert nonstock items with customer service stock set to 
stock items. 

To add service stock for a customer: 

1. Set user control parameters for a product. 

2. In the Product User Control Parameters dialog box, select a branch, and, from the Additional 
Controls menu, select Customer Service Stock to display the Product Inventory Customer 
Service Stock dialog box. 

3. In the Service columns, complete the following for each customer, as needed: 

Field Description 
Customer The name of the customer requiring the service stock. 

Quantity The amount of service stock the customer required. 

Effective Date The date to begin adding the service stock to the order point and line point 
calculations. 

Expire Date The date to stop adding the service stock to the order point and line point 
calculations. 

Note: The effective and expiration date are for reporting purposes only. They do not 
affect the order point and line point calculations. For more information, see 
Running the Customer Service Stock Report in the Reporting in Eclipse 
documentation. 

4. View service stock for contracts, as needed. 

5. Click OK to save the information exit the dialog box. 

The system populates the Customer Service Stock field with the total quantity required by 
customers. 
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Setting the Percentage of Parent Order Point to Protect 
When calculating the order or line point for a baby branch in a parent/baby relationship, the lead time for 
the baby branch is the greater of the lead time of the parent branch or the transfer cycle from the parent 
branch to the baby branch. This method protects the baby branch from running out of material during the 
transfer cycle and ensures that the baby branch's order point is not higher than its line point. 

When the system determines the quantity of products to transfer from the parent branch to the child 
branch, it does not transfer a quantity that takes the parent branch below its order point, unless there is an 
immediate need in the child branch. For non-immediate need suggested transfers, the parent branch will, 
by default, not transfer a quantity that takes the parent branch below its order point. 

In regards to non-immediate need suggested transfers to child branches, you can modify how much of the 
parent branch's order point the system protects. You can set this parameter at the system, buy line, and 
product level. 

The following procedure is a manual process for a single product. Use Mass Load to enter inventory 
parameters to groups of products. 

To set the percentage of a parent branch order point to protect for suggested transfers: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select Additional Parameters to display the Additional Inventory 
Parameters dialog box. 

5. From the File menu, select Insert Branch to display the Additional Inventory Parameters dialog 
box. 

6. In the Enter new branch or territory field, enter the branch or territory ID. 

7. Click OK to return the ID to the Branch/Terr field in the Additional Inventory Parameters 
dialog box. 

8. Enable stock/nonstock determination for the product, if needed. 

9. Set the product buy package quantity and divisibility, if needed. 

10. In the %OP field, enter a percentage of the parent branch's order point to be protected in 
suggested transfers for non-immediate needs. For example, if the calculated order point is 12 and 
the %OP is 50, the system reads the parent branch order point as 6 for calculating suggested 
order quantities. 

• A value set at the product level overrides that set at the buy line level. If no percentage is set at 
the product level, but one is set at the buy line level, the value at the buy line is used. 

• A value set at the buy line level overrides that set at the system level. If no percentage is set at 
the buy line level, but one is set at the system level, the value at the system level is used. 

• If no percentage is set for the parent branch-that is, the field is left blank-the system uses the 
default of 100%. 

Note: The calculated order point at the parent branch includes manual service stock. 
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11. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

More Options in the Additional Inventory Parameters Dialog Box 

The Additional Inventory Parameters dialog box also offers these options: 

To... Select this menu option... 
remove a branch from the 
Additional Inventory 
Parameters dialog box, select 
the branch and 

File > Clear Branch 

find a branch that is not 
currently visible in the dialog 
box 

File > Find Branch 
The Additional Inventory Parameters dialog box displays. In the Enter 
branch or territory to find field, enter the branch or territory ID and click 
OK to return to the Additional Inventory Parameters dialog box. The cursor 
moves to the requested branch. 

toggle between prompting for a 
branch to display branch-
specific parameters and 
displaying all branches 

File > Toggle Hierarchy 
The Additional Inventory Parameters dialog box displays. In the Enter 
hierarchy branch field, enter the branch or territory ID to which you want to 
toggle and click OK to return to the Additional Inventory Parameters dialog 
box. 
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Using Minimum-Only Order Points 
You can set up an order point or transfer point for a product using a minimum-only order point. The 
system uses the value entered for the minimum as both the order point and the line point until the demand 
of the product exceeds the minimum value. When the value exceeds the minimum value, the system uses 
the calculated line point. The system still pulls and displays products on the Suggested Purchase Order 
Queue regardless if the product uses minimum-only or minimum-maximum order points. 

For example, you want to have at least three of a product in a branch, but if the true demand would result 
in a line point of more than three, you want the system to use the greater line point. 

Note: Order points and transfer points are the same. The system considers order points in 
a child branch to be transfer points. 

Use the User Inventory Controls screen to set up an order point with only a minimum value. The 
following are true for this screen for this scenario: 

• The Exp Date field and Calc Dmnd field functions do not change. 

• The value in the Min field displays as the value for the order point and transfer point (OP/XP 
field) on the Primary Inventory Maintenance and Product Order Points/Line Points screens. 

• A lowercase m, such as 15m, next to the EOQ (Economic Order Quantity) field's value indicates 
that it is a minimum-only order point. An uppercase M, such as 15M, indicates that the system 
must consider both minimum and maximum values from the User Inventory Controls screen. 

• A minimum-only value acts as an order point for a purchasing branch and a transfer point for the 
child branch. 

• After you have loaded a minimum value for a branch, the system stops checking hits at this 
location because the item is considered stock. However, if a product is a nonstock, the system does 
not use a min/max or min only setting. 

• The system uses the value entered for the minimum as both the order point and the line point until 
the demand of the product exceeds the minimum value. When the value exceeds the minimum 
value, then the system uses the calculated line point. The system uses the greater value. 

• If a product has a minimum setting but no maximum setting, the order point and the line point 
quantity are equal to the value in the Min field unless the system calculated line point quantity is 
greater than the minimum. In this case, the system uses the calculated line point quantity. 
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How the System Calculates Line Points 
A product's line point is the upper limit to the amount of stock you want to have on the shelf for a given 
item. It includes enough stock to carry you through the order cycle, plus an amount of safety stock. When 
an item's projected inventory level (PIL) falls below its order point, the Suggested P/O program suggests 
that you purchase enough stock to bring all items in the buy line up to their adjusted line points. The line 
point adjusts up or down to meet the vendor target, depending on where you are in the order cycle when 
the Suggested P/O program runs. 

A product's line point is the sum of the lead time days plus order cycle days, plus line point safety days, 
multiplied by the average demand for the item per day. If you define manual safety stock, the system adds 
this stock as a last step in determining the item's line point. 

 
Note: If a maximum amount of quantity to stock is set on the User Inventory Controls 

window and the setting has not expired, then that amount overrides the line point 
calculation. 

Components of the Line Point 
• Lead Time Days - The time it takes to replenish a product. You do not want your stock levels to 

fall below the amount that you can sell during the time it takes the vendor to ship the material to 
you. 

• Order Cycle Days - The time it takes to sell enough of an item to meet its contribution to the 
vendor target. The normal order cycle for a buy line is the vendor target for the buy line, divided by 
the cumulative demand of all the products in that buy line. 

• Line Point Safety Days - To ensure against possible out of stock periods, you also want to 
consider safety days in the line point calculation. Safety days translate into safety stock, which 
provides a cushion when daily sales exceed the average daily sale quantity. 

• Demand per Day - Product demand drives the automated purchasing and transfer system. 
Formulas built into the safety day calculation compensate for the differences between fast-moving, 
high demand items, and slow-moving, low demand items. 

• Manual Safety Stock - Also known as service stock, this is a quantity added to the order point to 
honor a commitment to keep a quantity of stock on the shelf. 
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Parent/Baby Branches 
When calculating the line point for a baby branch in a parent/baby relationship, the lead time for the baby 
branch is the greater of the lead time of the parent branch or the transfer cycle from the parent branch to 
the baby branch. This method ensures that the baby branch's order point is not higher than its line point. 
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How the System Calculates Order Points 
A product's order point indicates the minimum amount of stock you want to have on the shelf for a given 
item. When an item's projected inventory level (PIL) falls below its order point, the Suggested P/O 
program suggests that you purchase enough stock to bring all items in the buy line to their adjusted line 
points. That is, the line point adjusted up or down to meet the vendor target. 

The Suggested P/O report can include products that were not below their order points. 

A product's order point is the sum of the lead time days plus order point safety days, multiplied by the 
average demand for the item per day. If you define manual safety stock, the system adds this stock as a 
last step in determining the item's order point. 

 
Note: If a minimum amount of quantity to stock is set on the User Inventory Controls 

window and the setting has not expired, then that amount overrides the line point 
calculation. You can set a minimum-only order point for a product to make sure 
the system uses the largest line point available. 

Components of the Order Point 
• Lead Time Days - The time it takes to replenish a product. You do not want your stock levels to 

fall below the amount that you can sell during the time it takes the vendor to ship the material to 
you. 

• Order Point Safety Days - To ensure against possible out of stock periods, you also want to 
consider safety days in the order point calculation. Safety days translate into safety stock, which 
provides a cushion when daily sales exceed the average daily sale quantity. 

• Demand per Day - Product demand drives the automated purchasing and transfer system. 
Formulas built into the safety day calculation compensate for the differences between fast-moving, 
high demand items, and slow-moving, low demand items. 

• Manual Safety Stock - Also known as service stock, this is a quantity added to the order point to 
honor a commitment to keep a quantity of stock on the shelf. 

Parent/Baby Branches 
When calculating the order point for a baby branch in a parent/baby relationship, the lead time for the 
baby branch is the greater of the lead time of the parent branch or the transfer cycle from the parent 
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branch to the baby branch. This method protects the baby branch from running out of material during the 
transfer cycle. 
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Adjusting Additional Inventory Parameters 
The Additional Inventory Parameters window lets you adjust the percentage or quantity below which you 
do not want to include the remnant in the projected inventory level or the percentage of the parent 
branch's order point to be protected in suggested transfers for non-immediate needs. You can also indicate 
buy package quantities to purchase or transfer in and whether or not you allow package divisibility. 

To adjust the parameters: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Enter the product for which you want to adjust parameters. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance window. 

4. From the Edit menu, select Additional Parameters to display the Additional Inventory 
Parameters window. 

5. In the Exclude Remnant PIL % and Quantity fields, indicate the percentage and quantity below 
which you do not want the system to include the values in the project inventory level calculations. 
For example: 

Item Value 
Available Qty 50 ft 
Remnant On Hand 10 ft (including in process) 
Exclude Remnant PIL% 30 

Exclude Remnant Qty 2 

6. First, the system calculates the following: 

Item Value 
Exclude Percent Qty Integer (Remnant On hand X (Exclude Remnant PIL% / 100)) 
Exclude Percent Qty 10 X .3 
Exclude Percent Qty 3 

7. Then, the system subtracts from the Available Qty whichever of the following is larger: Exclude 
Percent Qty or Exclude Remnant Qty 

8. In this example, since Exclude Percent Qty = 3 and is larger, then the system subtracts as 
follows: Available Qty = 50 - 3 

9. Result = The system uses 47 as the Available Qty. 

10. In the OP% field, indicate how much of the parent branch's order point to protect when 
suggesting transfers. 

11. Set buy package quantities and package divisibility, if needed. 

12. Save your changes and exit the window. 
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How the System Calculates Line Point Safety Days 
The system calculates safety days for each product's line point, based on lead time and the following 
equations: 

• Using the sum of lead time days plus order cycle days to determine base line point safety days. 

• Modifying base line point safety days using the hits related safety coefficient (HRSC) factor. 

How the System Calculates Base Line Point Safety Days 
The system first applies an inverse relationship to the sum of the lead time and the order cycle and the 
number of safety days. That is, for shorter the lead time and order cycle, the more safety stock the system 
recommends. For longer lead times and order cycles, the system recommends less safety stock to protect 
against the carrying costs of the extra inventory. 

For base Line Point Safety Days, three equations apply. 

If the sum of 
Lead Time plus 
Order Cycle is... 

the base Line Point 
Safety Days is... The formula is... 

less than or equal to 
15 

the sum of lead time 
plus order cycle plus 
seven days. 

If (LT + OC) < 15, Then LPSD = (LT + OC) + 7. 

greater than 15 but 
less than 60 days 

one half the sum of lead 
time plus order cycle 
plus 15 days. 

If (LT + OC) > 15 and < 60, Then LPSD = ((LT + OC)/2) + 15. 

greater than 60 
the sum of lead time 
plus order cycle divided 
by 4 plus 30 days. 

If (LT + OC) > 60, Then LPSD = ((LT + OC)/4) + 30. 

How the System Adjusts Line Point Safety Days by the HRSC Factor 
The system next adjusts the base line point safety days to consider whether the item is a fast-moving, high 
demand item, or a slow-moving, low demand item using the Hits Related Safety Coefficient (HRSC) 
factor. The system uses this to compensate for the relative unreliability of demand forecasting for slow-
moving items compared to fast-moving items. 

For example, an item that sells an average of once a day for a month is a fast-moving item. An item that 
sells an average of once a month for a year is a slow-moving item. 

The HRSC is 4 divided by the total number of hits in the last 365 days, plus 0.6. Products with less than 4 
hits in the past year use 4 as the number of hits in the calculation. The highest HRSC is 1.6 while the 
lowest HRSC approaches 0.6. The HRSC value displays in the Hits Adjusted SF field on the Product 
Order Points/Line Points window. 

You can change the HRSC by changing the value of the Safety Factor (SF) field on the Product Order 
Points/Line Points window. 
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How the System Calculates Order Point Safety Days 
The system calculates safety days for each product's order point, based on lead time and the following 
equations: 

• Using lead time days to determine base lead time safety days. 

• Applying the hits related safety coefficient (HRSC) factor to base lead time safety days to calculate 
order point safety days. 

How the System Calculates Base Order Point Safety Days 
The system first applies an inverse relationship to the length of the lead time and the number of safety 
days. That is, for shorter lead times, the system recommends more safety stock to protect customer 
service levels. For longer lead times, the system recommends less safety stock to protect against carrying 
costs on the extra inventory. 

For base Order Point Safety Days, three equations apply: 

If the Lead 
Time is... 

The base Order Point Safety 
Days is... The formula is... 

less than 15 0 If LT < 1, then LTSD = 0 

greater than 1 
up to 15 

the lead time plus seven days 
multiplied by the hits related safety 
coefficient with the result added to 
the lead time. 

If LT 1 to 15, then LTSD = ((LT + 7) * HRSC) 

greater than 15 
but less than 60 
days 

one half the lead time plus 15 days 
multiplied by the hits related safety 
coefficient with the result added to 
the lead time. 

If LT 16 to 60, then LTSD = ((LT/2) + 15) *HRSC 

greater than 60 

the lead time divided by 4 plus 30 
days multiplied by the hits related 
safety coefficient with the result 
added to the lead time. 

If LT 61 or higher, then LTSD = ((LT/4) + 30) *HRSC 

How the System Adjusts Base Lead Time Safety Days by the HRSC 
Factor 
The system next adjusts the base lead time safety days to consider whether the item is a fast-moving, high 
demand item or a slow-moving, low demand item using the Hits Related Safety Coefficient (HRSC) 
factor. This adjustment enables the system to compensate for the relative unreliability of demand 
forecasting for slow-moving items compared to fast-moving items. 

The system uses the following equation: 

( ( 4 / Total Hits on Product in Last 365 Days) + 0.6 ) * Safety Factor 

The result of this equation displays in the Hits Adjusted SF field on the Product Order Points/Line Points 
window. You can change the HRSC by changing the Safety Factor (SF) field on the Product Order 
Points/Line Points window. The default value is 1.0. If you update your service levels on the Product 
Order Point/Line Point window, then the HRSC factor also changes. 
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About Service Level Numbers and Standard Deviation 
The system calculates the service level number based on the standard deviation of the safety factor. The 
service level determines the amount of stock you want to guarantee to be in your warehouse. For 
example, you have a hardware store and you want AA batteries to be available 99.9% of the time. You 
make the AA batteries an A Ranked product with a service level of 99.9% and therefore a safety factor of 
3.72. The system uses the calculated safety factor to determine the amount of safety days needed to 
provide the desired service level. 

The most popular distribution level for determining probability is referred to as normal distribution. This 
term used in statistical analysis describes a distribution of numbers in which the probability of an 
occurrence, if graphed, follows the form of a bell-shaped curve. 

Standard deviation refers to the spread of the distribution number. The system calculates this as follows: 

1. Determine the mean of a set of numbers. 

2. Determine the difference of each number and the mean. 

3. Square each difference. 

4. Calculate the average of the squares. 

5. Calculate the square root of the average. 

Note: In safety stock calculations, the forecast quantity is often used instead of the mean 
in determining the standard deviation. 

Service Levels and Related Safety Factors 
The following table shows the service level and its corresponding safety factor using the above 
calculation process: 

Service Level Safety Factor 
50.00 % 0 
55.00 % 0.13 
60.00 % 0.25 
65.00 % 0.39 
70.00 % 0.52 
75.00 % 0.67 
80.00 % 0.84 
81.00 % 0.88 
82.00 % 0.92 
83.00 % 0.95 
84.00 % 0.99 
85.00 % 1.04 
86.00 % 1.08 
87.00 % 1.13 
88.00 % 1.17 
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Service Level Safety Factor 
89.00 % 1.23 
90.00 % 1.28 
91.00 % 1.34 
92.00 % 1.41 
93.00 % 1.48 
94.00 % 1.55 
95.00 % 1.64 
96.00 % 1.75 
97.00 % 1.88 
98.00 % 2.05 
99.00 % 2.33 
99.50 % 2.58 
99.60 % 2.65 
99.70 % 2.75 
99.80 % 2.88 
99.90 % 3.09 
99.99 % 3.72 

Example: How Safety Factor Impacts the Lead Safe Days 
Following is an example of how the system handles a change to the Projected Service Level which 
updates the Safety Factor which then updates the Lead Safe Days calculated for the product. 
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• The lead time for this product is 18 and calculated from received purchase orders. 

• The Hits Adjusted Safety Factor is using this calculation: 

safety factor X (4 / annualized hits) + .6 = 1.35 

If there are no hits, the system uses 4 in the calculation. Annualized hits are calculated as follows: 
raw hits X 365 / Forecast Period 

• Since the Lead Time Days equal 15, then the normal safety days rules apply. 

• If the lead time days are less than or equal to 18, the safety days are equal to the lead time plus 7. 

• If the lead time days are greater than 15, but less than 61, then the safety days are equal to one-half 
of the lead time, plus 15. 

• If the lead time days are greater than 60, then the safety days are equal to one quarter of the lead 
time, plus 30. 

Therefore: (18 / 2 + 15) X 1.35 (HRSC) = 35.2 and Lead Time Safety Days = 32 
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Updating Product Demand Overview 
Use the Update Demand Forecast program to forecast the demand of products in your inventory. The 
system consults the branch zip code table when calculating demand. If demand does not display as 
anticipated, ensure the zip code table is accurate and no changes have been made. Changes to Branch Zip 
Code table should be made with the assistance of Eclipse Support personnel. For more information, see 
Zip Codes Overview. 

This program serves four primary functions. By product by branch, it updates the following: 

• Demand per day 

• Economic order quantity (EOQ) 

• Lead time 

• Buy line's average lead time 

Several programs use the demand forecast data: 

• The plenty date calculation uses the lead time and buy line average lead time data. 

• The order point and line point calculations use the demand per day and lead time data. 

• The Maximum Days' Supply for a product is based on the demand per day. 

• The Product Ranking program uses the demand per day data for ranking products. 

• The Suggested P/O and Suggested Transfer programs rely on order point, line point, and product 
ranking calculations for suggesting purchases and transfers. 
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Viewing Product Demand Information 
Use the Primary Inventory Maintenance dialog box to view product information related to inventory 
management. 

• The system continually updates the product's projected inventory level (PIL) and order/transfer 
point (OP/XP) in real time. 

• The system updates the remaining fields in the window each time you run the Update Product 
Demand Forecast program for the product. 

When you assign a product the product status of Stock, the Primary Inventory Maintenance window 
displays a summary of the product's current demand information. 

When you assign a product the status of NonStock, the system does not calculate the order point, line 
point, Economic Order Quantity (EOQ), and monthly demand. 

To view product demand information: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. In the Br column, review the branch numbers and types. 

Branch or warehouse identifiers with letter suffixes indicate the warehousing scheme used for 
replenishing that product. These lines display calculated information for all branches combined 
under the defined warehouse scheme. 

Suffix Defines a... Which... 
P Central purchasing branch Purchases for other branches. 

W Central distribution branch Warehouses for other branches. 

C Central warehousing branch Purchases and warehouses for other 
branches. 

5. In the Stock column, review whether the item is a known stock (Yes) or nonstock (No) item, or 
whether the system calculates (Auto) the stock or nonstock status based on the number of hits the 
product receives in a branch warehouse network. 

The product's stock or nonstock status can be set in the Additional Inventory Parameters dialog 
box. 

6. In the Buy Pkg <unit of measure> column, review the quantity multiple in which stock is 
purchased or transferred. For example, if set to 6, stock is purchased or transferred in quantities of 
6, 12, 18, 24, and so forth. 

7. In the Div column, review whether the buy package can be divided either by the vendor when 
purchasing or by the warehousing branch before transfers occur. 

Note: Both the Buy Pkg and Div columns remains blank if no territory is selected. 

8. Review the fields, as needed, for each parent branch and child branch: 
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Field For a parent branch, shows 
the... 

For a child branch, shows the... 

PIL projected inventory level. projected inventory level. 
OP/XP order point. 

If a minimum-only is set for the 
product, the system uses that 
minimum as the order point until 
the calculated order point exceeds 
the minimum-only setting. The 
system then uses the calculated 
order point. Minimum-only is in 
effect when a lower case "m" 
displays after the EOQ value. 
If there is a min/max order point set 
for the product, the min is always 
the order point and an upper case 
"M" displays after the EOQ value. 

Note: The order point displays as a 
whole number. 

system-calculated transfer point if there is no 
min/max order point set for the product. 
If the Respect Item Min/Max For Suggested 
Transfers control maintenance record is set to 
No, the system checks the Max setting for the 
product. 
• If there is a min/max set for the product, the 

transfer point is the max and an uppercase "M" 
displays next to the EOQ value. 

• If there is no min/max set for the product, the 
system uses the system-calculated transfer 
point. 

• If there is a minimum-only set for the product 
the system uses the minimum-only is in effect 
when a lowercase "m" displays after the EOQ 
calculation. 

If the Respect Item Min/Max For Suggested 
Transfers control maintenance record is set to 
Yes, the system checks the min setting for the 
product. 
• If there is a min/max set for the product, the 

transfer point is the min and an uppercase "M" 
displays next to the EOQ value. 

• If there is no min/max set for the product, the 
system uses the system-calculated transfer 
point. 

• If there is a minimum-only set for the product, 
the system uses the minimum-only as the 
transfer point until the calculated transfer point 
exceeds the minimum-only setting, the system 
uses the system-calculated demand. A 
minimum-only is in effect when a lower case 
"m" displays after the EOQ value. 

Note: The transfer point displays as a whole 
number. 

Low Sale 
<unit of 
measure> 

lowest sale in the branch within the 
forecast period. 

lowest sale in the branch within the forecast 
period. 
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Field For a parent branch, shows 
the... 

For a child branch, shows the... 

EOQ Economic Order Quantity, based on 
the combined demand of the multi-
branch network. 
When the low sale quantity exceeds 
the calculated EOQ, the system 
uses the low sale quantity in place 
of the EOQ in associated 
calculations. In this case, the field 
displays with an asterisk to indicate 
the exception. 
• An uppercase "M" in this field 

indicates that the system is using 
the min/max setting as the 
transfer point. 

• A lowercase "m" in this field 
indicates that the system is using 
the minimum-only setting as the 
transfer point. 

Economic Order Quantity for the item in the 
branch. 
• An uppercase "M" in this field indicates that the 

system is using the min/max setting as the 
transfer point. 

• A lowercase "m" in this field indicates that the 
system is using the minimum-only setting as the 
transfer point. 

• An EOQ with no letter indicates that the system 
is using the system-calculated transfer point. 

An EOQ with no letter indicates 
that the system is using the system-
calculated transfer point. 
• An uppercase "M" in this field 

indicates that the system is using 
the min/max setting as the 
transfer point. 

• A lowercase "m" in this field 
indicates that the system is using 
the minimum-only setting as the 
transfer point. 

• An EOQ with no letter indicates 
that the system is using the 
system-calculated transfer point. 

Monthly 
Demand 

monthly demand for the item in the 
branch. 

monthly demand for the item in the branch. 

Monthly Hits monthly hits for the item in the 
branch. 

monthly hits for the item in the branch. 

Leadtime XF 
Cycle 

product's lead time for a purchasing 
branch. 

transfer cycle days for selling (child) branches. 

Safety LT Day number of lead time safety days for 
the item in the branch. 

number of lead time safety days for the item in the 
branch. 

9. When you have finished reviewing the information, exit the dialog box. 
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More Options in the Primary Inventory Maintenance Dialog Box 

The Primary Inventory Maintenance dialog box also offers these options: 

To... Select this menu option... 
view product demand calculation information Edit > Audit 

The Demand Calculation Audit dialog box displays. 
view product order point and line point 
calculation information 

Edit > Order Points 
The Product Order Points/Line Points dialog box displays. 

change the safety factor and projected gross 
margin for an individual branch 

Edit > Order Points 
The Product Order Points/Line Points dialog box displays. 

set the parameters used to forecast product 
demand 

Edit > Forecast Parameters 
The Product Forecast Parameters dialog box displays. 

enter specialized product-level user inventory 
control parameters 

Edit > User Controls 
The Product User Controls Parameters dialog box displays. 

view inventory details for the product in all 
branches 

Edit > Inventory Inquiry 
The Inventory Inquiry dialog box displays. 

define whether the item is stock and nonstock 
determination, by branch, and determine the buy 
package and divisibility overrides for branches 
and territories or to indicate how to calculate 
PIL when handling remnants 

Edit > Additional Parameters 
The Additional Inventory Parameters dialog box displays. 

flag the product as vendor-managed inventory 
for EDI 

Edit > EDI/VMI Maintenance 
The Product EDI/VMI Maintenance dialog box displays. 
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Running the Update Demand Forecast Program 
Use the Update Demand Forecast program to forecast the demand of one, some, or all products in your 
inventory. 

You can run the program for a single product or buy line during the day, when necessary. When using the 
"All" or "Changes" option, schedule the program to run overnight because it can take a long time to 
complete. 

To run the Update Demand Forecast program: 

1. From the Purchase > Forecasting menu, select Update Demand Forecast to display a selection 
list. 

2. In the Select Group field, select one of the following options to indicate the products for which 
to run the program: 

Option Selects... 
All All products in inventory. 

Changed 

Only those products that have sold since the last time you ran the Update Forecast 
Demand program. 
The system also tests products that, in a given period of time, have decreased in sales 
activity as compared to the average period between past sales. The system does this to 
include products in the "changed" group that might be experiencing a decrease in 
demand. 

Buy Line 

Only those products within a buy line. This option activates the Line/Product field, 
where you define the buy line. 
Use this option when you know that significant changes have been made to the 
products in a given buy line. 

Product 

Only a specified product. This option activates the Line or Product field, where you 
define the product. 
For example, if you correct an error on a transaction that affects a product's sales 
history, use this option to recalculate the product's demand. 

3. In the Branch field, enter a branch to define the branches for which to run the update. To run the 
report for all branches, enter All. 

4. If you selected either Buy Line or Product in the Select Group field, in the Line or Product 
field, enter the corresponding buy line or product. 

5. In the As of Date field, enter the actual or system variable date on which the forecast is based. 

Note: When using the Phantom Scheduler to run a program at regular intervals, enter a 
variable date in this field; otherwise, each time the program runs, it will use the 
same as of date. 

6. Do one of the following: 

• From the File menu, select Begin to run the program immediately. 

• From the Options menu, select Schedule to display the Phantom Scheduler, where you can 
schedule the program to run at a defined date and time. 
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Using Advanced Update Demand Forecasting 
Advanced Update Demand Forecasting does not replace the current, standard and median Eclipse 
forecasting methods or the standard Update Demand program. These calculations complement the current 
forecasting to help you delve more deeply into how your products should be managed for replenishment. 
The system looks through the sales history going back a specified amount of time. 

Eclipse calculates demand, finds the current forecast, and then applies the new forecasting. By default, the 
system uses a 5-year period to calculate demand unless a value is set in the Advanced Demand Forecast 
Parameters control maintenance record. Eliminates slow moving items that would not generate accurate 
demand. Smoothing factors for calculating the forecast behind-the-scenes then populate the factors after 
running the program. With the new methods the system tests seasonality on all products that meet the 
minimum hits and minimum history for the calculations. By default, the system uses 24 months. Then, 
Eclipse uses your selected group and goes back the number of weeks indicated in the Advanced Demand 
Forecast Parameters control maintenance record to gather the most recent sales history on your buy line 
or product set. 

Important: If running the advanced forecasting for all products or all branches, we recommend running 
the calculations off-hours so as not to impact system performance. If running the forecast for 
a single product or branch, system performance should not be affected. 

Set these parameters using the Advanced Demand Forecast Parameters control maintenance record. 

For more information about advanced forecasting methods, see About Advanced Forecasting Methods in 
this documentation. 

To run the advanced update demand program: 

1. From the Purchase > Forecasting menu, select Update Advanced Demand Forecast to display 
a selection list. 

2. In the Select Group field, select one of the following: 

Option Selects... 
All* All products in inventory. 

Changed* Only those products that have sold since the last time you ran the Update Forecast 
Demand program. 
The system also tests products that, in a given period of time, have decreased in sales 
activity as compared to the average period between past sales. The system does this to 
include products in the "changed" group that might be experiencing a decrease in 
demand. 

Buy Line Only those products within a buy line. This option activates the Line or Product 
field, where you define the buy line. 
Use this option when you know that significant changes have been made to the 
products in a given buy line. 

Product Only a specified product. This option activates the Line or Product field, where you 
define the product. 
For example, if you correct an error on a transaction that affects a product's sales 
history, use this option to recalculate the product's demand. 

* If you select Changed or All, the Line / Product field does not display. 
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3. In the Branch field, enter a branch to define the branches for which to run the update. To run the 
report for all branches, enter All. 

4. In the Line / Product field, enter the specific buy line or product for which you want to run the 
forecasting. 

Note:  The field name changes based on your selection in the Select Group field.  

5. In the As of Date field, enter the actual or system variable date on which the forecast is based. 

Note: When using the Phantom Scheduler to run a program at regular intervals, enter a 
variable date in this field; otherwise, each time the program runs, it will use the 
same as of date you enter now. 

6. Select the forecast method or methods you want to use for advanced update demand: 

Note: Current forecasting methods cannot be deselected. 

• Single Exponential Smoothing - Standard smoothing factors for forecasting. 

• Holt - The standard smoothing and includes trending calculations. 

• Holt-Winters - The standard smoothing and trending calculations, and adds seasonality 
calculations. Holt-Winters calculations are not made with less than three years demand history. 

Note: For more information about these methods and their calculations, see About 
Advanced Forecasting Methods in this documentation. 

6. Set the Auto Set Best Fit field to Yes to automatically use the best fit method for advanced 
demand forecasting. The report indicates this setting in the header of the report. 

7. Do one of the following: 

• From the File menu, select Begin to run the program immediately. You can also use the 
Run button to run the calculations immediately. 

• From the Options menu, select Schedule to display the Phantom Scheduler, where you can 
schedule the program to run at a defined date and time. 
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Auditing Demand Calculations 
View the components of the demand forecast calculation for an individual product on the Demand 
Calculation Audit dialog box. 

These values update each time you run the Update Demand Forecast program for the product. 

To audit the demand calculation: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. Select a branch and, from the Edit menu, select Audit to display the Demand Calculation Audit 
dialog box for that branch. 

The Product ID displays in the Product Description area. All fields on this window are view-
only. 

5. In the Transaction Information area, review the following fields, as needed: 

Field  Description 
Raw Hits for Period Number of hits recorded during the forecast period. The system uses the number 

of sales occurrences to determine the amount of sales history to review. 

Number of Bill-To 
Customers 

Number of individual customers billed for the raw hits during the forecast period. 
This value demonstrates whether the market or individual customers drive a 
product's demand. 

Median Sale Quantity sold on the median sale from the forecast period. 
Days Out of Stock Number of days the product's on-hand quantity was zero or less during the 

forecast period. 
By default, if you ship items directly from another branch to the customer to 
meet an order, fulfilling demand, the system does not count the product in your 
branch as out of stock. To change this setting, use the Control Forecast 
Parameters Maintenance control maintenance record and select the Exclude 
Ship From Different Branch check box. 

Note: This calculation uses transactions only as far back as when the item was 
created. 

Lost Sale Factor 
Used 

Lost sale factor used by the demand calculation. 

Largest Transaction Largest quantity sold on a single transaction during the forecast period. 

6. In the Demand Information area, review the following fields: 

Field Description 
Date Last Calculated Date the Update Demand Forecast program was last run. 

Demand Pattern Whether the product is seasonal or non-seasonal. 
Demand Period Used Number of days in the forecast period. 
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Field Description 
Raw Demand for 
Period Total quantity sold during the forecast period. 

Exceptional Quantity 
to be Excluded Quantity excluded from the demand calculation due to being an exceptional sale. 

Customer Demand 
Excluded Number of products excluded from the demand calculation. 

7. In the Trend Information area, review the following fields: 

Field Description 
Trend Factor Used Trend factor, if any, used by the demand calculation. 
Automatic Trend Whether the automatic trend calculation is enabled for this product's demand 

calculation. 

Note: Use this figure to compare to the DEMAND (PER DAY) field on the 
Product Order Points/Line Points window to ensure that the audit demand is 
calculating correctly. 

8. Click OK to exit the dialog box. 
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How the System Calculates Demand per Day 
Demand is how often a customer requests a product, whether that product is on the shelf ready to be sold, 
or whether it must be ordered and direct shipped from a vendor, or transferred in from another branch. To 
provide for the needs of your customers, you want to have enough product on the shelf. How much you 
purchase, and how often, often depends on how often a sold in the recent past. 

The basic formula for calculating a product's demand per day is: 

Total Demand in Forecast Period / Days in the Demand Period = Demand per Day 

However, past performance is not always an accurate predictor of future sales. For this reason, the system 
uses different inventory control parameters as part of the demand calculation. 

To calculate daily demand for each product, the system does the following: 

1. Determine whether to do the demand calculation. 

• If the product status is Stock or NonStock, calculate demand. 

• Otherwise, do not calculate demand. 

2. Determine whether product is seasonal or non-seasonal and whether to use product, buy line or 
system forecast parameters, and then determine the product's forecast period. 

3. Within the product's forecast period, scan the sales and work order transactions, but not returns or 
transfers, for Stock and Tagged, not Direct, Overship, Exceptional or Review quantity types. 

For each qualifying transaction, collect the: 

• Transaction date 

• Number of hits 

• Bill-To ID 

• Order quantity 

Continue collecting data until the number of transactions reaches the minimum number of hits 
required for forecasting-as defined on the Forecast Parameters window at the product, buy line or 
system level-or the end of the forecast period. 

• If the total number of hits collected is less than the minimum number of hits required for 
forecasting, check to see whether the product is set up to add the demand of other products to 
its demand. If so, repeat step 3 to gather the same information for the additional items. 

• If, after all sales transaction information has been gathered, the total hits is still less than the 
minimum hits requirement as defined in the Minimum Hits control maintenance record, then 
discontinue the demand calculation for this product. 

4. Remove the exceptional sales, if they exist. 

5. Sort the new transaction list by quantity and identify the order quantity of the median sale. That 
is, the quantity of the middle transaction in the data sample. 

6. For a seasonal product with automatic trend enabled, adjust the demand according to the system-
calculated trend percent. 

7. If a lost sale percentage exists for the product, increase the demand to account for lost sales. 
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8. If it exists for a non-seasonal product, adjust the demand by the manual trend percent. 
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Setting Product User Control Parameters 
Use the Product User Control Parameters dialog box to enter specialized product-level inventory 
parameters, to: 

• Estimate product demand for a new branch 

When you have a new branch that has no product history, use the Min, Max, Exp Date, and Calc 
Dmnd fields to define minimum and maximum stocking levels for the products until there is 
sufficient product history for the demand calculation to take over. 

You can estimate the minimum and maximum stocking levels for a new product until the product 
accrues enough demand history for the system to begin forecasting. As the system monitors a 
product's demand, you can set an expiration date after which the system will stop using estimated 
minimum and maximum levels for suggested purchasing, and begin forecasting demand for 
regular product order points and line points. 

• Add service stock to the demand 

Use the Service Stock and Serv Stock Exp Date fields to add service stock, to the product's 
order point and line point calculations. This adjustment, also known as manual safety stock, is a 
quantity of stock above your normal stocking level that you have committed to keep on the shelf 
at a branch for a set period. 

For example, assume the following it true: 

• You run a promotion on an item, guaranteeing that you will have it in stock. 

• A contractor requests that you keep an item in stock in case he or she needs one in an emergency. 

• Your branch utilizes items for its own maintenance and you do not want your use of the items to 
count towards the item's demand. 

When you assign service stock, the system assigns the additional quantities to the order point and 
line point calculations. When you reach the expiration date of the service stock the system 
removes the additional quantities from the order point and line point calculations. 

You can set service stock for a branch or for a customer at a branch using the Product User 
Control Parameters dialog box. 

Use the Customer Service Stock menu option to add customer service stock to the product's 
normal demand. Customer service stock is a quantity of stock above your normal stocking level 
that you have committed to keep on the shelf for a set period, as a courtesy to a customer. After 
entering customer service stock information for a product, the total requirements display in the 
CusServ Stock field. The system adds the additional stock requirements to the product's order 
point and line point calculations. 

The following procedure is a manual process for a single product. Use the Mass Load program to enter 
inventory parameters to groups of products. 

To set User Control Parameters for a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 
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4. From the Edit menu, select User Controls to display the Product User Control Parameters 
window. 

5. Do one of the following: 

• From the File menu, select Hierarchy to display the Product User Control Parameters dialog 
box. In the Enter hierarchy branch field, enter the branch or territory ID. 

• From the File menu, select Add Branch. In the Enter Branch field, enter the branch or 
territory ID you want to view. 

Important: Only stocking branches are allowed. 

6. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

7. For each branch or territory, complete the User Control Parameter columns, as needed. 

Field View Description 
Min (ea) All The estimated minimum quantity to stock: 

• Purchasing branches use this quantity in place of a calculated order 
point until the expiration date. 

• When the Respect Item Min/Max For Suggested Transfers 
control maintenance record is set to Y, child branches use this 
quantity in place of a calculated transfer point until the expiration 
date. 

• Enter 0 (zero) if the branch does not stock the item, or enter the 
actual quantity that should ever be stored at the child branch when 
using this field with the Calculate Demand 
field.                                                                

If a product has a min setting but no max setting, the order point and 
the line point quantity are equal to the value in the Min field unless 
the system calculated line point quantity is greater than the minimum. 
In this case, the system uses the calculated line point quantity. Any 
child branches inherit the minimum only setting. 

Note: If you use vendor managed inventory and generate EDI 852s, 
the MIN only should only report if it is greater than the OP. If it is 
greater than the order point, it should net to the Available and report 
the difference between the MIN and the available as the quantity 
reserved (QD). If the order point is 10 and MIN only is 15 and 
available is 5, then report 10 as quantity reserved (QD). If the order 
point is 10 and MIN only is 15 and available is 20, then report 
nothing, as the product has enough available to cover the MIN only. 
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Field View Description 
Max (ea) All The estimated maximum quantity to stock: 

• Purchasing branches use this quantity in place of a calculated order 
point until the expiration date. 

• When the Respect Item Min/Max For Suggested Transfers 
control maintenance record is set to Y, child branches use this 
quantity in place of a calculated transfer point until the expiration 
date. 

• Enter 0 (zero) if the branch does not stock the item, or enter the 
actual quantity that should be stored at the child branch when using 
this field with the Calculate Demand field. 

If a product has a min setting but no max setting, the order point and 
the line point quantity are equal to the value in the Min field unless 
the system calculated line point quantity is greater than the min. In this 
case, the system uses the calculated line point quantity. Any child 
branches inherit the minimum only setting. 

Expiration 
Date 

All The date after which the values in the Min and Max fields are no 
longer valid. We recommend that you use an expiration date six 
months from the current date. 

Calculate 
Demand 

All To calculate demand from dependent selling branches for use at 
purchasing branches, select the check box in the selling branch rows; 
otherwise, leave it empty. 
If you use a minimum-only order point for your newer products, 
ensure that the Calculate Demand field is deselected. For more 
information, see Setting Minimum and Maximum Stocking Levels for 
New Products. 

Service 
Stock 

Service 
Stock 

The quantity of the product to reserve as service stock. 

Service 
Stock 
Expiration 
Date 

Service 
Stock 

The date the system stops adding the service stock quantity to the 
product's order point and line points. 

Customer 
Service 
Stock 

Service 
Stock 

The system populates this field with the total quantity of service stock 
reserved for selected customers. The total quantity only includes those 
quantities within their respective effective date and expiration date. 
The effective and expiration dates are for reporting purposes only and 
do not affect automated purchasing or automated transfers. For more 
information, see Customer Service Stock Report. 
When a branch or territory appears on the User Inventory Control 
window without a value in the CusServ Stock field, this indicates that 
a customer contract stock quantity is set. For more information, see 
Viewing Customer/Vendor Specific Part Number Details. 
This field is view-only. 

Product 
Lifecycle 

Service 
Stock 

Select the product lifecycle to classify the product you are adding. For 
information about product lifecycles, see Creating Product Lifecycles 
in Product Maintenance. 
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Field View Description 
Vendor 
Return 
Allowed 

Product 
Returns 

Select one of the following: 
• Always - Allow returns regardless of return type. 
• RGA - Allow returns only if customer has Return Goods 

Authorization number provided by the vendor. Users must be 
assigned the SOE.RGA.REQUIRED authorization key to return any 
products without an RGA number, but flagged with this setting. 

• Never - Disallows all returns from this vendor. This setting can be 
used for items like remnants that you cannot take back into 
inventory. Products flagged as non-returnable are not included in the 
Suggested PO Return Queue. Users must be assigned the 
SOE.NONRETURN.PROCESS authorization key to return any 
products with this setting. 

Customer 
Return 
Allowed 

Product 
Returns 

Select one of the following: 
• Always - Allow returns regardless of return type. 
• Defective - Allow returns only if product is broken or otherwise 

defective. 
• Never - Disallows all returns from this customer. Users must be 

assigned the SOE.ALLOW.NONRETURN authorization key to 
return any products with this setting. 

Economic 
Amount 

Product 
Returns 

Enter the amount below which the system recommends not returning 
items to inventory. If the value of the item being returned falls short or 
below this amount, the system recommends the item not be returned to 
inventory because the processing costs outweigh the actual value of 
the item. For more information, see Determining the Economic Return 
Amount in the Purchasing documentation. 

Auto 
Generate 
Return? 

Product 
Returns 

Indicate if you want to allow the system to automatically generate a 
return. 

Auto Return 
Ship Via 

Product 
Returns 

Select the ship via that the system should use when automatically 
creating a return for products. 

Auto Return 
Status 

Product 
Returns 

Select the order status that the system should use when automatically 
creating a return for products. 

Auto Return 
Days for 
Ship Date 

Product 
Returns 

Select the number of days allowed for the customer to return the 
selected product. 

7. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 

More Options for the Product User Control Parameters Dialog Box 

The Product User Control Parameters dialog box also offers these options: 

To... Select this menu option... 
view inventory details about the product in all 
branches 

Inquiry > Inventory Inquiry 
The Inventory Inquiry window displays. 
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To... Select this menu option... 
view information pertaining to the calculation 
of the product's demand 

Inquiry > Audit 
The Demand Calculation Audit dialog box displays. 

add the demand history of discontinued 
products to their replacements 

Additional Controls > Add Demand 
The Add Demand dialog box displays. 

define hits-related inventory parameters for 
each branch 

Additional Controls > Hits Maintenance / Max Days 
Supply 
The Hits Control Maintenance dialog box displays. 
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Adding Demand History to Products 
Use the Product User Control Parameters to add demand from one product to another. You can copy 
existing demand history from one or more products to a new product with the Add Demand window. 
Demand history can be in units, weight, or load factor depending on the item and need. This choice 
enables you to create demand history for new product when: 

• A new product replaces a discontinued product. You can assume that the demand for the new item 
is similar to that of the old item. For example, you Product A Model 100 is being replaced by 
Product A Model 200. Use the demand for the old product to predict the demand of the new 
product. 

Note: Change the discontinued item's product status to something other than Stock. 
Otherwise, the system continues suggesting that you purchase both items. 

• A new product is sold that combines several items. The demand of the multiple products is totaled 
and added to the new product. For example, you sell individual tools. You now provide three tools 
in a one set. Use the demand for the individual tools to calculate the history for the set. 

• You must know how much material one product uses from its component parts. Copy the demand 
history based on the relationship between the components over to the finished product. For 
example, you must know how much sheet metal to order to manufacture duct work. By combining 
the monthly demand in weight of your duct-work components, you can estimate how much sheet 
metal you need each month. 

Use the Add Demand dialog box to: 

• Add the demand history of one or more discontinued products to their replacement. 

• Add a product's demand history in one branch to another branch. 

• Add or subtract a customer's demand history from one product to another. 

To add demand history to a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box 

4. From the Edit menu, select User Controls to display the Product User Control Parameters dialog 
box. 

5. From the File menu, select Hierarchy to display the Product User Control Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

8. From the Additional Controls menu, select Add Demand to display the Add Demand dialog 
box. 

Note: Use the Branch Fields Required To Add Product Demand control maintenance 
record to limit the branch fields you want the Add Demand program to use.  
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9. In the Include the following products' demand with the product above based on field, enter 
one of the following measurement types: 

• Units - Includes demand based on the number of items. 

• Weight - Includes demand based on the weight, in pounds, of the item. 

• Load - Includes demand based on the load factor for the item. 

10. Complete the following fields for each product from which to add demand: 

Field Description 
Products The product from which to copy demand history to the new product 

Use the Do Not List Item More Than Once On Add Demand Screen to 
indicate if you want to list products more than once on the Add Demand 
window.  

Expire Date The date after which to stop adding the demand of the product to the demand of the 
new product. 

To Branch The branch that will use the demand history. 

From Branch The branch from which to obtain the demand history. 
Add PIL Select if you want the projected inventory level (PIL) of the old product to flow 

through to the replacement product. 
When you add the demand of another product to a new or replacement product that 
has no inventory, the system purchases the replacement product before you have sold 
off what is left of the old product. Using the Add PIL option stops the replacement 
product from being suggested to purchase. As the PIL of the old product is reduced 
then the replacement product comes up to purchase once it is below the order point. 

Note: The PIL of the replacement product displays in bold after selecting this option. 

11. Add or change a customer's demand for a product, as needed. 

12. Save the information and exit the dialog box. 
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Changing Customers' Demand for Products 
When customers change their buying habits, the change can affect product demand. If a customer must 
change to a new model of product either by choice or by necessity, the customer can lose that buying 
history and thus effect demand. Update the customer's demand for the products using the Add Demand 
feature in Product Maintenance. 

For example, if a customer decides to start purchasing Brand A rather than Brand B products, you want to 
add the demand of Product B to Product A to assist the demand calculation. Or if a customer decides to 
purchase products from a different branch, you want to add the demand of those products from the old 
branch to the new branch. 

To change a customer's demand for a product: 

1. Add demand history to the product. 

2. From the File menu, select Customer Demand to display the Add Demand Customer 
Information dialog box. 

3. Complete the following fields for each customer: 

Field Description 

Customer The customer whose demand you are adding to or subtracting from the 
product. 

Option 

Enter one of the following: 
• Add - Adds the customer's demand for the selected product to the new 

product's demand. 
• Sub - Does not add the customer's demand for the selected product to the 

new product's demand. 

4. Click OK to save the information and exit the dialog box. 
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Viewing Contract Stock Quantities 
You can view customer or vendor contract quantities and their effective dates on the Product Inventory 
Customer Service Stock window. 

A customer or vendor can have contract quantities independent of service stock quantities. The system 
does not add contract quantities to the demand calculation; they are used for reporting purposes only. 

Assign contract stock quantities using the Customer/Vendor Part Number Detail window. 

Use the Customer Service Stock report to track demand for contract quantity items that have not expired. 

To view contract quantity information for a product: 

1. Set user control parameters for a product. 

2. In the Product User Control Parameters dialog box, select a branch, and, from the Additional 
Controls menu, select Customer Service Stock to display the Product Inventory Customer 
Service Stock dialog box. 

The system populates the Customer Service Stock field with the total quantity required by 
customers. 

3. Under the Contract heading, review the following: 

Column Description 
Customer The customer assigned the contract stock quantities. 
Quantity The contract quantity. This field is for reporting purposes only. 

Effective Date 
The date the contract goes into effect. This field is for reporting 
purposes only. It does not affect automatic purchasing or automatic 
transfers. 

Expire Date The date the contract expires. This field is for reporting purposes only. 
It does not affect automatic purchasing or automatic transfers. 

As contract quantities are for reporting purposes only, the system does not include them in the 
customer service stock totals in the Customer Service Stock field of the Product User Inventory 
Controls window. 

4. Click OK to save the information and return to the previous dialog box. 
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Adding Demand from Dependent Selling Branches to 
Purchasing Branches 
A dependent selling branch is a branch that does not warehouse the stock that it sells. Instead, it relies on 
a separate purchasing or warehousing branch to ship items that the selling branch has sold to customers. 
For example, your selling branch is a showroom branch without a warehouse. When you sell items, your 
purchasing branch or warehousing branch is responsible for shipping or transferring those items "as 
needed." 

• If a selling branch does not stock an item, but transfers it in "as needed" to fulfill a customer 
request, you will want to add the demand to the purchasing branch. If the Min/Max settings are less 
than the actual demand in the selling branch, the purchasing branch buys and keeps in reserve 
sufficient inventory based on demand and transfers it to the selling branch. 

• If the selling branch is closing out of the item at their location, you would not want to add the 
demand to the purchasing branch. If the Min/Max settings are more than the actual demand in the 
selling branch, the purchasing branch buys and keeps in reserve the specified amounts. 

To add demand from a selling branch to a purchasing branch: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box 

4. From the Edit menu, select User Controls to display the Product User Control Parameters dialog 
box. 

5. From the File menu, select Hierarchy to display the Product User Control Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

8. Complete the following fields: 

Field Setting 

Min 
Enter the actual quantity that should ever be stored at the child branch when using this 
field with the Calc Dmnd field. In this case, the minimum value must equal the 
maximum value. 

Max 
Enter the actual quantity that should ever be stored at the child branch when using this 
field with the Calc Dmnd field. In this case, the maximum value must equal the 
minimum value. 

Expiration 
Date Leave blank. 

Calculate 
Demand 

To include sales of the item at the selling branch in the calculation of demand at the 
purchasing branch, select the check box; otherwise, leave it blank. Use this option for 
situations wherein a selling branch does not normally stock an item, but transfers the 
item in as-needed from another location. 
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Field Setting 
For example, if the Min/Max settings are less than the actual demand in the baby 
branch, select the check box so the purchasing / parent branch buys and keeps in 
reserve sufficient inventory based on demand and transfers it to the child branch 
according to Min/Max. 

If you use a minimum-only order point for your newer products, ensure that the 
Calculate Demand field is deselected. For more information, see Setting Minimum 
and Maximum Stocking Levels for New Products. 

9. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 
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Estimating Demand for New Branches 
When you add a new branch to your company, you must estimate demand for the products sold at the 
branch. There are two ways to add demand for a new branch: 

• If you expect the new branch to be similar to an existing branch, you can add the product demand 
history of another branch to the new branch. 

• If you do not have suitable product demand to use for the new branch, you can set minimum and 
maximum stocking levels for products at the branch. 
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Setting Minimum and Maximum Stocking Levels for New 
Products 
Until a new product accrues enough demand history for the system to begin forecasting demand, you can 
enter estimated minimum and maximum stocking levels for the product. You can also set an expiration 
date, after which the system stops using estimated stocking levels for suggested purchasing. On this date, 
the system begins forecasting demand using the accumulated demand history and established order points 
and line points. 

Note: You can set a minimum-only order point for a product to make sure the system 
uses the largest line point available. If you use a minimum-only order point, 
ensure that the Calculate Demand field is deselected. 

The following procedure is a manual process for a single product. Use the Mass Load program to enter 
minimum and maximum levels for all the products in a buy line. 

To set minimum and maximum levels for suggested purchasing of a new product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Display a product record needing minimum and maximum stocking levels. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance dialog box. 

4. From the Edit menu, select User Controls to display the Product User Control Parameters dialog 
box. 

5. From the File menu, select Hierarchy to display the Product User Control Parameters dialog box. 

6. In the Enter hierarchy branch field, enter the branch or territory ID. 

7. Click OK to display user control parameters for the selected branch in the Product User Control 
Parameters dialog box. 

8. Complete the following fields: 

Field Description 
Min Enter the estimated minimum quantity to stock. 

• Enter 0 (zero) if the branch does not stock the item. 
• Purchasing branches use this quantity in place of a calculated order point until 

the expiration date. 
• When the Respect Item Min/Max For Suggested Transfers control 

maintenance record is set to "Y" child branches use this quantity in place of a 
calculated transfer point until the expiration date. 

• Enter the actual quantity that should ever be stored at the child branch when 
using this field with the Calc Dmnd field. 

If a product has a minimum setting but no max setting, the order point and the 
line point quantity are equal to the value in the Min field unless the system 
calculated line point quantity is greater than the min. In this case, the system 
uses the calculated line point quantity. Any child branches inherit the minimum 
only setting. 
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Field Description 
Max Enter the estimated maximum quantity to stock. 

• Enter 0 (zero) if the branch does not stock the item. 
• Purchasing branches use this quantity in place of a calculated line point until 

the expiration date. 
• When the Respect Item Min/Max For Suggested Transfers control 

maintenance record is set to "Y" child branches use this quantity in place of a 
calculated surplus point until the expiration date. 

• Enter the actual quantity that should ever be stored at the child branch when 
using this field with the Calc Dmnd field. 

If a product has a minimum setting but no max setting, the order point and the 
line point quantity are equal to the value in the Min field unless the system 
calculated line point quantity is greater than the min. In this case, the system 
uses the calculated line point quantity. Any child branches inherit the minimum 
only setting. 

Expiration Date The date after which the system no longer uses the values in the Min and Max 
fields. We recommend using six months. 

Calculate 
Demand 

Indicates whether to calculate demand for dependent selling branches. 
If you use a minimum-only order point, ensure that the Calculate Demand field 
is deselected. 

9. Enter service stock parameters, if needed. 

10. Save the information and exit the dialog box. 

Changes take effect when you exit Product Maintenance. 
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Defining the Maximum Day's Supply for Products 
Define a maximum number of days' supply of a product that your company permits to be maintained in 
inventory. Defining a maximum number of days' supply keeps your inventory at an efficient level so that 
you do not keep unnecessary stock in your warehouse. 

The system checks whether a product's current maximum days' supply is greater than a limit set for the 
individual product, buy line, or all products. This check also prevents you from bringing unnecessary 
stock into your warehouse and moving inventory in quantities greater than what you sell. The system 
makes this check whenever a product is placed on an sales order, purchase order, transfer order, or 
inventory adjustment. 

The system uses the following calculation to determine the product's projected maximum days' supply: 

Product Projected Maximum Days' Supply = Product's projected inventory level (PIL) / Demand 
per day 

You can define maximum days' supply at three levels: 

• Branch - Applies to all products, unless overridden at the buy line or product level. The 
Maximum Days Supply control maintenance record defines the maximum days' supply default for 
each branch. The branch default is used when products do not have maximum days' supply set at 
the product or buy line level. 

• Buy Line - Applies to all products assigned to the defined buy line, unless overridden at the 
product level. The buy line level overrides the branch default parameters. 

• Product - Applies to the defined product and overrides the buy line and branch default parameters. 
The maximum days' supply checking logic does not apply to products with a status of MiscCharge. 

When an item is added to a transaction, the system checks the PIL. If an item fails the check, the system 
warns that you are about to affect inventory levels set to the maximum days' supply limit. The warning 
displays the item's part number, description, PIL, daily demand, and its projected maximum days' supply. 

If you have the corresponding PIL override authorization key (AOE.PIL.DAYS.OVRD, 
POE.PIL.DAYS.OVRD, SOE.PIL.DAYS.OVRD or TOE.PIL.DAYS.OVRD) assigned, the message has 
a Continue (Y/N) prompt. Otherwise, the message prompts you to enter the password of another user 
who is authorized to override the maximum days' supply limit. 

For example, you set the system default for maximum days' supply to be 456. Product A has a daily 
demand of 0.03 and a PIL of 12. The system calculates that the maximum days' supply is 400. This 
product is not in violation of the maximum days' supply limit. A purchasing agent attempts to meet a 
vendor target by manually adding 3 more of Product A to a purchase order. Product A's PIL increases to 
15 and its maximum days' supply to 500. The system warns the purchasing agent that including this 
product on the purchase order in this quantity violates the maximum days' supply limit. 

If an item is removed from a transaction, or the transaction is deleted, the system compares the PIL at the 
time of the removal or deletion to a stored PIL. If the removal or deletion does not make the PIL higher 
than it was at the time of the addition, no maximum days' supply warning displays. 

To define the system default maximum days' supply: 

1. From the System > System Files menu, select Control Maintenance to display the Control 
Maintenance window. 
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2. In the Keyword field, enter max day supply to display the Maximum Days Supply control 
maintenance record window. 

3. Double-click the description to display the Maximum Days Supply window. 

4. In the Branch/Territory field, enter the branch or territory you want to select. Enter All to select 
all branches and territories. The default is All. 

5. For each branch, enter the maximum days' supply that your company permits to be stocked for all 
products in the warehouse. 

Note: We recommend setting the system default to 99999. This causes the system to 
warn users when they attempt to purchase or transfer nonstock items that have a 
daily demand of 0. 

6. Click Save to save changes and exit the screen. 

To define the maximum days supply for a product: 

1. From the Files menu, select Product to display the Product Maintenance window. 

2. Select a product. 

3. From the Inventory menu, select Primary Inventory Maintenance to display the Primary 
Inventory Maintenance window. 

4. From the Edit menu, select User Controls to display the Product User Controls Parameter 
window. 

5. From the Additional Controls menu, select Hits Maintenance / Max Days' Supply to display 
the Hits Control Maintenance window. 

6. In the Central Warehouse Type field, enter Top-Down or Bottom-Up to define which type of 
warehouse you are working with. 

7. Use the Find menu as necessary to locate a branch that is in the list, but not in the viewable area, 
add a branch or territory to the list, or remove a branch or territory from the list. Select the branch 
to which you need to make changes. 

Note: The new branch or territory inherits the settings of the previous entry. 

8. In the Max Days Supply field for a branch or territory, enter the maximum days' supply of the 
product that your company permits to be stocked in the warehouse. 

9. Set hits control parameters, as needed 

10. Press Esc to save changes and exit the screen. 
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Product Ranking Overview 
Use the Product Ranking program to analyze the activity of a product, including dynamic kits, in each 
branch of your company. Product Ranking is used to compare the activity of a product against all other 
products within the same price line, a group of price lines, or all price lines. Product ranking is a way to 
label all your products as to their relative impact to sales, inventory, and purchasing activities. Product 
ranking is calculated by the system based on the parameters set. For more a breakdown of the parameters 
in the system, see Product Ranking Method and Breakpoint Rules . 

When you run the ranking program, the system sorts the products according to the ranking method and 
then ranks the products according to the percentages defined as the ranking breakpoints. The system 
makes a pass through each branch for each ranking method and populates the Rank Maintenance 
information for each product based on the parameters you define. Adjust product ranks in Rank 
Maintenance in Product Maintenance, if needed. You can also relabel rank IDs, if needed depending on 
your business needs. 

Note: The product ranking program updates records for only active branches. If the 
system finds a record for an inactive branch, then the system deletes that record. 

A product has an X ranking in the following circumstances: 

• The product is a kit (not a dynamic kit). The true rank value is at the products that make up the kit. 

• The product has been set for deletion. 

• The product has a product status of MiscChrg. 

• The product has been set for purging. 

• The product is a non-stock and the Product Ranking program excluded non-stocks from the ranking 
process. 

The Product Ranking program, in conjunction with the Update Demand program, provides tools to help 
you decide how best to price your products. Using a matrix cell, you can detail product pricing based on 
product velocity. 

Important: Due to lengthy run times, we recommend updating demand and updating product ranking on 
different days. 

This section discusses the following topics: 

• Product Ranking Method and Breakpoint Rules 

• Viewing Product Ranks 

• Running the Product Ranking Report 

• Product Ranking Information Uses 

• Using the Product Ranking Program 
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Product Ranking Method and Breakpoint Rules 
Use the Product Ranking program to compare the activity of a product against all other products within 
the same price line, a group of price lines, or all price lines. Ranking methods for your product files 
depend on your company’s needs. After you have determined the ranking methods and breakpoints, you 
can generate the Product Ranking Report. 

You can use different ranking methods at different branches. You can use all of these methods or just the 
ones that meet your company's needs. 

Ranking Method Description 
Monthly Demand Average monthly usage in units. 
$ Demand (Dflt 
COGS) 

Dollar demand with respect to cost (unit demand times the cost of goods sold cost) 
over the course of 365 days. 

Gross Sales $ (12 
Mths) Gross sales dollars in the past 365 days. 

Hits Number of times the product was sold over the course of 365 days. 
Gross Profit $ (12 
Mths) Gross profit dollars in the past 365 days. 

Entering ranking methods in a descending order of importance is most effective, because the Inventory 
Inquiry window only displays the rank corresponding to the first three ranking methods. Descending 
order displays the highest percentage of products first. 

In addition, the Suggested P/O report only displays the rank corresponding to the first two ranking 
methods for a product that is listed on the report. If the items are listed in descending order, then the most 
needed items display as purchasing suggestions. 

Note: The system allows user-defined product ranks, if you need to map a specific 
character or number to a product rank. 

Incorporating Breakpoints 
After you decide what kind of methods to rank products with, then determine the percentage you attach to 
a Rank ID. After identifying what you want to track for each ranking, you need to decide how to break 
your products into groups for each rank you identified. 

For example, consider that you rank 100 percent of your products. You can set Rank IDs to track product 
issues, or methods, as follows: 

Rank ID Rank Method 
Rank # 1 Hits 

Rank # 2 Demand 
Rank # 3 Demand $ (Dflt-COGS) 
Rank # 4 Gross Sales $ (12 Mths) 

Rank # 5 Gross Profit $ (12 Mths) 
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Ranking methods are typically specified in a descending order, however this is not required.   

Important: You can create user-defined ranks, if you want to label your ranks differently. 

The following percentages reflect the normal industry convention for ranking breakpoints called the 80/20 
rule. This rule says that 20 percent of your products accounts for 80 percent of your sales: 

Rank ID % of Total Products 
A 80% 
B 15% 

C 4% 
D 1% 

E 0% 

When the ranking program runs, the system selects those products that meet the selection criteria 
specified for price lines and stock/nonstock items. After items are selected then the products are ranked 
for each specified ranking method according to the ranking breakpoints defined. For example, using the 
methods defined above, a product could have an A rank due to Hits, but a C rank due to Dollar Demand. 
View the ranking by individual product on the Product Ranking Maintenance window from Product 
Maintenance. 

Note: Normally, the system compares product activity within a price line. If the ranking 
is done globally, the system compares each product’s activity against the activity 
of all other products, regardless of price line.   

Individual versus Collective Ranking 
Indicate whether to rank the products Individually or Collectively. 

If you rank individually, product amounts within each branch are considered separately from every other 
branch when calculating product ranks. 

If you rank collectively, product amounts for all branches are combined before calculating product ranks. 
If ranked collectively, products then would be assigned the same rank in each of the branches selected. 

Global versus Non-Global Ranking 
When creating a new Ranking ID, you have the option of selecting how you want the program to rank the 
products: globally or non-globally. The default entry is No. 

If set to No, items are ranked with respect to the products in the same price line. Select No if you want 
items to be compared within the same price line for specific purposes, such as markup on slow moving 
items. 

If set to Yes, products are ranked with respect to all other selected products, regardless of price line. For 
example, if you selected Moen and Delta price lines, products within the Moen price line are ranked 
against the products in the Delta price line. Use Price Lines function to update this list. Select Yes if you 
are looking at overall inventory analysis. In addition, when the ranking method displays for the indicated 
branch on the Ranking window from Price Line Maintenance *Global* displays with the indicated rank. 
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Changing Product Ranking 
You can manually change product ranking for any of your branches when necessary. For example, a 
customer purchased a large volume of a D-ranked product in one day, turning the product into an A-
ranked product. You can manually change the rank back to D to reflect the product's true sales volume. 
Use the Product Rank Maintenance window to make manual changes. For more information about 
changing ranks on products, see Changing Product Ranking. 

Using a Template 
We recommend using the 80, 15, 4, and 1 template, which is the normal industry convention for ranking 
breakpoints. This convention reflects the 80/20 rule, that says 20 percent of your items account for 80 
percent of your sales. 

With these breakpoints, the items that contribute to the top 80 percent of the value, or the top 20 percent 
of your items, of the ranking category are A items. The items that comprise the next 15 percent are B 
items. The items that make up the next 4 percent are C items and the items that contribute to the last 1 
percent are D items.  You cannot go over 100% because anything greater than 100 percent has no rank. 
See the example below. 

After specifying a new template name, the default numbers are cleared. Enter the same or other numbers 
that reflect your ideas about ranking breakpoints. You can assign up to seven ranks. The total of the 
percentages should not exceed 100. Anything greater than 100% has no rank. 

We recommend that you use all the product ranking methods in the order that best suits your company's 
needs.  However, when using multiple Ranking IDs, be consistent with the order of the ranking methods. 

An Example 
Five ranking methods and ranking breakpoints have been selected in the example below. 
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Product Ranking Information Uses 
You can use product ranking information in several areas of your business: 

• Warehousing 

• Purchasing 

• Pricing 

• Inventory Management 

Warehousing 
The more times you pick a product, the more accessible it has to be. Therefore, high selling items have a 
higher ranking. You can set up your inventory location by Rank ID. higher selling items would need a 
more convenient and accessible storage location. 

Purchasing 
The more you sell a product, the more important it is that you never run out of it. 

The product ranking information on the Suggested P/O Report and the Suggested P/O Detail Queue helps 
you decide which products to order, transfer, or procure. 

The report and the queue display: 

• The most recent ranks calculated for the first two ranking methods for a product in the buying 
branch on the report. 

• The most recent ranks calculated for all five ranking methods for a needed product when it is in 
surplus at another branch. 

If two branches have a surplus of this product, transfer the product from the branch for which this product 
has the lowest rank. Use the Transfer Surplus Queue to convert the suggestion to transfer purchase orders. 

Pricing 
Use product ranking information with the product velocity pricing function in Assigning Rank in Product 
Velocity Pricing. This function lets you fine tune the pricing of the products in a matrix cell with respect 
to the ranking of those products. 

Use the product velocity function to be competitive when needed and to try to make more money on the 
items that do not have to be competitive. Assign an additional price break to faster moving items and 
progressively raise the price for slower moving items, according to their rank. 

For RF Receiving and PutAway, you can display product ranks on the RF window to provide guidance 
when changing locations for items being put away. Move products with a high ranking closer to the 
shipping area.  For more information, see RF Warehouse Management Overview. 

Inventory Management 
Manage your inventory in conjunction with Purchasing. 
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Inventory GMROI Report 
The Inventory GMROI Report displays the first three product rankings, based on the selected product 
ranking categories, for the product for each branch. For more information, see GMROI Overview. 

Cycle Counting 
When doing a cycle count, you can limit the count to items with certain product ranks. For more 
information, see Counting Inventory Overview. 
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Viewing Product Ranks 
You can view the program results for a product's latest product ranking from several windows. 

• Product Maintenance 

• Inventory Inquiry 

• Price Line Ranking 

• Product Ranking Report 

To view a ranking in Product Maintenance: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. From the Pricing menu, select Product Price Maintenance, enter the product ID for which you 
want to view the rank. 

3. From the Pricing menu, select Ranks to display the Rank Maintenance window. 

4. In the Branch/Territory/All filed, enter the branch or territory for which you want to display the 
rank information. 

The results of the last ranking that affected the specified product display. The rankings are 
dependent upon the criteria assigned to the Ranking ID that was used to run the ranking. 

5. Save your changes and exit the window. 

To view a ranking on the Inventory Inquiry window: 

1. From the Orders > Inquiries menu, select Inventory Inquiry to display the Inventory Inquiry 
window. 

2. In the Product field, enter the product for which you want to display the rank information. 

For each warehouse branch the Rank column displays the product's most recent ranks for the first 
three ranking methods. 

3. Exit the window. 

 To review a product ranking on a price line: 

1. From the Maintenance > Price Maintenance menu, select Price Line to display the Price Line 
Maintenance window. 

2. In the Price Line ID field, enter the price line for which you want to display the rank 
information. 

3. From the Edit menu, select Ranking to display the Price Line Ranking dialog box. 

For each branch, the ranking method used for each Rank # and the date and time the last ranking 
was done and the user who ran it displays. 

4. Click OK to exit. 

5. Exit the window. 



Using the Product Ranking Program 

126 

Using the Product Ranking Program 
Normally, the system compares product activity within a price line. If the ranking is done globally, then 
the system compares each product’s activity against the activity of all other products, regardless of price 
line. By default, the program runs for all price lines. Before running the Product Ranking program you 
need to determine how to rank the products and save the parameters. 

If you manually change a product rank through Product Maintenance, you have the option of maintaining 
or overwriting that rank when you run the Product Ranking program. The system prompts you with the 
following: Overwrite Manually Set Product Ranks (Y/N). Enter Yes to complete the override. 

Note: If a product has been ranked Collectively, the system does not delete the ranking 
even if the product is inactive for that branch. 

For more information about how the system uses methods and breakpoints in the system, see Product 
Ranking Method and Breakpoint Rules. 

The Product Ranking program provides the following information: 

Column Description 
Rank The sequential position of the item within the selected items. 

Rank% The rank divided by the number of items being ranked times 100. 
Formula: (rank / #of items) x 100 = Rank% 

Cum-Value% The percentage of the cumulative value divided by the total value. 
Formula: cum-value / total value = Cum-Value% 

Cum-Value Running total of the actual value. 
Product 
Description 

The product being ranked. 

Miscellaneous charges and purge items are excluded from the rank calculation and items with a negative 
GP$ are considered zero. 

Generating the Product Ranking Report 
Use the Product Ranking program to run the Product Ranking Report. This report is more like an audit 
and lists what the percentage of items is in each rank and the value of each breakpoint. Use this 
information to determine how and why your products are currently ranked the way they are, answering 
the question: Where did this product rank come from? 

To create a report from the Product Ranking Program follow the procedure below and change the 
Generate Report selection to Yes. The system saves this setting. The next time you run the program, you 
must change it back to No to rank your products without running the report. 

For more information, see What the Report Shows below. 

To run the Product Ranking Report: 

1. From the Purchase > Forecasting menu, select Product Ranking to display the Product 
Ranking Report window. 

2. In the Ranking ID field, select the ranking ID to include in the report. The system populates the 
current methods and breakpoints saved for that ranking ID. 
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3. Update the remaining fields, as needed: 

Field Description 
Branch/Territory Lets you rank products in a particular branch, branches, or territories. The results 

of the ranking process are always displayed on a branch-by-branch basis. 

Ranked Indicate whether to rank the products Individually or Collectively. 
• Individually - Product amounts within each branch are considered separately 

from every other branch when calculating product ranks. This is the default. 
• Collectively - Product amounts for all branches are combined before 

calculating product ranks. If ranked collectively, products would consequently 
be assigned the same rank in each of the branches selected. 

Nonstocks Specify whether to Include or Exclude product ranking for nonstock products. 
• Include - If a nonstock is selling often enough to earn a high ranking, you can 

consider changing it to a stock item so you do not run out of it. This is the 
default. 

• Exclude - The product is not included in the ranking process. For companies 
that do not rank nonstocks, this guarantees that ranked stock items that are 
changed to nonstock items do not retain their rank after the ranking program 
runs. 

• Only - Apply parameters or run for only nonstock items. 

Generate Report Select one of the following 
• Yes - The system applies rankings and methods and creates a report to send to 

your hold file. You may need to set options for the report before running it. If 
the Ranking Method uses multiple branches and is ranked individually, a 
separate report for each branch prints. If the method used to rank products is set 
to Collectively, a single report prints for all branches because the products 
received the same rank at all branches. Item rank displays on the report next to 
rank number. 

• No - The system applies rankings and methods without creating a report. This 
is the default. Generally, users only want to apply ranking changes and not run 
a new report. 

4. Use the Ranking Method and Ranking Breakpoints areas to limit the report: 

Area Description 
Ranking Method Select the ranking method used to rank the products, such as by demand or by 

total raw hits. 
You can also apply any user-defined ranking methods created. 

Note: In the Global field, for each ranking number, indicate whether to use 
global ranking. If set to No, items are ranked with respect to the products in the 
same price line. If set to Yes, products are ranked with respect to all other 
selected products, regardless of price line. 

Ranking 
Breakpoints 

Enter the percentages assigned to each product rank in the Rank As column. The 
total percentage must add up to 100. 
You can also apply any user-defined breakpoints created. 

Note: If you change or add user-defined product ranks or methods, you must 
reschedule the report so the system applies the changes. 
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5. Do one of the following: 

• From the File menu, select Save to save your rankings and methods. 

• From the File menu, select Begin to rank you products or run the report immediately. 

• From the Options menu, select Schedule to set the program to run at a later date or at regular 
intervals. 

To delete a product ranking ID: 

1. From the Purchase > Forecasting menu, select Product Ranking to display the Product 
Ranking window. 

2. In the Ranking ID field, select the product ranking template you want to delete and press Enter. 

3. From the File menu, select Delete and answer Yes at the prompt. 

What the Report Shows 
The Product Ranking Report lists the following fields and information. The report is used like an audit to 
figure out why your products are ranked the way they are. 

Normal Report View 
The following columns display regardless if you have advanced ranks or breakpoints. These column 
names display at the top of the report in the header. They line up with the values when normal report 
values display for a ranking method. 

Column Description 
Cum-Value% The percentage of the cumulative value divided by the total value. 

Formula: cum-value / total value = Cum-Value% 

Value Individual value of the item. 
Cum-Value Running total of the actual value. 
Rank The sequential position of the item within the selected items. 

Rank% The rank divided by the number of items being ranked times 100. 
Formula: (rank / #of items) x 100 = Rank% 

Product 
Description 

The product being ranked. 

Advanced Report View 
The advanced report view is written as an audit and describes why a ranking displays as it does. The 
system lists each ranking method, such as #1 Ranking Method: Annualized Hits for the Year and its 
ranking information separately. 

For example: 
Advanced Ranking - Value Match : B PRODUCT 5/6 WGHT SPECIAL 120082 
Product Ranking = 'C' because an Annualized Hits for the Year of 80 is 
greater than or equal to 50 AND is less than 100 

The product ID number listed with each product is a link that you can select to display information about, 
such as inventory history or product ledgers. For more about how report interfaces work, see Drilling Into 
Report Data. 
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Creating User-Defined Product Ranks 
Product Ranking is used to compare the activity of a product to all other products within the same price 
line, a group of price lines, or all price lines. By default, the system sets product ranks and uses the default 
methods: demand, hits, gross sales, etc. However, you can map conversions to each rank and create user-
defined labels for the product ranks based on the breakpoints you have defined. 

For example, you have Rank #2 set up to read the Demand. You have the breakpoints set to list all items 
in the top 20% as A items. However, you want the system to list those items as a 1 (one) on reports 
instead of an A. Set up your conversion table with the Rank Item and UD Rank appropriately: 

  

Note: You can map any alphabetical character or single-digit number to your rank levels. 

Use user-defined product ranks in conjunction with user-defined product breakpoints to tailor your 
ranking and best suit your warehouse set up. 

To create a user-defined product rank: 

1. From the Purchase > Forecasting menu, select Product Ranking. 

2. In the Ranking ID field, enter the rank to which you want to add user-defined ranks and press 
Enter. 

3. In the Ranking Method area, right-click on the method you want to update and select Edit User-
Defined Mapping. 

4. Use the Item Rank and UD Rank columns to map the rank and character. 

5. Save your changes and exit the window. 

The system automatically displays an indicator when a user-defined rank exists: .  

Note: After making changes you must reschedule the Product Ranking Program for the 
system to apply the changes. 
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Creating User-Defined Breakpoints 
Product Ranking is used to compare the activity of a product to all other products within the same price 
line, a group of price lines, or all price lines. By default, the system sets product ranking breakpoints by 
percentage only. These breakpoints are displayed in the Ranking Breakpoints area of the Product 
Ranking Report. These percentages apply to all product ranking methods. You can adjust the percentages, 
as needed. However, if the percentages alone do not assist your forecasting, you can add breakpoint rules 
to include ranges and percentages of totals to further define each rank. 

For example, Rank#1 is set to Hits. However, the standard breakpoints based on the cumulative % might 
not be what you consider an ”r;A” ranked item. The low moving line could have an ”r;A” ranked item 
with just six (6) hits for example, based on the cumulative %. 

With the Advanced Ranking you can set a different rule for each rank.  If a rule is not set, the system uses 
the standard break points.  In the example of Hits, a user can specify the absolute value for the number of 
hits required for a product to be classified as an ”r;A” ranked product. For example, a rule for Hits could 
be that ”r;A” ranked products must have 50 or more hits or 20% of the cumulative and still have at least 
30 hits. The additional ”r;or” statement adds additional flexibility to this and does not have to be used. 

The system uses standard product ranks or any user-defined ranks you have defined. Any user-defined 
breakpoints override the Ranking Breakpoints. Use user-defined product ranks in conjunction with user-
defined product breakpoints to tailor your ranking and best suit your warehouse set up. 

To create a user-defined breakpoint: 

1. From the Purchase > Forecasting menu, select Product Ranking. 

2. In the Ranking ID field, enter the rank to which you want to add user-defined ranks and press 
Enter. 

3. In the Ranking Method area, select the method you want to edit and from the Edit menu, select 
Edit Advance Ranking Breakpoints to display the Advanced Ranking for <method> window. 

You can also right-click the method you want to update and select Edit Advance Ranking 
Breakpoints. 

4. Use the columns to add or adjust the column values to refine your selected rank. 

Note: Alt-Delete clears the values in the table for the line the cursor is on. 

5. Save your changes and exit the window. 

The system automatically displays an indicator when a user-defined breakpoint exists: .  

Note: After making changes you must reschedule the Product Ranking Program for the 
system to apply the changes. 
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How Projected Services Levels Work 
A service level refers to the amount of stock you want to guarantee to be in your warehouse at a given 
time. The safety factor is a quantity added to the normal stocking level of a product for a period of time. 
These are both used to determine a projected service level, meaning how much you need to purchase to 
purchase to ensure you are replenishing your warehouse regularly enough to keep merchandise on the 
shelves for purchase. 

For example, you have a hardware store and want AA batteries to be available 99.9% of the time. You 
make the AA batteries an A Ranked product with a service level of 99.9% and therefore a safety factor of 
3.72. The system uses the calculated safety factor to determine the amount of safety days needed to 
provide the desired service level. 

The service level and safety factor are mutually dependent. Changing one field changes the other field's 
value also. If projected services levels are uploaded using mass Load, then the system adjusts the safety 
factors to match. 

To see how service levels are calculated and examples of corresponding safety factors, see Service Levels 
and Related Safety Factors section in the About Service Level Numbers and Standard Deviation topic in 
this documentation. 

As of Release 8.0, you can edit the Project Service Level field. The enables purchasing agents to rank 
products, as needed, and mass load projected service levels by product rank. As of Release 8.6.7, these 
uploads can be automated: service levels adjust based on product rank changes. 

For example, you can define a table of all your ranking combinations considering 1 to 2 different ranks 
and load the corresponding service level: 

Example 1: 

If Rank #1 = A, then SL is 90.0 % 

If Rank #1 = B, then SL is 85.0 % 

Example 2: 

If Rank #1 = A and Rank #2 = 1, then SL is 93.5 % 

If Rank #1 = B and Rank # 2 = 1, then SL is 87.5 % 

The Rank #2 of 1 is a user-defined rank. 

Once defined, you can update projected service levels by ranks, as needed. For more information and 
examples, see Updating Projected Service Levels by Ranks in this documentation. 
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Product Ranking Examples 
Following are examples for how you can setup your product rankings. After determining your ranking 
methods and breakpoints, you can decide how you want to rank your products and how many ranks you 
want to use. 

In this example, five ranking methods and ranking breakpoints have been selected in the example below. 

 

Example 1 - A and B Level Rankings Only: 
You run your Product Ranking program and are ready to update product service levels. You set your 
ranks as follows: 

 
This means, if a product has an A ranking, then the service level is set to 90%. However, if the product is 
A-ranked, but has a user-defined level of 1 for Hits, then the service level is set to 93.5. 

Additionally, if a product has an B ranking, then the service level is set to 85.5%. However, if the product 
is B-ranked, but has a user-defined level of 1 for Hits, then the service level is set to 87.5. 

Example 2 - A, B, and C Rankings: 
Service levels and ranking tools can be used in combinations. 

If Rank 
#1 is... 

and Rank #2 
is... 

then apply the following 
service level: 

A   90.0% 
A A 85.5% 

A B 80.0% 
B   70.0% 
B A 75.5% 

C   60.0% 
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If Rank 
#1 is... 

and Rank #2 
is... 

then apply the following 
service level: 

Null     

In this example, the product's service level is determined as follows: 

• If Rank#1 = A and Rank #2 = anything other than A or B, then the service level is 90%. 

• If Rank#1 = A and Rank#2 = A, then the service level is 85.5%. 

• If Rank#1 = A and Rank#2 = B, then the service level is 80%. 

• If Rank#1 = B and Rank#2 = anything other than A or B, then the service level is 70%. 

• If Rank#1 = B and Rank#2 = A, then the service level is 75.5%. 

• If Rank#1 = C and Rank#2 = anything else, then the service level is 60%. 

With this setup, you can see that if you do not have Eclipse checking second-level rankings, then your 
service levels can be very different. We recommend running this utility after your product ranks are 
updated. 
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Updating Projected Service Levels by Product Ranks 
In addition to assigning product ranks or user-defined ranks to help track product activity, you can load 
projected service levels by product rank automatically so the service level adjusts as product ranks 
change. You can define a table of all ranking combinations, looking at 1 to 2 different ranks and load in a 
corresponding service level. If a product falls into more than one rank breakpoint, the system uses the 
highest level of detail to determine the projected service level. 

For example, you set up the service level by rank as follows: 

 
The ranking is staggered using the first two rank positions. The first rank in the product ranking program 
is set to analyze hits and the second is set to Demand$. With this service level program, the system takes 
the top items based on hits and applies a service level. Then, the system looks at items that have the top 
hits plus higher dollar value and applies a different percentage. Applying service levels this way, you 
avoid overstocking your high dollar items based on hits alone. 

Important: Do not leave blank cells between ranks. In the example above, you cannot enter a 
rank in the first row, column Rank #3 without an entry in Rank #2. Leaving a rank 
blank in this way, may result in false matches. 

To update projected service levels by rank: 

1. From the Purchase > Forecasting menu, select Update Service Level by Rank to display the 
Update Service Level by Rank. 

2. In the Branch/Territory field, enter the branch or territory for which you want to update service 
levels based on product ranks. 

3. Use the Overwrite Manual Service Levels area to indicate if you want to ignore any service 
level that users have manually overwritten. The default is No. 

4. Use the Rank columns to enter which ranks and combination you want to use to update service 
levels. 

5. In the Service Level column, enter the service level you want to use, if the rank matches for the 
product. 
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6. From the File menu, select Begin or schedule the program to run at a later time. 
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